]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
9aab9b57061748175c77c6fea697a4012d2c8e32
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_without  sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_without  sslv3   # SSLv3: note - enables  CVE-2014-3566 vulnerability
7 %bcond_with     snap    # use GitHub snapshot to build branch release
8
9 %define         rel             0.1
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
12 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
13 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
14 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
15 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
16 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
17 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
18 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
19 Name:           openssl
20 # Version 1.1.0 will be supported until 2018-08-31.
21 # https://www.openssl.org/about/releasestrat.html
22 Version:        1.1.0h
23 Release:        1
24 License:        Apache-like
25 Group:          Libraries
26 %if %{without snap}
27 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
28 # Source0-md5:  5271477e4d93f4ea032b665ef095ff24
29 %else
30 Source1:        https://github.com/openssl/openssl/archive/OpenSSL_1_1_0-stable/%{name}-%{version}-dev.tar.gz
31 %endif
32 Source2:        %{name}.1.pl
33 Source3:        %{name}-ssl-certificate.sh
34 Source4:        %{name}-c_rehash.sh
35 Patch1:         %{name}-optflags.patch
36 Patch3:         %{name}-man-namespace.patch
37 Patch5:         %{name}-ca-certificates.patch
38 Patch7:         %{name}-find.patch
39 Patch8:         pic.patch
40 Patch10:        %{name}_fix_for_x32.patch
41 Patch11:        engines-dir.patch
42 URL:            http://www.openssl.org/
43 BuildRequires:  perl-devel >= 1:5.10.0
44 BuildRequires:  pkgconfig
45 BuildRequires:  rpm-perlprov >= 4.1-13
46 BuildRequires:  rpmbuild(macros) >= 1.213
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  zlib-devel
49 Requires:       ca-certificates >= 20120623-1.1
50 Requires:       rpm-whiteout >= 1.7
51 Obsoletes:      SSLeay
52 Obsoletes:      SSLeay-devel
53 Obsoletes:      SSLeay-perl
54 Obsoletes:      libopenssl0
55 %if "%{pld_release}" == "ac"
56 Conflicts:      neon < 0.26.3-3
57 Conflicts:      ntpd < 4.2.4p8-10
58 Conflicts:      openssh-clients < 2:5.8p1-9
59 Conflicts:      openssh-server < 2:5.8p1-9
60 %else
61 Conflicts:      neon < 0.29.6-8
62 Conflicts:      openssh-clients < 2:6.2p2-3
63 Conflicts:      openssh-server < 2:6.2p2-3
64 %endif
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 The OpenSSL Project is a collaborative effort to develop a robust,
69 commercial-grade, full-featured, and Open Source toolkit implementing
70 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
71 v1) protocols with full-strength cryptography world-wide. The project
72 is managed by a worldwide community of volunteers that use the
73 Internet to communicate, plan, and develop the OpenSSL tookit and its
74 related documentation.
75
76 OpenSSL is based on the excellent SSLeay library developed by Eric A.
77 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
78 Apache-style licence, which basically means that you are free to get
79 and use it for commercial and non-commercial purposes subject to some
80 simple license conditions.
81
82 This package contains shared libraries only, install openssl-tools if
83 you want to use openssl cmdline tool.
84
85 %description -l de.UTF-8
86 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
87 libraries, die verschiedene Verschlüsselungs- und
88 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
89 zur Verfügung stellen.
90
91 %description -l es.UTF-8
92 Biblioteca C que suministra algoritmos y protocolos criptográficos.
93
94 %description -l fr.UTF-8
95 OpenSSL est un outiil de gestion des certificats et les librairies
96 partagees qui fournit plusieurs protocoles et algorithmes de
97 codage/decodage, incluant DES, RC4, RSA et SSL.
98
99 %description -l pl.UTF-8
100 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
101 v2/v3 oraz Transport Layer Security (TLS v1).
102
103 %description -l pt_BR.UTF-8
104 Uma biblioteca C que fornece vários algoritmos e protocolos
105 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
106 compartilhadas e utilitários.
107
108 %description -l ru.UTF-8
109 Программа openssl для работы с сертификатами и разделяемые библиотеки,
110 которые реализуют множетсво криптографических алгоритмов, включая DES,
111 RC4, RSA и SSL.
112
113 %description -l uk.UTF-8
114 Програма openssl для роботи з сертифікатами та бібліотеки спільного
115 користування, що реалізують велику кількість криптографічних
116 алгоритмів, включаючи DES, RC4, RSA та SSL.
117
118 %package engines
119 Summary:        OpenSSL optional crypto engines
120 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123
124 %description engines
125 With OpenSSL 0.9.6, a new component was added to support alternative
126 cryptography implementations, most commonly for interfacing with
127 external crypto devices (eg. accelerator cards). This component is
128 called ENGINE.
129
130 There are currently built-in ENGINE implementations for the following
131 crypto devices:
132
133 - CryptoSwift
134 - Compaq Atalla
135 - nCipher CHIL
136 - Nuron
137 - Broadcom uBSec
138
139 In addition, dynamic binding to external ENGINE implementations is now
140 provided by a special ENGINE called "dynamic".
141
142 %description engines -l pl.UTF-8
143 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
144 wspierać alternatywne implementacje kryptografii, przeważnie
145 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
146 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
147 ENGINE).
148
149 Obecnie istnieją wbudowane implementacje silników dla następujących
150 urządzeń kryptograficznych:
151 - CryptoSwift
152 - Compaq Atalla
153 - nCipher CHIL
154 - Nuron
155 - Broadcom uBSec
156
157 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
158 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
159
160 %package tools
161 Summary:        OpenSSL command line tool and utilities
162 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
163 Group:          Applications/Communications
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       which
166
167 %description tools
168 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
169
170 %description tools -l pl.UTF-8
171 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
172
173 %package tools-perl
174 Summary:        OpenSSL utilities written in Perl
175 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
176 Group:          Applications/Communications
177 Requires:       %{name} = %{version}-%{release}
178
179 %description tools-perl
180 OpenSSL Toolkit tools written in Perl.
181
182 %description tools-perl -l pl.UTF-8
183 Narzędzia OpenSSL napisane w perlu.
184
185 %package devel
186 Summary:        Development part of OpenSSL Toolkit libraries
187 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
188 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
189 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
190 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
191 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
192 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
193 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
194 Group:          Development/Libraries
195 Requires:       %{name} = %{version}-%{release}
196 Obsoletes:      libopenssl0-devel
197
198 %description devel
199 Development part of OpenSSL library.
200
201 %description devel -l es.UTF-8
202 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
203
204 %description devel -l pl.UTF-8
205 Część biblioteki OpenSSL przeznaczona dla programistów.
206
207 %description devel -l pt_BR.UTF-8
208 Uma biblioteca C que fornece vários algoritmos e protocolos
209 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
210 arquivos de inclusão para desenvolvimento.
211
212 %description devel -l ru.UTF-8
213 Программа openssl для работы с сертификатами и разделяемые библиотеки,
214 которые реализуют множетсво криптографических алгоритмов, включая DES,
215 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
216 с использованием SSL.
217
218 %description devel -l uk.UTF-8
219 Програма openssl для роботи з сертифікатами та бібліотеки спільного
220 користування, що реалізують велику кількість криптографічних
221 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
222 хедери для розробки програм з використанням SSL.
223
224 %package static
225 Summary:        Static OpenSSL libraries
226 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
227 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
228 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
229 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
230 Group:          Development/Libraries
231 Requires:       %{name}-devel = %{version}-%{release}
232
233 %description static
234 Static OpenSSL Toolkit libraries.
235
236 %description static -l pl.UTF-8
237 Statyczne wersje bibliotek z OpenSSL.
238
239 %description static -l pt_BR.UTF-8
240 Bibliotecas estáticas para desenvolvimento com openssl.
241
242 %description static -l ru.UTF-8
243 Программа openssl для работы с сертификатами и разделяемые библиотеки,
244 которые реализуют множетсво криптографических алгоритмов, включая DES,
245 RC4, RSA и SSL. Включает статические библиотеки для разработки
246 приложений с использованием OpenSSL.
247
248 %description static -l uk.UTF-8
249 Програма openssl для роботи з сертифікатами та бібліотеки спільного
250 користування, що реалізують велику кількість криптографічних
251 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
252 бібліотеки для розробки програм з використанням SSL.
253
254 %prep
255 %if %{with snap}
256 %setup -qcT -a1
257 %{__mv} %{name}-OpenSSL_1_1_0-stable/* .
258 %else
259 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
260 %endif
261 %patch1 -p1
262 %patch3 -p1
263 %patch5 -p1
264 %patch7 -p1
265 %patch8 -p1
266 %ifarch x32
267 %patch10 -p1
268 %endif
269 %patch11 -p1
270
271 %build
272 touch Makefile.*
273
274 PERL="%{__perl}" \
275 %{__perl} ./Configure \
276         --prefix=%{_prefix} \
277         --openssldir=%{_sysconfdir}/%{name} \
278         --libdir=%{_lib} \
279         -Wa,--noexecstack \
280         shared \
281         threads \
282         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
283         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
284         %{!?with_zlib:no-}zlib \
285         enable-cms \
286         enable-idea \
287         enable-md2 \
288         enable-mdc2 \
289         enable-rc5 \
290         enable-rfc3779 \
291         enable-seed \
292 %ifarch %{x8664}
293         enable-ec_nistp_64_gcc_128 \
294 %endif
295 %ifarch %{ix86}
296 %ifarch i386
297         386 linux-elf
298 # ^- allow running on 80386 (default code uses bswapl available on i486+)
299 %else
300         linux-elf
301 %endif
302 %endif
303 %ifarch alpha
304         linux-alpha-gcc
305 %endif
306 %ifarch %{x8664}
307         linux-x86_64
308 %endif
309 %ifarch x32
310         linux-x32
311 %endif
312 %ifarch ia64
313         linux-ia64
314 %endif
315 %ifarch ppc
316         linux-ppc
317 %endif
318 %ifarch ppc64
319         linux-ppc64
320 %endif
321 %ifarch sparc
322         linux-sparcv8
323 %endif
324 %ifarch sparcv9
325         linux-sparcv9
326 %endif
327 %ifarch sparc64
328         linux64-sparcv9
329 %endif
330 %ifarch %{arm}
331         linux-armv4
332 %endif
333 %ifarch aarch64
334         linux-aarch64
335 %endif
336
337 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
338 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
339
340 %{__make} -j1 all %{?with_tests:tests} \
341         CC="%{__cc}" \
342         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
343         INSTALLTOP=%{_prefix}
344
345 # Rename POD sources of man pages. "openssl-" prefix is added to each
346 # manpage to avoid potential conflicts with other packages.
347 # (libcrypto/libssl function names are not affected)
348
349 %{__perl} -pi -e 's/(\W)((?<!openssl-)\w+)(\([157]\))/$1openssl-$2$3/g; s/openssl-openssl/openssl/g;' {apps,ssl,crypto}/*.pod;
350 for podfile in doc/apps/!(CA.pl|openssl*).pod doc/crypto/{bio,crypto,ct,des_modes,evp,x509}.pod  doc/ssl/ssl.pod ; do
351         dir=$(dirname "$podfile")
352         base=$(basename "$podfile")
353         %{__mv} "$podfile" "$dir/openssl-$base"
354 done
355
356 %install
357 rm -rf $RPM_BUILD_ROOT
358 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
359         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
360         $RPM_BUILD_ROOT%{_pkgconfigdir}
361
362 %{__make} -j1 install \
363         CC="%{__cc}" \
364         DESTDIR=$RPM_BUILD_ROOT
365
366 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
367 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
368 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
369
370 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
371 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
372
373 # html version of man pages - not packaged
374 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
375
376 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
377 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
378 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
379
380 %clean
381 rm -rf $RPM_BUILD_ROOT
382
383 %post   -p /sbin/ldconfig
384 %postun -p /sbin/ldconfig
385
386 %triggerpostun -- %{name}-tools < 1.0.0-5
387 # the hashing format has changed in 1.0.0
388 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
389
390 %triggerpostun -- %{name} < 0.9.8i-2
391 # don't do anything on --downgrade
392 if [ $1 -le 1 ]; then
393         exit 0
394 fi
395 if [ -d /var/lib/openssl/certs ] ; then
396         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
397 fi
398 if [ -d /var/lib/openssl/private ] ; then
399         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
400 fi
401 if [ -d /var/lib/openssl ] ; then
402         for f in /var/lib/openssl/* ; do
403                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
404         done
405         rmdir /var/lib/openssl/* 2>/dev/null || :
406         rmdir /var/lib/openssl 2>/dev/null || :
407 fi
408
409 %files
410 %defattr(644,root,root,755)
411 %doc CHANGES LICENSE NEWS README doc/*.txt
412 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
413 %attr(755,root,root) /%{_lib}/libssl.so.*.*
414 %dir %{_sysconfdir}/%{name}
415 %dir %{_sysconfdir}/%{name}/certs
416 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
417 %dir %{_datadir}/ssl
418
419 %files engines
420 %defattr(644,root,root,755)
421 %dir /%{_lib}/engines-1.1
422 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
423
424 %files tools
425 %defattr(644,root,root,755)
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
427 %attr(755,root,root) %{_bindir}/c_rehash.sh
428 %attr(755,root,root) %{_bindir}/openssl
429 %attr(754,root,root) %{_bindir}/ssl-certificate
430 %{_mandir}/man1/openssl.1*
431 %{_mandir}/man1/openssl-asn1parse.1*
432 %{_mandir}/man1/openssl-blake2b.1*
433 %{_mandir}/man1/openssl-blake2s.1*
434 %{_mandir}/man1/openssl-ca.1*
435 %{_mandir}/man1/openssl-ciphers.1*
436 %{_mandir}/man1/openssl-cms.1*
437 %{_mandir}/man1/openssl-crl.1*
438 %{_mandir}/man1/openssl-crl2pkcs7.1*
439 %{_mandir}/man1/openssl-dgst.1*
440 %{_mandir}/man1/openssl-dhparam.1*
441 %{_mandir}/man1/openssl-dsa.1*
442 %{_mandir}/man1/openssl-dsaparam.1*
443 %{_mandir}/man1/openssl-ec.1*
444 %{_mandir}/man1/openssl-ecparam.1*
445 %{_mandir}/man1/openssl-enc.1*
446 %{_mandir}/man1/openssl-engine.1*
447 %{_mandir}/man1/openssl-errstr.1*
448 %{_mandir}/man1/openssl-gendsa.1*
449 %{_mandir}/man1/openssl-genpkey.1*
450 %{_mandir}/man1/openssl-genrsa.1*
451 %{_mandir}/man1/openssl-list.1*
452 %{_mandir}/man1/openssl-md4.1*
453 %{_mandir}/man1/openssl-md5.1*
454 %{_mandir}/man1/openssl-mdc2.1*
455 %{_mandir}/man1/openssl-nseq.1*
456 %{_mandir}/man1/openssl-ocsp.1*
457 %{_mandir}/man1/openssl-passwd.1*
458 %{_mandir}/man1/openssl-pkcs12.1*
459 %{_mandir}/man1/openssl-pkcs7.1*
460 %{_mandir}/man1/openssl-pkcs8.1*
461 %{_mandir}/man1/openssl-pkey.1*
462 %{_mandir}/man1/openssl-pkeyparam.1*
463 %{_mandir}/man1/openssl-pkeyutl.1*
464 %{_mandir}/man1/openssl-rand.1*
465 %{_mandir}/man1/openssl-rehash.1*
466 %{_mandir}/man1/openssl-req.1*
467 %{_mandir}/man1/openssl-ripemd160.1*
468 %{_mandir}/man1/openssl-rsa.1*
469 %{_mandir}/man1/openssl-rsautl.1*
470 %{_mandir}/man1/openssl-s_client.1*
471 %{_mandir}/man1/openssl-s_server.1*
472 %{_mandir}/man1/openssl-s_time.1*
473 %{_mandir}/man1/openssl-sess_id.1*
474 %{_mandir}/man1/openssl-sha.1*
475 %{_mandir}/man1/openssl-sha1.1*
476 %{_mandir}/man1/openssl-sha224.1*
477 %{_mandir}/man1/openssl-sha256.1*
478 %{_mandir}/man1/openssl-sha384.1*
479 %{_mandir}/man1/openssl-sha512.1*
480 %{_mandir}/man1/openssl-smime.1*
481 %{_mandir}/man1/openssl-speed.1*
482 %{_mandir}/man1/openssl-spkac.1*
483 %{_mandir}/man1/openssl-ts.1*
484 %{_mandir}/man1/openssl-tsget.1*
485 %{_mandir}/man1/openssl-verify.1*
486 %{_mandir}/man1/openssl-version.1*
487 %{_mandir}/man1/openssl-x509.1*
488 %{_mandir}/man5/openssl-config.5*
489 %{_mandir}/man5/openssl-x509v3_config.5*
490 %lang(pl) %{_mandir}/pl/man1/openssl.1*
491
492 %files tools-perl
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/c_rehash
495 %dir %{_libdir}/%{name}
496 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
497 %attr(755,root,root) %{_libdir}/%{name}/tsget
498 %{_mandir}/man1/CA.pl.1*
499 %{_mandir}/man1/c_rehash.1*
500 %{_mandir}/man1/openssl-c_rehash.1*
501
502 %files devel
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_libdir}/libcrypto.so
505 %attr(755,root,root) %{_libdir}/libssl.so
506 %{_includedir}/%{name}
507 %{_pkgconfigdir}/libcrypto.pc
508 %{_pkgconfigdir}/libssl.pc
509 %{_pkgconfigdir}/openssl.pc
510 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
511 %{_mandir}/man3/ASId*.3*
512 %{_mandir}/man3/ASRange_*.3*
513 %{_mandir}/man3/ASN1_*.3*
514 %{_mandir}/man3/ASYNC_*.3*
515 %{_mandir}/man3/AUTHORITY_*.3*
516 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
517 %{_mandir}/man3/BF_*.3*
518 %{_mandir}/man3/BIO_*.3*
519 %{_mandir}/man3/BN_*.3*
520 %{_mandir}/man3/BUF_*.3*
521 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
522 %{_mandir}/man3/CMS_*.3*
523 %{_mandir}/man3/CONF_*.3*
524 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
525 %{_mandir}/man3/CRYPTO_*.3*
526 %{_mandir}/man3/CTLOG_*.3*
527 %{_mandir}/man3/CT_POLICY_*.3*
528 %{_mandir}/man3/DECLARE_*.3*
529 %{_mandir}/man3/DEFINE_*.3*
530 %{_mandir}/man3/DES_*.3*
531 %{_mandir}/man3/DH_*.3*
532 %{_mandir}/man3/DHparams_*.3*
533 %{_mandir}/man3/DIRECTORYSTRING_*.3*
534 %{_mandir}/man3/DISPLAYTEXT_*.3*
535 %{_mandir}/man3/DIST_POINT_*.3*
536 %{_mandir}/man3/DSA_*.3*
537 %{_mandir}/man3/DSAparams_*.3*
538 %{_mandir}/man3/DTLS_*.3*
539 %{_mandir}/man3/DTLSv1_*.3*
540 %{_mandir}/man3/ECDH_*.3*
541 %{_mandir}/man3/ECDSA_*.3*
542 %{_mandir}/man3/ECPARAMETERS_*.3*
543 %{_mandir}/man3/ECPKPARAMETERS_*.3*
544 %{_mandir}/man3/ECPKParameters_*.3*
545 %{_mandir}/man3/EC_*.3*
546 %{_mandir}/man3/EDIPARTYNAME_*.3*
547 %{_mandir}/man3/ENGINE_*.3*
548 %{_mandir}/man3/ERR_*.3*
549 %{_mandir}/man3/ESS_*.3*
550 %{_mandir}/man3/EVP_*.3*
551 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
552 %{_mandir}/man3/GENERAL_*.3*
553 %{_mandir}/man3/GEN_SESSION_CB.3*
554 %{_mandir}/man3/HMAC*.3*
555 %{_mandir}/man3/IMPLEMENT_*.3*
556 %{_mandir}/man3/IPAddress*.3*
557 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
558 %{_mandir}/man3/LHASH_*.3*
559 %{_mandir}/man3/MD2*.3*
560 %{_mandir}/man3/MD4*.3*
561 %{_mandir}/man3/MD5*.3*
562 %{_mandir}/man3/MDC2*.3*
563 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
564 %{_mandir}/man3/NETSCAPE_*.3*
565 %{_mandir}/man3/NOTICEREF_*.3*
566 %{_mandir}/man3/OBJ_*.3*
567 %{_mandir}/man3/OCSP_*.3*
568 %{_mandir}/man3/OPENSSL_*.3*
569 %{_mandir}/man3/OTHERNAME_*.3*
570 %{_mandir}/man3/OpenSSL_*.3*
571 %{_mandir}/man3/PBE2PARAM_*.3*
572 %{_mandir}/man3/PBEPARAM_*.3*
573 %{_mandir}/man3/PBKDF2PARAM_*.3*
574 %{_mandir}/man3/PEM_*.3*
575 %{_mandir}/man3/PKCS12_*.3*
576 %{_mandir}/man3/PKCS5_*.3*
577 %{_mandir}/man3/PKCS7_*.3*
578 %{_mandir}/man3/PKCS8_*.3*
579 %{_mandir}/man3/PKEY_*.3*
580 %{_mandir}/man3/POLICYINFO_*.3*
581 %{_mandir}/man3/POLICYQUALINFO_*.3*
582 %{_mandir}/man3/POLICY_*.3*
583 %{_mandir}/man3/PROXY_*.3*
584 %{_mandir}/man3/RAND_*.3*
585 %{_mandir}/man3/RC4*.3*
586 %{_mandir}/man3/RIPEMD160*.3*
587 %{_mandir}/man3/RSAPrivateKey_*.3*
588 %{_mandir}/man3/RSAPublicKey_*.3*
589 %{_mandir}/man3/RSA_*.3*
590 %{_mandir}/man3/SCT_*.3*
591 %{_mandir}/man3/SHA1*.3*
592 %{_mandir}/man3/SHA224*.3*
593 %{_mandir}/man3/SHA256*.3*
594 %{_mandir}/man3/SHA384*.3*
595 %{_mandir}/man3/SHA512*.3*
596 %{_mandir}/man3/SMIME_*.3*
597 %{_mandir}/man3/SSL_*.3*
598 %{_mandir}/man3/SSLv23_*.3*
599 %{_mandir}/man3/SSLv3_*.3*
600 %{_mandir}/man3/SXNET_*.3*
601 %{_mandir}/man3/SXNETID_*.3*
602 %{_mandir}/man3/TLS_*.3*
603 %{_mandir}/man3/TLSv1_*.3*
604 %{_mandir}/man3/TS_*.3*
605 %{_mandir}/man3/UI*.3*
606 %{_mandir}/man3/USERNOTICE_*.3*
607 %{_mandir}/man3/X509_*.3*
608 %{_mandir}/man3/X509V3_*.3*
609 %{_mandir}/man3/X509v3_*.3*
610 %{_mandir}/man3/custom_ext_*.3*
611 %{_mandir}/man3/d2i_*.3*
612 %{_mandir}/man3/i2d_*.3*
613 %{_mandir}/man3/i2o_*.3*
614 %{_mandir}/man3/i2t_*.3*
615 %{_mandir}/man3/lh_TYPE_*.3*
616 %{_mandir}/man3/o2i_*.3*
617 %{_mandir}/man3/pem_password_cb.3*
618 %{_mandir}/man3/sk_TYPE_*.3*
619 %{_mandir}/man3/ssl_ct_validation_cb.3*
620 %{_mandir}/man7/openssl-bio.7*
621 %{_mandir}/man7/openssl-crypto.7*
622 %{_mandir}/man7/openssl-ct.7*
623 %{_mandir}/man7/openssl-des_modes.7*
624 %{_mandir}/man7/openssl-evp.7*
625 %{_mandir}/man7/openssl-ssl.7*
626 %{_mandir}/man7/openssl-x509.7*
627
628 %files static
629 %defattr(644,root,root,755)
630 %{_libdir}/libcrypto.a
631 %{_libdir}/libssl.a
This page took 0.079455 seconds and 2 git commands to generate.