]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
up to 3.3.0 (fixes CVE-2024-2511)
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_with     sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_with     sslv3   # SSLv3: note - enables CVE-2014-3566 vulnerability
7
8 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
9 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
10 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
11 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
12 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
13 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
14 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
15 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
16 Name:           openssl
17 # Version 1.1.1 is LTS, supported until 2023-09-11.
18 # https://www.openssl.org/about/releasestrat.html
19 Version:        1.1.1e
20 Release:        1
21 License:        Apache-like
22 Group:          Libraries
23 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
24 # Source0-md5:  baeff2a64d2f3d7e0a69b677c9977b57
25 Source2:        %{name}.1.pl
26 Source3:        %{name}-ssl-certificate.sh
27 Source4:        %{name}-c_rehash.sh
28 Patch1:         %{name}-optflags.patch
29
30 Patch3:         %{name}-man-namespace.patch
31 Patch4:         bug-11378.patch
32 Patch5:         %{name}-ca-certificates.patch
33 Patch6:         %{name}-no-win32.patch
34 Patch7:         %{name}-find.patch
35 Patch8:         pic.patch
36
37 Patch11:        engines-dir.patch
38 URL:            http://www.openssl.org/
39 BuildRequires:  libsctp-devel
40 BuildRequires:  perl-devel >= 1:5.10.0
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpmbuild(macros) >= 1.213
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  zlib-devel
46 Requires:       ca-certificates >= 20141019-3
47 Requires:       rpm-whiteout >= 1.7
48 Obsoletes:      SSLeay
49 Obsoletes:      SSLeay-devel
50 Obsoletes:      SSLeay-perl
51 Obsoletes:      libopenssl0
52 %if "%{pld_release}" == "ac"
53 Conflicts:      neon < 0.26.3-3
54 Conflicts:      ntpd < 4.2.4p8-10
55 Conflicts:      openssh-clients < 2:5.8p1-9
56 Conflicts:      openssh-server < 2:5.8p1-9
57 %else
58 Conflicts:      neon < 0.29.6-8
59 Conflicts:      openssh-clients < 2:6.2p2-3
60 Conflicts:      openssh-server < 2:6.2p2-3
61 %endif
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 The OpenSSL Project is a collaborative effort to develop a robust,
66 commercial-grade, full-featured, and Open Source toolkit implementing
67 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
68 v1) protocols with full-strength cryptography world-wide. The project
69 is managed by a worldwide community of volunteers that use the
70 Internet to communicate, plan, and develop the OpenSSL tookit and its
71 related documentation.
72
73 OpenSSL is based on the excellent SSLeay library developed by Eric A.
74 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
75 Apache-style licence, which basically means that you are free to get
76 and use it for commercial and non-commercial purposes subject to some
77 simple license conditions.
78
79 This package contains shared libraries only, install openssl-tools if
80 you want to use openssl cmdline tool.
81
82 %description -l de.UTF-8
83 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
84 libraries, die verschiedene Verschlüsselungs- und
85 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
86 zur Verfügung stellen.
87
88 %description -l es.UTF-8
89 Biblioteca C que suministra algoritmos y protocolos criptográficos.
90
91 %description -l fr.UTF-8
92 OpenSSL est un outiil de gestion des certificats et les librairies
93 partagees qui fournit plusieurs protocoles et algorithmes de
94 codage/decodage, incluant DES, RC4, RSA et SSL.
95
96 %description -l pl.UTF-8
97 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
98 v2/v3 oraz Transport Layer Security (TLS v1).
99
100 %description -l pt_BR.UTF-8
101 Uma biblioteca C que fornece vários algoritmos e protocolos
102 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
103 compartilhadas e utilitários.
104
105 %description -l ru.UTF-8
106 Программа openssl для работы с сертификатами и разделяемые библиотеки,
107 которые реализуют множетсво криптографических алгоритмов, включая DES,
108 RC4, RSA и SSL.
109
110 %description -l uk.UTF-8
111 Програма openssl для роботи з сертифікатами та бібліотеки спільного
112 користування, що реалізують велику кількість криптографічних
113 алгоритмів, включаючи DES, RC4, RSA та SSL.
114
115 %package engines
116 Summary:        OpenSSL optional crypto engines
117 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description engines
122 With OpenSSL 0.9.6, a new component was added to support alternative
123 cryptography implementations, most commonly for interfacing with
124 external crypto devices (eg. accelerator cards). This component is
125 called ENGINE.
126
127 There are currently built-in ENGINE implementations for the following
128 crypto devices:
129
130 - CryptoSwift
131 - Compaq Atalla
132 - nCipher CHIL
133 - Nuron
134 - Broadcom uBSec
135
136 In addition, dynamic binding to external ENGINE implementations is now
137 provided by a special ENGINE called "dynamic".
138
139 %description engines -l pl.UTF-8
140 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
141 wspierać alternatywne implementacje kryptografii, przeważnie
142 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
143 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
144 ENGINE).
145
146 Obecnie istnieją wbudowane implementacje silników dla następujących
147 urządzeń kryptograficznych:
148 - CryptoSwift
149 - Compaq Atalla
150 - nCipher CHIL
151 - Nuron
152 - Broadcom uBSec
153
154 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
155 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
156
157 %package tools
158 Summary:        OpenSSL command line tool and utilities
159 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
160 Group:          Applications/Communications
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       which
163
164 %description tools
165 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
166
167 %description tools -l pl.UTF-8
168 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
169
170 %package tools-perl
171 Summary:        OpenSSL utilities written in Perl
172 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
173 Group:          Applications/Communications
174 Requires:       %{name} = %{version}-%{release}
175
176 %description tools-perl
177 OpenSSL Toolkit tools written in Perl.
178
179 %description tools-perl -l pl.UTF-8
180 Narzędzia OpenSSL napisane w perlu.
181
182 %package devel
183 Summary:        Development part of OpenSSL Toolkit libraries
184 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
185 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
186 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
187 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
188 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
189 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
190 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
191 Group:          Development/Libraries
192 Requires:       %{name} = %{version}-%{release}
193 Obsoletes:      libopenssl0-devel
194
195 %description devel
196 Development part of OpenSSL library.
197
198 %description devel -l es.UTF-8
199 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
200
201 %description devel -l pl.UTF-8
202 Część biblioteki OpenSSL przeznaczona dla programistów.
203
204 %description devel -l pt_BR.UTF-8
205 Uma biblioteca C que fornece vários algoritmos e protocolos
206 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
207 arquivos de inclusão para desenvolvimento.
208
209 %description devel -l ru.UTF-8
210 Программа openssl для работы с сертификатами и разделяемые библиотеки,
211 которые реализуют множетсво криптографических алгоритмов, включая DES,
212 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
213 с использованием SSL.
214
215 %description devel -l uk.UTF-8
216 Програма openssl для роботи з сертифікатами та бібліотеки спільного
217 користування, що реалізують велику кількість криптографічних
218 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
219 хедери для розробки програм з використанням SSL.
220
221 %package static
222 Summary:        Static OpenSSL libraries
223 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
224 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
225 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
226 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
227 Group:          Development/Libraries
228 Requires:       %{name}-devel = %{version}-%{release}
229
230 %description static
231 Static OpenSSL Toolkit libraries.
232
233 %description static -l pl.UTF-8
234 Statyczne wersje bibliotek z OpenSSL.
235
236 %description static -l pt_BR.UTF-8
237 Bibliotecas estáticas para desenvolvimento com openssl.
238
239 %description static -l ru.UTF-8
240 Программа openssl для работы с сертификатами и разделяемые библиотеки,
241 которые реализуют множетсво криптографических алгоритмов, включая DES,
242 RC4, RSA и SSL. Включает статические библиотеки для разработки
243 приложений с использованием OpenSSL.
244
245 %description static -l uk.UTF-8
246 Програма openssl для роботи з сертифікатами та бібліотеки спільного
247 користування, що реалізують велику кількість криптографічних
248 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
249 бібліотеки для розробки програм з використанням SSL.
250
251 %prep
252 %if %{with snap}
253 %setup -qcT -a1
254 %{__mv} %{name}-OpenSSL_1_1_0-stable/* .
255 %else
256 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
257 %endif
258 %patch1 -p1
259
260 %patch3 -p1
261 %patch4 -p1
262 %patch5 -p1
263 %patch6 -p1
264 %patch7 -p1
265 %patch8 -p1
266
267 %patch11 -p1
268
269 %build
270 touch Makefile.*
271
272 PERL="%{__perl}" \
273 %{__perl} ./Configure \
274         --prefix=%{_prefix} \
275         --openssldir=%{_sysconfdir}/%{name} \
276         --libdir=%{_lib} \
277         -Wa,--noexecstack \
278         shared \
279         threads \
280         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
281         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
282         %{!?with_zlib:no-}zlib \
283         enable-cms \
284         enable-idea \
285         enable-md2 \
286         enable-mdc2 \
287         enable-rc5 \
288         enable-rfc3779 \
289         enable-sctp \
290         enable-seed \
291 %ifarch %{x8664}
292         enable-ec_nistp_64_gcc_128 \
293 %endif
294 %ifarch %{ix86}
295 %ifarch i386
296         386 linux-elf
297 # ^- allow running on 80386 (default code uses bswapl available on i486+)
298 %else
299         linux-elf
300 %endif
301 %endif
302 %ifarch alpha
303         linux-alpha-gcc
304 %endif
305 %ifarch %{x8664}
306         linux-x86_64
307 %endif
308 %ifarch x32
309         linux-x32
310 %endif
311 %ifarch ia64
312         linux-ia64
313 %endif
314 %ifarch ppc
315         linux-ppc
316 %endif
317 %ifarch ppc64
318         linux-ppc64
319 %endif
320 %ifarch sparc
321         linux-sparcv8
322 %endif
323 %ifarch sparcv9
324         linux-sparcv9
325 %endif
326 %ifarch sparc64
327         linux64-sparcv9
328 %endif
329 %ifarch %{arm}
330         linux-armv4
331 %endif
332 %ifarch aarch64
333         linux-aarch64
334 %endif
335
336 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
337 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
338
339 # fails with enable-sctp as of 1.1.1
340 %{__rm} test/recipes/80-test_ssl_new.t
341
342 %{__make} -j1 all %{?with_tests:tests} \
343         CC="%{__cc}" \
344         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
345         INSTALLTOP=%{_prefix}
346
347 # Rename POD sources of man pages. "openssl-" prefix is added to each
348 # manpage to avoid potential conflicts with other packages.
349 # openssl-man-namespace.patch mostly marks these pages with "openssl-" prefix.
350
351 for podfile in $(grep -rl '^openssl-' doc/man*); do
352         dir=$(dirname "$podfile")
353         base=$(basename "$podfile")
354         %{__mv} "$podfile" "$dir/openssl-$base"
355 done
356
357 %install
358 rm -rf $RPM_BUILD_ROOT
359 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
360         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
361         $RPM_BUILD_ROOT%{_pkgconfigdir}
362
363 %{__make} -j1 install \
364         CC="%{__cc}" \
365         DESTDIR=$RPM_BUILD_ROOT
366
367 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
368 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
369 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
370
371 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
372 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
373
374 # html version of man pages - not packaged
375 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
376
377 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
378 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
379 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post   -p /sbin/ldconfig
385 %postun -p /sbin/ldconfig
386
387 %triggerpostun -- %{name}-tools < 1.0.0-5
388 # the hashing format has changed in 1.0.0
389 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
390
391 %triggerpostun -- %{name} < 0.9.8i-2
392 # don't do anything on --downgrade
393 if [ $1 -le 1 ]; then
394         exit 0
395 fi
396 if [ -d /var/lib/openssl/certs ] ; then
397         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
398 fi
399 if [ -d /var/lib/openssl/private ] ; then
400         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
401 fi
402 if [ -d /var/lib/openssl ] ; then
403         for f in /var/lib/openssl/* ; do
404                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
405         done
406         rmdir /var/lib/openssl/* 2>/dev/null || :
407         rmdir /var/lib/openssl 2>/dev/null || :
408 fi
409
410 %files
411 %defattr(644,root,root,755)
412 %doc CHANGES LICENSE NEWS README doc/*.txt
413 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
414 %attr(755,root,root) /%{_lib}/libssl.so.*.*
415 %dir %{_sysconfdir}/%{name}
416 %dir %{_sysconfdir}/%{name}/certs
417 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
418 %dir %{_datadir}/ssl
419
420 %files engines
421 %defattr(644,root,root,755)
422 %dir /%{_lib}/engines-1.1
423 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
424
425 %files tools
426 %defattr(644,root,root,755)
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
428 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
429 %attr(755,root,root) %{_bindir}/c_rehash.sh
430 %attr(755,root,root) %{_bindir}/openssl
431 %attr(754,root,root) %{_bindir}/ssl-certificate
432 %{_mandir}/man1/openssl.1*
433 %{_mandir}/man1/openssl-asn1parse.1*
434 %{_mandir}/man1/openssl-ca.1*
435 %{_mandir}/man1/openssl-ciphers.1*
436 %{_mandir}/man1/openssl-cms.1*
437 %{_mandir}/man1/openssl-crl.1*
438 %{_mandir}/man1/openssl-crl2pkcs7.1*
439 %{_mandir}/man1/openssl-dgst.1*
440 %{_mandir}/man1/openssl-dhparam.1*
441 %{_mandir}/man1/openssl-dsa.1*
442 %{_mandir}/man1/openssl-dsaparam.1*
443 %{_mandir}/man1/openssl-ec.1*
444 %{_mandir}/man1/openssl-ecparam.1*
445 %{_mandir}/man1/openssl-enc.1*
446 %{_mandir}/man1/openssl-engine.1*
447 %{_mandir}/man1/openssl-errstr.1*
448 %{_mandir}/man1/openssl-gendsa.1*
449 %{_mandir}/man1/openssl-genpkey.1*
450 %{_mandir}/man1/openssl-genrsa.1*
451 %{_mandir}/man1/openssl-list.1*
452 %{_mandir}/man1/openssl-nseq.1*
453 %{_mandir}/man1/openssl-ocsp.1*
454 %{_mandir}/man1/openssl-passwd.1*
455 %{_mandir}/man1/openssl-pkcs12.1*
456 %{_mandir}/man1/openssl-pkcs7.1*
457 %{_mandir}/man1/openssl-pkcs8.1*
458 %{_mandir}/man1/openssl-pkey.1*
459 %{_mandir}/man1/openssl-pkeyparam.1*
460 %{_mandir}/man1/openssl-pkeyutl.1*
461 %{_mandir}/man1/openssl-prime.1*
462 %{_mandir}/man1/openssl-rand.1*
463 %{_mandir}/man1/openssl-rehash.1*
464 %{_mandir}/man1/openssl-req.1*
465 %{_mandir}/man1/openssl-rsa.1*
466 %{_mandir}/man1/openssl-rsautl.1*
467 %{_mandir}/man1/openssl-s_client.1*
468 %{_mandir}/man1/openssl-s_server.1*
469 %{_mandir}/man1/openssl-s_time.1*
470 %{_mandir}/man1/openssl-sess_id.1*
471 %{_mandir}/man1/openssl-smime.1*
472 %{_mandir}/man1/openssl-speed.1*
473 %{_mandir}/man1/openssl-spkac.1*
474 %{_mandir}/man1/openssl-srp.1*
475 %{_mandir}/man1/openssl-storeutl.1*
476 %{_mandir}/man1/openssl-ts.1*
477 %{_mandir}/man1/openssl-tsget.1*
478 %{_mandir}/man1/openssl-verify.1*
479 %{_mandir}/man1/openssl-version.1*
480 %{_mandir}/man1/openssl-x509.1*
481 %{_mandir}/man5/openssl-config.5*
482 %{_mandir}/man5/openssl-x509v3_config.5*
483 %lang(pl) %{_mandir}/pl/man1/openssl.1*
484
485 %files tools-perl
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_bindir}/c_rehash
488 %dir %{_libdir}/%{name}
489 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
490 %attr(755,root,root) %{_libdir}/%{name}/tsget
491 %attr(755,root,root) %{_libdir}/%{name}/tsget.pl
492 %{_mandir}/man1/CA.pl.1*
493 %{_mandir}/man1/c_rehash.1*
494
495 %files devel
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_libdir}/libcrypto.so
498 %attr(755,root,root) %{_libdir}/libssl.so
499 %{_includedir}/%{name}
500 %{_pkgconfigdir}/libcrypto.pc
501 %{_pkgconfigdir}/libssl.pc
502 %{_pkgconfigdir}/openssl.pc
503 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
504 %{_mandir}/man3/ADMISSION*.3*
505 %{_mandir}/man3/ASId*.3*
506 %{_mandir}/man3/ASRange_*.3*
507 %{_mandir}/man3/ASN1_*.3*
508 %{_mandir}/man3/ASYNC_*.3*
509 %{_mandir}/man3/AUTHORITY_*.3*
510 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
511 %{_mandir}/man3/BF_*.3*
512 %{_mandir}/man3/BIO_*.3*
513 %{_mandir}/man3/BN_*.3*
514 %{_mandir}/man3/BUF_*.3*
515 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
516 %{_mandir}/man3/CMS_*.3*
517 %{_mandir}/man3/CONF_*.3*
518 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
519 %{_mandir}/man3/CRYPTO_*.3*
520 %{_mandir}/man3/CTLOG_*.3*
521 %{_mandir}/man3/CT_POLICY_*.3*
522 %{_mandir}/man3/DECLARE_*.3*
523 %{_mandir}/man3/DEFINE_*.3*
524 %{_mandir}/man3/DES_*.3*
525 %{_mandir}/man3/DH_*.3*
526 %{_mandir}/man3/DHparams_*.3*
527 %{_mandir}/man3/DIRECTORYSTRING_*.3*
528 %{_mandir}/man3/DISPLAYTEXT_*.3*
529 %{_mandir}/man3/DIST_POINT_*.3*
530 %{_mandir}/man3/DSA_*.3*
531 %{_mandir}/man3/DSAparams_*.3*
532 %{_mandir}/man3/DTLS_*.3*
533 %{_mandir}/man3/DTLSv1_*.3*
534 %{_mandir}/man3/ECDH_*.3*
535 %{_mandir}/man3/ECDSA_*.3*
536 %{_mandir}/man3/ECPARAMETERS_*.3*
537 %{_mandir}/man3/ECPKPARAMETERS_*.3*
538 %{_mandir}/man3/ECPKParameters_*.3*
539 %{_mandir}/man3/EC_*.3*
540 %{_mandir}/man3/EDIPARTYNAME_*.3*
541 %{_mandir}/man3/ENGINE_*.3*
542 %{_mandir}/man3/ERR_*.3*
543 %{_mandir}/man3/ESS_*.3*
544 %{_mandir}/man3/EVP_*.3*
545 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
546 %{_mandir}/man3/GENERAL_*.3*
547 %{_mandir}/man3/GEN_SESSION_CB.3*
548 %{_mandir}/man3/HMAC*.3*
549 %{_mandir}/man3/IMPLEMENT_*.3*
550 %{_mandir}/man3/IPAddress*.3*
551 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
552 %{_mandir}/man3/LHASH*.3*
553 %{_mandir}/man3/MD2*.3*
554 %{_mandir}/man3/MD4*.3*
555 %{_mandir}/man3/MD5*.3*
556 %{_mandir}/man3/MDC2*.3*
557 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
558 %{_mandir}/man3/NAMING_AUTHORITY*.3*
559 %{_mandir}/man3/NETSCAPE_*.3*
560 %{_mandir}/man3/NOTICEREF_*.3*
561 %{_mandir}/man3/OBJ_*.3*
562 %{_mandir}/man3/OCSP_*.3*
563 %{_mandir}/man3/OPENSSL_*.3*
564 %{_mandir}/man3/OSSL*.3*
565 %{_mandir}/man3/OTHERNAME_*.3*
566 %{_mandir}/man3/OpenSSL_*.3*
567 %{_mandir}/man3/PBE2PARAM_*.3*
568 %{_mandir}/man3/PBEPARAM_*.3*
569 %{_mandir}/man3/PBKDF2PARAM_*.3*
570 %{_mandir}/man3/PEM_*.3*
571 %{_mandir}/man3/PKCS12_*.3*
572 %{_mandir}/man3/PKCS5_*.3*
573 %{_mandir}/man3/PKCS7_*.3*
574 %{_mandir}/man3/PKCS8_*.3*
575 %{_mandir}/man3/PKEY_*.3*
576 %{_mandir}/man3/POLICYINFO_*.3*
577 %{_mandir}/man3/POLICYQUALINFO_*.3*
578 %{_mandir}/man3/POLICY_*.3*
579 %{_mandir}/man3/PROFESSION_INFO*.3*
580 %{_mandir}/man3/PROXY_*.3*
581 %{_mandir}/man3/RAND_*.3*
582 %{_mandir}/man3/RC4*.3*
583 %{_mandir}/man3/RIPEMD160*.3*
584 %{_mandir}/man3/RSAPrivateKey_*.3*
585 %{_mandir}/man3/RSAPublicKey_*.3*
586 %{_mandir}/man3/RSA_*.3*
587 %{_mandir}/man3/SCRYPT_PARAMS*.3*
588 %{_mandir}/man3/SCT_*.3*
589 %{_mandir}/man3/SHA1*.3*
590 %{_mandir}/man3/SHA224*.3*
591 %{_mandir}/man3/SHA256*.3*
592 %{_mandir}/man3/SHA384*.3*
593 %{_mandir}/man3/SHA512*.3*
594 %{_mandir}/man3/SMIME_*.3*
595 %{_mandir}/man3/SSL_*.3*
596 %{_mandir}/man3/SSLv23_*.3*
597 %{_mandir}/man3/SSLv3_*.3*
598 %{_mandir}/man3/SXNET_*.3*
599 %{_mandir}/man3/SXNETID_*.3*
600 %{_mandir}/man3/TLS_*.3*
601 %{_mandir}/man3/TLSv1_*.3*
602 %{_mandir}/man3/TS_*.3*
603 %{_mandir}/man3/UI*.3*
604 %{_mandir}/man3/USERNOTICE_*.3*
605 %{_mandir}/man3/X509_*.3*
606 %{_mandir}/man3/X509V3_*.3*
607 %{_mandir}/man3/X509v3_*.3*
608 %{_mandir}/man3/custom_ext_*.3*
609 %{_mandir}/man3/d2i_*.3*
610 %{_mandir}/man3/i2d_*.3*
611 %{_mandir}/man3/i2o_*.3*
612 %{_mandir}/man3/i2t_*.3*
613 %{_mandir}/man3/lh_TYPE_*.3*
614 %{_mandir}/man3/o2i_*.3*
615 %{_mandir}/man3/pem_password_cb.3*
616 %{_mandir}/man3/sk_TYPE_*.3*
617 %{_mandir}/man3/ssl_ct_validation_cb.3*
618 %{_mandir}/man7/openssl.7*
619 %{_mandir}/man7/openssl-bio.7*
620 %{_mandir}/man7/openssl-crypto.7*
621 %{_mandir}/man7/openssl-ct.7*
622 %{_mandir}/man7/openssl-des_modes.7*
623 %{_mandir}/man7/openssl-Ed25519.7*
624 %{_mandir}/man7/openssl-Ed448.7*
625 %{_mandir}/man7/openssl-evp.7*
626 %{_mandir}/man7/openssl-passphrase-encoding.7*
627 %{_mandir}/man7/openssl-RAND.7*
628 %{_mandir}/man7/openssl-RAND_DRBG.7*
629 %{_mandir}/man7/openssl-scrypt.7*
630 %{_mandir}/man7/openssl-SM2.7*
631 %{_mandir}/man7/openssl-ssl.7*
632 %{_mandir}/man7/openssl-X25519.7*
633 %{_mandir}/man7/openssl-X448.7*
634 %{_mandir}/man7/openssl-x509.7*
635 %{_mandir}/man7/ossl_store.7*
636 %{_mandir}/man7/ossl_store-file.7*
637 %{_mandir}/man7/proxy-certificates.7*
638 %{_mandir}/man7/RSA-PSS.7.gz
639
640 %files static
641 %defattr(644,root,root,755)
642 %{_libdir}/libcrypto.a
643 %{_libdir}/libssl.a
This page took 0.061975 seconds and 3 git commands to generate.