]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
08450e254edd39433b23cddb9c9daee5575d5a02
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary
4 Summary(fr):    Utilitaires de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.6
7 Release:        4
8 Group:          Libraries
9 Group(de):      Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-perl.patch
14 Patch1:         %{name}-alpha-ccc.patch
15 Vendor:         The OpenSSL Project
16 License:        Apache-style License
17 BuildRequires:  perl
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      SSLeay
20 Obsoletes:      SSLeay-devel
21 Obsoletes:      SSLeay-perl
22
23 %description
24 The OpenSSL Project is a collaborative effort to develop a robust,
25 commercial-grade, full-featured, and Open Source toolkit implementing
26 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
27 v1) protocols with full-strength cryptography world-wide. The project
28 is managed by a worldwide community of volunteers that use the
29 Internet to communicate, plan, and develop the OpenSSL tookit and its
30 related documentation.
31
32 OpenSSL is based on the excellent SSLeay library developed by Eric A.
33 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
34 Apache-style licence, which basically means that you are free to get
35 and use it for commercial and non-commercial purposes subject to some
36 simple license conditions.
37
38 This package contains shared libraries only, install openssl-tools if
39 you want to use openssl cmdline tool.
40
41 %description -l de
42 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
43 libraries, die verschiedene Verschlüsselungs- und
44 Entschlüsselungsalgorithmen und
45 - -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
46
47 %description -l fr
48 OpenSSL est un outiil de gestion des certificats et les librairies
49 partagees qui fournit plusieurs protocoles et algorithmes de
50 codage/decodage, incluant DES, RC4, RSA et SSL.
51
52 %package tools
53 Summary:        OpenSSL command line tool and utilities
54 Group:          Applications/Communications
55 Group(de):      Applikationen/Kommunikation
56 Group(pl):      Aplikacje/Komunikacja
57 Requires:       %{name} = %{version}
58
59 %description tools
60 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
61
62 %package tools-perl
63 Summary:        OpenSSL utilities written in Perl
64 Group:          Applications/Communications
65 Group(de):      Applikationen/Kommunikation
66 Group(fr):      Utilitaires
67 Group(pl):      Aplikacje/Komunikacja
68 Requires:       %{name} = %{version}
69
70 %description tools-perl
71 OpenSSL Toolkit tools written in Perl.
72
73 %package devel
74 Summary:        Development part of OpenSSL Toolkit libraries
75 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header
76 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL
77 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
78 Group:          Development/Libraries
79 Group(de):      Entwicklung/Libraries
80 Group(fr):      Development/Librairies
81 Group(pl):      Programowanie/Biblioteki
82 Requires:       %{name} = %{version}
83
84 %description devel
85 Development part of OpenSSL library.
86
87 %description devel -l pl
88 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
89
90 %package static
91 Summary:        Static OpenSSL libraries
92 Summary(pl):    Statyczne wersje bibliotek z OpenSSL
93 Group:          Development/Libraries
94 Group(de):      Entwicklung/Libraries
95 Group(fr):      Development/Librairies
96 Group(pl):      Programowanie/Biblioteki
97 Requires:       %{name}-devel = %{version}
98
99 %description static
100 Static OpenSSL Toolkit libraries.
101
102 %description static -l pl
103 Statyczne wersje bibliotek z OpenSSL.
104
105 %prep
106 %setup -q 
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 for i in Configure Makefile.org ; do
112         perl -pi -e 's#-m486##g' $i
113         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
114 done
115 touch Makefile.*
116
117 perl util/perlpath.pl %{_bindir}/perl
118
119 %ifarch i386 i486
120 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared 386
121 %endif
122 %ifarch i586 i686
123 ./Configure --openssldir=%{_var}/lib/%{name} linux-elf shared
124 %endif
125 %ifarch ppc
126 ./Configure --openssldir=%{_var}/lib/%{name} linux-ppc shared
127 %endif
128 %ifarch alpha
129 ./Configure --openssldir=%{_var}/lib/%{name} threads linux-alpha+bwx-ccc-generic
130 %endif
131
132 %{__make} OPT_FLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g} -DSSL_ALLOW_DH"
133 %{__make} INSTALLTOP=%{_prefix} \
134         OPT_FLAGS="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-O -g}"
135 %ifarch alpha
136 %{__make} linux-shared
137 %endif
138 %{__make} rehash
139
140 # Conv PODs to man pages. "openssl_" prefix is added to each manpage 
141 # to avoid potential conflicts with others packages.
142 center="OpenSSL 0.9.6"
143 rel="OpenSSL 0.9.6"
144
145 cd doc/apps || exit 1 
146 perl -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
147
148 for pod in *.pod; do 
149     if [ $pod != "openssl.pod" ]; then
150         mv -f $pod openssl_$pod;
151         pod=openssl_$pod;
152     fi
153
154     sec=1
155     if [ $pod = "openssl_config.pod" ]; then
156         sec=5
157     fi
158
159     manpage=`basename $pod .pod`.$sec;      
160     pod2man --section="$sec" --release="$rel" --center="$center" \
161             $pod > $manpage;
162     echo "$manpage";
163 done
164 cd ..
165
166 sec=3
167 for dir in ssl crypto; do 
168         cd $dir || exit 1;
169         if [ $dir = "ssl" ]; then
170                 rel="OpenSSL SSL/TLS library"
171         elif [ $dir = "crypto" ]; then 
172                 rel="OpenSSL cryptographic library"
173         fi
174         
175         perl -p -i -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
176         
177         for pod in *.pod; do 
178             sec=`[ "$pod" = "des_modes.pod" ] && echo 7 || echo 3`;     
179             mv -f $pod openssl_$pod;
180             pod=openssl_$pod;
181             manpage=`basename $pod .pod`.$sec;
182             pod2man --section="$sec" --release="$rel" --center=" " $pod > $manpage;
183             echo "$manpage";
184         done
185         cd ..
186 done
187
188 #cd perl
189 #perl Makefile.PL
190 #make
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
195            $RPM_BUILD_ROOT%{_mandir}/man{1,3,5,7}
196
197 %{__make} install \
198         INSTALLTOP=%{_prefix} \
199         INSTALL_PREFIX=$RPM_BUILD_ROOT
200
201 install libRSAglue.a libcrypto.a libssl.a       $RPM_BUILD_ROOT%{_libdir}
202 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
203 cp -df  lib*.so         $RPM_BUILD_ROOT%{_libdir}
204
205 #cd perl
206 #make install DESTDIR=$RPM_BUILD_ROOT
207 #cd ..
208
209 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
210 ln -s ../../../%{_sysconfdir}/%{name}/openssl.cnf \
211         $RPM_BUILD_ROOT%{_var}/lib/%{name}/%{name}.cnf
212
213 mv -f $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc/*  $RPM_BUILD_ROOT%{_libdir}/%{name}
214 rm -rf $RPM_BUILD_ROOT%{_var}/lib/%{name}/misc
215
216 mv -f $RPM_BUILD_ROOT%{_bindir}/c_rehash $RPM_BUILD_ROOT%{_libdir}/%{name}
217
218 find $RPM_BUILD_ROOT%{_mandir} -type f | xargs rm -f
219 install doc/apps/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
220 install doc/apps/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
221 install doc/ssl/*.3 doc/crypto/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
222 install doc/crypto/*.7 $RPM_BUILD_ROOT%{_mandir}/man7
223
224 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
225
226 %post   -p /sbin/ldconfig
227 %postun -p /sbin/ldconfig
228
229 %clean
230 rm -rf $RPM_BUILD_ROOT
231
232 %files
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/lib*.so.*.*
235 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
236 %doc doc/*.txt.gz doc/openssl_button.gif doc/openssl_button.html
237
238 %files tools
239 %defattr(644,root,root,755)
240 %dir %{_sysconfdir}/%{name}
241 %dir %{_var}/lib/%{name}
242 %dir %{_var}/lib/%{name}/private
243 %dir %{_var}/lib/%{name}/certs
244 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/%{name}/openssl.cnf
245 %verify(not md5 size mtime) %config(noreplace) %{_var}/lib/%{name}/openssl.cnf
246
247 %attr(755,root,root) %{_bindir}/%{name}
248 %dir %{_libdir}/%{name}
249 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
250 %attr(755,root,root) %{_libdir}/%{name}/c_hash
251 %attr(755,root,root) %{_libdir}/%{name}/c_rehash
252 %attr(755,root,root) %{_libdir}/%{name}/c_info
253 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
254 %attr(755,root,root) %{_libdir}/%{name}/c_name
255
256 %{_mandir}/man1/openssl.1*
257 %{_mandir}/man1/openssl_asn1parse.1*
258 %{_mandir}/man1/openssl_ca.1*
259 %{_mandir}/man1/openssl_ciphers.1*
260 %{_mandir}/man1/openssl_crl.1*
261 %{_mandir}/man1/openssl_crl2pkcs7.1*
262 %{_mandir}/man1/openssl_dgst.1*
263 %{_mandir}/man1/openssl_dhparam.1*
264 %{_mandir}/man1/openssl_dsa.1*
265 %{_mandir}/man1/openssl_dsaparam.1*
266 %{_mandir}/man1/openssl_enc.1*
267 %{_mandir}/man1/openssl_gendsa.1*
268 %{_mandir}/man1/openssl_genrsa.1*
269 %{_mandir}/man1/openssl_nseq.1*
270 %{_mandir}/man1/openssl_passwd.1*
271 %{_mandir}/man1/openssl_pkcs12.1*
272 %{_mandir}/man1/openssl_pkcs7.1*
273 %{_mandir}/man1/openssl_pkcs8.1*
274 %{_mandir}/man1/openssl_rand.1*
275 %{_mandir}/man1/openssl_req.1*
276 %{_mandir}/man1/openssl_rsa.1*
277 %{_mandir}/man1/openssl_s_client.1*
278 %{_mandir}/man1/openssl_s_server.1*
279 %{_mandir}/man1/openssl_sess_id.1*
280 %{_mandir}/man1/openssl_smime.1*
281 %{_mandir}/man1/openssl_speed.1*
282 %{_mandir}/man1/openssl_spkac.1*
283 %{_mandir}/man1/openssl_verify.1*
284 %{_mandir}/man1/openssl_version.1*
285 %{_mandir}/man1/openssl_x509.1*
286 %{_mandir}/man5/*.5*
287
288 %files tools-perl
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
291 %attr(755,root,root) %{_libdir}/%{name}/der_chop
292 %{_mandir}/man1/openssl_CA.pl.1*
293
294 %files devel
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{_libdir}/lib*.so
297 %{_includedir}/%{name}
298 %{_mandir}/man3/*.3*
299
300 %files static
301 %defattr(644,root,root,755)
302 %{_libdir}/lib*.a
This page took 0.074101 seconds and 3 git commands to generate.