]> git.pld-linux.org Git - packages/openssh.git/commitdiff
Rel 5; add upstream official fixes for stable release (https://lists.mindrot.org...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 Mar 2022 18:18:29 +0000 (19:18 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 16 Mar 2022 18:18:29 +0000 (19:18 +0100)
branch.sh [new file with mode: 0755]
openssh.spec

diff --git a/branch.sh b/branch.sh
new file mode 100755 (executable)
index 0000000..bf68940
--- /dev/null
+++ b/branch.sh
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+# https://lists.mindrot.org/pipermail/openssh-unix-dev/2022-March/040086.html
+
+set -e
+url=https://github.com/openssh/openssh-portable.git
+package=openssh
+tag=V_8_9_P1
+branch=V_8_9
+out=$package-git.patch
+repo=$package.git
+
+# use filterdiff, etc to exclude bad chunks from diff
+filter() {
+       cat
+}
+
+if [ ! -d $repo ]; then
+       git clone --bare $url -b $branch $repo
+fi
+
+cd $repo
+       git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
+       git log -p --reverse $tag..$branch ":(exclude)doc/doc-*" ":(exclude)test" ":(exclude).*" | filter > ../$out.tmp
+cd ..
+
+if cmp -s $out{,.tmp}; then
+       echo >&2 "No new diffs..."
+       rm -f $out.tmp
+       exit 0
+fi
+mv -f $out{.tmp,}
+
+../md5 $package.spec
+../dropin $out
index 7418f99ee257f130990bef2e4ca3403de971c9e7..2a095016ba3cc546e8c4999e88e94b4519755272 100644 (file)
@@ -37,7 +37,7 @@ Summary(ru.UTF-8):    OpenSSH - свободная реализация прото
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
 Version:       8.9p1
-Release:       4
+Release:       5
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
@@ -55,6 +55,8 @@ Source9:      sshd.service
 Source10:      sshd-keygen
 Source11:      sshd.socket
 Source12:      sshd@.service
+Patch100:      %{name}-git.patch
+# Patch100-md5: xyz
 Patch0:                %{name}-no-pty-tests.patch
 Patch1:                %{name}-tests-reuseport.patch
 Patch2:                %{name}-pam_misc.patch
@@ -540,6 +542,8 @@ openldap-a.
 
 %prep
 %setup -q
+%patch100 -p1
+
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
This page took 0.036452 seconds and 4 git commands to generate.