]> git.pld-linux.org Git - packages/openssh.git/commitdiff
Up to 8.7p1 auto/th/openssh-8.7p1-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 20 Aug 2021 20:07:33 +0000 (22:07 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 20 Aug 2021 20:07:33 +0000 (22:07 +0200)
openssh-chroot.patch
openssh-config.patch
openssh-ldap.patch
openssh-sigpipe.patch
openssh.spec

index b6a1ebb41ca0879c69256809d8b1c96c5c8b020a..694b95edd0282a610d4a9ed77dea6f4874457ded 100644 (file)
@@ -52,7 +52,7 @@ diff -urNp -x '*.orig' openssh-8.4p1.org/servconf.c openssh-8.4p1/servconf.c
 +
        /* Standard Options */
        case sBadOption:
-               return -1;
+               goto out;
 diff -urNp -x '*.orig' openssh-8.4p1.org/servconf.h openssh-8.4p1/servconf.h
 --- openssh-8.4p1.org/servconf.h       2020-09-27 09:25:01.000000000 +0200
 +++ openssh-8.4p1/servconf.h   2021-03-01 11:30:33.637508395 +0100
@@ -112,7 +112,7 @@ diff -urNp -x '*.orig' openssh-8.4p1.org/sshd_config openssh-8.4p1/sshd_config
 --- openssh-8.4p1.org/sshd_config      2021-03-01 11:30:33.370827964 +0100
 +++ openssh-8.4p1/sshd_config  2021-03-01 11:30:33.637508395 +0100
 @@ -85,6 +85,10 @@ GSSAPIAuthentication yes
- # and ChallengeResponseAuthentication to 'no'.
+ # and KbdInteractiveAuthentication to 'no'.
  UsePAM yes
  
 +# Set this to 'yes' to enable support for chrooted user environment.
index b6bf85388788b92d625dac184590cfedb9e4792d..b1d84cc2bec1bdb67dcbcdafcc24ab9f5aa90bb3 100644 (file)
@@ -54,7 +54,7 @@ diff -urNp -x '*.orig' openssh-8.4p1.org/sshd_config openssh-8.4p1/sshd_config
 +## PubkeyAcceptedKeyTypes +ssh-dss
 +
  # Change to no to disable s/key passwords
- #ChallengeResponseAuthentication yes
+ #KbdInteractiveAuthentication yes
  
 @@ -69,6 +72,7 @@ AuthorizedKeysFile   .ssh/authorized_keys
  # GSSAPI options
@@ -67,7 +67,7 @@ diff -urNp -x '*.orig' openssh-8.4p1.org/sshd_config openssh-8.4p1/sshd_config
 @@ -79,10 +83,12 @@ AuthorizedKeysFile .ssh/authorized_keys
  # If you just want the PAM account and session checks to run without
  # PAM authentication, then enable this but set PasswordAuthentication
- # and ChallengeResponseAuthentication to 'no'.
+ # and KbdInteractiveAuthentication to 'no'.
 -#UsePAM no
 +UsePAM yes
  
index 4585cbe4cd0ca92458a0a9c5cfb2bcd5fc79eea0..86a708969e90133be9b378b4042bf4b1b1543078 100644 (file)
@@ -137,7 +137,7 @@ diff -urNp -x '*.orig' openssh-8.4p1.org/Makefile.in openssh-8.4p1/Makefile.in
        ssh-xmss.o \
 @@ -150,8 +153,8 @@ SFTPSERVER_OBJS=sftp-common.o sftp-serve
  
- SFTP_OBJS=    sftp.o sftp-client.o sftp-common.o sftp-glob.o progressmeter.o
+ SFTP_OBJS=    sftp.o progressmeter.o $(SFTP_CLIENT_OBJS)
  
 -MANPAGES      = moduli.5.out scp.1.out ssh-add.1.out ssh-agent.1.out ssh-keygen.1.out ssh-keyscan.1.out ssh.1.out sshd.8.out sftp-server.8.out sftp.1.out ssh-keysign.8.out ssh-pkcs11-helper.8.out ssh-sk-helper.8.out sshd_config.5.out ssh_config.5.out
 -MANPAGES_IN   = moduli.5 scp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 ssh.1 sshd.8 sftp-server.8 sftp.1 ssh-keysign.8 ssh-pkcs11-helper.8 ssh-sk-helper.8 sshd_config.5 ssh_config.5
index 244b1774eeb34d62e515221c540addad5af11290..6d6b8fcecf66f77877678c1eafdf47776d0d1026 100644 (file)
@@ -60,8 +60,8 @@ diff -urNp -x '*.orig' openssh-8.4p1.org/ssh.c openssh-8.4p1/ssh.c
 --- openssh-8.4p1.org/ssh.c    2020-09-27 09:25:01.000000000 +0200
 +++ openssh-8.4p1/ssh.c        2021-03-01 11:29:10.909905265 +0100
 @@ -190,6 +190,9 @@ struct sshbuf *command;
- /* Should we execute a command or invoke a subsystem? */
int subsystem_flag = 0;
+ /* command to be executed */
struct sshbuf *command;
  
 +/* Enable sigpipe */
 +int enable_sigpipe = 0;
index ea8c44f5c8f12a96d2413101f74f4715c44be16a..2de3d0cbcd591b0145d0bb5b18963237533d5a82 100644 (file)
@@ -36,13 +36,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       8.6p1
+Version:       8.7p1
 Release:       1
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: 805f7048aec6dd752584e570383a6f00
+# Source0-md5: f545230799f131aecca04da56e61990a
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
This page took 0.194595 seconds and 4 git commands to generate.