]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- added blacklist.sshd
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2.2
4 Release:        1
5 License:        BSD
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Source0:        http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
9 Source1:        opensshd.conf
10 Source2:        openssh.conf
11 Source3:        opensshd.init
12 Source4:        opensshd.pamd
13 Source5:        openssh.sysconfig
14 Source6:        passwd.pamd
15 Patch0:         openssh-PAM_NEW_AUTHTOK.patch
16 Patch1:         openssh-libwrap.patch
17 BuildRequires:  openssl-devel >= 0.9.4-2
18 BuildRequires:  zlib-devel
19 BuildRequires:  pam-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  gnome-libs-devel
22 BuildRoot:      /tmp/%{name}-%{version}-root
23 Obsoletes:      ssh < %{version}, ssh > %{version}
24
25 %define         _sysconfdir     /etc/ssh
26
27 %description
28 Ssh (Secure Shell) a program for logging into a remote machine and for
29 executing commands in a remote machine. It is intended to replace rlogin and
30 rsh, and provide secure encrypted communications between two untrusted hosts
31 over an insecure network. X11 connections and arbitrary TCP/IP ports can
32 also be forwarded over the secure channel.
33
34 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
35 to date in terms of security and features, as well as removing all patented
36 algorithms to seperate libraries (OpenSSL).
37
38 This package includes the core files necessary for both the OpenSSH
39 client and server. To make this package useful, you should also
40 install openssh-clients, openssh-server, or both.
41
42 %package clients
43 Summary:        OpenSSH Secure Shell protocol clients
44 Requires:       openssh
45 Group:          Applications/Networking
46 Group(pl):      Aplikacje/Sieciowe
47 Obsoletes:      ssh-clients < %{version}, ssh-clients > %{version}
48 Requires:       %{name} = %{version}
49
50 %description clients
51 Ssh (Secure Shell) a program for logging into a remote machine and for
52 executing commands in a remote machine. It is intended to replace rlogin and
53 rsh, and provide secure encrypted communications between two untrusted hosts
54 over an insecure network. X11 connections and arbitrary TCP/IP ports can
55 also be forwarded over the secure channel.
56
57 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
58 to date in terms of security and features, as well as removing all patented
59 algorithms to seperate libraries (OpenSSL).
60
61 This package includes the clients necessary to make encrypted connections to
62 SSH servers.
63
64 %package server
65 Summary:        OpenSSH Secure Shell protocol server (sshd)
66 Requires:       openssh chkconfig >= 0.9
67 Group:          Networking/Daemons
68 Group(pl):      Sieciowe/Serwery
69 Obsoletes:      ssh-server < %{version}, ssh-server > %{version}
70 Requires:       rc-scripts
71 Requires:       /bin/login
72 Requires:       util-linux
73 Prereq:         %{name} = %{version}
74
75 %description server
76 Ssh (Secure Shell) a program for logging into a remote machine and for
77 executing commands in a remote machine. It is intended to replace rlogin and
78 rsh, and provide secure encrypted communications between two untrusted hosts
79 over an insecure network. X11 connections and arbitrary TCP/IP ports can
80 also be forwarded over the secure channel.
81
82 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
83 to date in terms of security and features, as well as removing all patented
84 algorithms to seperate libraries (OpenSSL).
85
86 This package contains the secure shell daemon. The sshd is the server part
87 of the secure shell protocol and allows ssh clients to connect to your host.
88
89 %package gnome-askpass
90 Summary:        OpenSSH GNOME passphrase dialog
91 Group:          Applications/Networking
92 Group(pl):      Aplikacje/Sieciowe
93 Requires:       %{name} = %{version}
94 Obsoletes:      ssh-extras < %{version}, ssh-extras > %{version}
95 Obsoletes:      ssh-askpass < %{version}, ssh-askpass > %{version}
96 Obsoletes:      openssh-askpass < %{version}, openssh-askpass > %{version}
97
98 %description gnome-askpass
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine. It is intended to replace rlogin
101 and rsh, and provide secure encrypted communications between two untrusted
102 hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
103 can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
106 to date in terms of security and features, as well as removing all patented
107 algorithms to seperate libraries (OpenSSL).
108
109 This package contains the GNOME passphrase dialog.
110
111 %prep
112 %setup  -q
113 %patch0 -p1
114 %patch1 -p0
115
116 %build
117 autoconf
118 %configure \
119         --with-gnome-askpass \
120         --with-tcp-wrappers \
121         --with-md5-passwords \
122         --enable-ipv6 \
123         --with-ipaddr-display \
124         --enable-log-auth 
125         
126 #       --without-kerberos4 \
127 #       --without-afs \
128 #       --without-skey 
129
130 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
131
132 make
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
138
139 make install DESTDIR="$RPM_BUILD_ROOT"
140
141 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
142 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
143 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
144 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
145 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
146 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
147
148 mv -f   $RPM_BUILD_ROOT%{_libexecdir}/ssh/gnome-ssh-askpass \
149         $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
150
151 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
152         $RPM_BUILD_ROOT/%{_mandir}/man*/*
153
154 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
155         
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post server
160 /sbin/chkconfig --add sshd
161 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
162         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
163 fi
164 if [ ! -f /var/lock/subsys/sshd ]; then
165         /etc/rc.d/init.d/sshd restart >&2
166 fi
167 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
168         echo "ssh" >> /etc/security/passwd.conf
169 fi
170
171 %preun server
172 if [ "$1" = 0 ]; then
173         if [ ! -f /var/lock/subsys/sshd ]; then
174                 /etc/rc.d/init.d/sshd stop >&2
175         fi
176         /sbin/chkconfig --del sshd
177 fi
178
179 %files
180 %defattr(644,root,root,755)
181 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
182 %attr(755,root,root) %{_bindir}/ssh-keygen
183 %{_mandir}/man1/ssh-keygen.1*
184 %dir %{_sysconfdir}
185
186 %files clients
187 %defattr(644,root,root,755)
188 # suid root ?
189 #%attr(4755,root,root) %{_bindir}/ssh
190 %attr(0755,root,root) %{_bindir}/ssh
191 %attr(0755,root,root) %{_bindir}/ssh-agent
192 %attr(0755,root,root) %{_bindir}/ssh-add
193 #%attr(0755,root,root) %{_bindir}/slogin
194 %attr(755,root,root) %{_bindir}/scp
195 %{_mandir}/man1/scp.1*
196 %{_mandir}/man1/ssh.1*
197 %{_mandir}/man1/ssh-agent.1*
198 %{_mandir}/man1/ssh-add.1*
199 #%{_mandir}/man1/slogin.1
200 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
201
202 %files server
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_sbindir}/sshd
205 %{_mandir}/man8/sshd.8*
206 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
207 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
208 %attr(754,root,root) /etc/rc.d/init.d/sshd
209 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
210 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
211
212 %files gnome-askpass
213 %defattr(644,root,root,755)
214 %dir %{_libexecdir}/ssh
215 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.046355 seconds and 4 git commands to generate.