]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- shit
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 Summary:        OpenSSH free Secure Shell (SSH) implementation
20 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
21 Summary(es):    Implementación libre de SSH
22 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
23 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
24 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
25 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
26 Summary(pt_BR): Implementação livre do SSH
27 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
28 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
29 Name:           openssh
30 Version:        4.3p1
31 Release:        3%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
32 Epoch:          2
33 License:        BSD
34 Group:          Applications/Networking
35 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
36 # Source0-md5:  eaeb880b1b6c63b9a4d7c5b1e74727c4
37 Source1:        %{name}d.conf
38 Source2:        %{name}.conf
39 Source3:        %{name}d.init
40 Source4:        %{name}d.pamd
41 Source5:        %{name}.sysconfig
42 Source6:        passwd.pamd
43 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
44 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
45 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
46 # NoSource9-md5:        e1c3cbed88f08ea778d90813d48cd428
47 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
48 # NoSource10-md5:       ec74f3e3b2ea3a7dc84c7988235b6fcf
49 Source11:       ssh-agent.sh
50 Source12:       ssh-agent.conf
51 Patch0:         %{name}-no_libnsl.patch
52 Patch2:         %{name}-linux-ipv6.patch
53 Patch3:         %{name}-pam_misc.patch
54 Patch4:         %{name}-sigpipe.patch
55 # http://www.opendarwin.org/projects/openssh-lpk/
56 Patch5:         %{name}-lpk-4.1p1-0.3.6.patch
57 Patch6:         %{name}-heimdal.patch
58 Patch7:         %{name}-pam-conv.patch
59 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
60 Patch8:         %{name}-chroot.patch
61 Patch9:         %{name}-selinux.patch
62 Patch10:        %{name}-selinux-pld.patch
63 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/ 
64 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
65 Patch11:        %{name}-4.2p1-hpn11.patch
66 # Adds HPN (see p11) and an undocumented -z none cipher flag
67 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
68 Patch12:        %{name}-4.2p1-hpn11-none.patch
69 Patch13:        %{name}-include.patch
70 URL:            http://www.openssh.com/
71 BuildRequires:  autoconf
72 BuildRequires:  automake
73 %{?with_gnome:BuildRequires:    gnome-libs-devel}
74 %{?with_gtk:BuildRequires:      gtk+2-devel}
75 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
76 %{?with_libedit:BuildRequires:  libedit-devel}
77 %{?with_selinux:BuildRequires:  libselinux-devel}
78 BuildRequires:  libwrap-devel
79 %{?with_ldap:BuildRequires:     openldap-devel}
80 BuildRequires:  openssl-devel >= 0.9.7d
81 BuildRequires:  pam-devel
82 BuildRequires:  %{__perl}
83 %{?with_gtk:BuildRequires:      pkgconfig}
84 BuildRequires:  rpmbuild(macros) >= 1.202
85 BuildRequires:  zlib-devel
86 Requires:       FHS >= 2.1-24
87 Requires:       pam >= 0.79.0
88 Obsoletes:      ssh
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         _sysconfdir     /etc/ssh
92 %define         _libexecdir     %{_libdir}/%{name}
93 %define         _privsepdir     /usr/share/empty
94
95 %description
96 Ssh (Secure Shell) a program for logging into a remote machine and for
97 executing commands in a remote machine. It is intended to replace
98 rlogin and rsh, and provide secure encrypted communications between
99 two untrusted hosts over an insecure network. X11 connections and
100 arbitrary TCP/IP ports can also be forwarded over the secure channel.
101
102 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
103 it up to date in terms of security and features, as well as removing
104 all patented algorithms to seperate libraries (OpenSSL).
105
106 This package includes the core files necessary for both the OpenSSH
107 client and server. To make this package useful, you should also
108 install openssh-clients, openssh-server, or both.
109 %if %{with hpn} || %{with hpn_none}
110 This release includes High Performance SSH/SCP patches from 
111 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed 
112 to increase throughput on fast connections with high RTT (20-150 msec).
113 See the website for '-w' values for your connection and /proc/sys TCP
114 values. BTW. in a LAN you have got generally RTT < 1 msec.
115 %endif
116 %if %{with hpn_none}
117 It also includes an undocumented '-z' option which switches
118 the cipher to none after authentication is completed. Data is 
119 still secured from tampering and corruption in transit through 
120 the use of the Message Authentication Code (MAC).
121 This option will significantly reduce the number of cpu cycles used 
122 by the SSH/SCP process. This may allow some users to see significant 
123 improvement in (sniffable) data tranfer rates. 
124 %endif
125
126 %description -l de
127 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
128 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
129 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
130 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
131 andere TCP/IP Ports können ebenso über den sicheren Channel
132 weitergeleitet werden.
133
134 %description -l es
135 SSH es un programa para accesar y ejecutar órdenes en computadores
136 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
137 seguro entre dos servidores en una red insegura. Conexiones X11 y
138 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
139 seguro.
140
141 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
142 continuar la última versión gratuita de SSH, actualizándolo en
143 términos de seguridad y recursos,así también eliminando todos los
144 algoritmos patentados y colocándolos en bibliotecas separadas
145 (OpenSSL).
146
147 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
148 también el paquete openssh-clients u openssh-server o ambos.
149
150 %description -l fr
151 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
152 remplace telnet, rlogin, rexec et rsh, tout en assurant des
153 communications cryptées securisées entre deux hôtes non fiabilisés sur
154 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
155 arbitraires peuvent également être transmis sur le canal sécurisé.
156
157 %description -l it
158 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
159 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
160 sicure e crittate tra due host non fidati su una rete non sicura. Le
161 connessioni X11 ad una porta TCP/IP arbitraria possono essere
162 inoltrate attraverso un canale sicuro.
163
164 %description -l pl
165 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
166 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
167 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
168 pomiêdzy dwoma hostami.
169
170 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
171 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
172 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
173 %if %{with hpn} || %{with hpn_none}
174 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP 
175 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
176 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ 
177 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na 
178 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz 
179 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.  
180 %endif
181 %if %{with hpn_none}
182 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
183 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
184 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez 
185 stosowanie Message Authentication Code (MAC).
186 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez 
187 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ 
188 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych. 
189 %endif
190
191 %description -l pt
192 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
193 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
194 cifradas entre duas máquinas sem confiança mútua sobre uma rede
195 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
196 reenviados pelo canal seguro.
197
198 %description -l pt_BR
199 SSH é um programa para acessar e executar comandos em máquinas
200 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
201 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
202 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
203
204 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
205 última versão gratuita do SSH, atualizando-o em termos de segurança e
206 recursos, assim como removendo todos os algoritmos patenteados e
207 colocando-os em bibliotecas separadas (OpenSSL).
208
209 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
210 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
211
212 %description -l ru
213 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
214 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
215 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
216 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
217 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
218 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
219
220 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
221 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
222 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
223 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
224
225 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
226 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
227 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
228
229 %description -l uk
230 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
231 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
232 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
233 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
234 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
235 ËÁÎÁÌ.
236
237 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
238 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
239 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
240 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
241
242 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
243 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
244 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
245
246 %package clients
247 Summary:        OpenSSH Secure Shell protocol clients
248 Summary(es):    Clientes de OpenSSH
249 Summary(pl):    Klienci protoko³u Secure Shell
250 Summary(pt_BR): Clientes do OpenSSH
251 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
252 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
253 Group:          Applications/Networking
254 Requires:       %{name} = %{epoch}:%{version}-%{release}
255 %{?with_sshagentsh:Requires:    xinitrc}
256 Provides:       ssh-clients
257 Obsoletes:      ssh-clients
258
259 %description clients
260 Ssh (Secure Shell) a program for logging into a remote machine and for
261 executing commands in a remote machine. It is intended to replace
262 rlogin and rsh, and provide secure encrypted communications between
263 two untrusted hosts over an insecure network. X11 connections and
264 arbitrary TCP/IP ports can also be forwarded over the secure channel.
265
266 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
267 it up to date in terms of security and features, as well as removing
268 all patented algorithms to seperate libraries (OpenSSL).
269
270 This package includes the clients necessary to make encrypted
271 connections to SSH servers.
272
273 %description clients -l es
274 Este paquete incluye los clientes que se necesitan para hacer
275 conexiones codificadas con servidores SSH.
276
277 %description clients -l pl
278 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
279 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
280 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
281 pomiêdzy dwoma hostami.
282
283 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
284
285 %description clients -l pt_BR
286 Esse pacote inclui os clientes necessários para fazer conexões
287 encriptadas com servidores SSH.
288
289 %description clients -l ru
290 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
291 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
292
293 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
294 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
295
296 %description clients -l uk
297 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
298 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
299
300 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
301 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
302
303 %package server
304 Summary:        OpenSSH Secure Shell protocol server (sshd)
305 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
306 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
307 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
308 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
309 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
310 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
311 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
312 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
313 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
314 Group:          Networking/Daemons
315 Requires:       %{name} = %{epoch}:%{version}-%{release}
316 Requires:       rc-scripts >= 0.4.0.18
317 Requires(pre):  /bin/id
318 Requires(pre):  /usr/sbin/useradd
319 Requires(post,preun):   /sbin/chkconfig
320 Requires(post): chkconfig >= 0.9
321 Requires(post): grep
322 Requires(postun):       /usr/sbin/userdel
323 Requires:       /bin/login
324 Requires:       util-linux
325 Requires:       pam >= 0.77.3
326 Provides:       user(sshd)
327 Provides:       ssh-server
328
329 %description server
330 Ssh (Secure Shell) a program for logging into a remote machine and for
331 executing commands in a remote machine. It is intended to replace
332 rlogin and rsh, and provide secure encrypted communications between
333 two untrusted hosts over an insecure network. X11 connections and
334 arbitrary TCP/IP ports can also be forwarded over the secure channel.
335
336 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
337 it up to date in terms of security and features, as well as removing
338 all patented algorithms to seperate libraries (OpenSSL).
339
340 This package contains the secure shell daemon. The sshd is the server
341 part of the secure shell protocol and allows ssh clients to connect to
342 your host.
343
344 %description server -l de
345 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
346
347 %description server -l es
348 Este paquete contiene el servidor SSH. sshd es la parte servidor del
349 protocolo secure shell y permite que clientes ssh se conecten a su
350 servidor.
351
352 %description server -l fr
353 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
354
355 %description server -l it
356 Questo pacchetto installa sshd, il server di OpenSSH.
357
358 %description server -l pl
359 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
360 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
361 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
362 pomiêdzy dwoma hostami.
363
364 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
365 ssh).
366
367 %description server -l pt
368 Este pacote intala o sshd, o servidor do OpenSSH.
369
370 %description server -l pt_BR
371 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
372 protocolo secure shell e permite que clientes ssh se conectem ao seu
373 host.
374
375 %description server -l ru
376 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
377 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
378
379 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
380 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
381 ×ÁÛÉÍ ÈÏÓÔÏÍ.
382
383 %description server -l uk
384 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
385 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
386
387 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
388 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
389 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
390
391 %package gnome-askpass
392 Summary:        OpenSSH GNOME passphrase dialog
393 Summary(de):    OpenSSH GNOME Passwort-Dialog
394 Summary(es):    Diálogo para introducción de passphrase para GNOME
395 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
396 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
397 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
398 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
399 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
400 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
401 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
402 Group:          Applications/Networking
403 Requires:       %{name} = %{epoch}:%{version}-%{release}
404 Obsoletes:      ssh-extras
405 Obsoletes:      ssh-askpass
406 Obsoletes:      openssh-askpass
407
408 %description gnome-askpass
409 Ssh (Secure Shell) a program for logging into a remote machine and for
410 executing commands in a remote machine. It is intended to replace
411 rlogin and rsh, and provide secure encrypted communications between
412 two untrusted hosts over an insecure network. X11 connections and
413 arbitrary TCP/IP ports can also be forwarded over the secure channel.
414
415 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
416 it up to date in terms of security and features, as well as removing
417 all patented algorithms to seperate libraries (OpenSSL).
418
419 This package contains the GNOME passphrase dialog.
420
421 %description gnome-askpass -l es
422 Este paquete contiene un programa que abre una caja de diálogo para
423 entrada de passphrase en GNOME.
424
425 %description gnome-askpass -l pl
426 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
427 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
428 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
429 pomiêdzy dwoma hostami.
430
431 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
432
433 %description gnome-askpass -l pt_BR
434 Esse pacote contém um programa que abre uma caixa de diálogo para
435 entrada de passphrase no GNOME.
436
437 %description gnome-askpass -l ru
438 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
439 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
440
441 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
442 GNOME.
443
444 %description gnome-askpass -l uk
445 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
446 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
447
448 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
449 GNOME.
450
451 %prep
452 %setup -q
453 %patch0 -p1
454 %patch2 -p1
455 %patch3 -p1
456 %patch4 -p1
457 %{?with_ldap:%patch5 -p1}
458 %{?with_kerberos5:%patch6 -p1}
459 #%patch7 -p1
460 %patch8 -p1
461 %{?with_selinux:%patch9 -p1}
462 %{?with_selinux:%patch10 -p1}
463 %{?with_hpn:%patch11 -p1}
464 %{?with_hpn_none:%patch12 -p1}
465 %patch13 -p1
466
467 %build
468 cp %{_datadir}/automake/config.sub .
469 %{__aclocal}
470 %{__autoconf}
471 %{?with_chroot:CPPFLAGS="-DCHROOT"}
472 %configure \
473         PERL=%{__perl} \
474         --with-dns \
475         --with-pam \
476         --with-mantype=man \
477         --with-md5-passwords \
478         --with-ipaddr-display \
479         %{?with_libedit:--with-libedit} \
480         --with-4in6 \
481         --disable-suid-ssh \
482         --with-tcp-wrappers \
483         %{?with_ldap:--with-libs="-lldap -llber"} \
484         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
485         %{?with_kerberos5:--with-kerberos5} \
486         --with-privsep-path=%{_privsepdir} \
487         --with-pid-dir=%{_localstatedir}/run \
488         --with-xauth=/usr/bin/xauth
489
490 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
491
492 %{__make}
493
494 cp -f %{SOURCE9} .
495 cp -f %{SOURCE10} .
496 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
497
498 cd contrib
499 %if %{with gnome}
500 %{__make} gnome-ssh-askpass1 \
501         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
502 %endif
503 %if %{with gtk}
504 %{__make} gnome-ssh-askpass2 \
505         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
506 %endif
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
511         $RPM_BUILD_ROOT%{_libexecdir}/ssh
512 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
513
514 %{__make} install \
515         DESTDIR=$RPM_BUILD_ROOT
516
517 install connect    $RPM_BUILD_ROOT%{_bindir}
518 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
519 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
520 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
521 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
522 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
523 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
524 %if %{with sshagentsh}
525 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
526 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
527 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
528 %endif
529
530 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
531
532 %if %{with gnome}
533 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
534 %endif
535 %if %{with gtk}
536 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
537 %endif
538 %if %{with gnome} || %{with gtk}
539 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
540 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
541 EOF
542 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
543 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
544 EOF
545 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
546 %endif
547
548 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
549 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
550
551 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
552
553 %if "%{_lib}" != "lib"
554 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 perl -pi -e "s#/usr/lib#/usr/%{_lib}#"
555 %endif
556
557 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
558 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
559 EOF
560
561 %clean
562 rm -rf $RPM_BUILD_ROOT
563
564 %pre server
565 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
566
567 %post server
568 /sbin/chkconfig --add sshd
569 if [ -f /var/lock/subsys/sshd ]; then
570         /etc/rc.d/init.d/sshd restart 1>&2
571 else
572         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
573 fi
574 if ! grep -qs ssh /etc/security/passwd.conf ; then
575         umask 022
576         echo "ssh" >> /etc/security/passwd.conf
577 fi
578
579 %preun server
580 if [ "$1" = "0" ]; then
581         if [ -f /var/lock/subsys/sshd ]; then
582                 /etc/rc.d/init.d/sshd stop 1>&2
583         fi
584         /sbin/chkconfig --del sshd
585 fi
586
587 %postun server
588 if [ "$1" = "0" ]; then
589         %userremove sshd
590 fi
591
592 %files
593 %defattr(644,root,root,755)
594 %doc *.RNG TODO README OVERVIEW CREDITS Change*
595 %attr(755,root,root) %{_bindir}/ssh-key*
596 %{_mandir}/man1/ssh-key*.1*
597 %dir %{_sysconfdir}
598 %dir %{_libexecdir}
599
600 %files clients
601 %defattr(644,root,root,755)
602 %doc connect.html
603 %attr(755,root,root) %{_bindir}/connect
604 %attr(755,root,root) %{_bindir}/ssh
605 %attr(755,root,root) %{_bindir}/slogin
606 %attr(755,root,root) %{_bindir}/sftp
607 %attr(755,root,root) %{_bindir}/ssh-agent
608 %attr(755,root,root) %{_bindir}/ssh-add
609 %attr(755,root,root) %{_bindir}/scp
610 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
611 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
612 %if %{with sshagentsh}
613 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
614 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
615 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
616 %endif
617 %{_mandir}/man1/scp.1*
618 %{_mandir}/man1/ssh.1*
619 %{_mandir}/man1/slogin.1*
620 %{_mandir}/man1/sftp.1*
621 %{_mandir}/man1/ssh-agent.1*
622 %{_mandir}/man1/ssh-add.1*
623 %{_mandir}/man5/ssh_config.5*
624 %lang(it) %{_mandir}/it/man1/ssh.1*
625 %lang(it) %{_mandir}/it/man5/ssh_config.5*
626 %lang(pl) %{_mandir}/pl/man1/scp.1*
627 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
628
629 # for host-based auth (suid required for accessing private host key)
630 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
631 #%{_mandir}/man8/ssh-keysign.8*
632
633 %files server
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_sbindir}/sshd
636 %attr(755,root,root) %{_libexecdir}/sftp-server
637 %attr(755,root,root) %{_libexecdir}/ssh-keysign
638 %{_mandir}/man8/sshd.8*
639 %{_mandir}/man8/sftp-server.8*
640 %{_mandir}/man8/ssh-keysign.8*
641 %{_mandir}/man5/sshd_config.5*
642 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
643 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
644 %attr(640,root,root) %{_sysconfdir}/moduli
645 %attr(754,root,root) /etc/rc.d/init.d/sshd
646 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
647 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
648
649 %if %{with gnome} || %{with gtk}
650 %files gnome-askpass
651 %defattr(644,root,root,755)
652 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
653 %dir %{_libexecdir}/ssh
654 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
655 %attr(755,root,root) %{_libexecdir}/ssh-askpass
656 %endif
This page took 0.846502 seconds and 4 git commands to generate.