]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- fixed and uncommented PAM_NEW_AUTHTOK patch
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2.1pre24
4 Release:        2
5 Source0:        http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
6 Source1:        opensshd.conf
7 Source2:        openssh.conf
8 Source3:        opensshd.init
9 Source4:        opensshd.pamd
10 Source5:        openssh.sysconfig
11 Source6:        passwd.pamd
12 Patch1:         openssh-DESTDIR.patch
13 Patch2:         openssh-PAM_NEW_AUTHTOK.patch
14 Patch3:         http://www.misiek.eu.org/ipv6/openssh-1.2.1pre24-ipv6-03012000.patch.gz
15 License:        BSD
16 Group:          Applications/Networking
17 Group(pl):      Aplikacje/Sieciowe
18 BuildRequires:  openssl-devel >= 0.9.4-2
19 BuildRequires:  zlib-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRoot:      /tmp/%{name}-%{version}-root
24 Obsoletes:      ssh
25
26 %define         _sysconfdir     /etc/ssh
27
28 %description
29 Ssh (Secure Shell) a program for logging into a remote machine and for
30 executing commands in a remote machine.  It is intended to replace
31 rlogin and rsh, and provide secure encrypted communications between
32 two untrusted hosts over an insecure network.  X11 connections and
33 arbitrary TCP/IP ports can also be forwarded over the secure channel.
34
35 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
36 up to date in terms of security and features, as well as removing all 
37 patented algorithms to seperate libraries (OpenSSL).
38
39 This package includes the core files necessary for both the OpenSSH
40 client and server.  To make this package useful, you should also
41 install openssh-clients, openssh-server, or both.
42
43 %package clients
44 Summary:        OpenSSH Secure Shell protocol clients
45 Requires:       openssh
46 Group:          Applications/Networking
47 Group(pl):      Aplikacje/Sieciowe
48 Obsoletes:      ssh-clients
49 Requires:       %{name} = %{version}
50
51 %description clients
52 Ssh (Secure Shell) a program for logging into a remote machine and for
53 executing commands in a remote machine.  It is intended to replace
54 rlogin and rsh, and provide secure encrypted communications between
55 two untrusted hosts over an insecure network.  X11 connections and
56 arbitrary TCP/IP ports can also be forwarded over the secure channel.
57
58 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
59 up to date in terms of security and features, as well as removing all 
60 patented algorithms to seperate libraries (OpenSSL).
61
62 This package includes the clients necessary to make encrypted connections
63 to SSH servers.
64
65 %package server
66 Summary:        OpenSSH Secure Shell protocol server (sshd)
67 Requires:       openssh chkconfig >= 0.9
68 Group:          Networking/Daemons
69 Group(pl):      Sieciowe/Serwery
70 Obsoletes:      ssh-server
71 Requires:       rc-scripts
72 Prereq:         %{name} = %{version}
73
74 %description server
75 Ssh (Secure Shell) a program for logging into a remote machine and for
76 executing commands in a remote machine.  It is intended to replace
77 rlogin and rsh, and provide secure encrypted communications between
78 two untrusted hosts over an insecure network.  X11 connections and
79 arbitrary TCP/IP ports can also be forwarded over the secure channel.
80
81 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
82 up to date in terms of security and features, as well as removing all 
83 patented algorithms to seperate libraries (OpenSSL).
84
85 This package contains the secure shell daemon. The sshd is the server 
86 part of the secure shell protocol and allows ssh clients to connect to 
87 your host.
88
89 %package gnome-askpass
90 Summary:        OpenSSH GNOME passphrase dialog
91 Group:          Applications/Networking
92 Group(pl):      Aplikacje/Sieciowe
93 Requires:       %{name} = %{version}
94 Obsoletes:      ssh-extras
95 Obsoletes:      ssh-askpass
96 Obsoletes:      openssh-askpass
97
98 %description gnome-askpass
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine.  It is intended to replace
101 rlogin and rsh, and provide secure encrypted communications between
102 two untrusted hosts over an insecure network.  X11 connections and
103 arbitrary TCP/IP ports can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
106 up to date in terms of security and features, as well as removing all 
107 patented algorithms to seperate libraries (OpenSSL).
108
109 This package contains the GNOME passphrase dialog.
110
111
112 %prep
113 %setup  -q
114 %patch1 -p1
115 %patch2 -p1
116 %patch3 -p1
117
118 %build
119 autoconf
120 %configure \
121         --with-gnome-askpass \
122         --with-tcp-wrappers \
123         --with-md5-passwords \
124         --enable-ipv6 \
125         --enable-log-auth 
126         
127 #       --without-kerberos4 \
128 #       --without-afs \
129 #       --without-skey 
130
131 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
132
133 make
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
139
140 make install \
141         DESTDIR="$RPM_BUILD_ROOT"
142
143 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
144 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
145 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
146 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
147 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
148 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
149
150 mv -f   $RPM_BUILD_ROOT%{_libexecdir}/ssh/gnome-ssh-askpass \
151         $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
152
153 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
154         $RPM_BUILD_ROOT/%{_mandir}/man*/*
155         
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post server
160 /sbin/chkconfig --add sshd
161 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
162         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
163 fi
164 if test -r /var/run/sshd.pid
165 then
166         /etc/rc.d/init.d/sshd restart >&2
167 fi
168 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
169         echo "ssh" >> /etc/security/passwd.conf
170 fi
171
172 %preun server
173 if [ "$1" = 0 ]
174 then
175         /etc/rc.d/init.d/sshd stop >&2
176         /sbin/chkconfig --del sshd
177 fi
178
179 %files
180 %defattr(644,root,root,755)
181 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
182 %attr(755,root,root) %{_bindir}/ssh-keygen
183 %{_mandir}/man1/ssh-keygen.1*
184 %dir %{_sysconfdir}
185
186 %files clients
187 %defattr(644,root,root,755)
188 # suid root ?
189 #%attr(4755,root,root) %{_bindir}/ssh
190 %attr(0755,root,root) %{_bindir}/ssh
191 %attr(0755,root,root) %{_bindir}/ssh-agent
192 %attr(0755,root,root) %{_bindir}/ssh-add
193 #%attr(0755,root,root) %{_bindir}/slogin
194 %attr(755,root,root) %{_bindir}/scp
195 %{_mandir}/man1/scp.1*
196 %{_mandir}/man1/ssh.1*
197 %{_mandir}/man1/ssh-agent.1*
198 %{_mandir}/man1/ssh-add.1*
199 #%{_mandir}/man1/slogin.1
200 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
201
202 %files server
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_sbindir}/sshd
205 %{_mandir}/man8/sshd.8*
206 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
207 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
208 %attr(754,root,root) /etc/rc.d/init.d/sshd
209 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
210
211 %files gnome-askpass
212 %defattr(644,root,root,755)
213 %dir %{_libexecdir}/ssh
214 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.048171 seconds and 4 git commands to generate.