]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
fixes
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        2.1.0
4 Release:        1
5 License:        BSD
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
9 Source1:        opensshd.conf
10 Source2:        openssh.conf
11 Source3:        opensshd.init
12 Source4:        opensshd.pamd
13 Source5:        openssh.sysconfig
14 Source6:        passwd.pamd
15 Patch0:         openssh-PAM_NEW_AUTHTOK.patch
16 Patch1:         openssh-libwrap.patch
17 BuildRequires:  openssl-devel >= 0.9.4-2
18 BuildRequires:  rpm >= 3.0.4
19 BuildRequires:  zlib-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRequires:  gtk+-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25 Prereq:         openssl >= 0.9.4-2
26 Obsoletes:      ssh < %{version}, ssh > %{version}
27
28 %define         _sysconfdir     /etc/ssh
29
30 %description
31 Ssh (Secure Shell) a program for logging into a remote machine and for
32 executing commands in a remote machine. It is intended to replace rlogin and
33 rsh, and provide secure encrypted communications between two untrusted hosts
34 over an insecure network. X11 connections and arbitrary TCP/IP ports can
35 also be forwarded over the secure channel.
36
37 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
38 to date in terms of security and features, as well as removing all patented
39 algorithms to seperate libraries (OpenSSL).
40
41 This package includes the core files necessary for both the OpenSSH
42 client and server. To make this package useful, you should also
43 install openssh-clients, openssh-server, or both.
44
45 %package clients
46 Summary:        OpenSSH Secure Shell protocol clients
47 Requires:       openssh
48 Group:          Applications/Networking
49 Group(pl):      Aplikacje/Sieciowe
50 Obsoletes:      ssh-clients < %{version}, ssh-clients > %{version}
51 Requires:       %{name} = %{version}
52
53 %description clients
54 Ssh (Secure Shell) a program for logging into a remote machine and for
55 executing commands in a remote machine. It is intended to replace rlogin and
56 rsh, and provide secure encrypted communications between two untrusted hosts
57 over an insecure network. X11 connections and arbitrary TCP/IP ports can
58 also be forwarded over the secure channel.
59
60 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
61 to date in terms of security and features, as well as removing all patented
62 algorithms to seperate libraries (OpenSSL).
63
64 This package includes the clients necessary to make encrypted connections to
65 SSH servers.
66
67 %package server
68 Summary:        OpenSSH Secure Shell protocol server (sshd)
69 Requires:       openssh chkconfig >= 0.9
70 Group:          Networking/Daemons
71 Group(pl):      Sieciowe/Serwery
72 Obsoletes:      ssh-server < %{version}, ssh-server > %{version}
73 Requires:       rc-scripts
74 Requires:       /bin/login
75 Requires:       util-linux
76 Prereq:         %{name} = %{version}
77
78 %description server
79 Ssh (Secure Shell) a program for logging into a remote machine and for
80 executing commands in a remote machine. It is intended to replace rlogin and
81 rsh, and provide secure encrypted communications between two untrusted hosts
82 over an insecure network. X11 connections and arbitrary TCP/IP ports can
83 also be forwarded over the secure channel.
84
85 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
86 to date in terms of security and features, as well as removing all patented
87 algorithms to seperate libraries (OpenSSL).
88
89 This package contains the secure shell daemon. The sshd is the server part
90 of the secure shell protocol and allows ssh clients to connect to your host.
91
92 %package gnome-askpass
93 Summary:        OpenSSH GNOME passphrase dialog
94 Group:          Applications/Networking
95 Group(pl):      Aplikacje/Sieciowe
96 Requires:       %{name} = %{version}
97 Obsoletes:      ssh-extras < %{version}, ssh-extras > %{version}
98 Obsoletes:      ssh-askpass < %{version}, ssh-askpass > %{version}
99 Obsoletes:      openssh-askpass < %{version}, openssh-askpass > %{version}
100
101 %description gnome-askpass
102 Ssh (Secure Shell) a program for logging into a remote machine and for
103 executing commands in a remote machine. It is intended to replace rlogin
104 and rsh, and provide secure encrypted communications between two untrusted
105 hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
106 can also be forwarded over the secure channel.
107
108 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
109 to date in terms of security and features, as well as removing all patented
110 algorithms to seperate libraries (OpenSSL).
111
112 This package contains the GNOME passphrase dialog.
113
114 %prep
115 %setup  -q
116 %patch0 -p1
117 %patch1 -p1
118
119 %build
120 autoconf
121 %configure \
122         --with-gnome-askpass \
123         --with-tcp-wrappers \
124         --with-md5-passwords \
125         --with-ipaddr-display \
126         --enable-ipv6 \
127         --enable-log-auth 
128
129 # with ipv4-default sshd can't listen on IPv6 and IPv4 sockets
130 #       --with-ipv4-default \
131 # broken options
132 #       --without-kerberos4 \
133 #       --without-afs \
134 #       --without-skey 
135
136 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
137
138 make
139 cd contrib && gcc `gnome-config --cflags gnome gnomeui` \
140      gnome-ssh-askpass.c -o gnome-ssh-askpass \
141      `gnome-config --libs gnome gnomeui`
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
147
148 make install DESTDIR="$RPM_BUILD_ROOT"
149
150 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
151 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
152 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
153 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
154 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
155 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
156 install -d $RPM_BUILD_ROOT%{_libexecdir}/ssh
157 install contrib/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
158
159 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
160         $RPM_BUILD_ROOT/%{_mandir}/man*/*
161
162 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
163         
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post server
168 /sbin/chkconfig --add sshd
169 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
170         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' 1>&2
171 fi
172 if [ -f /var/lock/subsys/sshd ]; then
173         /etc/rc.d/init.d/sshd restart 1>&2
174 else
175         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
176 fi
177 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
178         echo "ssh" >> /etc/security/passwd.conf
179 fi
180
181 %preun server
182 if [ "$1" = 0 ]; then
183         if [ -f /var/lock/subsys/sshd ]; then
184                 /etc/rc.d/init.d/sshd stop 1>&2
185         fi
186         /sbin/chkconfig --del sshd
187 fi
188
189 %files
190 %defattr(644,root,root,755)
191 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
192 %attr(755,root,root) %{_bindir}/ssh-keygen
193 %{_mandir}/man1/ssh-keygen.1*
194 %dir %{_sysconfdir}
195
196 %files clients
197 %defattr(644,root,root,755)
198 # suid root ?
199 #%attr(4755,root,root) %{_bindir}/ssh
200 %attr(0755,root,root) %{_bindir}/ssh
201 %attr(0755,root,root) %{_bindir}/ssh-agent
202 %attr(0755,root,root) %{_bindir}/ssh-add
203 #%attr(0755,root,root) %{_bindir}/slogin
204 %attr(755,root,root) %{_bindir}/scp
205 %{_mandir}/man1/scp.1*
206 %{_mandir}/man1/ssh.1*
207 %{_mandir}/man1/ssh-agent.1*
208 %{_mandir}/man1/ssh-add.1*
209 #%{_mandir}/man1/slogin.1
210 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
211
212 %files server
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_sbindir}/sshd
215 %{_mandir}/man8/sshd.8*
216 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
217 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
218 %attr(754,root,root) /etc/rc.d/init.d/sshd
219 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
220 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
221
222 %files gnome-askpass
223 %defattr(644,root,root,755)
224 %dir %{_libexecdir}/ssh
225 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.084961 seconds and 4 git commands to generate.