]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- updated to 4.3p1
[packages/openssh.git] / openssh.spec
1 #
2 # todo:
3 # - for modularized xorg use /usr/bin/xauth
4 #
5 # Conditional build:
6 %bcond_without  chroot          # without chrooted user environment support
7 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
8 %bcond_without  gtk             # without GTK+ (2.x)
9 %bcond_with     ldap            # with ldap support
10 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
11 %bcond_without  kerberos5       # without kerberos5 support
12 %bcond_without  selinux         # build without SELinux support
13 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
14 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
15 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
16 #
17 %if %{with hpn_none}
18 %undefine       with_hpn
19 %endif
20 # gtk2-based gnome-askpass means no gnome1-based
21 %{?with_gtk:%undefine with_gnome}
22 Summary:        OpenSSH free Secure Shell (SSH) implementation
23 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
24 Summary(es):    Implementación libre de SSH
25 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
26 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
27 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
28 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29 Summary(pt_BR): Implementação livre do SSH
30 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
31 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
32 Name:           openssh
33 Version:        4.3p1
34 Release:        2%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
35 Epoch:          2
36 License:        BSD
37 Group:          Applications/Networking
38 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
39 # Source0-md5:  eaeb880b1b6c63b9a4d7c5b1e74727c4
40 Source1:        %{name}d.conf
41 Source2:        %{name}.conf
42 Source3:        %{name}d.init
43 Source4:        %{name}d.pamd
44 Source5:        %{name}.sysconfig
45 Source6:        passwd.pamd
46 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
47 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
48 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
49 # NoSource9-md5:        e1c3cbed88f08ea778d90813d48cd428
50 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
51 # NoSource10-md5:       ec74f3e3b2ea3a7dc84c7988235b6fcf
52 Source11:       ssh-agent.sh
53 Source12:       ssh-agent.conf
54 Patch0:         %{name}-no_libnsl.patch
55 Patch2:         %{name}-linux-ipv6.patch
56 Patch3:         %{name}-pam_misc.patch
57 Patch4:         %{name}-sigpipe.patch
58 # http://www.opendarwin.org/projects/openssh-lpk/
59 Patch5:         %{name}-lpk-4.1p1-0.3.6.patch
60 Patch6:         %{name}-heimdal.patch
61 Patch7:         %{name}-pam-conv.patch
62 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
63 Patch8:         %{name}-chroot.patch
64 Patch9:         %{name}-selinux.patch
65 Patch10:        %{name}-selinux-pld.patch
66 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/ 
67 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
68 Patch11:        %{name}-4.2p1-hpn11.patch
69 # Adds HPN (see p11) and an undocumented -z none cipher flag
70 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
71 Patch12:        %{name}-4.2p1-hpn11-none.patch
72 Patch13:        %{name}-include.patch
73 URL:            http://www.openssh.com/
74 BuildRequires:  autoconf
75 BuildRequires:  automake
76 %{?with_gnome:BuildRequires:    gnome-libs-devel}
77 %{?with_gtk:BuildRequires:      gtk+2-devel}
78 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
79 %{?with_libedit:BuildRequires:  libedit-devel}
80 %{?with_selinux:BuildRequires:  libselinux-devel}
81 BuildRequires:  libwrap-devel
82 %{?with_ldap:BuildRequires:     openldap-devel}
83 BuildRequires:  openssl-devel >= 0.9.7d
84 BuildRequires:  pam-devel
85 BuildRequires:  %{__perl}
86 %{?with_gtk:BuildRequires:      pkgconfig}
87 BuildRequires:  rpmbuild(macros) >= 1.202
88 BuildRequires:  zlib-devel
89 Requires:       FHS >= 2.1-24
90 Requires:       pam >= 0.79.0
91 Obsoletes:      ssh
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sysconfdir     /etc/ssh
95 %define         _libexecdir     %{_libdir}/%{name}
96 %define         _privsepdir     /usr/share/empty
97
98 %description
99 Ssh (Secure Shell) a program for logging into a remote machine and for
100 executing commands in a remote machine. It is intended to replace
101 rlogin and rsh, and provide secure encrypted communications between
102 two untrusted hosts over an insecure network. X11 connections and
103 arbitrary TCP/IP ports can also be forwarded over the secure channel.
104
105 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
106 it up to date in terms of security and features, as well as removing
107 all patented algorithms to seperate libraries (OpenSSL).
108
109 This package includes the core files necessary for both the OpenSSH
110 client and server. To make this package useful, you should also
111 install openssh-clients, openssh-server, or both.
112 %if %{with hpn} || %{with hpn_none}
113 This release includes High Performance SSH/SCP patches from 
114 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed 
115 to increase throughput on fast connections with high RTT (20-150 msec).
116 See the website for '-w' values for your connection and /proc/sys TCP
117 values. BTW. in a LAN you have got generally RTT < 1 msec.
118 %endif
119 %if %{with hpn_none}
120 It also includes an undocumented '-z' option which switches
121 the cipher to none after authentication is completed. Data is 
122 still secured from tampering and corruption in transit through 
123 the use of the Message Authentication Code (MAC).
124 This option will significantly reduce the number of cpu cycles used 
125 by the SSH/SCP process. This may allow some users to see significant 
126 improvement in (sniffable) data tranfer rates. 
127 %endif
128
129 %description -l de
130 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
131 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
132 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
133 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
134 andere TCP/IP Ports können ebenso über den sicheren Channel
135 weitergeleitet werden.
136
137 %description -l es
138 SSH es un programa para accesar y ejecutar órdenes en computadores
139 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
140 seguro entre dos servidores en una red insegura. Conexiones X11 y
141 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
142 seguro.
143
144 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
145 continuar la última versión gratuita de SSH, actualizándolo en
146 términos de seguridad y recursos,así también eliminando todos los
147 algoritmos patentados y colocándolos en bibliotecas separadas
148 (OpenSSL).
149
150 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
151 también el paquete openssh-clients u openssh-server o ambos.
152
153 %description -l fr
154 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
155 remplace telnet, rlogin, rexec et rsh, tout en assurant des
156 communications cryptées securisées entre deux hôtes non fiabilisés sur
157 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
158 arbitraires peuvent également être transmis sur le canal sécurisé.
159
160 %description -l it
161 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
162 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
163 sicure e crittate tra due host non fidati su una rete non sicura. Le
164 connessioni X11 ad una porta TCP/IP arbitraria possono essere
165 inoltrate attraverso un canale sicuro.
166
167 %description -l pl
168 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
169 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
170 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
171 pomiêdzy dwoma hostami.
172
173 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
174 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
175 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
176 %if %{with hpn} || %{with hpn_none}
177 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP 
178 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
179 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ 
180 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na 
181 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz 
182 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.  
183 %endif
184 %if %{with hpn_none}
185 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
186 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
187 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez 
188 stosowanie Message Authentication Code (MAC).
189 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez 
190 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ 
191 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych. 
192 %endif
193
194 %description -l pt
195 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
196 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
197 cifradas entre duas máquinas sem confiança mútua sobre uma rede
198 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
199 reenviados pelo canal seguro.
200
201 %description -l pt_BR
202 SSH é um programa para acessar e executar comandos em máquinas
203 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
204 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
205 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
206
207 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
208 última versão gratuita do SSH, atualizando-o em termos de segurança e
209 recursos, assim como removendo todos os algoritmos patenteados e
210 colocando-os em bibliotecas separadas (OpenSSL).
211
212 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
213 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
214
215 %description -l ru
216 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
217 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
218 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
219 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
220 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
221 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
222
223 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
224 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
225 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
226 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
227
228 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
229 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
230 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
231
232 %description -l uk
233 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
234 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
235 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
236 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
237 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
238 ËÁÎÁÌ.
239
240 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
241 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
242 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
243 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
244
245 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
246 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
247 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
248
249 %package clients
250 Summary:        OpenSSH Secure Shell protocol clients
251 Summary(es):    Clientes de OpenSSH
252 Summary(pl):    Klienci protoko³u Secure Shell
253 Summary(pt_BR): Clientes do OpenSSH
254 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
255 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
256 Group:          Applications/Networking
257 Requires:       %{name} = %{epoch}:%{version}-%{release}
258 %{?with_sshagentsh:Requires:    xinitrc}
259 Provides:       ssh-clients
260 Obsoletes:      ssh-clients
261
262 %description clients
263 Ssh (Secure Shell) a program for logging into a remote machine and for
264 executing commands in a remote machine. It is intended to replace
265 rlogin and rsh, and provide secure encrypted communications between
266 two untrusted hosts over an insecure network. X11 connections and
267 arbitrary TCP/IP ports can also be forwarded over the secure channel.
268
269 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
270 it up to date in terms of security and features, as well as removing
271 all patented algorithms to seperate libraries (OpenSSL).
272
273 This package includes the clients necessary to make encrypted
274 connections to SSH servers.
275
276 %description clients -l es
277 Este paquete incluye los clientes que se necesitan para hacer
278 conexiones codificadas con servidores SSH.
279
280 %description clients -l pl
281 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
282 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
283 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
284 pomiêdzy dwoma hostami.
285
286 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
287
288 %description clients -l pt_BR
289 Esse pacote inclui os clientes necessários para fazer conexões
290 encriptadas com servidores SSH.
291
292 %description clients -l ru
293 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
294 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
295
296 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
297 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
298
299 %description clients -l uk
300 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
301 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
302
303 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
304 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
305
306 %package server
307 Summary:        OpenSSH Secure Shell protocol server (sshd)
308 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
309 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
310 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
311 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
312 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
313 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
314 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
315 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
316 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
317 Group:          Networking/Daemons
318 Requires:       %{name} = %{epoch}:%{version}-%{release}
319 Requires:       rc-scripts >= 0.4.0.18
320 Requires(pre):  /bin/id
321 Requires(pre):  /usr/sbin/useradd
322 Requires(post,preun):   /sbin/chkconfig
323 Requires(post): chkconfig >= 0.9
324 Requires(post): grep
325 Requires(postun):       /usr/sbin/userdel
326 Requires:       /bin/login
327 Requires:       util-linux
328 Requires:       pam >= 0.77.3
329 Provides:       user(sshd)
330 Provides:       ssh-server
331
332 %description server
333 Ssh (Secure Shell) a program for logging into a remote machine and for
334 executing commands in a remote machine. It is intended to replace
335 rlogin and rsh, and provide secure encrypted communications between
336 two untrusted hosts over an insecure network. X11 connections and
337 arbitrary TCP/IP ports can also be forwarded over the secure channel.
338
339 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
340 it up to date in terms of security and features, as well as removing
341 all patented algorithms to seperate libraries (OpenSSL).
342
343 This package contains the secure shell daemon. The sshd is the server
344 part of the secure shell protocol and allows ssh clients to connect to
345 your host.
346
347 %description server -l de
348 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
349
350 %description server -l es
351 Este paquete contiene el servidor SSH. sshd es la parte servidor del
352 protocolo secure shell y permite que clientes ssh se conecten a su
353 servidor.
354
355 %description server -l fr
356 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
357
358 %description server -l it
359 Questo pacchetto installa sshd, il server di OpenSSH.
360
361 %description server -l pl
362 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
363 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
364 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
365 pomiêdzy dwoma hostami.
366
367 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
368 ssh).
369
370 %description server -l pt
371 Este pacote intala o sshd, o servidor do OpenSSH.
372
373 %description server -l pt_BR
374 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
375 protocolo secure shell e permite que clientes ssh se conectem ao seu
376 host.
377
378 %description server -l ru
379 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
380 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
381
382 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
383 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
384 ×ÁÛÉÍ ÈÏÓÔÏÍ.
385
386 %description server -l uk
387 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
388 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
389
390 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
391 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
392 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
393
394 %package gnome-askpass
395 Summary:        OpenSSH GNOME passphrase dialog
396 Summary(de):    OpenSSH GNOME Passwort-Dialog
397 Summary(es):    Diálogo para introducción de passphrase para GNOME
398 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
399 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
400 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
401 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
402 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
403 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
404 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
405 Group:          Applications/Networking
406 Requires:       %{name} = %{epoch}:%{version}-%{release}
407 Obsoletes:      ssh-extras
408 Obsoletes:      ssh-askpass
409 Obsoletes:      openssh-askpass
410
411 %description gnome-askpass
412 Ssh (Secure Shell) a program for logging into a remote machine and for
413 executing commands in a remote machine. It is intended to replace
414 rlogin and rsh, and provide secure encrypted communications between
415 two untrusted hosts over an insecure network. X11 connections and
416 arbitrary TCP/IP ports can also be forwarded over the secure channel.
417
418 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
419 it up to date in terms of security and features, as well as removing
420 all patented algorithms to seperate libraries (OpenSSL).
421
422 This package contains the GNOME passphrase dialog.
423
424 %description gnome-askpass -l es
425 Este paquete contiene un programa que abre una caja de diálogo para
426 entrada de passphrase en GNOME.
427
428 %description gnome-askpass -l pl
429 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
430 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
431 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
432 pomiêdzy dwoma hostami.
433
434 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
435
436 %description gnome-askpass -l pt_BR
437 Esse pacote contém um programa que abre uma caixa de diálogo para
438 entrada de passphrase no GNOME.
439
440 %description gnome-askpass -l ru
441 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
442 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
443
444 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
445 GNOME.
446
447 %description gnome-askpass -l uk
448 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
449 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
450
451 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
452 GNOME.
453
454 %prep
455 %setup -q
456 %patch0 -p1
457 %patch2 -p1
458 %patch3 -p1
459 %patch4 -p1
460 %{?with_ldap:%patch5 -p1}
461 %{?with_kerberos5:%patch6 -p1}
462 #%patch7 -p1
463 %patch8 -p1
464 %{?with_selinux:%patch9 -p1}
465 %{?with_selinux:%patch10 -p1}
466 %{?with_hpn:%patch11 -p1}
467 %{?with_hpn_none:%patch12 -p1}
468 %patch13 -p1
469
470 %build
471 cp %{_datadir}/automake/config.sub .
472 %{__aclocal}
473 %{__autoconf}
474 %{?with_chroot:CPPFLAGS="-DCHROOT"}
475 %configure \
476         PERL=%{__perl} \
477         --with-dns \
478         --with-pam \
479         --with-mantype=man \
480         --with-md5-passwords \
481         --with-ipaddr-display \
482         %{?with_libedit:--with-libedit} \
483         --with-4in6 \
484         --disable-suid-ssh \
485         --with-tcp-wrappers \
486         %{?with_ldap:--with-libs="-lldap -llber"} \
487         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
488         %{?with_kerberos5:--with-kerberos5} \
489         --with-privsep-path=%{_privsepdir} \
490         --with-pid-dir=%{_localstatedir}/run \
491         --with-xauth=/usr/X11R6/bin/xauth
492
493 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
494
495 %{__make}
496
497 cp -f %{SOURCE9} .
498 cp -f %{SOURCE10} .
499 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
500
501 cd contrib
502 %if %{with gnome}
503 %{__make} gnome-ssh-askpass1 \
504         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
505 %endif
506 %if %{with gtk}
507 %{__make} gnome-ssh-askpass2 \
508         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
509 %endif
510
511 %install
512 rm -rf $RPM_BUILD_ROOT
513 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
514         $RPM_BUILD_ROOT%{_libexecdir}/ssh
515 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
516
517 %{__make} install \
518         DESTDIR=$RPM_BUILD_ROOT
519
520 install connect    $RPM_BUILD_ROOT%{_bindir}
521 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
522 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
523 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
524 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
525 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
526 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
527 %if %{with sshagentsh}
528 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
529 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
530 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
531 %endif
532
533 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
534
535 %if %{with gnome}
536 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
537 %endif
538 %if %{with gtk}
539 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
540 %endif
541 %if %{with gnome} || %{with gtk}
542 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
543 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
544 EOF
545 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
546 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
547 EOF
548 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
549 %endif
550
551 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
552 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
553
554 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
555
556 %if "%{_lib}" != "lib"
557 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 perl -pi -e "s#/usr/lib#/usr/%{_lib}#"
558 %endif
559
560 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
561 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
562 EOF
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %pre server
568 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
569
570 %post server
571 /sbin/chkconfig --add sshd
572 if [ -f /var/lock/subsys/sshd ]; then
573         /etc/rc.d/init.d/sshd restart 1>&2
574 else
575         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
576 fi
577 if ! grep -qs ssh /etc/security/passwd.conf ; then
578         umask 022
579         echo "ssh" >> /etc/security/passwd.conf
580 fi
581
582 %preun server
583 if [ "$1" = "0" ]; then
584         if [ -f /var/lock/subsys/sshd ]; then
585                 /etc/rc.d/init.d/sshd stop 1>&2
586         fi
587         /sbin/chkconfig --del sshd
588 fi
589
590 %postun server
591 if [ "$1" = "0" ]; then
592         %userremove sshd
593 fi
594
595 %files
596 %defattr(644,root,root,755)
597 %doc *.RNG TODO README OVERVIEW CREDITS Change*
598 %attr(755,root,root) %{_bindir}/ssh-key*
599 %{_mandir}/man1/ssh-key*.1*
600 %dir %{_sysconfdir}
601 %dir %{_libexecdir}
602
603 %files clients
604 %defattr(644,root,root,755)
605 %doc connect.html
606 %attr(755,root,root) %{_bindir}/connect
607 %attr(755,root,root) %{_bindir}/ssh
608 %attr(755,root,root) %{_bindir}/slogin
609 %attr(755,root,root) %{_bindir}/sftp
610 %attr(755,root,root) %{_bindir}/ssh-agent
611 %attr(755,root,root) %{_bindir}/ssh-add
612 %attr(755,root,root) %{_bindir}/scp
613 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
614 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
615 %if %{with sshagentsh}
616 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
617 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
618 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
619 %endif
620 %{_mandir}/man1/scp.1*
621 %{_mandir}/man1/ssh.1*
622 %{_mandir}/man1/slogin.1*
623 %{_mandir}/man1/sftp.1*
624 %{_mandir}/man1/ssh-agent.1*
625 %{_mandir}/man1/ssh-add.1*
626 %{_mandir}/man5/ssh_config.5*
627 %lang(it) %{_mandir}/it/man1/ssh.1*
628 %lang(it) %{_mandir}/it/man5/ssh_config.5*
629 %lang(pl) %{_mandir}/pl/man1/scp.1*
630 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
631
632 # for host-based auth (suid required for accessing private host key)
633 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
634 #%{_mandir}/man8/ssh-keysign.8*
635
636 %files server
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_sbindir}/sshd
639 %attr(755,root,root) %{_libexecdir}/sftp-server
640 %attr(755,root,root) %{_libexecdir}/ssh-keysign
641 %{_mandir}/man8/sshd.8*
642 %{_mandir}/man8/sftp-server.8*
643 %{_mandir}/man8/ssh-keysign.8*
644 %{_mandir}/man5/sshd_config.5*
645 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
646 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
647 %attr(640,root,root) %{_sysconfdir}/moduli
648 %attr(754,root,root) /etc/rc.d/init.d/sshd
649 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
650 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
651
652 %if %{with gnome} || %{with gtk}
653 %files gnome-askpass
654 %defattr(644,root,root,755)
655 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
656 %dir %{_libexecdir}/ssh
657 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
658 %attr(755,root,root) %{_libexecdir}/ssh-askpass
659 %endif
This page took 0.072818 seconds and 4 git commands to generate.