]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- release 3,
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2.1pre24
4 Release:        3
5 License:        BSD
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Source0:        http://violet.ibs.com.au/openssh/files/%{name}-%{version}.tar.gz
9 Source1:        opensshd.conf
10 Source2:        openssh.conf
11 Source3:        opensshd.init
12 Source4:        opensshd.pamd
13 Source5:        openssh.sysconfig
14 Source6:        passwd.pamd
15 Patch1:         openssh-DESTDIR.patch
16 Patch2:         openssh-PAM_NEW_AUTHTOK.patch
17 Patch3:         http://www.misiek.eu.org/ipv6/openssh-1.2.1pre24-ipv6-03012000.patch.gz
18 BuildRequires:  openssl-devel >= 0.9.4-2
19 BuildRequires:  zlib-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRoot:      /tmp/%{name}-%{version}-root
24 Obsoletes:      ssh < %{version}, ssh > %{version}
25
26 %define         _sysconfdir     /etc/ssh
27
28 %description
29 Ssh (Secure Shell) a program for logging into a remote machine and for
30 executing commands in a remote machine. It is intended to replace rlogin and
31 rsh, and provide secure encrypted communications between two untrusted hosts
32 over an insecure network. X11 connections and arbitrary TCP/IP ports can
33 also be forwarded over the secure channel.
34
35 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
36 to date in terms of security and features, as well as removing all patented
37 algorithms to seperate libraries (OpenSSL).
38
39 This package includes the core files necessary for both the OpenSSH
40 client and server. To make this package useful, you should also
41 install openssh-clients, openssh-server, or both.
42
43 %package clients
44 Summary:        OpenSSH Secure Shell protocol clients
45 Requires:       openssh
46 Group:          Applications/Networking
47 Group(pl):      Aplikacje/Sieciowe
48 Obsoletes:      ssh-clients < %{version}, ssh-clients > %{version}
49 Requires:       %{name} = %{version}
50
51 %description clients
52 Ssh (Secure Shell) a program for logging into a remote machine and for
53 executing commands in a remote machine. It is intended to replace rlogin and
54 rsh, and provide secure encrypted communications between two untrusted hosts
55 over an insecure network. X11 connections and arbitrary TCP/IP ports can
56 also be forwarded over the secure channel.
57
58 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
59 to date in terms of security and features, as well as removing all patented
60 algorithms to seperate libraries (OpenSSL).
61
62 This package includes the clients necessary to make encrypted connections to
63 SSH servers.
64
65 %package server
66 Summary:        OpenSSH Secure Shell protocol server (sshd)
67 Requires:       openssh chkconfig >= 0.9
68 Group:          Networking/Daemons
69 Group(pl):      Sieciowe/Serwery
70 Obsoletes:      ssh-server < %{version}, ssh-server > %{version}
71 Requires:       rc-scripts
72 Requires:       /bin/login
73 Requires:       util-linux
74 Prereq:         %{name} = %{version}
75
76 %description server
77 Ssh (Secure Shell) a program for logging into a remote machine and for
78 executing commands in a remote machine. It is intended to replace rlogin and
79 rsh, and provide secure encrypted communications between two untrusted hosts
80 over an insecure network. X11 connections and arbitrary TCP/IP ports can
81 also be forwarded over the secure channel.
82
83 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
84 to date in terms of security and features, as well as removing all patented
85 algorithms to seperate libraries (OpenSSL).
86
87 This package contains the secure shell daemon. The sshd is the server part
88 of the secure shell protocol and allows ssh clients to connect to your host.
89
90 %package gnome-askpass
91 Summary:        OpenSSH GNOME passphrase dialog
92 Group:          Applications/Networking
93 Group(pl):      Aplikacje/Sieciowe
94 Requires:       %{name} = %{version}
95 Obsoletes:      ssh-extras < %{version}, ssh-extras > %{version}
96 Obsoletes:      ssh-askpass < %{version}, ssh-askpass > %{version}
97 Obsoletes:      openssh-askpass < %{version}, openssh-askpass > %{version}
98
99 %description gnome-askpass
100 Ssh (Secure Shell) a program for logging into a remote machine and for
101 executing commands in a remote machine. It is intended to replace rlogin
102 and rsh, and provide secure encrypted communications between two untrusted
103 hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
104 can also be forwarded over the secure channel.
105
106 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
107 to date in terms of security and features, as well as removing all patented
108 algorithms to seperate libraries (OpenSSL).
109
110 This package contains the GNOME passphrase dialog.
111
112 %prep
113 %setup  -q
114 %patch1 -p1
115 %patch2 -p1
116 %patch3 -p1
117
118 %build
119 autoconf
120 %configure \
121         --with-gnome-askpass \
122         --with-tcp-wrappers \
123         --with-md5-passwords \
124         --enable-ipv6 \
125         --enable-log-auth 
126         
127 #       --without-kerberos4 \
128 #       --without-afs \
129 #       --without-skey 
130
131 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
132
133 make
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
139
140 make install DESTDIR="$RPM_BUILD_ROOT"
141
142 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
143 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
144 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
145 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
146 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
147 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
148
149 mv -f   $RPM_BUILD_ROOT%{_libexecdir}/ssh/gnome-ssh-askpass \
150         $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
151
152 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
153         $RPM_BUILD_ROOT/%{_mandir}/man*/*
154         
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post server
159 /sbin/chkconfig --add sshd
160 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
161         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
162 fi
163 if [ ! -f /var/lock/subsys/sshd ]; then
164         /etc/rc.d/init.d/sshd restart >&2
165 fi
166 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
167         echo "ssh" >> /etc/security/passwd.conf
168 fi
169
170 %preun server
171 if [ "$1" = 0 ]; then
172         if [ ! -f /var/lock/subsys/sshd ]; then
173                 /etc/rc.d/init.d/sshd stop >&2
174         fi
175         /sbin/chkconfig --del sshd
176 fi
177
178 %files
179 %defattr(644,root,root,755)
180 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
181 %attr(755,root,root) %{_bindir}/ssh-keygen
182 %{_mandir}/man1/ssh-keygen.1*
183 %dir %{_sysconfdir}
184
185 %files clients
186 %defattr(644,root,root,755)
187 # suid root ?
188 #%attr(4755,root,root) %{_bindir}/ssh
189 %attr(0755,root,root) %{_bindir}/ssh
190 %attr(0755,root,root) %{_bindir}/ssh-agent
191 %attr(0755,root,root) %{_bindir}/ssh-add
192 #%attr(0755,root,root) %{_bindir}/slogin
193 %attr(755,root,root) %{_bindir}/scp
194 %{_mandir}/man1/scp.1*
195 %{_mandir}/man1/ssh.1*
196 %{_mandir}/man1/ssh-agent.1*
197 %{_mandir}/man1/ssh-add.1*
198 #%{_mandir}/man1/slogin.1
199 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
200
201 %files server
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_sbindir}/sshd
204 %{_mandir}/man8/sshd.8*
205 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
206 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
207 %attr(754,root,root) /etc/rc.d/init.d/sshd
208 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
209
210 %files gnome-askpass
211 %defattr(644,root,root,755)
212 %dir %{_libexecdir}/ssh
213 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.053807 seconds and 4 git commands to generate.