]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- release 2.
[packages/openssh.git] / openssh.spec
1 Summary:        OpenSSH free Secure Shell (SSH) implementation
2 Name:           openssh
3 Version:        1.2.3
4 Release:        2
5 License:        BSD
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Source0:        ftp://ftp.franken.de/pub/Linux/openssh/files/%{name}-%{version}.tar.gz
9 Source1:        opensshd.conf
10 Source2:        openssh.conf
11 Source3:        opensshd.init
12 Source4:        opensshd.pamd
13 Source5:        openssh.sysconfig
14 Source6:        passwd.pamd
15 Patch0:         openssh-PAM_NEW_AUTHTOK.patch
16 Patch1:         openssh-libwrap.patch
17 BuildRequires:  openssl-devel >= 0.9.4-2
18 BuildRequires:  rpm >= 3.0.4
19 BuildRequires:  zlib-devel
20 BuildRequires:  pam-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  gnome-libs-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 Obsoletes:      ssh < %{version}, ssh > %{version}
25
26 %define         _sysconfdir     /etc/ssh
27
28 %description
29 Ssh (Secure Shell) a program for logging into a remote machine and for
30 executing commands in a remote machine. It is intended to replace rlogin and
31 rsh, and provide secure encrypted communications between two untrusted hosts
32 over an insecure network. X11 connections and arbitrary TCP/IP ports can
33 also be forwarded over the secure channel.
34
35 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
36 to date in terms of security and features, as well as removing all patented
37 algorithms to seperate libraries (OpenSSL).
38
39 This package includes the core files necessary for both the OpenSSH
40 client and server. To make this package useful, you should also
41 install openssh-clients, openssh-server, or both.
42
43 %package clients
44 Summary:        OpenSSH Secure Shell protocol clients
45 Requires:       openssh
46 Group:          Applications/Networking
47 Group(pl):      Aplikacje/Sieciowe
48 Obsoletes:      ssh-clients < %{version}, ssh-clients > %{version}
49 Requires:       %{name} = %{version}
50
51 %description clients
52 Ssh (Secure Shell) a program for logging into a remote machine and for
53 executing commands in a remote machine. It is intended to replace rlogin and
54 rsh, and provide secure encrypted communications between two untrusted hosts
55 over an insecure network. X11 connections and arbitrary TCP/IP ports can
56 also be forwarded over the secure channel.
57
58 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
59 to date in terms of security and features, as well as removing all patented
60 algorithms to seperate libraries (OpenSSL).
61
62 This package includes the clients necessary to make encrypted connections to
63 SSH servers.
64
65 %package server
66 Summary:        OpenSSH Secure Shell protocol server (sshd)
67 Requires:       openssh chkconfig >= 0.9
68 Group:          Networking/Daemons
69 Group(pl):      Sieciowe/Serwery
70 Obsoletes:      ssh-server < %{version}, ssh-server > %{version}
71 Requires:       rc-scripts
72 Requires:       /bin/login
73 Requires:       util-linux
74 Prereq:         %{name} = %{version}
75
76 %description server
77 Ssh (Secure Shell) a program for logging into a remote machine and for
78 executing commands in a remote machine. It is intended to replace rlogin and
79 rsh, and provide secure encrypted communications between two untrusted hosts
80 over an insecure network. X11 connections and arbitrary TCP/IP ports can
81 also be forwarded over the secure channel.
82
83 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
84 to date in terms of security and features, as well as removing all patented
85 algorithms to seperate libraries (OpenSSL).
86
87 This package contains the secure shell daemon. The sshd is the server part
88 of the secure shell protocol and allows ssh clients to connect to your host.
89
90 %package gnome-askpass
91 Summary:        OpenSSH GNOME passphrase dialog
92 Group:          Applications/Networking
93 Group(pl):      Aplikacje/Sieciowe
94 Requires:       %{name} = %{version}
95 Obsoletes:      ssh-extras < %{version}, ssh-extras > %{version}
96 Obsoletes:      ssh-askpass < %{version}, ssh-askpass > %{version}
97 Obsoletes:      openssh-askpass < %{version}, openssh-askpass > %{version}
98
99 %description gnome-askpass
100 Ssh (Secure Shell) a program for logging into a remote machine and for
101 executing commands in a remote machine. It is intended to replace rlogin
102 and rsh, and provide secure encrypted communications between two untrusted
103 hosts over an insecure network. X11 connections and arbitrary TCP/IP ports
104 can also be forwarded over the secure channel.
105
106 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it up
107 to date in terms of security and features, as well as removing all patented
108 algorithms to seperate libraries (OpenSSL).
109
110 This package contains the GNOME passphrase dialog.
111
112 %prep
113 %setup  -q
114 %patch0 -p1
115 %patch1 -p1
116
117 %build
118 autoconf
119 %configure \
120         --with-gnome-askpass \
121         --with-tcp-wrappers \
122         --with-md5-passwords \
123         --with-ipaddr-display \
124         --enable-ipv6 \
125         --enable-log-auth 
126
127 # with ipv4-default sshd can't listen on IPv6 and IPv4 sockets
128 #       --with-ipv4-default \
129 # broken options
130 #       --without-kerberos4 \
131 #       --without-afs \
132 #       --without-skey 
133
134 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
135
136 make
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security}}
142
143 make install DESTDIR="$RPM_BUILD_ROOT"
144
145 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
146 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
147 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
148 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
149 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
150 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
151 install -d $RPM_BUILD_ROOT%{_libexecdir}/ssh
152 install ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
153
154 gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
155         $RPM_BUILD_ROOT/%{_mandir}/man*/*
156
157 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
158         
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post server
163 /sbin/chkconfig --add sshd
164 if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
165         /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' 1>&2
166 fi
167 if [ -f /var/lock/subsys/sshd ]; then
168         /etc/rc.d/init.d/sshd restart 1>&2
169 fi
170 if ! grep ssh /etc/security/passwd.conf >/dev/null 2>&1 ; then
171         echo "ssh" >> /etc/security/passwd.conf
172 fi
173
174 %preun server
175 if [ "$1" = 0 ]; then
176         if [ -f /var/lock/subsys/sshd ]; then
177                 /etc/rc.d/init.d/sshd stop 1>&2
178         fi
179         /sbin/chkconfig --del sshd
180 fi
181
182 %files
183 %defattr(644,root,root,755)
184 %doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
185 %attr(755,root,root) %{_bindir}/ssh-keygen
186 %{_mandir}/man1/ssh-keygen.1*
187 %dir %{_sysconfdir}
188
189 %files clients
190 %defattr(644,root,root,755)
191 # suid root ?
192 #%attr(4755,root,root) %{_bindir}/ssh
193 %attr(0755,root,root) %{_bindir}/ssh
194 %attr(0755,root,root) %{_bindir}/ssh-agent
195 %attr(0755,root,root) %{_bindir}/ssh-add
196 #%attr(0755,root,root) %{_bindir}/slogin
197 %attr(755,root,root) %{_bindir}/scp
198 %{_mandir}/man1/scp.1*
199 %{_mandir}/man1/ssh.1*
200 %{_mandir}/man1/ssh-agent.1*
201 %{_mandir}/man1/ssh-add.1*
202 #%{_mandir}/man1/slogin.1
203 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
204
205 %files server
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_sbindir}/sshd
208 %{_mandir}/man8/sshd.8*
209 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
210 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
211 %attr(754,root,root) /etc/rc.d/init.d/sshd
212 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
213 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
214
215 %files gnome-askpass
216 %defattr(644,root,root,755)
217 %dir %{_libexecdir}/ssh
218 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.087045 seconds and 4 git commands to generate.