]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
dde7c167a539e5a7b5e848461ea99c983898d7d8
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14
15 %if "%{pld_release}" == "ac"
16 %define         pam_ver 0.79.0
17 %else
18 %define         pam_ver 0.99.7.1
19 %endif
20
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        5.9p1
33 Release:        2
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  b50a499fa02616a47984b1920848b565
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Source7:        %{name}-lpk.schema
47 Source8:        %{name}d.upstart
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
53 Patch4:         %{name}-5.9p1-ldap.patch
54 Patch5:         %{name}-5.9p1-ldap-fixes.patch
55 Patch6:         %{name}-config.patch
56 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
57 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
58 Patch9:         %{name}-5.2p1-hpn13v6.diff
59 Patch10:        %{name}-include.patch
60 Patch11:        %{name}-chroot.patch
61 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
62 Patch12:        %{name}-blacklist.diff
63 Patch13:        %{name}-kuserok.patch
64 URL:            http://www.openssh.com/portable.html
65 BuildRequires:  %{__perl}
66 %{?with_audit:BuildRequires:    audit-libs-devel}
67 BuildRequires:  autoconf >= 2.50
68 BuildRequires:  automake
69 %{?with_gnome:BuildRequires:    gnome-libs-devel}
70 %{?with_gtk:BuildRequires:      gtk+2-devel}
71 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
72 %{?with_libedit:BuildRequires:  libedit-devel}
73 %{?with_selinux:BuildRequires:  libselinux-devel}
74 BuildRequires:  libwrap-devel
75 %{?with_ldap:BuildRequires:     openldap-devel}
76 BuildRequires:  openssl-devel >= 0.9.7d
77 BuildRequires:  pam-devel
78 %{?with_gtk:BuildRequires:      pkgconfig}
79 BuildRequires:  rpm >= 4.4.9-56
80 BuildRequires:  rpmbuild(macros) >= 1.318
81 BuildRequires:  sed >= 4.0
82 BuildRequires:  zlib-devel
83 %if "%{pld_release}" == "ac"
84 Requires:       filesystem >= 2.0-1
85 Requires:       pam >= 0.79.0
86 %else
87 Requires:       filesystem >= 3.0-11
88 Requires:       pam >= %{pam_ver}
89 Suggests:       openssh-blacklist
90 Suggests:       xorg-app-xauth
91 %endif
92 Obsoletes:      ssh
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _sysconfdir     /etc/ssh
96 %define         _libexecdir     %{_libdir}/%{name}
97 %define         _privsepdir     /usr/share/empty
98 %define         schemadir       /usr/share/openldap/schema
99
100 %description
101 Ssh (Secure Shell) a program for logging into a remote machine and for
102 executing commands in a remote machine. It is intended to replace
103 rlogin and rsh, and provide secure encrypted communications between
104 two untrusted hosts over an insecure network. X11 connections and
105 arbitrary TCP/IP ports can also be forwarded over the secure channel.
106
107 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
108 it up to date in terms of security and features, as well as removing
109 all patented algorithms to seperate libraries (OpenSSL).
110
111 This package includes the core files necessary for both the OpenSSH
112 client and server. To make this package useful, you should also
113 install openssh-clients, openssh-server, or both.
114
115 %if %{with hpn}
116 This release includes High Performance SSH/SCP patches from
117 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
118 increase throughput on fast connections with high RTT (20-150 msec).
119 See the website for '-w' values for your connection and /proc/sys TCP
120 values. BTW. in a LAN you have got generally RTT < 1 msec.
121 %endif
122
123 %description -l de.UTF-8
124 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
125 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
126 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
127 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
128 andere TCP/IP Ports können ebenso über den sicheren Channel
129 weitergeleitet werden.
130
131 %description -l es.UTF-8
132 SSH es un programa para accesar y ejecutar órdenes en computadores
133 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
134 seguro entre dos servidores en una red insegura. Conexiones X11 y
135 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
136 seguro.
137
138 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
139 continuar la última versión gratuita de SSH, actualizándolo en
140 términos de seguridad y recursos,así también eliminando todos los
141 algoritmos patentados y colocándolos en bibliotecas separadas
142 (OpenSSL).
143
144 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
145 también el paquete openssh-clients u openssh-server o ambos.
146
147 %description -l fr.UTF-8
148 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
149 remplace telnet, rlogin, rexec et rsh, tout en assurant des
150 communications cryptées securisées entre deux hôtes non fiabilisés sur
151 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
152 arbitraires peuvent également être transmis sur le canal sécurisé.
153
154 %description -l it.UTF-8
155 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
156 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
157 sicure e crittate tra due host non fidati su una rete non sicura. Le
158 connessioni X11 ad una porta TCP/IP arbitraria possono essere
159 inoltrate attraverso un canale sicuro.
160
161 %description -l pl.UTF-8
162 Ssh (Secure Shell) to program służący do logowania się na zdalną
163 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
164 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
165 pomiędzy dwoma hostami.
166
167 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
168 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
169 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
170
171 %if %{with hpn}
172 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
173 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
174 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
175 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
176 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
177 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
178 %endif
179
180 %description -l pt.UTF-8
181 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
182 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
183 cifradas entre duas máquinas sem confiança mútua sobre uma rede
184 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
185 reenviados pelo canal seguro.
186
187 %description -l pt_BR.UTF-8
188 SSH é um programa para acessar e executar comandos em máquinas
189 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
190 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
191 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
192
193 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
194 última versão gratuita do SSH, atualizando-o em termos de segurança e
195 recursos, assim como removendo todos os algoritmos patenteados e
196 colocando-os em bibliotecas separadas (OpenSSL).
197
198 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
199 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
200
201 %description -l ru.UTF-8
202 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
203 машину и для выполнения команд на удаленной машине. Она предназначена
204 для замены rlogin и rsh и обеспечивает безопасную шифрованную
205 коммуникацию между двумя хостами в сети, являющейся небезопасной.
206 Соединения X11 и любые порты TCP/IP могут также быть проведены через
207 безопасный канал.
208
209 OpenSSH - это переделка командой разработчиков OpenBSD последней
210 свободной версии SSH, доведенная до современного состояния в терминах
211 уровня безопасности и поддерживаемых возможностей. Все патентованные
212 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
213
214 Этот пакет содержит файлы, необходимые как для клиента, так и для
215 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
216 openssh-server, или оба пакета.
217
218 %description -l uk.UTF-8
219 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
220 машини та для виконання команд на віддаленій машині. Вона призначена
221 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
222 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
223 довільні порти TCP/IP можуть також бути проведені через безпечний
224 канал.
225
226 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
227 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
228 підтримуваних можливостей. Всі патентовані алгоритми винесені до
229 окремих бібліотек (OpenSSL).
230
231 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
232 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
233 openssh-server, чи обидва пакети.
234
235 %package clients
236 Summary:        OpenSSH Secure Shell protocol clients
237 Summary(es.UTF-8):      Clientes de OpenSSH
238 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
239 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
240 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
241 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
242 Group:          Applications/Networking
243 Requires:       %{name}
244 Provides:       ssh-clients
245 Obsoletes:      ssh-clients
246
247 %description clients
248 Ssh (Secure Shell) a program for logging into a remote machine and for
249 executing commands in a remote machine. It is intended to replace
250 rlogin and rsh, and provide secure encrypted communications between
251 two untrusted hosts over an insecure network. X11 connections and
252 arbitrary TCP/IP ports can also be forwarded over the secure channel.
253
254 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
255 it up to date in terms of security and features, as well as removing
256 all patented algorithms to seperate libraries (OpenSSL).
257
258 This package includes the clients necessary to make encrypted
259 connections to SSH servers.
260
261 %description clients -l es.UTF-8
262 Este paquete incluye los clientes que se necesitan para hacer
263 conexiones codificadas con servidores SSH.
264
265 %description clients -l pl.UTF-8
266 Ssh (Secure Shell) to program służący do logowania się na zdalną
267 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
268 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
269 pomiędzy dwoma hostami.
270
271 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
272
273 %description clients -l pt_BR.UTF-8
274 Esse pacote inclui os clientes necessários para fazer conexões
275 encriptadas com servidores SSH.
276
277 %description clients -l ru.UTF-8
278 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
279 машину и для выполнения команд на удаленной машине.
280
281 Этот пакет содержит программы-клиенты, необходимые для установления
282 зашифрованных соединений с серверами SSH.
283
284 %description clients -l uk.UTF-8
285 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
286 машини та для виконання команд на віддаленій машині.
287
288 Цей пакет містить програми-клієнти, необхідні для встановлення
289 зашифрованих з'єднань з серверами SSH.
290
291 %package clients-agent-profile_d
292 Summary:        OpenSSH Secure Shell agent init script
293 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
294 Group:          Applications/Networking
295 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
296
297 %description clients-agent-profile_d
298 profile.d scripts for starting SSH agent.
299
300 %description clients-agent-profile_d -l pl.UTF-8
301 Skrypty profile.d do uruchamiania agenta SSH.
302
303 %package clients-agent-xinitrc
304 Summary:        OpenSSH Secure Shell agent init script
305 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
306 Group:          Applications/Networking
307 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
308 Requires:       xinitrc
309
310 %description clients-agent-xinitrc
311 xinitrc scripts for starting SSH agent.
312
313 %description clients-agent-xinitrc -l pl.UTF-8
314 Skrypty xinitrc do uruchamiania agenta SSH.
315
316 %package server
317 Summary:        OpenSSH Secure Shell protocol server (sshd)
318 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
319 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
320 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
321 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
322 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
323 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
324 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
325 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
326 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
327 Group:          Networking/Daemons
328 Requires(post): /sbin/chkconfig
329 Requires(post): grep
330 Requires(post,preun):   /sbin/chkconfig
331 Requires(postun):       /usr/sbin/userdel
332 Requires(pre):  /bin/id
333 Requires(pre):  /usr/sbin/useradd
334 Requires:       %{name} = %{epoch}:%{version}-%{release}
335 Requires:       pam >= %{pam_ver}
336 Requires:       rc-scripts >= 0.4.3.0
337 Requires:       util-linux
338 Suggests:       /bin/login
339 Provides:       ssh-server
340 Provides:       user(sshd)
341
342 %description server
343 Ssh (Secure Shell) a program for logging into a remote machine and for
344 executing commands in a remote machine. It is intended to replace
345 rlogin and rsh, and provide secure encrypted communications between
346 two untrusted hosts over an insecure network. X11 connections and
347 arbitrary TCP/IP ports can also be forwarded over the secure channel.
348
349 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
350 it up to date in terms of security and features, as well as removing
351 all patented algorithms to seperate libraries (OpenSSL).
352
353 This package contains the secure shell daemon. The sshd is the server
354 part of the secure shell protocol and allows ssh clients to connect to
355 your host.
356
357 %description server -l de.UTF-8
358 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
359
360 %description server -l es.UTF-8
361 Este paquete contiene el servidor SSH. sshd es la parte servidor del
362 protocolo secure shell y permite que clientes ssh se conecten a su
363 servidor.
364
365 %description server -l fr.UTF-8
366 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
367
368 %description server -l it.UTF-8
369 Questo pacchetto installa sshd, il server di OpenSSH.
370
371 %description server -l pl.UTF-8
372 Ssh (Secure Shell) to program służący do logowania się na zdalną
373 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
374 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
375 pomiędzy dwoma hostami.
376
377 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
378 ssh).
379
380 %description server -l pt.UTF-8
381 Este pacote intala o sshd, o servidor do OpenSSH.
382
383 %description server -l pt_BR.UTF-8
384 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
385 protocolo secure shell e permite que clientes ssh se conectem ao seu
386 host.
387
388 %description server -l ru.UTF-8
389 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
390 машину и для выполнения команд на удаленной машине.
391
392 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
393 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
394 вашим хостом.
395
396 %description server -l uk.UTF-8
397 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
398 машини та для виконання команд на віддаленій машині.
399
400 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
401 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
402 з вашим хостом.
403
404 %package server-upstart
405 Summary:        Upstart job description for OpenSSH server
406 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
407 Group:          Daemons
408 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
409 Requires:       upstart >= 0.6
410 Conflicts:      syslog-ng < 3.2.4-1
411
412 %description server-upstart
413 Upstart job description for OpenSSH.
414
415 %description server-upstart -l pl.UTF-8
416 Opis zadania Upstart dla OpenSSH.
417
418 %package gnome-askpass
419 Summary:        OpenSSH GNOME passphrase dialog
420 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
421 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
422 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
423 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
424 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
425 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
426 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
427 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
428 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
429 Group:          Applications/Networking
430 Requires:       %{name} = %{epoch}:%{version}-%{release}
431 Obsoletes:      openssh-askpass
432 Obsoletes:      ssh-askpass
433 Obsoletes:      ssh-extras
434
435 %description gnome-askpass
436 Ssh (Secure Shell) a program for logging into a remote machine and for
437 executing commands in a remote machine. It is intended to replace
438 rlogin and rsh, and provide secure encrypted communications between
439 two untrusted hosts over an insecure network. X11 connections and
440 arbitrary TCP/IP ports can also be forwarded over the secure channel.
441
442 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
443 it up to date in terms of security and features, as well as removing
444 all patented algorithms to seperate libraries (OpenSSL).
445
446 This package contains the GNOME passphrase dialog.
447
448 %description gnome-askpass -l es.UTF-8
449 Este paquete contiene un programa que abre una caja de diálogo para
450 entrada de passphrase en GNOME.
451
452 %description gnome-askpass -l pl.UTF-8
453 Ssh (Secure Shell) to program służący do logowania się na zdalną
454 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
455 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
456 pomiędzy dwoma hostami.
457
458 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
459
460 %description gnome-askpass -l pt_BR.UTF-8
461 Esse pacote contém um programa que abre uma caixa de diálogo para
462 entrada de passphrase no GNOME.
463
464 %description gnome-askpass -l ru.UTF-8
465 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
466 машину и для выполнения команд на удаленной машине.
467
468 Этот пакет содержит диалог ввода ключевой фразы для использования под
469 GNOME.
470
471 %description gnome-askpass -l uk.UTF-8
472 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
473 машини та для виконання команд на віддаленій машині.
474
475 Цей пакет містить діалог вводу ключової фрази для використання під
476 GNOME.
477
478 %package -n openldap-schema-openssh-lpk
479 Summary:        OpenSSH LDAP Public Key schema
480 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
481 Group:          Networking/Daemons
482 Requires(post,postun):  sed >= 4.0
483 Requires:       openldap-servers
484
485 %description -n openldap-schema-openssh-lpk
486 This package contains OpenSSH LDAP Public Key schema for openldap.
487
488 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
489 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
490 openldap-a.
491
492 %prep
493 %setup -q
494 %{?with_kerberos5:%patch100 -p1}
495 %patch0 -p1
496 %patch2 -p1
497 %patch3 -p1
498 %{?with_ldap:%patch4 -p1}
499 %patch5 -p1
500 %patch6 -p1
501 %{?with_hpn:%patch9 -p1}
502 %patch10 -p1
503 %patch11 -p1
504 %patch12 -p1
505 %patch13 -p1
506
507 cp -p %{SOURCE3} sshd.pam
508 install -p %{SOURCE2} sshd.init
509
510 %if "%{pld_release}" == "ac"
511 # fix for missing x11.pc
512 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
513 # not present in ac, no point searching it
514 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
515
516 # openssl on ac does not have OPENSSL_HAS_ECC
517 %{__sed} -i -e '/ecdsa/d' sshd.init
518 %endif
519
520 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
521 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
522
523 %build
524 cp /usr/share/automake/config.sub .
525 %{__aclocal}
526 %{__autoconf}
527 %{__autoheader}
528 CPPFLAGS="-DCHROOT"
529 %configure \
530         PERL=%{__perl} \
531         --disable-strip \
532         --enable-utmpx \
533         --enable-wtmpx \
534         --with-4in6 \
535         %{?with_audit:--with-audit=linux} \
536         --with-ipaddr-display \
537         %{?with_kerberos5:--with-kerberos5=/usr} \
538         %{?with_ldap:--with-ldap} \
539         %{?with_libedit:--with-libedit} \
540         --with-mantype=man \
541         --with-md5-passwords \
542         --with-pam \
543         --with-pid-dir=%{_localstatedir}/run \
544         --with-privsep-path=%{_privsepdir} \
545         %{?with_selinux:--with-selinux} \
546         --with-tcp-wrappers \
547 %if "%{pld_release}" == "ac"
548         --with-xauth=/usr/X11R6/bin/xauth
549 %else
550         --with-xauth=%{_bindir}/xauth
551 %endif
552
553 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
554
555 %{__make}
556
557 cd contrib
558 %if %{with gnome}
559 %{__make} gnome-ssh-askpass1 \
560         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
561 %endif
562 %if %{with gtk}
563 %{__make} gnome-ssh-askpass2 \
564         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
565 %endif
566
567 %install
568 rm -rf $RPM_BUILD_ROOT
569 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
570         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
571 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
572
573 %{__make} install \
574         DESTDIR=$RPM_BUILD_ROOT
575
576 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
577
578 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
579 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
580 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
581 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
582 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
583 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
584 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
585 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
586
587 %if %{with gnome}
588 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
589 %endif
590 %if %{with gtk}
591 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
592 %endif
593 %if %{with gnome} || %{with gtk}
594 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
595 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
596 EOF
597 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
598 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
599 EOF
600 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
601 %endif
602
603 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
604 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
605
606 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
607 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
608
609 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
610
611 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
612 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
613 EOF
614
615 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
616
617 %clean
618 rm -rf $RPM_BUILD_ROOT
619
620 %post clients
621 %env_update
622
623 %postun clients
624 %env_update
625
626 %post gnome-askpass
627 %env_update
628
629 %postun gnome-askpass
630 %env_update
631
632 %pre server
633 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
634
635 %post server
636 /sbin/chkconfig --add sshd
637 %service sshd reload "openssh daemon"
638 if ! grep -qs ssh /etc/security/passwd.conf ; then
639         umask 022
640         echo "ssh" >> /etc/security/passwd.conf
641 fi
642
643 %preun server
644 if [ "$1" = "0" ]; then
645         %service sshd stop
646         /sbin/chkconfig --del sshd
647 fi
648
649 %postun server
650 if [ "$1" = "0" ]; then
651         %userremove sshd
652 fi
653
654 %triggerpostun server -- %{name}-server < 5.9p1-1
655 # lpk.patch to ldap.patch
656 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
657         echo >&2 "Migrating LPK patch to LDAP patch"
658         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
659         %{__sed} -i -e '
660                 # disable old configs
661                 # just UseLPK/LkpLdapConf supported for now
662                 s/^UseLPK/## Obsolete &/
663                 s/^LPK/## Obsolete &/
664                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
665                 /UseLPK/iAuthorizedKeysCommand "%{_libexecdir}/ssh-ldap-wrapper"
666         ' %{_sysconfdir}/sshd_config
667 fi
668
669 %post server-upstart
670 %upstart_post sshd
671
672 %postun server-upstart
673 %upstart_postun sshd
674
675 %post -n openldap-schema-openssh-lpk
676 %openldap_schema_register %{schemadir}/openssh-lpk.schema
677 %service -q ldap restart
678
679 %postun -n openldap-schema-openssh-lpk
680 if [ "$1" = "0" ]; then
681         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
682         %service -q ldap restart
683 fi
684
685 %files
686 %defattr(644,root,root,755)
687 %doc TODO README OVERVIEW CREDITS Change*
688 %attr(755,root,root) %{_bindir}/ssh-key*
689 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
690 %{_mandir}/man1/ssh-key*.1*
691 %{_mandir}/man1/ssh-vulnkey*.1*
692 %dir %{_sysconfdir}
693 %dir %{_libexecdir}
694
695 %files clients
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_bindir}/ssh
698 %attr(755,root,root) %{_bindir}/slogin
699 %attr(755,root,root) %{_bindir}/sftp
700 %attr(755,root,root) %{_bindir}/ssh-agent
701 %attr(755,root,root) %{_bindir}/ssh-add
702 %attr(755,root,root) %{_bindir}/ssh-copy-id
703 %attr(755,root,root) %{_bindir}/scp
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
705 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
706 %{_mandir}/man1/scp.1*
707 %{_mandir}/man1/ssh.1*
708 %{_mandir}/man1/slogin.1*
709 %{_mandir}/man1/sftp.1*
710 %{_mandir}/man1/ssh-agent.1*
711 %{_mandir}/man1/ssh-add.1*
712 %{_mandir}/man1/ssh-copy-id.1*
713 %{_mandir}/man5/ssh_config.5*
714 %lang(it) %{_mandir}/it/man1/ssh.1*
715 %lang(it) %{_mandir}/it/man5/ssh_config.5*
716 %lang(pl) %{_mandir}/pl/man1/scp.1*
717 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
718
719 # for host-based auth (suid required for accessing private host key)
720 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
721 #%{_mandir}/man8/ssh-keysign.8*
722
723 %files clients-agent-profile_d
724 %defattr(644,root,root,755)
725 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
726 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
727
728 %files clients-agent-xinitrc
729 %defattr(644,root,root,755)
730 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
731
732 %files server
733 %defattr(644,root,root,755)
734 %doc HOWTO.ldap-keys
735 %attr(755,root,root) %{_sbindir}/sshd
736 %attr(755,root,root) %{_libexecdir}/sftp-server
737 %attr(755,root,root) %{_libexecdir}/ssh-keysign
738 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
739 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
740 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
741 %{_mandir}/man8/sshd.8*
742 %{_mandir}/man8/sftp-server.8*
743 %{_mandir}/man8/ssh-keysign.8*
744 %{_mandir}/man8/ssh-ldap-helper.8*
745 %{_mandir}/man8/ssh-pkcs11-helper.8*
746 %{_mandir}/man5/sshd_config.5*
747 %{_mandir}/man5/ssh-ldap.conf.5*
748 %{_mandir}/man5/moduli.5*
749 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
750 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ldap.conf
751 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
752 %attr(640,root,root) %{_sysconfdir}/moduli
753 %attr(754,root,root) /etc/rc.d/init.d/sshd
754 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
755 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
756
757 %if %{with gnome} || %{with gtk}
758 %files gnome-askpass
759 %defattr(644,root,root,755)
760 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
761 %dir %{_libexecdir}/ssh
762 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
763 %attr(755,root,root) %{_libexecdir}/ssh-askpass
764 %endif
765
766 %if %{with ldap}
767 %files -n openldap-schema-openssh-lpk
768 %defattr(644,root,root,755)
769 %{schemadir}/openssh-lpk.schema
770 %endif
771
772 %if "%{pld_release}" != "ti"
773 %files server-upstart
774 %defattr(644,root,root,755)
775 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
776 %endif
This page took 0.096112 seconds and 2 git commands to generate.