]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
suggest xauth in server package as well
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15 %bcond_without  tests
16
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19
20 %if "%{pld_release}" == "ac"
21 %define         pam_ver 0.79.0
22 %else
23 %define         pam_ver 1:1.1.5-5
24 %endif
25
26 Summary:        OpenSSH free Secure Shell (SSH) implementation
27 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
28 Summary(es.UTF-8):      Implementación libre de SSH
29 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
30 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
31 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
32 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
33 Summary(pt_BR.UTF-8):   Implementação livre do SSH
34 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
35 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
36 Name:           openssh
37 Version:        6.1p1
38 Release:        2
39 Epoch:          2
40 License:        BSD
41 Group:          Applications/Networking
42 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
43 # Source0-md5:  3345cbf4efe90ffb06a78670ab2d05d5
44 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
46 Source2:        %{name}d.init
47 Source3:        %{name}d.pamd
48 Source4:        %{name}.sysconfig
49 Source5:        ssh-agent.sh
50 Source6:        ssh-agent.conf
51 Source7:        %{name}-lpk.schema
52 Source8:        %{name}d.upstart
53 Source9:        sshd.service
54 Source10:       sshd-keygen
55 Source11:       sshd.socket
56 Source12:       sshd@.service
57 Patch100:       %{name}-heimdal.patch
58 Patch0:         %{name}-no_libnsl.patch
59 Patch2:         %{name}-pam_misc.patch
60 Patch3:         %{name}-sigpipe.patch
61 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
62 Patch4:         %{name}-5.9p1-ldap.patch
63 Patch5:         %{name}-5.9p1-ldap-fixes.patch
64 Patch8:         ldap.conf.patch
65 Patch6:         %{name}-config.patch
66 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
67 Patch7:         authorized-keys-command.patch
68 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
69 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
70 Patch9:         %{name}-5.2p1-hpn13v6.diff
71 Patch10:        %{name}-include.patch
72 Patch11:        %{name}-chroot.patch
73 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
74 Patch12:        %{name}-blacklist.diff
75 Patch13:        %{name}-kuserok.patch
76 Patch14:        %{name}-bind.patch
77 Patch15:        %{name}-disable_ldap.patch
78 URL:            http://www.openssh.com/portable.html
79 BuildRequires:  %{__perl}
80 %{?with_tests:BuildRequires:    %{name}-server}
81 %{?with_audit:BuildRequires:    audit-libs-devel}
82 BuildRequires:  autoconf >= 2.50
83 BuildRequires:  automake
84 %{?with_gnome:BuildRequires:    gnome-libs-devel}
85 %{?with_gtk:BuildRequires:      gtk+2-devel}
86 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
87 %{?with_libedit:BuildRequires:  libedit-devel}
88 %{?with_selinux:BuildRequires:  libselinux-devel}
89 BuildRequires:  libwrap-devel
90 %{?with_ldap:BuildRequires:     openldap-devel}
91 BuildRequires:  openssl-devel >= 0.9.7d
92 BuildRequires:  pam-devel
93 %{?with_gtk:BuildRequires:      pkgconfig}
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.627
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  zlib-devel >= 1.2.3
98 Requires:       zlib >= 1.2.3
99 %if "%{pld_release}" == "ac"
100 Requires:       filesystem >= 2.0-1
101 Requires:       pam >= 0.79.0
102 %else
103 Requires:       filesystem >= 3.0-11
104 Requires:       pam >= %{pam_ver}
105 Suggests:       openssh-blacklist
106 Suggests:       xorg-app-xauth
107 %endif
108 Obsoletes:      ssh
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         _sysconfdir     /etc/ssh
112 %define         _libexecdir     %{_libdir}/%{name}
113 %define         _privsepdir     /usr/share/empty
114 %define         schemadir       /usr/share/openldap/schema
115
116 %description
117 Ssh (Secure Shell) a program for logging into a remote machine and for
118 executing commands in a remote machine. It is intended to replace
119 rlogin and rsh, and provide secure encrypted communications between
120 two untrusted hosts over an insecure network. X11 connections and
121 arbitrary TCP/IP ports can also be forwarded over the secure channel.
122
123 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
124 it up to date in terms of security and features, as well as removing
125 all patented algorithms to seperate libraries (OpenSSL).
126
127 This package includes the core files necessary for both the OpenSSH
128 client and server. To make this package useful, you should also
129 install openssh-clients, openssh-server, or both.
130
131 %if %{with hpn}
132 This release includes High Performance SSH/SCP patches from
133 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
134 increase throughput on fast connections with high RTT (20-150 msec).
135 See the website for '-w' values for your connection and /proc/sys TCP
136 values. BTW. in a LAN you have got generally RTT < 1 msec.
137 %endif
138
139 %description -l de.UTF-8
140 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
141 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
142 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
143 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
144 andere TCP/IP Ports können ebenso über den sicheren Channel
145 weitergeleitet werden.
146
147 %description -l es.UTF-8
148 SSH es un programa para accesar y ejecutar órdenes en computadores
149 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
150 seguro entre dos servidores en una red insegura. Conexiones X11 y
151 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
152 seguro.
153
154 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
155 continuar la última versión gratuita de SSH, actualizándolo en
156 términos de seguridad y recursos,así también eliminando todos los
157 algoritmos patentados y colocándolos en bibliotecas separadas
158 (OpenSSL).
159
160 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
161 también el paquete openssh-clients u openssh-server o ambos.
162
163 %description -l fr.UTF-8
164 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
165 remplace telnet, rlogin, rexec et rsh, tout en assurant des
166 communications cryptées securisées entre deux hôtes non fiabilisés sur
167 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
168 arbitraires peuvent également être transmis sur le canal sécurisé.
169
170 %description -l it.UTF-8
171 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
172 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
173 sicure e crittate tra due host non fidati su una rete non sicura. Le
174 connessioni X11 ad una porta TCP/IP arbitraria possono essere
175 inoltrate attraverso un canale sicuro.
176
177 %description -l pl.UTF-8
178 Ssh (Secure Shell) to program służący do logowania się na zdalną
179 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
180 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
181 pomiędzy dwoma hostami.
182
183 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
184 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
185 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
186
187 %if %{with hpn}
188 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
189 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
190 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
191 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
192 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
193 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
194 %endif
195
196 %description -l pt.UTF-8
197 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
198 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
199 cifradas entre duas máquinas sem confiança mútua sobre uma rede
200 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
201 reenviados pelo canal seguro.
202
203 %description -l pt_BR.UTF-8
204 SSH é um programa para acessar e executar comandos em máquinas
205 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
206 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
207 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
208
209 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
210 última versão gratuita do SSH, atualizando-o em termos de segurança e
211 recursos, assim como removendo todos os algoritmos patenteados e
212 colocando-os em bibliotecas separadas (OpenSSL).
213
214 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
215 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
216
217 %description -l ru.UTF-8
218 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
219 машину и для выполнения команд на удаленной машине. Она предназначена
220 для замены rlogin и rsh и обеспечивает безопасную шифрованную
221 коммуникацию между двумя хостами в сети, являющейся небезопасной.
222 Соединения X11 и любые порты TCP/IP могут также быть проведены через
223 безопасный канал.
224
225 OpenSSH - это переделка командой разработчиков OpenBSD последней
226 свободной версии SSH, доведенная до современного состояния в терминах
227 уровня безопасности и поддерживаемых возможностей. Все патентованные
228 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
229
230 Этот пакет содержит файлы, необходимые как для клиента, так и для
231 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
232 openssh-server, или оба пакета.
233
234 %description -l uk.UTF-8
235 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
236 машини та для виконання команд на віддаленій машині. Вона призначена
237 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
238 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
239 довільні порти TCP/IP можуть також бути проведені через безпечний
240 канал.
241
242 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
243 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
244 підтримуваних можливостей. Всі патентовані алгоритми винесені до
245 окремих бібліотек (OpenSSL).
246
247 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
248 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
249 openssh-server, чи обидва пакети.
250
251 %package clients
252 Summary:        OpenSSH Secure Shell protocol clients
253 Summary(es.UTF-8):      Clientes de OpenSSH
254 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
255 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
256 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
257 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
258 Group:          Applications/Networking
259 Requires:       %{name}
260 Provides:       ssh-clients
261 Obsoletes:      ssh-clients
262
263 %description clients
264 Ssh (Secure Shell) a program for logging into a remote machine and for
265 executing commands in a remote machine. It is intended to replace
266 rlogin and rsh, and provide secure encrypted communications between
267 two untrusted hosts over an insecure network. X11 connections and
268 arbitrary TCP/IP ports can also be forwarded over the secure channel.
269
270 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
271 it up to date in terms of security and features, as well as removing
272 all patented algorithms to seperate libraries (OpenSSL).
273
274 This package includes the clients necessary to make encrypted
275 connections to SSH servers.
276
277 %description clients -l es.UTF-8
278 Este paquete incluye los clientes que se necesitan para hacer
279 conexiones codificadas con servidores SSH.
280
281 %description clients -l pl.UTF-8
282 Ssh (Secure Shell) to program służący do logowania się na zdalną
283 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
284 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
285 pomiędzy dwoma hostami.
286
287 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
288
289 %description clients -l pt_BR.UTF-8
290 Esse pacote inclui os clientes necessários para fazer conexões
291 encriptadas com servidores SSH.
292
293 %description clients -l ru.UTF-8
294 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
295 машину и для выполнения команд на удаленной машине.
296
297 Этот пакет содержит программы-клиенты, необходимые для установления
298 зашифрованных соединений с серверами SSH.
299
300 %description clients -l uk.UTF-8
301 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
302 машини та для виконання команд на віддаленій машині.
303
304 Цей пакет містить програми-клієнти, необхідні для встановлення
305 зашифрованих з'єднань з серверами SSH.
306
307 %package clients-agent-profile_d
308 Summary:        OpenSSH Secure Shell agent init script
309 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
310 Group:          Applications/Networking
311 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
312
313 %description clients-agent-profile_d
314 profile.d scripts for starting SSH agent.
315
316 %description clients-agent-profile_d -l pl.UTF-8
317 Skrypty profile.d do uruchamiania agenta SSH.
318
319 %package clients-agent-xinitrc
320 Summary:        OpenSSH Secure Shell agent init script
321 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
322 Group:          Applications/Networking
323 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
324 Requires:       xinitrc
325
326 %description clients-agent-xinitrc
327 xinitrc scripts for starting SSH agent.
328
329 %description clients-agent-xinitrc -l pl.UTF-8
330 Skrypty xinitrc do uruchamiania agenta SSH.
331
332 %package server
333 Summary:        OpenSSH Secure Shell protocol server (sshd)
334 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
335 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
336 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
337 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
338 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
339 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
340 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
341 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
342 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
343 Group:          Networking/Daemons
344 Requires(post): /sbin/chkconfig
345 Requires(post): grep
346 Requires(post,preun):   /sbin/chkconfig
347 Requires(postun):       /usr/sbin/userdel
348 Requires(pre):  /bin/id
349 Requires(pre):  /usr/sbin/useradd
350 Requires(post,preun,postun):    systemd-units >= 38
351 Requires:       %{name} = %{epoch}:%{version}-%{release}
352 # remove in 6.0, kept for flawless upgrade
353 %{?with_ldap:Requires:  %{name}-server-ldap = %{epoch}:%{version}-%{release}}
354 Requires:       pam >= %{pam_ver}
355 Requires:       rc-scripts >= 0.4.3.0
356 Requires:       systemd-units >= 38
357 Requires:       util-linux
358 Suggests:       /bin/login
359 Suggests:       xorg-app-xauth
360 Provides:       ssh-server
361 Provides:       user(sshd)
362
363 %description server
364 Ssh (Secure Shell) a program for logging into a remote machine and for
365 executing commands in a remote machine. It is intended to replace
366 rlogin and rsh, and provide secure encrypted communications between
367 two untrusted hosts over an insecure network. X11 connections and
368 arbitrary TCP/IP ports can also be forwarded over the secure channel.
369
370 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
371 it up to date in terms of security and features, as well as removing
372 all patented algorithms to seperate libraries (OpenSSL).
373
374 This package contains the secure shell daemon. The sshd is the server
375 part of the secure shell protocol and allows ssh clients to connect to
376 your host.
377
378 %description server -l de.UTF-8
379 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
380
381 %description server -l es.UTF-8
382 Este paquete contiene el servidor SSH. sshd es la parte servidor del
383 protocolo secure shell y permite que clientes ssh se conecten a su
384 servidor.
385
386 %description server -l fr.UTF-8
387 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
388
389 %description server -l it.UTF-8
390 Questo pacchetto installa sshd, il server di OpenSSH.
391
392 %description server -l pl.UTF-8
393 Ssh (Secure Shell) to program służący do logowania się na zdalną
394 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
395 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
396 pomiędzy dwoma hostami.
397
398 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
399 ssh).
400
401 %description server -l pt.UTF-8
402 Este pacote intala o sshd, o servidor do OpenSSH.
403
404 %description server -l pt_BR.UTF-8
405 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
406 protocolo secure shell e permite que clientes ssh se conectem ao seu
407 host.
408
409 %description server -l ru.UTF-8
410 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
411 машину и для выполнения команд на удаленной машине.
412
413 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
414 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
415 вашим хостом.
416
417 %description server -l uk.UTF-8
418 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
419 машини та для виконання команд на віддаленій машині.
420
421 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
422 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
423 з вашим хостом.
424
425 %package server-ldap
426 Summary:        A LDAP support for open source SSH server daemon
427 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
428 Group:          Daemons
429 Requires:       %{name} = %{epoch}:%{version}-%{release}
430
431 %description server-ldap
432 OpenSSH LDAP backend is a way how to distribute the authorized tokens
433 among the servers in the network.
434
435 %description server-ldap -l pl.UTF-8
436 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
437 tokenów między serwerami w sieci.
438
439 %package server-upstart
440 Summary:        Upstart job description for OpenSSH server
441 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
442 Group:          Daemons
443 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
444 Requires:       upstart >= 0.6
445 Conflicts:      syslog-ng < 3.2.4-1
446
447 %description server-upstart
448 Upstart job description for OpenSSH.
449
450 %description server-upstart -l pl.UTF-8
451 Opis zadania Upstart dla OpenSSH.
452
453 %package gnome-askpass
454 Summary:        OpenSSH GNOME passphrase dialog
455 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
456 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
457 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
458 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
459 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
460 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
461 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
462 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
463 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
464 Group:          Applications/Networking
465 Requires:       %{name} = %{epoch}:%{version}-%{release}
466 Obsoletes:      openssh-askpass
467 Obsoletes:      ssh-askpass
468 Obsoletes:      ssh-extras
469
470 %description gnome-askpass
471 Ssh (Secure Shell) a program for logging into a remote machine and for
472 executing commands in a remote machine. It is intended to replace
473 rlogin and rsh, and provide secure encrypted communications between
474 two untrusted hosts over an insecure network. X11 connections and
475 arbitrary TCP/IP ports can also be forwarded over the secure channel.
476
477 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
478 it up to date in terms of security and features, as well as removing
479 all patented algorithms to seperate libraries (OpenSSL).
480
481 This package contains the GNOME passphrase dialog.
482
483 %description gnome-askpass -l es.UTF-8
484 Este paquete contiene un programa que abre una caja de diálogo para
485 entrada de passphrase en GNOME.
486
487 %description gnome-askpass -l pl.UTF-8
488 Ssh (Secure Shell) to program służący do logowania się na zdalną
489 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
490 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
491 pomiędzy dwoma hostami.
492
493 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
494
495 %description gnome-askpass -l pt_BR.UTF-8
496 Esse pacote contém um programa que abre uma caixa de diálogo para
497 entrada de passphrase no GNOME.
498
499 %description gnome-askpass -l ru.UTF-8
500 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
501 машину и для выполнения команд на удаленной машине.
502
503 Этот пакет содержит диалог ввода ключевой фразы для использования под
504 GNOME.
505
506 %description gnome-askpass -l uk.UTF-8
507 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
508 машини та для виконання команд на віддаленій машині.
509
510 Цей пакет містить діалог вводу ключової фрази для використання під
511 GNOME.
512
513 %package -n openldap-schema-openssh-lpk
514 Summary:        OpenSSH LDAP Public Key schema
515 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
516 Group:          Networking/Daemons
517 Requires(post,postun):  sed >= 4.0
518 Requires:       openldap-servers
519
520 %description -n openldap-schema-openssh-lpk
521 This package contains OpenSSH LDAP Public Key schema for openldap.
522
523 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
524 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
525 openldap-a.
526
527 %prep
528 %setup -q
529 %{?with_kerberos5:%patch100 -p1}
530 %patch0 -p1
531 %patch2 -p1
532 %patch3 -p1
533 %patch4 -p1
534 %patch5 -p1
535 %patch8 -p1
536 %patch6 -p1
537 %patch7 -p1
538 %{?with_hpn:%patch9 -p1}
539 %patch10 -p1
540 %patch11 -p1
541 %patch12 -p1
542 %patch13 -p1
543 %patch14 -p1
544 %{!?with_ldap:%patch15 -p1}
545
546 %if "%{pld_release}" == "ac"
547 # fix for missing x11.pc
548 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
549 %endif
550
551 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
552 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
553
554 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
555 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
556
557 %build
558 cp /usr/share/automake/config.sub .
559 %{__aclocal}
560 %{__autoconf}
561 %{__autoheader}
562 CPPFLAGS="-DCHROOT"
563 %configure \
564         PERL=%{__perl} \
565         --disable-strip \
566         --enable-utmpx \
567         --enable-wtmpx \
568         --with-4in6 \
569         %{?with_audit:--with-audit=linux} \
570         --with-ipaddr-display \
571         %{?with_kerberos5:--with-kerberos5=/usr} \
572         --with-ldap%{!?with_ldap:=no} \
573         %{?with_libedit:--with-libedit} \
574         --with-mantype=man \
575         --with-md5-passwords \
576         --with-pam \
577         --with-authorized-keys-command \
578         --with-pid-dir=%{_localstatedir}/run \
579         --with-privsep-path=%{_privsepdir} \
580         %{?with_selinux:--with-selinux} \
581         --with-tcp-wrappers \
582 %if "%{pld_release}" == "ac"
583         --with-xauth=/usr/X11R6/bin/xauth
584 %else
585         --with-xauth=%{_bindir}/xauth
586 %endif
587
588 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
589
590 %{__make}
591
592 %{?with_tests:%{__make} tests}
593
594 cd contrib
595 %if %{with gnome}
596 %{__make} gnome-ssh-askpass1 \
597         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
598 %endif
599 %if %{with gtk}
600 %{__make} gnome-ssh-askpass2 \
601         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
602 %endif
603
604 %install
605 rm -rf $RPM_BUILD_ROOT
606 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
607         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
608 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
609
610 %{__make} install \
611         DESTDIR=$RPM_BUILD_ROOT
612
613 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
614
615 cp -p %{SOURCE3} sshd.pam
616 install -p %{SOURCE2} sshd.init
617
618 %if "%{pld_release}" == "ac"
619 # not present in ac, no point searching it
620 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
621 # openssl on ac does not have OPENSSL_HAS_ECC
622 %{__sed} -i -e '/ecdsa/d' sshd.init
623 %endif
624
625 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
626 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
627 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
628 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
629 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
630 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
631 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
632 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
633
634 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
635 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
636
637 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
638 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
639
640 %if %{with gnome}
641 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
642 %endif
643 %if %{with gtk}
644 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
645 %endif
646 %if %{with gnome} || %{with gtk}
647 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
648 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
649 EOF
650 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
651 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
652 EOF
653 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
654 %endif
655
656 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
657 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
658
659 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
660 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
661
662 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
663
664 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
665 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
666 EOF
667
668 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
669 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
670
671 %clean
672 rm -rf $RPM_BUILD_ROOT
673
674 %post clients
675 %env_update
676
677 %postun clients
678 %env_update
679
680 %post gnome-askpass
681 %env_update
682
683 %postun gnome-askpass
684 %env_update
685
686 %pre server
687 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
688
689 %post server
690 /sbin/chkconfig --add sshd
691 %service sshd reload "OpenSSH Daemon"
692 NORESTART=1
693 %systemd_post sshd.service
694
695 %preun server
696 if [ "$1" = "0" ]; then
697         %service sshd stop
698         /sbin/chkconfig --del sshd
699 fi
700 %systemd_preun sshd.service
701
702 %postun server
703 if [ "$1" = "0" ]; then
704         %userremove sshd
705 fi
706 %systemd_reload
707
708 %triggerpostun server -- %{name}-server < 2:5.9p1-8
709 # lpk.patch to ldap.patch
710 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
711         echo >&2 "Migrating LPK patch to LDAP patch"
712         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
713         %{__sed} -i -e '
714                 # disable old configs
715                 # just UseLPK/LkpLdapConf supported for now
716                 s/^\s*UseLPK/## Obsolete &/
717                 s/^\s*Lpk/## Obsolete &/
718                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
719                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
720         ' %{_sysconfdir}/sshd_config
721         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
722                 /bin/systemctl try-restart sshd.service || :
723         else
724                 %service -q sshd reload
725         fi
726 fi
727 %systemd_trigger sshd.service
728 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
729 %banner %{name}-server -e << EOF
730 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
731 ! Native systemd support for sshd has been installed.   !
732 ! Restarting sshd.service with systemctl WILL kill all  !
733 ! active ssh sessions (daemon as such will be started). !
734 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
735 EOF
736 fi
737
738 %post server-upstart
739 %upstart_post sshd
740
741 %postun server-upstart
742 %upstart_postun sshd
743
744 %post -n openldap-schema-openssh-lpk
745 %openldap_schema_register %{schemadir}/openssh-lpk.schema
746 %service -q ldap restart
747
748 %postun -n openldap-schema-openssh-lpk
749 if [ "$1" = "0" ]; then
750         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
751         %service -q ldap restart
752 fi
753
754 %files
755 %defattr(644,root,root,755)
756 %doc TODO README OVERVIEW CREDITS Change*
757 %attr(755,root,root) %{_bindir}/ssh-key*
758 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
759 %{_mandir}/man1/ssh-key*.1*
760 %{_mandir}/man1/ssh-vulnkey*.1*
761 %dir %{_sysconfdir}
762 %dir %{_libexecdir}
763
764 %files clients
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_bindir}/ssh
767 %attr(755,root,root) %{_bindir}/slogin
768 %attr(755,root,root) %{_bindir}/sftp
769 %attr(755,root,root) %{_bindir}/ssh-agent
770 %attr(755,root,root) %{_bindir}/ssh-add
771 %attr(755,root,root) %{_bindir}/ssh-copy-id
772 %attr(755,root,root) %{_bindir}/scp
773 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
774 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
775 %{_mandir}/man1/scp.1*
776 %{_mandir}/man1/ssh.1*
777 %{_mandir}/man1/slogin.1*
778 %{_mandir}/man1/sftp.1*
779 %{_mandir}/man1/ssh-agent.1*
780 %{_mandir}/man1/ssh-add.1*
781 %{_mandir}/man1/ssh-copy-id.1*
782 %{_mandir}/man5/ssh_config.5*
783 %lang(it) %{_mandir}/it/man1/ssh.1*
784 %lang(it) %{_mandir}/it/man5/ssh_config.5*
785 %lang(pl) %{_mandir}/pl/man1/scp.1*
786 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
787
788 # for host-based auth (suid required for accessing private host key)
789 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
790 #%{_mandir}/man8/ssh-keysign.8*
791
792 %files clients-agent-profile_d
793 %defattr(644,root,root,755)
794 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
795 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
796
797 %files clients-agent-xinitrc
798 %defattr(644,root,root,755)
799 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
800
801 %files server
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_sbindir}/sshd
804 %attr(755,root,root) %{_libexecdir}/sftp-server
805 %attr(755,root,root) %{_libexecdir}/ssh-keysign
806 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
807 %attr(755,root,root) %{_libexecdir}/sshd-keygen
808 %{_mandir}/man8/sshd.8*
809 %{_mandir}/man8/sftp-server.8*
810 %{_mandir}/man8/ssh-keysign.8*
811 %{_mandir}/man8/ssh-pkcs11-helper.8*
812 %{_mandir}/man5/sshd_config.5*
813 %{_mandir}/man5/moduli.5*
814 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
815 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
816 %attr(640,root,root) %{_sysconfdir}/moduli
817 %attr(754,root,root) /etc/rc.d/init.d/sshd
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
819 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
820 %{systemdunitdir}/sshd.service
821 %{systemdunitdir}/sshd.socket
822 %{systemdunitdir}/sshd@.service
823
824 %if %{with ldap}
825 %files server-ldap
826 %defattr(644,root,root,755)
827 %doc HOWTO.ldap-keys ldap.conf
828 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
829 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
830 %{_mandir}/man5/ssh-ldap.conf.5*
831 %{_mandir}/man8/ssh-ldap-helper.8*
832 %endif
833
834 %if %{with gnome} || %{with gtk}
835 %files gnome-askpass
836 %defattr(644,root,root,755)
837 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
838 %dir %{_libexecdir}/ssh
839 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
840 %attr(755,root,root) %{_libexecdir}/ssh-askpass
841 %endif
842
843 %if %{with ldap}
844 %files -n openldap-schema-openssh-lpk
845 %defattr(644,root,root,755)
846 %{schemadir}/openssh-lpk.schema
847 %endif
848
849 %if "%{pld_release}" != "ti"
850 %files server-upstart
851 %defattr(644,root,root,755)
852 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
853 %endif
This page took 0.138095 seconds and 3 git commands to generate.