]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 4.7p1
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
12 #
13 %if %{with hpn_none}
14 %undefine       with_hpn
15 %endif
16 # gtk2-based gnome-askpass means no gnome1-based
17 %{?with_gtk:%undefine with_gnome}
18 #
19 %define         _rel    1
20 #
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        4.7p1
33 Release:        %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  50a800fd2c6def9e9a53068837e87b91
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Patch0:         %{name}-no_libnsl.patch
47 Patch2:         %{name}-linux-ipv6.patch
48 Patch3:         %{name}-pam_misc.patch
49 Patch4:         %{name}-sigpipe.patch
50 # http://www.opendarwin.org/projects/openssh-lpk/
51 Patch5:         %{name}-lpk-4.3p1-0.3.7.patch
52 Patch6:         %{name}-config.patch
53 Patch7:         %{name}-pam-conv.patch
54 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
55 Patch8:         %{name}-chroot.patch
56 Patch9:         %{name}-selinux.patch
57 # HPN patches rediffed due sigpipe patch.
58 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
59 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
60 Patch10:        %{name}-4.3p1-hpn11.patch
61 # Adds HPN (see p11) and an undocumented -z none cipher flag
62 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
63 Patch11:        %{name}-4.3p1-hpn11-none.patch
64 Patch12:        %{name}-include.patch
65 URL:            http://www.openssh.com/
66 BuildRequires:  %{__perl}
67 BuildRequires:  autoconf
68 BuildRequires:  automake
69 %{?with_gnome:BuildRequires:    gnome-libs-devel}
70 %{?with_gtk:BuildRequires:      gtk+2-devel}
71 %{?with_kerberos5:BuildRequires:        krb5-devel}
72 %{?with_libedit:BuildRequires:  libedit-devel}
73 %{?with_selinux:BuildRequires:  libselinux-devel}
74 BuildRequires:  libwrap-devel
75 %{?with_ldap:BuildRequires:     openldap-devel}
76 BuildRequires:  openssl-devel >= 0.9.7d
77 BuildRequires:  pam-devel
78 %{?with_gtk:BuildRequires:      pkgconfig}
79 BuildRequires:  rpmbuild(macros) >= 1.318
80 BuildRequires:  zlib-devel
81 Requires:       filesystem >= 3.0-11
82 Requires:       pam >= 0.99.7.1
83 Obsoletes:      ssh
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _sysconfdir     /etc/ssh
87 %define         _libexecdir     %{_libdir}/%{name}
88 %define         _privsepdir     /usr/share/empty
89
90 %description
91 Ssh (Secure Shell) a program for logging into a remote machine and for
92 executing commands in a remote machine. It is intended to replace
93 rlogin and rsh, and provide secure encrypted communications between
94 two untrusted hosts over an insecure network. X11 connections and
95 arbitrary TCP/IP ports can also be forwarded over the secure channel.
96
97 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
98 it up to date in terms of security and features, as well as removing
99 all patented algorithms to seperate libraries (OpenSSL).
100
101 This package includes the core files necessary for both the OpenSSH
102 client and server. To make this package useful, you should also
103 install openssh-clients, openssh-server, or both.
104 %if %{with hpn} || %{with hpn_none}
105 This release includes High Performance SSH/SCP patches from
106 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
107 to increase throughput on fast connections with high RTT (20-150 msec).
108 See the website for '-w' values for your connection and /proc/sys TCP
109 values. BTW. in a LAN you have got generally RTT < 1 msec.
110 %endif
111 %if %{with hpn_none}
112 It also includes an undocumented '-z' option which switches
113 the cipher to none after authentication is completed. Data is
114 still secured from tampering and corruption in transit through
115 the use of the Message Authentication Code (MAC).
116 This option will significantly reduce the number of cpu cycles used
117 by the SSH/SCP process. This may allow some users to see significant
118 improvement in (sniffable) data tranfer rates.
119 %endif
120
121 %description -l de.UTF-8
122 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
123 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
124 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
125 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
126 andere TCP/IP Ports können ebenso über den sicheren Channel
127 weitergeleitet werden.
128
129 %description -l es.UTF-8
130 SSH es un programa para accesar y ejecutar órdenes en computadores
131 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
132 seguro entre dos servidores en una red insegura. Conexiones X11 y
133 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
134 seguro.
135
136 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
137 continuar la última versión gratuita de SSH, actualizándolo en
138 términos de seguridad y recursos,así también eliminando todos los
139 algoritmos patentados y colocándolos en bibliotecas separadas
140 (OpenSSL).
141
142 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
143 también el paquete openssh-clients u openssh-server o ambos.
144
145 %description -l fr.UTF-8
146 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
147 remplace telnet, rlogin, rexec et rsh, tout en assurant des
148 communications cryptées securisées entre deux hôtes non fiabilisés sur
149 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
150 arbitraires peuvent également être transmis sur le canal sécurisé.
151
152 %description -l it.UTF-8
153 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
154 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
155 sicure e crittate tra due host non fidati su una rete non sicura. Le
156 connessioni X11 ad una porta TCP/IP arbitraria possono essere
157 inoltrate attraverso un canale sicuro.
158
159 %description -l pl.UTF-8
160 Ssh (Secure Shell) to program służący do logowania się na zdalną
161 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
162 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
163 pomiędzy dwoma hostami.
164
165 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
166 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
167 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
168 %if %{with hpn} || %{with hpn_none}
169 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
170 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
171 zwiększenie przepustowości transmisji dla szybkich połączeń
172 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
173 odpowednie dla danego połączenia wartości parametru '-w' oraz
174 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
175 %endif
176 %if %{with hpn_none}
177 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
178 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
179 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
180 stosowanie Message Authentication Code (MAC).
181 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
182 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
183 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
184 %endif
185
186 %description -l pt.UTF-8
187 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
188 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
189 cifradas entre duas máquinas sem confiança mútua sobre uma rede
190 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
191 reenviados pelo canal seguro.
192
193 %description -l pt_BR.UTF-8
194 SSH é um programa para acessar e executar comandos em máquinas
195 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
196 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
197 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
198
199 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
200 última versão gratuita do SSH, atualizando-o em termos de segurança e
201 recursos, assim como removendo todos os algoritmos patenteados e
202 colocando-os em bibliotecas separadas (OpenSSL).
203
204 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
205 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
206
207 %description -l ru.UTF-8
208 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
209 машину и для выполнения команд на удаленной машине. Она предназначена
210 для замены rlogin и rsh и обеспечивает безопасную шифрованную
211 коммуникацию между двумя хостами в сети, являющейся небезопасной.
212 Соединения X11 и любые порты TCP/IP могут также быть проведены через
213 безопасный канал.
214
215 OpenSSH - это переделка командой разработчиков OpenBSD последней
216 свободной версии SSH, доведенная до современного состояния в терминах
217 уровня безопасности и поддерживаемых возможностей. Все патентованные
218 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
219
220 Этот пакет содержит файлы, необходимые как для клиента, так и для
221 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
222 openssh-server, или оба пакета.
223
224 %description -l uk.UTF-8
225 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
226 машини та для виконання команд на віддаленій машині. Вона призначена
227 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
228 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
229 довільні порти TCP/IP можуть також бути проведені через безпечний
230 канал.
231
232 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
233 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
234 підтримуваних можливостей. Всі патентовані алгоритми винесені до
235 окремих бібліотек (OpenSSL).
236
237 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
238 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
239 openssh-server, чи обидва пакети.
240
241 %package clients
242 Summary:        OpenSSH Secure Shell protocol clients
243 Summary(es.UTF-8):      Clientes de OpenSSH
244 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
245 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
246 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
247 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
248 Group:          Applications/Networking
249 Provides:       ssh-clients
250 Requires:       %{name} = %{epoch}:%{version}-%{release}
251 Obsoletes:      ssh-clients
252
253 %description clients
254 Ssh (Secure Shell) a program for logging into a remote machine and for
255 executing commands in a remote machine. It is intended to replace
256 rlogin and rsh, and provide secure encrypted communications between
257 two untrusted hosts over an insecure network. X11 connections and
258 arbitrary TCP/IP ports can also be forwarded over the secure channel.
259
260 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
261 it up to date in terms of security and features, as well as removing
262 all patented algorithms to seperate libraries (OpenSSL).
263
264 This package includes the clients necessary to make encrypted
265 connections to SSH servers.
266
267 %description clients -l es.UTF-8
268 Este paquete incluye los clientes que se necesitan para hacer
269 conexiones codificadas con servidores SSH.
270
271 %description clients -l pl.UTF-8
272 Ssh (Secure Shell) to program służący do logowania się na zdalną
273 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
274 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
275 pomiędzy dwoma hostami.
276
277 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
278
279 %description clients -l pt_BR.UTF-8
280 Esse pacote inclui os clientes necessários para fazer conexões
281 encriptadas com servidores SSH.
282
283 %description clients -l ru.UTF-8
284 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
285 машину и для выполнения команд на удаленной машине.
286
287 Этот пакет содержит программы-клиенты, необходимые для установления
288 зашифрованных соединений с серверами SSH.
289
290 %description clients -l uk.UTF-8
291 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
292 машини та для виконання команд на віддаленій машині.
293
294 Цей пакет містить програми-клієнти, необхідні для встановлення
295 зашифрованих з'єднань з серверами SSH.
296
297 %package clients-agent-profile_d
298 Summary:        OpenSSH Secure Shell agent init script
299 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
300 Group:          Applications/Networking
301 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
302
303 %description clients-agent-profile_d
304 profile.d scripts for starting SSH agent.
305
306 %description clients-agent-profile_d -l pl.UTF-8
307 Skrypty profile.d do uruchamiania agenta SSH.
308
309 %package clients-agent-xinitrc
310 Summary:        OpenSSH Secure Shell agent init script
311 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
312 Group:          Applications/Networking
313 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
314 Requires:       xinitrc
315
316 %description clients-agent-xinitrc
317 xinitrc scripts for starting SSH agent.
318
319 %description clients-agent-xinitrc -l pl.UTF-8
320 Skrypty xinitrc do uruchamiania agenta SSH.
321
322 %package server
323 Summary:        OpenSSH Secure Shell protocol server (sshd)
324 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
325 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
326 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
327 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
328 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
329 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
330 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
331 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
332 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
333 Group:          Networking/Daemons
334 Provides:       ssh-server
335 Provides:       user(sshd)
336 Requires(post): chkconfig >= 0.9
337 Requires(post): grep
338 Requires(post,preun):   /sbin/chkconfig
339 Requires(postun):       /usr/sbin/userdel
340 Requires(pre):  /bin/id
341 Requires(pre):  /usr/sbin/useradd
342 Requires:       %{name} = %{epoch}:%{version}-%{release}
343 Requires:       /bin/login
344 Requires:       pam >= 0.99.7.1
345 Requires:       rc-scripts >= 0.4.0.18
346 Requires:       util-linux
347
348 %description server
349 Ssh (Secure Shell) a program for logging into a remote machine and for
350 executing commands in a remote machine. It is intended to replace
351 rlogin and rsh, and provide secure encrypted communications between
352 two untrusted hosts over an insecure network. X11 connections and
353 arbitrary TCP/IP ports can also be forwarded over the secure channel.
354
355 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
356 it up to date in terms of security and features, as well as removing
357 all patented algorithms to seperate libraries (OpenSSL).
358
359 This package contains the secure shell daemon. The sshd is the server
360 part of the secure shell protocol and allows ssh clients to connect to
361 your host.
362
363 %description server -l de.UTF-8
364 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
365
366 %description server -l es.UTF-8
367 Este paquete contiene el servidor SSH. sshd es la parte servidor del
368 protocolo secure shell y permite que clientes ssh se conecten a su
369 servidor.
370
371 %description server -l fr.UTF-8
372 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
373
374 %description server -l it.UTF-8
375 Questo pacchetto installa sshd, il server di OpenSSH.
376
377 %description server -l pl.UTF-8
378 Ssh (Secure Shell) to program służący do logowania się na zdalną
379 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
380 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
381 pomiędzy dwoma hostami.
382
383 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
384 ssh).
385
386 %description server -l pt.UTF-8
387 Este pacote intala o sshd, o servidor do OpenSSH.
388
389 %description server -l pt_BR.UTF-8
390 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
391 protocolo secure shell e permite que clientes ssh se conectem ao seu
392 host.
393
394 %description server -l ru.UTF-8
395 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
396 машину и для выполнения команд на удаленной машине.
397
398 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
399 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
400 вашим хостом.
401
402 %description server -l uk.UTF-8
403 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
404 машини та для виконання команд на віддаленій машині.
405
406 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
407 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
408 з вашим хостом.
409
410 %package gnome-askpass
411 Summary:        OpenSSH GNOME passphrase dialog
412 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
413 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
414 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
415 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
416 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
417 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
418 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
419 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
420 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
421 Group:          Applications/Networking
422 Requires:       %{name} = %{epoch}:%{version}-%{release}
423 Obsoletes:      openssh-askpass
424 Obsoletes:      ssh-askpass
425 Obsoletes:      ssh-extras
426
427 %description gnome-askpass
428 Ssh (Secure Shell) a program for logging into a remote machine and for
429 executing commands in a remote machine. It is intended to replace
430 rlogin and rsh, and provide secure encrypted communications between
431 two untrusted hosts over an insecure network. X11 connections and
432 arbitrary TCP/IP ports can also be forwarded over the secure channel.
433
434 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
435 it up to date in terms of security and features, as well as removing
436 all patented algorithms to seperate libraries (OpenSSL).
437
438 This package contains the GNOME passphrase dialog.
439
440 %description gnome-askpass -l es.UTF-8
441 Este paquete contiene un programa que abre una caja de diálogo para
442 entrada de passphrase en GNOME.
443
444 %description gnome-askpass -l pl.UTF-8
445 Ssh (Secure Shell) to program służący do logowania się na zdalną
446 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
447 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
448 pomiędzy dwoma hostami.
449
450 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
451
452 %description gnome-askpass -l pt_BR.UTF-8
453 Esse pacote contém um programa que abre uma caixa de diálogo para
454 entrada de passphrase no GNOME.
455
456 %description gnome-askpass -l ru.UTF-8
457 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
458 машину и для выполнения команд на удаленной машине.
459
460 Этот пакет содержит диалог ввода ключевой фразы для использования под
461 GNOME.
462
463 %description gnome-askpass -l uk.UTF-8
464 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
465 машини та для виконання команд на віддаленій машині.
466
467 Цей пакет містить діалог вводу ключової фрази для використання під
468 GNOME.
469
470 %prep
471 %setup -q
472 %patch0 -p1
473 %patch2 -p1
474 %patch3 -p1
475 %patch4 -p1
476 %{?with_ldap:%patch5 -p1}
477 %patch6 -p1
478 #%patch7 -p1
479 %patch8 -p1
480 %patch9 -p1
481 %{?with_hpn:%patch10 -p1}
482 %{?with_hpn_none:%patch11 -p1}
483 %patch12 -p1
484
485 %build
486 cp /usr/share/automake/config.sub .
487 %{__aclocal}
488 %{__autoconf}
489 %{?with_chroot:CPPFLAGS="-DCHROOT"}
490 %configure \
491         PERL=%{__perl} \
492         --with-dns \
493         --with-pam \
494         --with-mantype=man \
495         --with-md5-passwords \
496         --with-ipaddr-display \
497         %{?with_libedit:--with-libedit} \
498         --with-4in6 \
499         --disable-suid-ssh \
500         --with-tcp-wrappers \
501         %{?with_ldap:--with-libs="-lldap -llber"} \
502         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
503         %{?with_kerberos5:--with-kerberos5=/usr} \
504         --with-privsep-path=%{_privsepdir} \
505         --with-pid-dir=%{_localstatedir}/run \
506         --with-xauth=/usr/bin/xauth \
507         --enable-utmpx \
508         --enable-wtmpx
509
510 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
511
512 %{__make}
513
514 cd contrib
515 %if %{with gnome}
516 %{__make} gnome-ssh-askpass1 \
517         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
518 %endif
519 %if %{with gtk}
520 %{__make} gnome-ssh-askpass2 \
521         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
522 %endif
523
524 %install
525 rm -rf $RPM_BUILD_ROOT
526 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
527         $RPM_BUILD_ROOT%{_libexecdir}/ssh
528 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
529
530 %{__make} install \
531         DESTDIR=$RPM_BUILD_ROOT
532
533 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
534
535 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
536 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
537 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
538 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
539 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
540 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
541
542 %if %{with gnome}
543 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
544 %endif
545 %if %{with gtk}
546 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
547 %endif
548 %if %{with gnome} || %{with gtk}
549 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
550 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
551 EOF
552 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
553 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
554 EOF
555 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
556 %endif
557
558 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
559 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
560
561 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
562
563 %if "%{_lib}" != "lib"
564 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
565 %endif
566
567 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
568 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
569 EOF
570
571 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
572 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
573
574 %clean
575 rm -rf $RPM_BUILD_ROOT
576
577 %post clients
578 %env_update
579
580 %postun clients
581 %env_update
582
583 %post gnome-askpass
584 %env_update
585
586 %postun gnome-askpass
587 %env_update
588
589 %pre server
590 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
591
592 %post server
593 /sbin/chkconfig --add sshd
594 %service sshd reload "openssh daemon"
595 if ! grep -qs ssh /etc/security/passwd.conf ; then
596         umask 022
597         echo "ssh" >> /etc/security/passwd.conf
598 fi
599
600 %preun server
601 if [ "$1" = "0" ]; then
602         %service sshd stop
603         /sbin/chkconfig --del sshd
604 fi
605
606 %postun server
607 if [ "$1" = "0" ]; then
608         %userremove sshd
609 fi
610
611 %files
612 %defattr(644,root,root,755)
613 %doc *.RNG TODO README OVERVIEW CREDITS Change*
614 %attr(755,root,root) %{_bindir}/ssh-key*
615 %{_mandir}/man1/ssh-key*.1*
616 %dir %{_sysconfdir}
617 %dir %{_libexecdir}
618
619 %files clients
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_bindir}/ssh
622 %attr(755,root,root) %{_bindir}/slogin
623 %attr(755,root,root) %{_bindir}/sftp
624 %attr(755,root,root) %{_bindir}/ssh-agent
625 %attr(755,root,root) %{_bindir}/ssh-add
626 %attr(755,root,root) %{_bindir}/scp
627 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
628 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
629 %{_mandir}/man1/scp.1*
630 %{_mandir}/man1/ssh.1*
631 %{_mandir}/man1/slogin.1*
632 %{_mandir}/man1/sftp.1*
633 %{_mandir}/man1/ssh-agent.1*
634 %{_mandir}/man1/ssh-add.1*
635 %{_mandir}/man5/ssh_config.5*
636 %lang(it) %{_mandir}/it/man1/ssh.1*
637 %lang(it) %{_mandir}/it/man5/ssh_config.5*
638 %lang(pl) %{_mandir}/pl/man1/scp.1*
639 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
640
641 # for host-based auth (suid required for accessing private host key)
642 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
643 #%{_mandir}/man8/ssh-keysign.8*
644
645 %files clients-agent-profile_d
646 %defattr(644,root,root,755)
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
648 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
649
650 %files clients-agent-xinitrc
651 %defattr(644,root,root,755)
652 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
653
654 %files server
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_sbindir}/sshd
657 %attr(755,root,root) %{_libexecdir}/sftp-server
658 %attr(755,root,root) %{_libexecdir}/ssh-keysign
659 %{_mandir}/man8/sshd.8*
660 %{_mandir}/man8/sftp-server.8*
661 %{_mandir}/man8/ssh-keysign.8*
662 %{_mandir}/man5/sshd_config.5*
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
665 %attr(640,root,root) %{_sysconfdir}/moduli
666 %attr(754,root,root) /etc/rc.d/init.d/sshd
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
669
670 %if %{with gnome} || %{with gtk}
671 %files gnome-askpass
672 %defattr(644,root,root,755)
673 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
674 %dir %{_libexecdir}/ssh
675 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
676 %attr(755,root,root) %{_libexecdir}/ssh-askpass
677 %endif
This page took 0.091145 seconds and 3 git commands to generate.