]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 6.0p1
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11 %bcond_without  tests
12
13 # gtk2-based gnome-askpass means no gnome1-based
14 %{?with_gtk:%undefine with_gnome}
15
16 %if "%{pld_release}" == "ac"
17 %define         pam_ver 0.79.0
18 %else
19 %define         pam_ver 1:1.1.5-5
20 %endif
21
22 Summary:        OpenSSH free Secure Shell (SSH) implementation
23 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
24 Summary(es.UTF-8):      Implementación libre de SSH
25 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
26 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
27 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
28 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29 Summary(pt_BR.UTF-8):   Implementação livre do SSH
30 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
31 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
32 Name:           openssh
33 Version:        6.0p1
34 Release:        1
35 Epoch:          2
36 License:        BSD
37 Group:          Applications/Networking
38 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
39 # Source0-md5:  3c9347aa67862881c5da3f3b1c08da7b
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
42 Source2:        %{name}d.init
43 Source3:        %{name}d.pamd
44 Source4:        %{name}.sysconfig
45 Source5:        ssh-agent.sh
46 Source6:        ssh-agent.conf
47 Source7:        %{name}-lpk.schema
48 Source8:        %{name}d.upstart
49 Source9:        sshd.service
50 Source10:       sshd-keygen
51 Patch100:       %{name}-heimdal.patch
52 Patch0:         %{name}-no_libnsl.patch
53 Patch2:         %{name}-pam_misc.patch
54 Patch3:         %{name}-sigpipe.patch
55 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
56 Patch4:         %{name}-5.9p1-ldap.patch
57 Patch5:         %{name}-5.9p1-ldap-fixes.patch
58 Patch8:         ldap.conf.patch
59 Patch6:         %{name}-config.patch
60 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
61 Patch7:         authorized-keys-command.patch
62 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
63 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
64 Patch9:         %{name}-5.2p1-hpn13v6.diff
65 Patch10:        %{name}-include.patch
66 Patch11:        %{name}-chroot.patch
67 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
68 Patch12:        %{name}-blacklist.diff
69 Patch13:        %{name}-kuserok.patch
70 Patch14:        %{name}-bind.patch
71 URL:            http://www.openssh.com/portable.html
72 BuildRequires:  %{__perl}
73 %{?with_audit:BuildRequires:    audit-libs-devel}
74 BuildRequires:  autoconf >= 2.50
75 BuildRequires:  automake
76 %{?with_gnome:BuildRequires:    gnome-libs-devel}
77 %{?with_gtk:BuildRequires:      gtk+2-devel}
78 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
79 %{?with_libedit:BuildRequires:  libedit-devel}
80 %{?with_selinux:BuildRequires:  libselinux-devel}
81 BuildRequires:  libwrap-devel
82 %{?with_ldap:BuildRequires:     openldap-devel}
83 BuildRequires:  openssl-devel >= 0.9.7d
84 BuildRequires:  pam-devel
85 %{?with_gtk:BuildRequires:      pkgconfig}
86 BuildRequires:  rpm >= 4.4.9-56
87 BuildRequires:  rpmbuild(macros) >= 1.627
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  zlib-devel
90 %if "%{pld_release}" == "ac"
91 Requires:       filesystem >= 2.0-1
92 Requires:       pam >= 0.79.0
93 %else
94 Requires:       filesystem >= 3.0-11
95 Requires:       pam >= %{pam_ver}
96 Suggests:       openssh-blacklist
97 Suggests:       xorg-app-xauth
98 %endif
99 Obsoletes:      ssh
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _sysconfdir     /etc/ssh
103 %define         _libexecdir     %{_libdir}/%{name}
104 %define         _privsepdir     /usr/share/empty
105 %define         schemadir       /usr/share/openldap/schema
106
107 %description
108 Ssh (Secure Shell) a program for logging into a remote machine and for
109 executing commands in a remote machine. It is intended to replace
110 rlogin and rsh, and provide secure encrypted communications between
111 two untrusted hosts over an insecure network. X11 connections and
112 arbitrary TCP/IP ports can also be forwarded over the secure channel.
113
114 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
115 it up to date in terms of security and features, as well as removing
116 all patented algorithms to seperate libraries (OpenSSL).
117
118 This package includes the core files necessary for both the OpenSSH
119 client and server. To make this package useful, you should also
120 install openssh-clients, openssh-server, or both.
121
122 %if %{with hpn}
123 This release includes High Performance SSH/SCP patches from
124 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
125 increase throughput on fast connections with high RTT (20-150 msec).
126 See the website for '-w' values for your connection and /proc/sys TCP
127 values. BTW. in a LAN you have got generally RTT < 1 msec.
128 %endif
129
130 %description -l de.UTF-8
131 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
132 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
133 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
134 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
135 andere TCP/IP Ports können ebenso über den sicheren Channel
136 weitergeleitet werden.
137
138 %description -l es.UTF-8
139 SSH es un programa para accesar y ejecutar órdenes en computadores
140 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
141 seguro entre dos servidores en una red insegura. Conexiones X11 y
142 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
143 seguro.
144
145 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
146 continuar la última versión gratuita de SSH, actualizándolo en
147 términos de seguridad y recursos,así también eliminando todos los
148 algoritmos patentados y colocándolos en bibliotecas separadas
149 (OpenSSL).
150
151 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
152 también el paquete openssh-clients u openssh-server o ambos.
153
154 %description -l fr.UTF-8
155 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
156 remplace telnet, rlogin, rexec et rsh, tout en assurant des
157 communications cryptées securisées entre deux hôtes non fiabilisés sur
158 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
159 arbitraires peuvent également être transmis sur le canal sécurisé.
160
161 %description -l it.UTF-8
162 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
163 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
164 sicure e crittate tra due host non fidati su una rete non sicura. Le
165 connessioni X11 ad una porta TCP/IP arbitraria possono essere
166 inoltrate attraverso un canale sicuro.
167
168 %description -l pl.UTF-8
169 Ssh (Secure Shell) to program służący do logowania się na zdalną
170 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
171 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
172 pomiędzy dwoma hostami.
173
174 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
175 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
176 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
177
178 %if %{with hpn}
179 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
180 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
181 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
182 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
183 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
184 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
185 %endif
186
187 %description -l pt.UTF-8
188 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190 cifradas entre duas máquinas sem confiança mútua sobre uma rede
191 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192 reenviados pelo canal seguro.
193
194 %description -l pt_BR.UTF-8
195 SSH é um programa para acessar e executar comandos em máquinas
196 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201 última versão gratuita do SSH, atualizando-o em termos de segurança e
202 recursos, assim como removendo todos os algoritmos patenteados e
203 colocando-os em bibliotecas separadas (OpenSSL).
204
205 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208 %description -l ru.UTF-8
209 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
210 машину и для выполнения команд на удаленной машине. Она предназначена
211 для замены rlogin и rsh и обеспечивает безопасную шифрованную
212 коммуникацию между двумя хостами в сети, являющейся небезопасной.
213 Соединения X11 и любые порты TCP/IP могут также быть проведены через
214 безопасный канал.
215
216 OpenSSH - это переделка командой разработчиков OpenBSD последней
217 свободной версии SSH, доведенная до современного состояния в терминах
218 уровня безопасности и поддерживаемых возможностей. Все патентованные
219 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
220
221 Этот пакет содержит файлы, необходимые как для клиента, так и для
222 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
223 openssh-server, или оба пакета.
224
225 %description -l uk.UTF-8
226 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
227 машини та для виконання команд на віддаленій машині. Вона призначена
228 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
229 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
230 довільні порти TCP/IP можуть також бути проведені через безпечний
231 канал.
232
233 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
234 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
235 підтримуваних можливостей. Всі патентовані алгоритми винесені до
236 окремих бібліотек (OpenSSL).
237
238 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
239 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
240 openssh-server, чи обидва пакети.
241
242 %package clients
243 Summary:        OpenSSH Secure Shell protocol clients
244 Summary(es.UTF-8):      Clientes de OpenSSH
245 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
246 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
247 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
248 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
249 Group:          Applications/Networking
250 Requires:       %{name}
251 Provides:       ssh-clients
252 Obsoletes:      ssh-clients
253
254 %description clients
255 Ssh (Secure Shell) a program for logging into a remote machine and for
256 executing commands in a remote machine. It is intended to replace
257 rlogin and rsh, and provide secure encrypted communications between
258 two untrusted hosts over an insecure network. X11 connections and
259 arbitrary TCP/IP ports can also be forwarded over the secure channel.
260
261 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
262 it up to date in terms of security and features, as well as removing
263 all patented algorithms to seperate libraries (OpenSSL).
264
265 This package includes the clients necessary to make encrypted
266 connections to SSH servers.
267
268 %description clients -l es.UTF-8
269 Este paquete incluye los clientes que se necesitan para hacer
270 conexiones codificadas con servidores SSH.
271
272 %description clients -l pl.UTF-8
273 Ssh (Secure Shell) to program służący do logowania się na zdalną
274 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
275 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
276 pomiędzy dwoma hostami.
277
278 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
279
280 %description clients -l pt_BR.UTF-8
281 Esse pacote inclui os clientes necessários para fazer conexões
282 encriptadas com servidores SSH.
283
284 %description clients -l ru.UTF-8
285 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
286 машину и для выполнения команд на удаленной машине.
287
288 Этот пакет содержит программы-клиенты, необходимые для установления
289 зашифрованных соединений с серверами SSH.
290
291 %description clients -l uk.UTF-8
292 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
293 машини та для виконання команд на віддаленій машині.
294
295 Цей пакет містить програми-клієнти, необхідні для встановлення
296 зашифрованих з'єднань з серверами SSH.
297
298 %package clients-agent-profile_d
299 Summary:        OpenSSH Secure Shell agent init script
300 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
301 Group:          Applications/Networking
302 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
303
304 %description clients-agent-profile_d
305 profile.d scripts for starting SSH agent.
306
307 %description clients-agent-profile_d -l pl.UTF-8
308 Skrypty profile.d do uruchamiania agenta SSH.
309
310 %package clients-agent-xinitrc
311 Summary:        OpenSSH Secure Shell agent init script
312 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
313 Group:          Applications/Networking
314 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
315 Requires:       xinitrc
316
317 %description clients-agent-xinitrc
318 xinitrc scripts for starting SSH agent.
319
320 %description clients-agent-xinitrc -l pl.UTF-8
321 Skrypty xinitrc do uruchamiania agenta SSH.
322
323 %package server
324 Summary:        OpenSSH Secure Shell protocol server (sshd)
325 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
326 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
327 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
328 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
329 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
330 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
331 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
332 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
333 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
334 Group:          Networking/Daemons
335 Requires(post): /sbin/chkconfig
336 Requires(post): grep
337 Requires(post,preun):   /sbin/chkconfig
338 Requires(postun):       /usr/sbin/userdel
339 Requires(pre):  /bin/id
340 Requires(pre):  /usr/sbin/useradd
341 Requires(post,preun,postun):    systemd-units >= 38
342 Requires:       %{name} = %{epoch}:%{version}-%{release}
343 # remove in 6.0, kept for flawless upgrade
344 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
345 Requires:       pam >= %{pam_ver}
346 Requires:       rc-scripts >= 0.4.3.0
347 Requires:       systemd-units >= 38
348 Requires:       util-linux
349 Suggests:       /bin/login
350 Provides:       ssh-server
351 Provides:       user(sshd)
352
353 %description server
354 Ssh (Secure Shell) a program for logging into a remote machine and for
355 executing commands in a remote machine. It is intended to replace
356 rlogin and rsh, and provide secure encrypted communications between
357 two untrusted hosts over an insecure network. X11 connections and
358 arbitrary TCP/IP ports can also be forwarded over the secure channel.
359
360 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
361 it up to date in terms of security and features, as well as removing
362 all patented algorithms to seperate libraries (OpenSSL).
363
364 This package contains the secure shell daemon. The sshd is the server
365 part of the secure shell protocol and allows ssh clients to connect to
366 your host.
367
368 %description server -l de.UTF-8
369 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
370
371 %description server -l es.UTF-8
372 Este paquete contiene el servidor SSH. sshd es la parte servidor del
373 protocolo secure shell y permite que clientes ssh se conecten a su
374 servidor.
375
376 %description server -l fr.UTF-8
377 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
378
379 %description server -l it.UTF-8
380 Questo pacchetto installa sshd, il server di OpenSSH.
381
382 %description server -l pl.UTF-8
383 Ssh (Secure Shell) to program służący do logowania się na zdalną
384 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
385 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
386 pomiędzy dwoma hostami.
387
388 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
389 ssh).
390
391 %description server -l pt.UTF-8
392 Este pacote intala o sshd, o servidor do OpenSSH.
393
394 %description server -l pt_BR.UTF-8
395 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
396 protocolo secure shell e permite que clientes ssh se conectem ao seu
397 host.
398
399 %description server -l ru.UTF-8
400 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
401 машину и для выполнения команд на удаленной машине.
402
403 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
404 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
405 вашим хостом.
406
407 %description server -l uk.UTF-8
408 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
409 машини та для виконання команд на віддаленій машині.
410
411 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
412 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
413 з вашим хостом.
414
415 %package server-ldap
416 Summary:        A LDAP support for open source SSH server daemon
417 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
418 Group:          Daemons
419 Requires:       %{name} = %{epoch}:%{version}-%{release}
420
421 %description server-ldap
422 OpenSSH LDAP backend is a way how to distribute the authorized tokens
423 among the servers in the network.
424
425 %description server-ldap -l pl.UTF-8
426 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
427 tokenów między serwerami w sieci.
428
429 %package server-upstart
430 Summary:        Upstart job description for OpenSSH server
431 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
432 Group:          Daemons
433 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
434 Requires:       upstart >= 0.6
435 Conflicts:      syslog-ng < 3.2.4-1
436
437 %description server-upstart
438 Upstart job description for OpenSSH.
439
440 %description server-upstart -l pl.UTF-8
441 Opis zadania Upstart dla OpenSSH.
442
443 %package gnome-askpass
444 Summary:        OpenSSH GNOME passphrase dialog
445 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
446 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
447 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
448 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
449 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
450 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
451 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
452 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
453 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
454 Group:          Applications/Networking
455 Requires:       %{name} = %{epoch}:%{version}-%{release}
456 Obsoletes:      openssh-askpass
457 Obsoletes:      ssh-askpass
458 Obsoletes:      ssh-extras
459
460 %description gnome-askpass
461 Ssh (Secure Shell) a program for logging into a remote machine and for
462 executing commands in a remote machine. It is intended to replace
463 rlogin and rsh, and provide secure encrypted communications between
464 two untrusted hosts over an insecure network. X11 connections and
465 arbitrary TCP/IP ports can also be forwarded over the secure channel.
466
467 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
468 it up to date in terms of security and features, as well as removing
469 all patented algorithms to seperate libraries (OpenSSL).
470
471 This package contains the GNOME passphrase dialog.
472
473 %description gnome-askpass -l es.UTF-8
474 Este paquete contiene un programa que abre una caja de diálogo para
475 entrada de passphrase en GNOME.
476
477 %description gnome-askpass -l pl.UTF-8
478 Ssh (Secure Shell) to program służący do logowania się na zdalną
479 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
480 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
481 pomiędzy dwoma hostami.
482
483 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
484
485 %description gnome-askpass -l pt_BR.UTF-8
486 Esse pacote contém um programa que abre uma caixa de diálogo para
487 entrada de passphrase no GNOME.
488
489 %description gnome-askpass -l ru.UTF-8
490 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
491 машину и для выполнения команд на удаленной машине.
492
493 Этот пакет содержит диалог ввода ключевой фразы для использования под
494 GNOME.
495
496 %description gnome-askpass -l uk.UTF-8
497 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
498 машини та для виконання команд на віддаленій машині.
499
500 Цей пакет містить діалог вводу ключової фрази для використання під
501 GNOME.
502
503 %package -n openldap-schema-openssh-lpk
504 Summary:        OpenSSH LDAP Public Key schema
505 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
506 Group:          Networking/Daemons
507 Requires(post,postun):  sed >= 4.0
508 Requires:       openldap-servers
509
510 %description -n openldap-schema-openssh-lpk
511 This package contains OpenSSH LDAP Public Key schema for openldap.
512
513 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
514 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
515 openldap-a.
516
517 %prep
518 %setup -q
519 %{?with_kerberos5:%patch100 -p1}
520 %patch0 -p1
521 %patch2 -p1
522 %patch3 -p1
523 %patch4 -p1
524 %patch5 -p1
525 %patch8 -p1
526 %patch6 -p1
527 %patch7 -p1
528 %{?with_hpn:%patch9 -p1}
529 %patch10 -p1
530 %patch11 -p1
531 %patch12 -p1
532 %patch13 -p1
533 %patch14 -p1
534
535 %if "%{pld_release}" == "ac"
536 # fix for missing x11.pc
537 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
538 %endif
539
540 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
541 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
542
543 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
544 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
545
546 %build
547 cp /usr/share/automake/config.sub .
548 %{__aclocal}
549 %{__autoconf}
550 %{__autoheader}
551 CPPFLAGS="-DCHROOT"
552 %configure \
553         PERL=%{__perl} \
554         --disable-strip \
555         --enable-utmpx \
556         --enable-wtmpx \
557         --with-4in6 \
558         %{?with_audit:--with-audit=linux} \
559         --with-ipaddr-display \
560         %{?with_kerberos5:--with-kerberos5=/usr} \
561         --with-ldap%{!?with_ldap:=no} \
562         %{?with_libedit:--with-libedit} \
563         --with-mantype=man \
564         --with-md5-passwords \
565         --with-pam \
566         --with-authorized-keys-command \
567         --with-pid-dir=%{_localstatedir}/run \
568         --with-privsep-path=%{_privsepdir} \
569         %{?with_selinux:--with-selinux} \
570         --with-tcp-wrappers \
571 %if "%{pld_release}" == "ac"
572         --with-xauth=/usr/X11R6/bin/xauth
573 %else
574         --with-xauth=%{_bindir}/xauth
575 %endif
576
577 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
578
579 %{__make}
580
581 %{?with_tests:%{__make} tests}
582
583 cd contrib
584 %if %{with gnome}
585 %{__make} gnome-ssh-askpass1 \
586         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
587 %endif
588 %if %{with gtk}
589 %{__make} gnome-ssh-askpass2 \
590         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
591 %endif
592
593 %install
594 rm -rf $RPM_BUILD_ROOT
595 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
596         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
597 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
598
599 %{__make} install \
600         DESTDIR=$RPM_BUILD_ROOT
601
602 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
603
604 cp -p %{SOURCE3} sshd.pam
605 install -p %{SOURCE2} sshd.init
606
607 %if "%{pld_release}" == "ac"
608 # not present in ac, no point searching it
609 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
610 # openssl on ac does not have OPENSSL_HAS_ECC
611 %{__sed} -i -e '/ecdsa/d' sshd.init
612 %endif
613
614 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
615 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
616 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
617 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
618 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
619 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
620 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
621 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
622
623 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
624 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
625
626 %if %{with gnome}
627 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
628 %endif
629 %if %{with gtk}
630 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
631 %endif
632 %if %{with gnome} || %{with gtk}
633 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
634 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
635 EOF
636 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
637 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
638 EOF
639 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
640 %endif
641
642 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
643 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
644
645 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
646 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
647
648 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
649
650 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
651 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
652 EOF
653
654 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
655 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
656
657 %clean
658 rm -rf $RPM_BUILD_ROOT
659
660 %post clients
661 %env_update
662
663 %postun clients
664 %env_update
665
666 %post gnome-askpass
667 %env_update
668
669 %postun gnome-askpass
670 %env_update
671
672 %pre server
673 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
674
675 %post server
676 /sbin/chkconfig --add sshd
677 %service sshd reload "OpenSSH Daemon"
678 if ! grep -qs ssh /etc/security/passwd.conf ; then
679         umask 022
680         echo "ssh" >> /etc/security/passwd.conf
681 fi
682 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
683 %banner %{name}-server -e << EOF
684 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
685 ! Native systemd support for sshd has been installed.   !
686 ! Restarting sshd.service with systemctl WILL kill all  !
687 ! active ssh sessions (daemon as such will be started). !
688 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
689 EOF
690 fi
691 NORESTART=1
692 %systemd_post sshd.service
693
694 %preun server
695 if [ "$1" = "0" ]; then
696         %service sshd stop
697         /sbin/chkconfig --del sshd
698 fi
699 %systemd_preun sshd.service
700
701 %postun server
702 if [ "$1" = "0" ]; then
703         %userremove sshd
704 fi
705 %systemd_reload
706
707 %triggerpostun server -- %{name}-server < 2:5.9p1-8
708 # lpk.patch to ldap.patch
709 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
710         echo >&2 "Migrating LPK patch to LDAP patch"
711         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
712         %{__sed} -i -e '
713                 # disable old configs
714                 # just UseLPK/LkpLdapConf supported for now
715                 s/^UseLPK/## Obsolete &/
716                 s/^Lpk/## Obsolete &/
717                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
718                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
719         ' %{_sysconfdir}/sshd_config
720         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
721                 /bin/systemctl try-restart sshd.service || :
722         else
723                 %service -q sshd reload
724         fi
725 fi
726 %systemd_trigger sshd.service
727
728 %post server-upstart
729 %upstart_post sshd
730
731 %postun server-upstart
732 %upstart_postun sshd
733
734 %post -n openldap-schema-openssh-lpk
735 %openldap_schema_register %{schemadir}/openssh-lpk.schema
736 %service -q ldap restart
737
738 %postun -n openldap-schema-openssh-lpk
739 if [ "$1" = "0" ]; then
740         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
741         %service -q ldap restart
742 fi
743
744 %files
745 %defattr(644,root,root,755)
746 %doc TODO README OVERVIEW CREDITS Change*
747 %attr(755,root,root) %{_bindir}/ssh-key*
748 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
749 %{_mandir}/man1/ssh-key*.1*
750 %{_mandir}/man1/ssh-vulnkey*.1*
751 %dir %{_sysconfdir}
752 %dir %{_libexecdir}
753
754 %files clients
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_bindir}/ssh
757 %attr(755,root,root) %{_bindir}/slogin
758 %attr(755,root,root) %{_bindir}/sftp
759 %attr(755,root,root) %{_bindir}/ssh-agent
760 %attr(755,root,root) %{_bindir}/ssh-add
761 %attr(755,root,root) %{_bindir}/ssh-copy-id
762 %attr(755,root,root) %{_bindir}/scp
763 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
764 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
765 %{_mandir}/man1/scp.1*
766 %{_mandir}/man1/ssh.1*
767 %{_mandir}/man1/slogin.1*
768 %{_mandir}/man1/sftp.1*
769 %{_mandir}/man1/ssh-agent.1*
770 %{_mandir}/man1/ssh-add.1*
771 %{_mandir}/man1/ssh-copy-id.1*
772 %{_mandir}/man5/ssh_config.5*
773 %lang(it) %{_mandir}/it/man1/ssh.1*
774 %lang(it) %{_mandir}/it/man5/ssh_config.5*
775 %lang(pl) %{_mandir}/pl/man1/scp.1*
776 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
777
778 # for host-based auth (suid required for accessing private host key)
779 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
780 #%{_mandir}/man8/ssh-keysign.8*
781
782 %files clients-agent-profile_d
783 %defattr(644,root,root,755)
784 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
785 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
786
787 %files clients-agent-xinitrc
788 %defattr(644,root,root,755)
789 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
790
791 %files server
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_sbindir}/sshd
794 %attr(755,root,root) %{_libexecdir}/sftp-server
795 %attr(755,root,root) %{_libexecdir}/ssh-keysign
796 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
797 %attr(755,root,root) %{_libexecdir}/sshd-keygen
798 %{_mandir}/man8/sshd.8*
799 %{_mandir}/man8/sftp-server.8*
800 %{_mandir}/man8/ssh-keysign.8*
801 %{_mandir}/man8/ssh-pkcs11-helper.8*
802 %{_mandir}/man5/sshd_config.5*
803 %{_mandir}/man5/moduli.5*
804 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
805 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
806 %attr(640,root,root) %{_sysconfdir}/moduli
807 %attr(754,root,root) /etc/rc.d/init.d/sshd
808 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
809 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
810 %{systemdunitdir}/sshd.service
811
812 %if %{with ldap}
813 %files server-ldap
814 %defattr(644,root,root,755)
815 %doc HOWTO.ldap-keys ldap.conf
816 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
817 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
818 %{_mandir}/man5/ssh-ldap.conf.5*
819 %{_mandir}/man8/ssh-ldap-helper.8*
820 %endif
821
822 %if %{with gnome} || %{with gtk}
823 %files gnome-askpass
824 %defattr(644,root,root,755)
825 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
826 %dir %{_libexecdir}/ssh
827 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
828 %attr(755,root,root) %{_libexecdir}/ssh-askpass
829 %endif
830
831 %if %{with ldap}
832 %files -n openldap-schema-openssh-lpk
833 %defattr(644,root,root,755)
834 %{schemadir}/openssh-lpk.schema
835 %endif
836
837 %if "%{pld_release}" != "ti"
838 %files server-upstart
839 %defattr(644,root,root,755)
840 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
841 %endif
This page took 0.086888 seconds and 3 git commands to generate.