]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- rel 3
[packages/openssh.git] / openssh.spec
1 # Conditional build:
2 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
3 %bcond_without  gtk             # without GTK+ (2.x)
4 %bcond_without  ldap            # with ldap support
5 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  selinux         # build without SELinux support
8 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
9
10 # gtk2-based gnome-askpass means no gnome1-based
11 %{?with_gtk:%undefine with_gnome}
12 #
13 Summary:        OpenSSH free Secure Shell (SSH) implementation
14 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
15 Summary(es.UTF-8):      Implementación libre de SSH
16 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
17 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
18 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
19 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20 Summary(pt_BR.UTF-8):   Implementação livre do SSH
21 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
22 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
23 Name:           openssh
24 Version:        5.2p1
25 Release:        3
26 Epoch:          2
27 License:        BSD
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30 # Source0-md5:  ada79c7328a8551bdf55c95e631e7dad
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
33 Source2:        %{name}d.init
34 Source3:        %{name}d.pamd
35 Source4:        %{name}.sysconfig
36 Source5:        ssh-agent.sh
37 Source6:        ssh-agent.conf
38 Source7:        %{name}-lpk.schema
39 Patch0:         %{name}-no_libnsl.patch
40 Patch2:         %{name}-pam_misc.patch
41 Patch3:         %{name}-sigpipe.patch
42 # http://code.google.com/p/openssh-lpk/
43 Patch4:         %{name}-lpk.patch
44 Patch5:         %{name}-config.patch
45 Patch7:         %{name}-selinux.patch
46 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
47 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.9p1-hpn13v2.diff.gz
48 Patch9:         %{name}-5.0p1-hpn13v4.diff
49 Patch10:        %{name}-include.patch
50 Patch11:        %{name}-chroot.patch
51 Patch12:        http://people.debian.org/~cjwatson/%{name}-blacklist.diff
52 URL:            http://www.openssh.com/
53 BuildRequires:  %{__perl}
54 BuildRequires:  autoconf
55 BuildRequires:  automake
56 %{?with_gnome:BuildRequires:    gnome-libs-devel}
57 %{?with_gtk:BuildRequires:      gtk+2-devel}
58 %{?with_kerberos5:BuildRequires:        krb5-devel}
59 %{?with_libedit:BuildRequires:  libedit-devel}
60 %{?with_selinux:BuildRequires:  libselinux-devel}
61 BuildRequires:  libwrap-devel
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 BuildRequires:  pam-devel
65 %{?with_gtk:BuildRequires:      pkgconfig}
66 BuildRequires:  rpmbuild(macros) >= 1.318
67 BuildRequires:  zlib-devel
68 Requires:       filesystem >= 3.0-11
69 Requires:       pam >= 0.99.7.1
70 Suggests:       openssh-blacklist
71 Suggests:       xorg-app-xauth
72 Obsoletes:      ssh
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/ssh
76 %define         _libexecdir     %{_libdir}/%{name}
77 %define         _privsepdir     /usr/share/empty
78 %define         schemadir       /usr/share/openldap/schema
79
80 %description
81 Ssh (Secure Shell) a program for logging into a remote machine and for
82 executing commands in a remote machine. It is intended to replace
83 rlogin and rsh, and provide secure encrypted communications between
84 two untrusted hosts over an insecure network. X11 connections and
85 arbitrary TCP/IP ports can also be forwarded over the secure channel.
86
87 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
88 it up to date in terms of security and features, as well as removing
89 all patented algorithms to seperate libraries (OpenSSL).
90
91 This package includes the core files necessary for both the OpenSSH
92 client and server. To make this package useful, you should also
93 install openssh-clients, openssh-server, or both.
94 %if %{with hpn} || %{with hpn_none}
95 This release includes High Performance SSH/SCP patches from
96 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
97 to increase throughput on fast connections with high RTT (20-150 msec).
98 See the website for '-w' values for your connection and /proc/sys TCP
99 values. BTW. in a LAN you have got generally RTT < 1 msec.
100 %endif
101 %if %{with hpn_none}
102 It also includes an undocumented '-z' option which switches
103 the cipher to none after authentication is completed. Data is
104 still secured from tampering and corruption in transit through
105 the use of the Message Authentication Code (MAC).
106 This option will significantly reduce the number of cpu cycles used
107 by the SSH/SCP process. This may allow some users to see significant
108 improvement in (sniffable) data tranfer rates.
109 %endif
110
111 %description -l de.UTF-8
112 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
113 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
114 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
115 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
116 andere TCP/IP Ports können ebenso über den sicheren Channel
117 weitergeleitet werden.
118
119 %description -l es.UTF-8
120 SSH es un programa para accesar y ejecutar órdenes en computadores
121 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
122 seguro entre dos servidores en una red insegura. Conexiones X11 y
123 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
124 seguro.
125
126 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
127 continuar la última versión gratuita de SSH, actualizándolo en
128 términos de seguridad y recursos,así también eliminando todos los
129 algoritmos patentados y colocándolos en bibliotecas separadas
130 (OpenSSL).
131
132 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
133 también el paquete openssh-clients u openssh-server o ambos.
134
135 %description -l fr.UTF-8
136 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
137 remplace telnet, rlogin, rexec et rsh, tout en assurant des
138 communications cryptées securisées entre deux hôtes non fiabilisés sur
139 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
140 arbitraires peuvent également être transmis sur le canal sécurisé.
141
142 %description -l it.UTF-8
143 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
144 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
145 sicure e crittate tra due host non fidati su una rete non sicura. Le
146 connessioni X11 ad una porta TCP/IP arbitraria possono essere
147 inoltrate attraverso un canale sicuro.
148
149 %description -l pl.UTF-8
150 Ssh (Secure Shell) to program służący do logowania się na zdalną
151 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
152 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
153 pomiędzy dwoma hostami.
154
155 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
156 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
157 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
158 %if %{with hpn} || %{with hpn_none}
159 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
160 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
161 zwiększenie przepustowości transmisji dla szybkich połączeń
162 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
163 odpowednie dla danego połączenia wartości parametru '-w' oraz
164 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
165 %endif
166 %if %{with hpn_none}
167 Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
168 za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
169 Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
170 stosowanie Message Authentication Code (MAC).
171 Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
172 procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
173 na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
174 %endif
175
176 %description -l pt.UTF-8
177 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
178 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
179 cifradas entre duas máquinas sem confiança mútua sobre uma rede
180 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
181 reenviados pelo canal seguro.
182
183 %description -l pt_BR.UTF-8
184 SSH é um programa para acessar e executar comandos em máquinas
185 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
186 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
187 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
188
189 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
190 última versão gratuita do SSH, atualizando-o em termos de segurança e
191 recursos, assim como removendo todos os algoritmos patenteados e
192 colocando-os em bibliotecas separadas (OpenSSL).
193
194 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
195 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
196
197 %description -l ru.UTF-8
198 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
199 машину и для выполнения команд на удаленной машине. Она предназначена
200 для замены rlogin и rsh и обеспечивает безопасную шифрованную
201 коммуникацию между двумя хостами в сети, являющейся небезопасной.
202 Соединения X11 и любые порты TCP/IP могут также быть проведены через
203 безопасный канал.
204
205 OpenSSH - это переделка командой разработчиков OpenBSD последней
206 свободной версии SSH, доведенная до современного состояния в терминах
207 уровня безопасности и поддерживаемых возможностей. Все патентованные
208 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
209
210 Этот пакет содержит файлы, необходимые как для клиента, так и для
211 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
212 openssh-server, или оба пакета.
213
214 %description -l uk.UTF-8
215 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
216 машини та для виконання команд на віддаленій машині. Вона призначена
217 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
218 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
219 довільні порти TCP/IP можуть також бути проведені через безпечний
220 канал.
221
222 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
223 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
224 підтримуваних можливостей. Всі патентовані алгоритми винесені до
225 окремих бібліотек (OpenSSL).
226
227 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
228 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
229 openssh-server, чи обидва пакети.
230
231 %package clients
232 Summary:        OpenSSH Secure Shell protocol clients
233 Summary(es.UTF-8):      Clientes de OpenSSH
234 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
235 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
236 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
237 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
238 Group:          Applications/Networking
239 Requires:       %{name} = %{epoch}:%{version}-%{release}
240 Provides:       ssh-clients
241 Obsoletes:      ssh-clients
242
243 %description clients
244 Ssh (Secure Shell) a program for logging into a remote machine and for
245 executing commands in a remote machine. It is intended to replace
246 rlogin and rsh, and provide secure encrypted communications between
247 two untrusted hosts over an insecure network. X11 connections and
248 arbitrary TCP/IP ports can also be forwarded over the secure channel.
249
250 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
251 it up to date in terms of security and features, as well as removing
252 all patented algorithms to seperate libraries (OpenSSL).
253
254 This package includes the clients necessary to make encrypted
255 connections to SSH servers.
256
257 %description clients -l es.UTF-8
258 Este paquete incluye los clientes que se necesitan para hacer
259 conexiones codificadas con servidores SSH.
260
261 %description clients -l pl.UTF-8
262 Ssh (Secure Shell) to program służący do logowania się na zdalną
263 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
264 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
265 pomiędzy dwoma hostami.
266
267 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
268
269 %description clients -l pt_BR.UTF-8
270 Esse pacote inclui os clientes necessários para fazer conexões
271 encriptadas com servidores SSH.
272
273 %description clients -l ru.UTF-8
274 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
275 машину и для выполнения команд на удаленной машине.
276
277 Этот пакет содержит программы-клиенты, необходимые для установления
278 зашифрованных соединений с серверами SSH.
279
280 %description clients -l uk.UTF-8
281 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
282 машини та для виконання команд на віддаленій машині.
283
284 Цей пакет містить програми-клієнти, необхідні для встановлення
285 зашифрованих з'єднань з серверами SSH.
286
287 %package clients-agent-profile_d
288 Summary:        OpenSSH Secure Shell agent init script
289 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
290 Group:          Applications/Networking
291 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
292
293 %description clients-agent-profile_d
294 profile.d scripts for starting SSH agent.
295
296 %description clients-agent-profile_d -l pl.UTF-8
297 Skrypty profile.d do uruchamiania agenta SSH.
298
299 %package clients-agent-xinitrc
300 Summary:        OpenSSH Secure Shell agent init script
301 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
302 Group:          Applications/Networking
303 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
304 Requires:       xinitrc
305
306 %description clients-agent-xinitrc
307 xinitrc scripts for starting SSH agent.
308
309 %description clients-agent-xinitrc -l pl.UTF-8
310 Skrypty xinitrc do uruchamiania agenta SSH.
311
312 %package server
313 Summary:        OpenSSH Secure Shell protocol server (sshd)
314 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
315 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
316 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
317 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
318 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
319 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
320 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
321 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
322 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
323 Group:          Networking/Daemons
324 Requires(post): chkconfig >= 0.9
325 Requires(post): grep
326 Requires(post,preun):   /sbin/chkconfig
327 Requires(postun):       /usr/sbin/userdel
328 Requires(pre):  /bin/id
329 Requires(pre):  /usr/sbin/useradd
330 Requires:       %{name} = %{epoch}:%{version}-%{release}
331 Requires:       /bin/login
332 Requires:       pam >= 0.99.7.1
333 Requires:       rc-scripts >= 0.4.1.23
334 Requires:       util-linux
335 Provides:       ssh-server
336 Provides:       user(sshd)
337
338 %description server
339 Ssh (Secure Shell) a program for logging into a remote machine and for
340 executing commands in a remote machine. It is intended to replace
341 rlogin and rsh, and provide secure encrypted communications between
342 two untrusted hosts over an insecure network. X11 connections and
343 arbitrary TCP/IP ports can also be forwarded over the secure channel.
344
345 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
346 it up to date in terms of security and features, as well as removing
347 all patented algorithms to seperate libraries (OpenSSL).
348
349 This package contains the secure shell daemon. The sshd is the server
350 part of the secure shell protocol and allows ssh clients to connect to
351 your host.
352
353 %description server -l de.UTF-8
354 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
355
356 %description server -l es.UTF-8
357 Este paquete contiene el servidor SSH. sshd es la parte servidor del
358 protocolo secure shell y permite que clientes ssh se conecten a su
359 servidor.
360
361 %description server -l fr.UTF-8
362 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
363
364 %description server -l it.UTF-8
365 Questo pacchetto installa sshd, il server di OpenSSH.
366
367 %description server -l pl.UTF-8
368 Ssh (Secure Shell) to program służący do logowania się na zdalną
369 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
370 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
371 pomiędzy dwoma hostami.
372
373 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
374 ssh).
375
376 %description server -l pt.UTF-8
377 Este pacote intala o sshd, o servidor do OpenSSH.
378
379 %description server -l pt_BR.UTF-8
380 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
381 protocolo secure shell e permite que clientes ssh se conectem ao seu
382 host.
383
384 %description server -l ru.UTF-8
385 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
386 машину и для выполнения команд на удаленной машине.
387
388 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
389 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
390 вашим хостом.
391
392 %description server -l uk.UTF-8
393 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
394 машини та для виконання команд на віддаленій машині.
395
396 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
397 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
398 з вашим хостом.
399
400 %package gnome-askpass
401 Summary:        OpenSSH GNOME passphrase dialog
402 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
403 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
404 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
405 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
406 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
407 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
408 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
409 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
410 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
411 Group:          Applications/Networking
412 Requires:       %{name} = %{epoch}:%{version}-%{release}
413 Obsoletes:      openssh-askpass
414 Obsoletes:      ssh-askpass
415 Obsoletes:      ssh-extras
416
417 %description gnome-askpass
418 Ssh (Secure Shell) a program for logging into a remote machine and for
419 executing commands in a remote machine. It is intended to replace
420 rlogin and rsh, and provide secure encrypted communications between
421 two untrusted hosts over an insecure network. X11 connections and
422 arbitrary TCP/IP ports can also be forwarded over the secure channel.
423
424 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
425 it up to date in terms of security and features, as well as removing
426 all patented algorithms to seperate libraries (OpenSSL).
427
428 This package contains the GNOME passphrase dialog.
429
430 %description gnome-askpass -l es.UTF-8
431 Este paquete contiene un programa que abre una caja de diálogo para
432 entrada de passphrase en GNOME.
433
434 %description gnome-askpass -l pl.UTF-8
435 Ssh (Secure Shell) to program służący do logowania się na zdalną
436 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
437 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
438 pomiędzy dwoma hostami.
439
440 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
441
442 %description gnome-askpass -l pt_BR.UTF-8
443 Esse pacote contém um programa que abre uma caixa de diálogo para
444 entrada de passphrase no GNOME.
445
446 %description gnome-askpass -l ru.UTF-8
447 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
448 машину и для выполнения команд на удаленной машине.
449
450 Этот пакет содержит диалог ввода ключевой фразы для использования под
451 GNOME.
452
453 %description gnome-askpass -l uk.UTF-8
454 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
455 машини та для виконання команд на віддаленій машині.
456
457 Цей пакет містить діалог вводу ключової фрази для використання під
458 GNOME.
459
460 %package -n openldap-schema-openssh-lpk
461 Summary:        OpenSSH LDAP Public Key schema
462 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
463 Group:          Networking/Daemons
464 Requires(post,postun):  sed >= 4.0
465 Requires:       openldap-servers
466
467 %description -n openldap-schema-openssh-lpk
468 This package contains OpenSSH LDAP Public Key schema for openldap.
469
470 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
471 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH
472 dla openldap-a.
473
474 %prep
475 %setup -q
476 %patch0 -p1
477 %patch2 -p1
478 %patch3 -p1
479 %{?with_ldap:%patch4 -p1}
480 %patch5 -p1
481 %patch7 -p1
482 %{?with_hpn:%patch9 -p1}
483 %patch10 -p1
484 %patch11 -p1
485 %patch12 -p1
486
487 %build
488 cp /usr/share/automake/config.sub .
489 %{__aclocal}
490 %{__autoconf}
491 CPPFLAGS="-DCHROOT"
492 %configure \
493         PERL=%{__perl} \
494         --with-dns \
495         --with-pam \
496         --with-mantype=man \
497         --with-md5-passwords \
498         --with-ipaddr-display \
499         %{?with_libedit:--with-libedit} \
500         --with-4in6 \
501         --disable-suid-ssh \
502         --with-tcp-wrappers \
503         %{?with_ldap:--with-libs="-lldap -llber"} \
504         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
505         %{?with_kerberos5:--with-kerberos5=/usr} \
506         --with-privsep-path=%{_privsepdir} \
507         --with-pid-dir=%{_localstatedir}/run \
508         --with-xauth=/usr/bin/xauth \
509         --enable-utmpx \
510         --enable-wtmpx
511
512 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
513
514 %{__make}
515
516 cd contrib
517 %if %{with gnome}
518 %{__make} gnome-ssh-askpass1 \
519         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520 %endif
521 %if %{with gtk}
522 %{__make} gnome-ssh-askpass2 \
523         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
524 %endif
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
529         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
530 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
531
532 %{__make} install \
533         DESTDIR=$RPM_BUILD_ROOT
534
535 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
536
537 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
538 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
539 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
540 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
541 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
542 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
543 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
544
545 %if %{with gnome}
546 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
547 %endif
548 %if %{with gtk}
549 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
550 %endif
551 %if %{with gnome} || %{with gtk}
552 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
553 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
554 EOF
555 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
556 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
557 EOF
558 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
559 %endif
560
561 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
562 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
563
564 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
565 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
566
567 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
568
569 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
570 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
571 EOF
572
573 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
574 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
575
576 %clean
577 rm -rf $RPM_BUILD_ROOT
578
579 %post clients
580 %env_update
581
582 %postun clients
583 %env_update
584
585 %post gnome-askpass
586 %env_update
587
588 %postun gnome-askpass
589 %env_update
590
591 %pre server
592 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
593
594 %post server
595 /sbin/chkconfig --add sshd
596 %service sshd reload "openssh daemon"
597 if ! grep -qs ssh /etc/security/passwd.conf ; then
598         umask 022
599         echo "ssh" >> /etc/security/passwd.conf
600 fi
601
602 %preun server
603 if [ "$1" = "0" ]; then
604         %service sshd stop
605         /sbin/chkconfig --del sshd
606 fi
607
608 %postun server
609 if [ "$1" = "0" ]; then
610         %userremove sshd
611 fi
612
613 %post -n openldap-schema-openssh-lpk
614 %openldap_schema_register %{schemadir}/openssh-lpk.schema
615 %service -q ldap restart
616
617 %postun -n openldap-schema-openssh-lpk
618 if [ "$1" = "0" ]; then
619         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
620         %service -q ldap restart
621 fi
622
623 %files
624 %defattr(644,root,root,755)
625 %doc *.RNG TODO README OVERVIEW CREDITS Change*
626 %attr(755,root,root) %{_bindir}/ssh-key*
627 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
628 %{_mandir}/man1/ssh-key*.1*
629 %{_mandir}/man1/ssh-vulnkey*.1*
630 %dir %{_sysconfdir}
631 %dir %{_libexecdir}
632
633 %files clients
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_bindir}/ssh
636 %attr(755,root,root) %{_bindir}/slogin
637 %attr(755,root,root) %{_bindir}/sftp
638 %attr(755,root,root) %{_bindir}/ssh-agent
639 %attr(755,root,root) %{_bindir}/ssh-add
640 %attr(755,root,root) %{_bindir}/ssh-copy-id
641 %attr(755,root,root) %{_bindir}/scp
642 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
643 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
644 %{_mandir}/man1/scp.1*
645 %{_mandir}/man1/ssh.1*
646 %{_mandir}/man1/slogin.1*
647 %{_mandir}/man1/sftp.1*
648 %{_mandir}/man1/ssh-agent.1*
649 %{_mandir}/man1/ssh-add.1*
650 %{_mandir}/man1/ssh-copy-id.1*
651 %{_mandir}/man5/ssh_config.5*
652 %lang(it) %{_mandir}/it/man1/ssh.1*
653 %lang(it) %{_mandir}/it/man5/ssh_config.5*
654 %lang(pl) %{_mandir}/pl/man1/scp.1*
655 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
656
657 # for host-based auth (suid required for accessing private host key)
658 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
659 #%{_mandir}/man8/ssh-keysign.8*
660
661 %files clients-agent-profile_d
662 %defattr(644,root,root,755)
663 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
664 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
665
666 %files clients-agent-xinitrc
667 %defattr(644,root,root,755)
668 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
669
670 %files server
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_sbindir}/sshd
673 %attr(755,root,root) %{_libexecdir}/sftp-server
674 %attr(755,root,root) %{_libexecdir}/ssh-keysign
675 %{_mandir}/man8/sshd.8*
676 %{_mandir}/man8/sftp-server.8*
677 %{_mandir}/man8/ssh-keysign.8*
678 %{_mandir}/man5/sshd_config.5*
679 %{_mandir}/man5/moduli.5*
680 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
681 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
682 %attr(640,root,root) %{_sysconfdir}/moduli
683 %attr(754,root,root) /etc/rc.d/init.d/sshd
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
685 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
686
687 %if %{with gnome} || %{with gtk}
688 %files gnome-askpass
689 %defattr(644,root,root,755)
690 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
691 %dir %{_libexecdir}/ssh
692 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
693 %attr(755,root,root) %{_libexecdir}/ssh-askpass
694 %endif
695
696 %if %{with ldap}
697 %files -n openldap-schema-openssh-lpk
698 %defattr(644,root,root,755)
699 %{schemadir}/openssh-lpk.schema
700 %endif
This page took 2.074006 seconds and 3 git commands to generate.