]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- add authorized-keys-command.patch, needed for ldap support to work at all
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11
12 # gtk2-based gnome-askpass means no gnome1-based
13 %{?with_gtk:%undefine with_gnome}
14
15 %if "%{pld_release}" == "ac"
16 %define         pam_ver 0.79.0
17 %else
18 %define         pam_ver 0.99.7.1
19 %endif
20
21 Summary:        OpenSSH free Secure Shell (SSH) implementation
22 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
23 Summary(es.UTF-8):      Implementación libre de SSH
24 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
25 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
26 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
27 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28 Summary(pt_BR.UTF-8):   Implementação livre do SSH
29 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
30 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31 Name:           openssh
32 Version:        5.9p1
33 Release:        2
34 Epoch:          2
35 License:        BSD
36 Group:          Applications/Networking
37 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38 # Source0-md5:  b50a499fa02616a47984b1920848b565
39 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
41 Source2:        %{name}d.init
42 Source3:        %{name}d.pamd
43 Source4:        %{name}.sysconfig
44 Source5:        ssh-agent.sh
45 Source6:        ssh-agent.conf
46 Source7:        %{name}-lpk.schema
47 Source8:        %{name}d.upstart
48 Patch100:       %{name}-heimdal.patch
49 Patch0:         %{name}-no_libnsl.patch
50 Patch2:         %{name}-pam_misc.patch
51 Patch3:         %{name}-sigpipe.patch
52 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
53 Patch4:         %{name}-5.9p1-ldap.patch
54 Patch5:         %{name}-5.9p1-ldap-fixes.patch
55 Patch6:         %{name}-config.patch
56 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
57 Patch7:         authorized-keys-command.patch
58 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
59 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
60 Patch9:         %{name}-5.2p1-hpn13v6.diff
61 Patch10:        %{name}-include.patch
62 Patch11:        %{name}-chroot.patch
63 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
64 Patch12:        %{name}-blacklist.diff
65 Patch13:        %{name}-kuserok.patch
66 URL:            http://www.openssh.com/portable.html
67 BuildRequires:  %{__perl}
68 %{?with_audit:BuildRequires:    audit-libs-devel}
69 BuildRequires:  autoconf >= 2.50
70 BuildRequires:  automake
71 %{?with_gnome:BuildRequires:    gnome-libs-devel}
72 %{?with_gtk:BuildRequires:      gtk+2-devel}
73 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
74 %{?with_libedit:BuildRequires:  libedit-devel}
75 %{?with_selinux:BuildRequires:  libselinux-devel}
76 BuildRequires:  libwrap-devel
77 %{?with_ldap:BuildRequires:     openldap-devel}
78 BuildRequires:  openssl-devel >= 0.9.7d
79 BuildRequires:  pam-devel
80 %{?with_gtk:BuildRequires:      pkgconfig}
81 BuildRequires:  rpm >= 4.4.9-56
82 BuildRequires:  rpmbuild(macros) >= 1.318
83 BuildRequires:  sed >= 4.0
84 BuildRequires:  zlib-devel
85 %if "%{pld_release}" == "ac"
86 Requires:       filesystem >= 2.0-1
87 Requires:       pam >= 0.79.0
88 %else
89 Requires:       filesystem >= 3.0-11
90 Requires:       pam >= %{pam_ver}
91 Suggests:       openssh-blacklist
92 Suggests:       xorg-app-xauth
93 %endif
94 Obsoletes:      ssh
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _sysconfdir     /etc/ssh
98 %define         _libexecdir     %{_libdir}/%{name}
99 %define         _privsepdir     /usr/share/empty
100 %define         schemadir       /usr/share/openldap/schema
101
102 %description
103 Ssh (Secure Shell) a program for logging into a remote machine and for
104 executing commands in a remote machine. It is intended to replace
105 rlogin and rsh, and provide secure encrypted communications between
106 two untrusted hosts over an insecure network. X11 connections and
107 arbitrary TCP/IP ports can also be forwarded over the secure channel.
108
109 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
110 it up to date in terms of security and features, as well as removing
111 all patented algorithms to seperate libraries (OpenSSL).
112
113 This package includes the core files necessary for both the OpenSSH
114 client and server. To make this package useful, you should also
115 install openssh-clients, openssh-server, or both.
116
117 %if %{with hpn}
118 This release includes High Performance SSH/SCP patches from
119 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
120 increase throughput on fast connections with high RTT (20-150 msec).
121 See the website for '-w' values for your connection and /proc/sys TCP
122 values. BTW. in a LAN you have got generally RTT < 1 msec.
123 %endif
124
125 %description -l de.UTF-8
126 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
127 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
128 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
129 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
130 andere TCP/IP Ports können ebenso über den sicheren Channel
131 weitergeleitet werden.
132
133 %description -l es.UTF-8
134 SSH es un programa para accesar y ejecutar órdenes en computadores
135 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
136 seguro entre dos servidores en una red insegura. Conexiones X11 y
137 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
138 seguro.
139
140 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
141 continuar la última versión gratuita de SSH, actualizándolo en
142 términos de seguridad y recursos,así también eliminando todos los
143 algoritmos patentados y colocándolos en bibliotecas separadas
144 (OpenSSL).
145
146 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
147 también el paquete openssh-clients u openssh-server o ambos.
148
149 %description -l fr.UTF-8
150 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
151 remplace telnet, rlogin, rexec et rsh, tout en assurant des
152 communications cryptées securisées entre deux hôtes non fiabilisés sur
153 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
154 arbitraires peuvent également être transmis sur le canal sécurisé.
155
156 %description -l it.UTF-8
157 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
158 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
159 sicure e crittate tra due host non fidati su una rete non sicura. Le
160 connessioni X11 ad una porta TCP/IP arbitraria possono essere
161 inoltrate attraverso un canale sicuro.
162
163 %description -l pl.UTF-8
164 Ssh (Secure Shell) to program służący do logowania się na zdalną
165 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
166 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
167 pomiędzy dwoma hostami.
168
169 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
170 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
171 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
172
173 %if %{with hpn}
174 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
175 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
176 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
177 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
178 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
179 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
180 %endif
181
182 %description -l pt.UTF-8
183 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
184 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
185 cifradas entre duas máquinas sem confiança mútua sobre uma rede
186 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
187 reenviados pelo canal seguro.
188
189 %description -l pt_BR.UTF-8
190 SSH é um programa para acessar e executar comandos em máquinas
191 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
192 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
193 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
194
195 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
196 última versão gratuita do SSH, atualizando-o em termos de segurança e
197 recursos, assim como removendo todos os algoritmos patenteados e
198 colocando-os em bibliotecas separadas (OpenSSL).
199
200 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
201 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
202
203 %description -l ru.UTF-8
204 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
205 машину и для выполнения команд на удаленной машине. Она предназначена
206 для замены rlogin и rsh и обеспечивает безопасную шифрованную
207 коммуникацию между двумя хостами в сети, являющейся небезопасной.
208 Соединения X11 и любые порты TCP/IP могут также быть проведены через
209 безопасный канал.
210
211 OpenSSH - это переделка командой разработчиков OpenBSD последней
212 свободной версии SSH, доведенная до современного состояния в терминах
213 уровня безопасности и поддерживаемых возможностей. Все патентованные
214 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
215
216 Этот пакет содержит файлы, необходимые как для клиента, так и для
217 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
218 openssh-server, или оба пакета.
219
220 %description -l uk.UTF-8
221 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
222 машини та для виконання команд на віддаленій машині. Вона призначена
223 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
224 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
225 довільні порти TCP/IP можуть також бути проведені через безпечний
226 канал.
227
228 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
229 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
230 підтримуваних можливостей. Всі патентовані алгоритми винесені до
231 окремих бібліотек (OpenSSL).
232
233 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
234 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
235 openssh-server, чи обидва пакети.
236
237 %package clients
238 Summary:        OpenSSH Secure Shell protocol clients
239 Summary(es.UTF-8):      Clientes de OpenSSH
240 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
241 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
242 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
243 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
244 Group:          Applications/Networking
245 Requires:       %{name}
246 Provides:       ssh-clients
247 Obsoletes:      ssh-clients
248
249 %description clients
250 Ssh (Secure Shell) a program for logging into a remote machine and for
251 executing commands in a remote machine. It is intended to replace
252 rlogin and rsh, and provide secure encrypted communications between
253 two untrusted hosts over an insecure network. X11 connections and
254 arbitrary TCP/IP ports can also be forwarded over the secure channel.
255
256 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
257 it up to date in terms of security and features, as well as removing
258 all patented algorithms to seperate libraries (OpenSSL).
259
260 This package includes the clients necessary to make encrypted
261 connections to SSH servers.
262
263 %description clients -l es.UTF-8
264 Este paquete incluye los clientes que se necesitan para hacer
265 conexiones codificadas con servidores SSH.
266
267 %description clients -l pl.UTF-8
268 Ssh (Secure Shell) to program służący do logowania się na zdalną
269 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
270 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
271 pomiędzy dwoma hostami.
272
273 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
274
275 %description clients -l pt_BR.UTF-8
276 Esse pacote inclui os clientes necessários para fazer conexões
277 encriptadas com servidores SSH.
278
279 %description clients -l ru.UTF-8
280 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
281 машину и для выполнения команд на удаленной машине.
282
283 Этот пакет содержит программы-клиенты, необходимые для установления
284 зашифрованных соединений с серверами SSH.
285
286 %description clients -l uk.UTF-8
287 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
288 машини та для виконання команд на віддаленій машині.
289
290 Цей пакет містить програми-клієнти, необхідні для встановлення
291 зашифрованих з'єднань з серверами SSH.
292
293 %package clients-agent-profile_d
294 Summary:        OpenSSH Secure Shell agent init script
295 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
296 Group:          Applications/Networking
297 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
298
299 %description clients-agent-profile_d
300 profile.d scripts for starting SSH agent.
301
302 %description clients-agent-profile_d -l pl.UTF-8
303 Skrypty profile.d do uruchamiania agenta SSH.
304
305 %package clients-agent-xinitrc
306 Summary:        OpenSSH Secure Shell agent init script
307 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
308 Group:          Applications/Networking
309 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
310 Requires:       xinitrc
311
312 %description clients-agent-xinitrc
313 xinitrc scripts for starting SSH agent.
314
315 %description clients-agent-xinitrc -l pl.UTF-8
316 Skrypty xinitrc do uruchamiania agenta SSH.
317
318 %package server
319 Summary:        OpenSSH Secure Shell protocol server (sshd)
320 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
321 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
322 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
323 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
324 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
325 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
326 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
327 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
328 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
329 Group:          Networking/Daemons
330 Requires(post): /sbin/chkconfig
331 Requires(post): grep
332 Requires(post,preun):   /sbin/chkconfig
333 Requires(postun):       /usr/sbin/userdel
334 Requires(pre):  /bin/id
335 Requires(pre):  /usr/sbin/useradd
336 Requires:       %{name} = %{epoch}:%{version}-%{release}
337 Requires:       pam >= %{pam_ver}
338 Requires:       rc-scripts >= 0.4.3.0
339 Requires:       util-linux
340 Suggests:       /bin/login
341 Provides:       ssh-server
342 Provides:       user(sshd)
343
344 %description server
345 Ssh (Secure Shell) a program for logging into a remote machine and for
346 executing commands in a remote machine. It is intended to replace
347 rlogin and rsh, and provide secure encrypted communications between
348 two untrusted hosts over an insecure network. X11 connections and
349 arbitrary TCP/IP ports can also be forwarded over the secure channel.
350
351 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
352 it up to date in terms of security and features, as well as removing
353 all patented algorithms to seperate libraries (OpenSSL).
354
355 This package contains the secure shell daemon. The sshd is the server
356 part of the secure shell protocol and allows ssh clients to connect to
357 your host.
358
359 %description server -l de.UTF-8
360 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
361
362 %description server -l es.UTF-8
363 Este paquete contiene el servidor SSH. sshd es la parte servidor del
364 protocolo secure shell y permite que clientes ssh se conecten a su
365 servidor.
366
367 %description server -l fr.UTF-8
368 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
369
370 %description server -l it.UTF-8
371 Questo pacchetto installa sshd, il server di OpenSSH.
372
373 %description server -l pl.UTF-8
374 Ssh (Secure Shell) to program służący do logowania się na zdalną
375 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
376 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
377 pomiędzy dwoma hostami.
378
379 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
380 ssh).
381
382 %description server -l pt.UTF-8
383 Este pacote intala o sshd, o servidor do OpenSSH.
384
385 %description server -l pt_BR.UTF-8
386 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
387 protocolo secure shell e permite que clientes ssh se conectem ao seu
388 host.
389
390 %description server -l ru.UTF-8
391 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
392 машину и для выполнения команд на удаленной машине.
393
394 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
395 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
396 вашим хостом.
397
398 %description server -l uk.UTF-8
399 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
400 машини та для виконання команд на віддаленій машині.
401
402 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
403 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
404 з вашим хостом.
405
406 %package server-upstart
407 Summary:        Upstart job description for OpenSSH server
408 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
409 Group:          Daemons
410 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
411 Requires:       upstart >= 0.6
412 Conflicts:      syslog-ng < 3.2.4-1
413
414 %description server-upstart
415 Upstart job description for OpenSSH.
416
417 %description server-upstart -l pl.UTF-8
418 Opis zadania Upstart dla OpenSSH.
419
420 %package gnome-askpass
421 Summary:        OpenSSH GNOME passphrase dialog
422 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
423 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
424 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
425 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
426 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
427 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
428 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
429 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
430 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
431 Group:          Applications/Networking
432 Requires:       %{name} = %{epoch}:%{version}-%{release}
433 Obsoletes:      openssh-askpass
434 Obsoletes:      ssh-askpass
435 Obsoletes:      ssh-extras
436
437 %description gnome-askpass
438 Ssh (Secure Shell) a program for logging into a remote machine and for
439 executing commands in a remote machine. It is intended to replace
440 rlogin and rsh, and provide secure encrypted communications between
441 two untrusted hosts over an insecure network. X11 connections and
442 arbitrary TCP/IP ports can also be forwarded over the secure channel.
443
444 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
445 it up to date in terms of security and features, as well as removing
446 all patented algorithms to seperate libraries (OpenSSL).
447
448 This package contains the GNOME passphrase dialog.
449
450 %description gnome-askpass -l es.UTF-8
451 Este paquete contiene un programa que abre una caja de diálogo para
452 entrada de passphrase en GNOME.
453
454 %description gnome-askpass -l pl.UTF-8
455 Ssh (Secure Shell) to program służący do logowania się na zdalną
456 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
457 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
458 pomiędzy dwoma hostami.
459
460 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
461
462 %description gnome-askpass -l pt_BR.UTF-8
463 Esse pacote contém um programa que abre uma caixa de diálogo para
464 entrada de passphrase no GNOME.
465
466 %description gnome-askpass -l ru.UTF-8
467 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
468 машину и для выполнения команд на удаленной машине.
469
470 Этот пакет содержит диалог ввода ключевой фразы для использования под
471 GNOME.
472
473 %description gnome-askpass -l uk.UTF-8
474 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
475 машини та для виконання команд на віддаленій машині.
476
477 Цей пакет містить діалог вводу ключової фрази для використання під
478 GNOME.
479
480 %package -n openldap-schema-openssh-lpk
481 Summary:        OpenSSH LDAP Public Key schema
482 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
483 Group:          Networking/Daemons
484 Requires(post,postun):  sed >= 4.0
485 Requires:       openldap-servers
486
487 %description -n openldap-schema-openssh-lpk
488 This package contains OpenSSH LDAP Public Key schema for openldap.
489
490 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
491 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
492 openldap-a.
493
494 %prep
495 %setup -q
496 %{?with_kerberos5:%patch100 -p1}
497 %patch0 -p1
498 %patch2 -p1
499 %patch3 -p1
500 %{?with_ldap:%patch4 -p1}
501 %{?with_ldap:%patch5 -p1}
502 %patch6 -p1
503 %patch7 -p1
504 %{?with_hpn:%patch9 -p1}
505 %patch10 -p1
506 %patch11 -p1
507 %patch12 -p1
508 %patch13 -p1
509
510 cp -p %{SOURCE3} sshd.pam
511 install -p %{SOURCE2} sshd.init
512
513 %if "%{pld_release}" == "ac"
514 # fix for missing x11.pc
515 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
516 # not present in ac, no point searching it
517 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
518
519 # openssl on ac does not have OPENSSL_HAS_ECC
520 %{__sed} -i -e '/ecdsa/d' sshd.init
521 %endif
522
523 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
524 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
525
526 %build
527 cp /usr/share/automake/config.sub .
528 %{__aclocal}
529 %{__autoconf}
530 %{__autoheader}
531 CPPFLAGS="-DCHROOT"
532 %configure \
533         PERL=%{__perl} \
534         --disable-strip \
535         --enable-utmpx \
536         --enable-wtmpx \
537         --with-4in6 \
538         %{?with_audit:--with-audit=linux} \
539         --with-ipaddr-display \
540         %{?with_kerberos5:--with-kerberos5=/usr} \
541         %{?with_ldap:--with-ldap} \
542         %{?with_libedit:--with-libedit} \
543         --with-mantype=man \
544         --with-md5-passwords \
545         --with-pam \
546         --with-authorized-keys-command \
547         --with-pid-dir=%{_localstatedir}/run \
548         --with-privsep-path=%{_privsepdir} \
549         %{?with_selinux:--with-selinux} \
550         --with-tcp-wrappers \
551 %if "%{pld_release}" == "ac"
552         --with-xauth=/usr/X11R6/bin/xauth
553 %else
554         --with-xauth=%{_bindir}/xauth
555 %endif
556
557 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
558
559 %{__make}
560
561 cd contrib
562 %if %{with gnome}
563 %{__make} gnome-ssh-askpass1 \
564         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
565 %endif
566 %if %{with gtk}
567 %{__make} gnome-ssh-askpass2 \
568         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
569 %endif
570
571 %install
572 rm -rf $RPM_BUILD_ROOT
573 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
574         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
575 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
576
577 %{__make} install \
578         DESTDIR=$RPM_BUILD_ROOT
579
580 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
581
582 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
583 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
584 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
585 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
586 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
587 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
588 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
589 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
590
591 %if %{with gnome}
592 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
593 %endif
594 %if %{with gtk}
595 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
596 %endif
597 %if %{with gnome} || %{with gtk}
598 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
599 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
600 EOF
601 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
602 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
603 EOF
604 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
605 %endif
606
607 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
608 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
609
610 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
611 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
612
613 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
614
615 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
616 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
617 EOF
618
619 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
620
621 %clean
622 rm -rf $RPM_BUILD_ROOT
623
624 %post clients
625 %env_update
626
627 %postun clients
628 %env_update
629
630 %post gnome-askpass
631 %env_update
632
633 %postun gnome-askpass
634 %env_update
635
636 %pre server
637 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
638
639 %post server
640 /sbin/chkconfig --add sshd
641 %service sshd reload "openssh daemon"
642 if ! grep -qs ssh /etc/security/passwd.conf ; then
643         umask 022
644         echo "ssh" >> /etc/security/passwd.conf
645 fi
646
647 %preun server
648 if [ "$1" = "0" ]; then
649         %service sshd stop
650         /sbin/chkconfig --del sshd
651 fi
652
653 %postun server
654 if [ "$1" = "0" ]; then
655         %userremove sshd
656 fi
657
658 %triggerpostun server -- %{name}-server < 5.9p1-1
659 # lpk.patch to ldap.patch
660 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
661         echo >&2 "Migrating LPK patch to LDAP patch"
662         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
663         %{__sed} -i -e '
664                 # disable old configs
665                 # just UseLPK/LkpLdapConf supported for now
666                 s/^UseLPK/## Obsolete &/
667                 s/^LPK/## Obsolete &/
668                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
669                 /UseLPK/iAuthorizedKeysCommand "%{_libexecdir}/ssh-ldap-wrapper"
670         ' %{_sysconfdir}/sshd_config
671 fi
672
673 %post server-upstart
674 %upstart_post sshd
675
676 %postun server-upstart
677 %upstart_postun sshd
678
679 %post -n openldap-schema-openssh-lpk
680 %openldap_schema_register %{schemadir}/openssh-lpk.schema
681 %service -q ldap restart
682
683 %postun -n openldap-schema-openssh-lpk
684 if [ "$1" = "0" ]; then
685         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
686         %service -q ldap restart
687 fi
688
689 %files
690 %defattr(644,root,root,755)
691 %doc TODO README OVERVIEW CREDITS Change*
692 %attr(755,root,root) %{_bindir}/ssh-key*
693 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
694 %{_mandir}/man1/ssh-key*.1*
695 %{_mandir}/man1/ssh-vulnkey*.1*
696 %dir %{_sysconfdir}
697 %dir %{_libexecdir}
698
699 %files clients
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/ssh
702 %attr(755,root,root) %{_bindir}/slogin
703 %attr(755,root,root) %{_bindir}/sftp
704 %attr(755,root,root) %{_bindir}/ssh-agent
705 %attr(755,root,root) %{_bindir}/ssh-add
706 %attr(755,root,root) %{_bindir}/ssh-copy-id
707 %attr(755,root,root) %{_bindir}/scp
708 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
709 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
710 %{_mandir}/man1/scp.1*
711 %{_mandir}/man1/ssh.1*
712 %{_mandir}/man1/slogin.1*
713 %{_mandir}/man1/sftp.1*
714 %{_mandir}/man1/ssh-agent.1*
715 %{_mandir}/man1/ssh-add.1*
716 %{_mandir}/man1/ssh-copy-id.1*
717 %{_mandir}/man5/ssh_config.5*
718 %lang(it) %{_mandir}/it/man1/ssh.1*
719 %lang(it) %{_mandir}/it/man5/ssh_config.5*
720 %lang(pl) %{_mandir}/pl/man1/scp.1*
721 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
722
723 # for host-based auth (suid required for accessing private host key)
724 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
725 #%{_mandir}/man8/ssh-keysign.8*
726
727 %files clients-agent-profile_d
728 %defattr(644,root,root,755)
729 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
730 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
731
732 %files clients-agent-xinitrc
733 %defattr(644,root,root,755)
734 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
735
736 %files server
737 %defattr(644,root,root,755)
738 %doc HOWTO.ldap-keys
739 %attr(755,root,root) %{_sbindir}/sshd
740 %attr(755,root,root) %{_libexecdir}/sftp-server
741 %attr(755,root,root) %{_libexecdir}/ssh-keysign
742 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
743 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
744 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
745 %{_mandir}/man8/sshd.8*
746 %{_mandir}/man8/sftp-server.8*
747 %{_mandir}/man8/ssh-keysign.8*
748 %{_mandir}/man8/ssh-ldap-helper.8*
749 %{_mandir}/man8/ssh-pkcs11-helper.8*
750 %{_mandir}/man5/sshd_config.5*
751 %{_mandir}/man5/ssh-ldap.conf.5*
752 %{_mandir}/man5/moduli.5*
753 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
754 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ldap.conf
755 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
756 %attr(640,root,root) %{_sysconfdir}/moduli
757 %attr(754,root,root) /etc/rc.d/init.d/sshd
758 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
759 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
760
761 %if %{with gnome} || %{with gtk}
762 %files gnome-askpass
763 %defattr(644,root,root,755)
764 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
765 %dir %{_libexecdir}/ssh
766 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
767 %attr(755,root,root) %{_libexecdir}/ssh-askpass
768 %endif
769
770 %if %{with ldap}
771 %files -n openldap-schema-openssh-lpk
772 %defattr(644,root,root,755)
773 %{schemadir}/openssh-lpk.schema
774 %endif
775
776 %if "%{pld_release}" != "ti"
777 %files server-upstart
778 %defattr(644,root,root,755)
779 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
780 %endif
This page took 0.14965 seconds and 3 git commands to generate.