]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
without_ldap bcond fixed
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15 %bcond_without  tests
16
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19
20 %if "%{pld_release}" == "ac"
21 %define         pam_ver 0.79.0
22 %else
23 %define         pam_ver 1:1.1.5-5
24 %endif
25
26 Summary:        OpenSSH free Secure Shell (SSH) implementation
27 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
28 Summary(es.UTF-8):      Implementación libre de SSH
29 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
30 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
31 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
32 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
33 Summary(pt_BR.UTF-8):   Implementação livre do SSH
34 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
35 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
36 Name:           openssh
37 Version:        6.1p1
38 Release:        2
39 Epoch:          2
40 License:        BSD
41 Group:          Applications/Networking
42 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
43 # Source0-md5:  3345cbf4efe90ffb06a78670ab2d05d5
44 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
46 Source2:        %{name}d.init
47 Source3:        %{name}d.pamd
48 Source4:        %{name}.sysconfig
49 Source5:        ssh-agent.sh
50 Source6:        ssh-agent.conf
51 Source7:        %{name}-lpk.schema
52 Source8:        %{name}d.upstart
53 Source9:        sshd.service
54 Source10:       sshd-keygen
55 Source11:       sshd.socket
56 Source12:       sshd@.service
57 Patch100:       %{name}-heimdal.patch
58 Patch0:         %{name}-no_libnsl.patch
59 Patch2:         %{name}-pam_misc.patch
60 Patch3:         %{name}-sigpipe.patch
61 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
62 Patch4:         %{name}-5.9p1-ldap.patch
63 Patch5:         %{name}-5.9p1-ldap-fixes.patch
64 Patch8:         ldap.conf.patch
65 Patch6:         %{name}-config.patch
66 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
67 Patch7:         authorized-keys-command.patch
68 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
69 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
70 Patch9:         %{name}-5.2p1-hpn13v6.diff
71 Patch10:        %{name}-include.patch
72 Patch11:        %{name}-chroot.patch
73 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
74 Patch12:        %{name}-blacklist.diff
75 Patch13:        %{name}-kuserok.patch
76 Patch14:        %{name}-bind.patch
77 Patch15:        %{name}-disable_ldap.patch
78 URL:            http://www.openssh.com/portable.html
79 BuildRequires:  %{__perl}
80 %{?with_tests:BuildRequires:    %{name}-server}
81 %{?with_audit:BuildRequires:    audit-libs-devel}
82 BuildRequires:  autoconf >= 2.50
83 BuildRequires:  automake
84 %{?with_gnome:BuildRequires:    gnome-libs-devel}
85 %{?with_gtk:BuildRequires:      gtk+2-devel}
86 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
87 %{?with_libedit:BuildRequires:  libedit-devel}
88 %{?with_selinux:BuildRequires:  libselinux-devel}
89 BuildRequires:  libwrap-devel
90 %{?with_ldap:BuildRequires:     openldap-devel}
91 BuildRequires:  openssl-devel >= 0.9.7d
92 BuildRequires:  pam-devel
93 %{?with_gtk:BuildRequires:      pkgconfig}
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.627
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  zlib-devel >= 1.2.3
98 Requires:       zlib >= 1.2.3
99 %if "%{pld_release}" == "ac"
100 Requires:       filesystem >= 2.0-1
101 Requires:       pam >= 0.79.0
102 %else
103 Requires:       filesystem >= 3.0-11
104 Requires:       pam >= %{pam_ver}
105 Suggests:       openssh-blacklist
106 Suggests:       xorg-app-xauth
107 %endif
108 Obsoletes:      ssh
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         _sysconfdir     /etc/ssh
112 %define         _libexecdir     %{_libdir}/%{name}
113 %define         _privsepdir     /usr/share/empty
114 %define         schemadir       /usr/share/openldap/schema
115
116 %description
117 Ssh (Secure Shell) a program for logging into a remote machine and for
118 executing commands in a remote machine. It is intended to replace
119 rlogin and rsh, and provide secure encrypted communications between
120 two untrusted hosts over an insecure network. X11 connections and
121 arbitrary TCP/IP ports can also be forwarded over the secure channel.
122
123 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
124 it up to date in terms of security and features, as well as removing
125 all patented algorithms to seperate libraries (OpenSSL).
126
127 This package includes the core files necessary for both the OpenSSH
128 client and server. To make this package useful, you should also
129 install openssh-clients, openssh-server, or both.
130
131 %if %{with hpn}
132 This release includes High Performance SSH/SCP patches from
133 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
134 increase throughput on fast connections with high RTT (20-150 msec).
135 See the website for '-w' values for your connection and /proc/sys TCP
136 values. BTW. in a LAN you have got generally RTT < 1 msec.
137 %endif
138
139 %description -l de.UTF-8
140 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
141 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
142 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
143 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
144 andere TCP/IP Ports können ebenso über den sicheren Channel
145 weitergeleitet werden.
146
147 %description -l es.UTF-8
148 SSH es un programa para accesar y ejecutar órdenes en computadores
149 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
150 seguro entre dos servidores en una red insegura. Conexiones X11 y
151 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
152 seguro.
153
154 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
155 continuar la última versión gratuita de SSH, actualizándolo en
156 términos de seguridad y recursos,así también eliminando todos los
157 algoritmos patentados y colocándolos en bibliotecas separadas
158 (OpenSSL).
159
160 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
161 también el paquete openssh-clients u openssh-server o ambos.
162
163 %description -l fr.UTF-8
164 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
165 remplace telnet, rlogin, rexec et rsh, tout en assurant des
166 communications cryptées securisées entre deux hôtes non fiabilisés sur
167 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
168 arbitraires peuvent également être transmis sur le canal sécurisé.
169
170 %description -l it.UTF-8
171 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
172 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
173 sicure e crittate tra due host non fidati su una rete non sicura. Le
174 connessioni X11 ad una porta TCP/IP arbitraria possono essere
175 inoltrate attraverso un canale sicuro.
176
177 %description -l pl.UTF-8
178 Ssh (Secure Shell) to program służący do logowania się na zdalną
179 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
180 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
181 pomiędzy dwoma hostami.
182
183 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
184 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
185 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
186
187 %if %{with hpn}
188 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
189 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
190 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
191 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
192 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
193 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
194 %endif
195
196 %description -l pt.UTF-8
197 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
198 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
199 cifradas entre duas máquinas sem confiança mútua sobre uma rede
200 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
201 reenviados pelo canal seguro.
202
203 %description -l pt_BR.UTF-8
204 SSH é um programa para acessar e executar comandos em máquinas
205 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
206 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
207 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
208
209 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
210 última versão gratuita do SSH, atualizando-o em termos de segurança e
211 recursos, assim como removendo todos os algoritmos patenteados e
212 colocando-os em bibliotecas separadas (OpenSSL).
213
214 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
215 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
216
217 %description -l ru.UTF-8
218 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
219 машину и для выполнения команд на удаленной машине. Она предназначена
220 для замены rlogin и rsh и обеспечивает безопасную шифрованную
221 коммуникацию между двумя хостами в сети, являющейся небезопасной.
222 Соединения X11 и любые порты TCP/IP могут также быть проведены через
223 безопасный канал.
224
225 OpenSSH - это переделка командой разработчиков OpenBSD последней
226 свободной версии SSH, доведенная до современного состояния в терминах
227 уровня безопасности и поддерживаемых возможностей. Все патентованные
228 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
229
230 Этот пакет содержит файлы, необходимые как для клиента, так и для
231 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
232 openssh-server, или оба пакета.
233
234 %description -l uk.UTF-8
235 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
236 машини та для виконання команд на віддаленій машині. Вона призначена
237 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
238 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
239 довільні порти TCP/IP можуть також бути проведені через безпечний
240 канал.
241
242 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
243 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
244 підтримуваних можливостей. Всі патентовані алгоритми винесені до
245 окремих бібліотек (OpenSSL).
246
247 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
248 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
249 openssh-server, чи обидва пакети.
250
251 %package clients
252 Summary:        OpenSSH Secure Shell protocol clients
253 Summary(es.UTF-8):      Clientes de OpenSSH
254 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
255 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
256 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
257 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
258 Group:          Applications/Networking
259 Requires:       %{name}
260 Provides:       ssh-clients
261 Obsoletes:      ssh-clients
262
263 %description clients
264 Ssh (Secure Shell) a program for logging into a remote machine and for
265 executing commands in a remote machine. It is intended to replace
266 rlogin and rsh, and provide secure encrypted communications between
267 two untrusted hosts over an insecure network. X11 connections and
268 arbitrary TCP/IP ports can also be forwarded over the secure channel.
269
270 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
271 it up to date in terms of security and features, as well as removing
272 all patented algorithms to seperate libraries (OpenSSL).
273
274 This package includes the clients necessary to make encrypted
275 connections to SSH servers.
276
277 %description clients -l es.UTF-8
278 Este paquete incluye los clientes que se necesitan para hacer
279 conexiones codificadas con servidores SSH.
280
281 %description clients -l pl.UTF-8
282 Ssh (Secure Shell) to program służący do logowania się na zdalną
283 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
284 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
285 pomiędzy dwoma hostami.
286
287 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
288
289 %description clients -l pt_BR.UTF-8
290 Esse pacote inclui os clientes necessários para fazer conexões
291 encriptadas com servidores SSH.
292
293 %description clients -l ru.UTF-8
294 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
295 машину и для выполнения команд на удаленной машине.
296
297 Этот пакет содержит программы-клиенты, необходимые для установления
298 зашифрованных соединений с серверами SSH.
299
300 %description clients -l uk.UTF-8
301 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
302 машини та для виконання команд на віддаленій машині.
303
304 Цей пакет містить програми-клієнти, необхідні для встановлення
305 зашифрованих з'єднань з серверами SSH.
306
307 %package clients-agent-profile_d
308 Summary:        OpenSSH Secure Shell agent init script
309 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
310 Group:          Applications/Networking
311 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
312
313 %description clients-agent-profile_d
314 profile.d scripts for starting SSH agent.
315
316 %description clients-agent-profile_d -l pl.UTF-8
317 Skrypty profile.d do uruchamiania agenta SSH.
318
319 %package clients-agent-xinitrc
320 Summary:        OpenSSH Secure Shell agent init script
321 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
322 Group:          Applications/Networking
323 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
324 Requires:       xinitrc
325
326 %description clients-agent-xinitrc
327 xinitrc scripts for starting SSH agent.
328
329 %description clients-agent-xinitrc -l pl.UTF-8
330 Skrypty xinitrc do uruchamiania agenta SSH.
331
332 %package server
333 Summary:        OpenSSH Secure Shell protocol server (sshd)
334 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
335 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
336 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
337 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
338 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
339 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
340 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
341 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
342 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
343 Group:          Networking/Daemons
344 Requires(post): /sbin/chkconfig
345 Requires(post): grep
346 Requires(post,preun):   /sbin/chkconfig
347 Requires(postun):       /usr/sbin/userdel
348 Requires(pre):  /bin/id
349 Requires(pre):  /usr/sbin/useradd
350 Requires(post,preun,postun):    systemd-units >= 38
351 Requires:       %{name} = %{epoch}:%{version}-%{release}
352 # remove in 6.0, kept for flawless upgrade
353 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
354 Requires:       pam >= %{pam_ver}
355 Requires:       rc-scripts >= 0.4.3.0
356 Requires:       systemd-units >= 38
357 Requires:       util-linux
358 Suggests:       /bin/login
359 Provides:       ssh-server
360 Provides:       user(sshd)
361
362 %description server
363 Ssh (Secure Shell) a program for logging into a remote machine and for
364 executing commands in a remote machine. It is intended to replace
365 rlogin and rsh, and provide secure encrypted communications between
366 two untrusted hosts over an insecure network. X11 connections and
367 arbitrary TCP/IP ports can also be forwarded over the secure channel.
368
369 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
370 it up to date in terms of security and features, as well as removing
371 all patented algorithms to seperate libraries (OpenSSL).
372
373 This package contains the secure shell daemon. The sshd is the server
374 part of the secure shell protocol and allows ssh clients to connect to
375 your host.
376
377 %description server -l de.UTF-8
378 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
379
380 %description server -l es.UTF-8
381 Este paquete contiene el servidor SSH. sshd es la parte servidor del
382 protocolo secure shell y permite que clientes ssh se conecten a su
383 servidor.
384
385 %description server -l fr.UTF-8
386 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
387
388 %description server -l it.UTF-8
389 Questo pacchetto installa sshd, il server di OpenSSH.
390
391 %description server -l pl.UTF-8
392 Ssh (Secure Shell) to program służący do logowania się na zdalną
393 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
394 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
395 pomiędzy dwoma hostami.
396
397 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
398 ssh).
399
400 %description server -l pt.UTF-8
401 Este pacote intala o sshd, o servidor do OpenSSH.
402
403 %description server -l pt_BR.UTF-8
404 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
405 protocolo secure shell e permite que clientes ssh se conectem ao seu
406 host.
407
408 %description server -l ru.UTF-8
409 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
410 машину и для выполнения команд на удаленной машине.
411
412 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
413 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
414 вашим хостом.
415
416 %description server -l uk.UTF-8
417 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
418 машини та для виконання команд на віддаленій машині.
419
420 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
421 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
422 з вашим хостом.
423
424 %package server-ldap
425 Summary:        A LDAP support for open source SSH server daemon
426 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
427 Group:          Daemons
428 Requires:       %{name} = %{epoch}:%{version}-%{release}
429
430 %description server-ldap
431 OpenSSH LDAP backend is a way how to distribute the authorized tokens
432 among the servers in the network.
433
434 %description server-ldap -l pl.UTF-8
435 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
436 tokenów między serwerami w sieci.
437
438 %package server-upstart
439 Summary:        Upstart job description for OpenSSH server
440 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
441 Group:          Daemons
442 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
443 Requires:       upstart >= 0.6
444 Conflicts:      syslog-ng < 3.2.4-1
445
446 %description server-upstart
447 Upstart job description for OpenSSH.
448
449 %description server-upstart -l pl.UTF-8
450 Opis zadania Upstart dla OpenSSH.
451
452 %package gnome-askpass
453 Summary:        OpenSSH GNOME passphrase dialog
454 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
455 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
456 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
457 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
458 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
459 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
460 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
461 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
462 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
463 Group:          Applications/Networking
464 Requires:       %{name} = %{epoch}:%{version}-%{release}
465 Obsoletes:      openssh-askpass
466 Obsoletes:      ssh-askpass
467 Obsoletes:      ssh-extras
468
469 %description gnome-askpass
470 Ssh (Secure Shell) a program for logging into a remote machine and for
471 executing commands in a remote machine. It is intended to replace
472 rlogin and rsh, and provide secure encrypted communications between
473 two untrusted hosts over an insecure network. X11 connections and
474 arbitrary TCP/IP ports can also be forwarded over the secure channel.
475
476 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
477 it up to date in terms of security and features, as well as removing
478 all patented algorithms to seperate libraries (OpenSSL).
479
480 This package contains the GNOME passphrase dialog.
481
482 %description gnome-askpass -l es.UTF-8
483 Este paquete contiene un programa que abre una caja de diálogo para
484 entrada de passphrase en GNOME.
485
486 %description gnome-askpass -l pl.UTF-8
487 Ssh (Secure Shell) to program służący do logowania się na zdalną
488 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
489 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
490 pomiędzy dwoma hostami.
491
492 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
493
494 %description gnome-askpass -l pt_BR.UTF-8
495 Esse pacote contém um programa que abre uma caixa de diálogo para
496 entrada de passphrase no GNOME.
497
498 %description gnome-askpass -l ru.UTF-8
499 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
500 машину и для выполнения команд на удаленной машине.
501
502 Этот пакет содержит диалог ввода ключевой фразы для использования под
503 GNOME.
504
505 %description gnome-askpass -l uk.UTF-8
506 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
507 машини та для виконання команд на віддаленій машині.
508
509 Цей пакет містить діалог вводу ключової фрази для використання під
510 GNOME.
511
512 %package -n openldap-schema-openssh-lpk
513 Summary:        OpenSSH LDAP Public Key schema
514 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
515 Group:          Networking/Daemons
516 Requires(post,postun):  sed >= 4.0
517 Requires:       openldap-servers
518
519 %description -n openldap-schema-openssh-lpk
520 This package contains OpenSSH LDAP Public Key schema for openldap.
521
522 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
523 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
524 openldap-a.
525
526 %prep
527 %setup -q
528 %{?with_kerberos5:%patch100 -p1}
529 %patch0 -p1
530 %patch2 -p1
531 %patch3 -p1
532 %patch4 -p1
533 %patch5 -p1
534 %patch8 -p1
535 %patch6 -p1
536 %patch7 -p1
537 %{?with_hpn:%patch9 -p1}
538 %patch10 -p1
539 %patch11 -p1
540 %patch12 -p1
541 %patch13 -p1
542 %patch14 -p1
543 %patch15 -p1
544
545 %if "%{pld_release}" == "ac"
546 # fix for missing x11.pc
547 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
548 %endif
549
550 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
551 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
552
553 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
554 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
555
556 %build
557 cp /usr/share/automake/config.sub .
558 %{__aclocal}
559 %{__autoconf}
560 %{__autoheader}
561 CPPFLAGS="-DCHROOT"
562 %configure \
563         PERL=%{__perl} \
564         --disable-strip \
565         --enable-utmpx \
566         --enable-wtmpx \
567         --with-4in6 \
568         %{?with_audit:--with-audit=linux} \
569         --with-ipaddr-display \
570         %{?with_kerberos5:--with-kerberos5=/usr} \
571         --with-ldap%{!?with_ldap:=no} \
572         %{?with_libedit:--with-libedit} \
573         --with-mantype=man \
574         --with-md5-passwords \
575         --with-pam \
576         --with-authorized-keys-command \
577         --with-pid-dir=%{_localstatedir}/run \
578         --with-privsep-path=%{_privsepdir} \
579         %{?with_selinux:--with-selinux} \
580         --with-tcp-wrappers \
581 %if "%{pld_release}" == "ac"
582         --with-xauth=/usr/X11R6/bin/xauth
583 %else
584         --with-xauth=%{_bindir}/xauth
585 %endif
586
587 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
588
589 %{__make}
590
591 %{?with_tests:%{__make} tests}
592
593 cd contrib
594 %if %{with gnome}
595 %{__make} gnome-ssh-askpass1 \
596         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
597 %endif
598 %if %{with gtk}
599 %{__make} gnome-ssh-askpass2 \
600         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
601 %endif
602
603 %install
604 rm -rf $RPM_BUILD_ROOT
605 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
606         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
607 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
608
609 %{__make} install \
610         DESTDIR=$RPM_BUILD_ROOT
611
612 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
613
614 cp -p %{SOURCE3} sshd.pam
615 install -p %{SOURCE2} sshd.init
616
617 %if "%{pld_release}" == "ac"
618 # not present in ac, no point searching it
619 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
620 # openssl on ac does not have OPENSSL_HAS_ECC
621 %{__sed} -i -e '/ecdsa/d' sshd.init
622 %endif
623
624 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
625 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
626 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
627 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
628 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
629 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
630 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
631 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
632
633 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
634 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
635
636 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
637 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
638
639 %if %{with gnome}
640 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
641 %endif
642 %if %{with gtk}
643 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
644 %endif
645 %if %{with gnome} || %{with gtk}
646 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
647 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
648 EOF
649 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
650 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
651 EOF
652 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
653 %endif
654
655 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
656 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
657
658 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
659 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
660
661 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
662
663 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
664 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
665 EOF
666
667 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
668 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
669
670 %clean
671 rm -rf $RPM_BUILD_ROOT
672
673 %post clients
674 %env_update
675
676 %postun clients
677 %env_update
678
679 %post gnome-askpass
680 %env_update
681
682 %postun gnome-askpass
683 %env_update
684
685 %pre server
686 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
687
688 %post server
689 /sbin/chkconfig --add sshd
690 %service sshd reload "OpenSSH Daemon"
691 NORESTART=1
692 %systemd_post sshd.service
693
694 %preun server
695 if [ "$1" = "0" ]; then
696         %service sshd stop
697         /sbin/chkconfig --del sshd
698 fi
699 %systemd_preun sshd.service
700
701 %postun server
702 if [ "$1" = "0" ]; then
703         %userremove sshd
704 fi
705 %systemd_reload
706
707 %triggerpostun server -- %{name}-server < 2:5.9p1-8
708 # lpk.patch to ldap.patch
709 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
710         echo >&2 "Migrating LPK patch to LDAP patch"
711         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
712         %{__sed} -i -e '
713                 # disable old configs
714                 # just UseLPK/LkpLdapConf supported for now
715                 s/^\s*UseLPK/## Obsolete &/
716                 s/^\s*Lpk/## Obsolete &/
717                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
718                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
719         ' %{_sysconfdir}/sshd_config
720         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
721                 /bin/systemctl try-restart sshd.service || :
722         else
723                 %service -q sshd reload
724         fi
725 fi
726 %systemd_trigger sshd.service
727 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
728 %banner %{name}-server -e << EOF
729 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
730 ! Native systemd support for sshd has been installed.   !
731 ! Restarting sshd.service with systemctl WILL kill all  !
732 ! active ssh sessions (daemon as such will be started). !
733 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
734 EOF
735 fi
736
737 %post server-upstart
738 %upstart_post sshd
739
740 %postun server-upstart
741 %upstart_postun sshd
742
743 %post -n openldap-schema-openssh-lpk
744 %openldap_schema_register %{schemadir}/openssh-lpk.schema
745 %service -q ldap restart
746
747 %postun -n openldap-schema-openssh-lpk
748 if [ "$1" = "0" ]; then
749         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
750         %service -q ldap restart
751 fi
752
753 %files
754 %defattr(644,root,root,755)
755 %doc TODO README OVERVIEW CREDITS Change*
756 %attr(755,root,root) %{_bindir}/ssh-key*
757 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
758 %{_mandir}/man1/ssh-key*.1*
759 %{_mandir}/man1/ssh-vulnkey*.1*
760 %dir %{_sysconfdir}
761 %dir %{_libexecdir}
762
763 %files clients
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_bindir}/ssh
766 %attr(755,root,root) %{_bindir}/slogin
767 %attr(755,root,root) %{_bindir}/sftp
768 %attr(755,root,root) %{_bindir}/ssh-agent
769 %attr(755,root,root) %{_bindir}/ssh-add
770 %attr(755,root,root) %{_bindir}/ssh-copy-id
771 %attr(755,root,root) %{_bindir}/scp
772 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
773 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
774 %{_mandir}/man1/scp.1*
775 %{_mandir}/man1/ssh.1*
776 %{_mandir}/man1/slogin.1*
777 %{_mandir}/man1/sftp.1*
778 %{_mandir}/man1/ssh-agent.1*
779 %{_mandir}/man1/ssh-add.1*
780 %{_mandir}/man1/ssh-copy-id.1*
781 %{_mandir}/man5/ssh_config.5*
782 %lang(it) %{_mandir}/it/man1/ssh.1*
783 %lang(it) %{_mandir}/it/man5/ssh_config.5*
784 %lang(pl) %{_mandir}/pl/man1/scp.1*
785 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
786
787 # for host-based auth (suid required for accessing private host key)
788 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
789 #%{_mandir}/man8/ssh-keysign.8*
790
791 %files clients-agent-profile_d
792 %defattr(644,root,root,755)
793 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
794 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
795
796 %files clients-agent-xinitrc
797 %defattr(644,root,root,755)
798 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
799
800 %files server
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_sbindir}/sshd
803 %attr(755,root,root) %{_libexecdir}/sftp-server
804 %attr(755,root,root) %{_libexecdir}/ssh-keysign
805 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
806 %attr(755,root,root) %{_libexecdir}/sshd-keygen
807 %{_mandir}/man8/sshd.8*
808 %{_mandir}/man8/sftp-server.8*
809 %{_mandir}/man8/ssh-keysign.8*
810 %{_mandir}/man8/ssh-pkcs11-helper.8*
811 %{_mandir}/man5/sshd_config.5*
812 %{_mandir}/man5/moduli.5*
813 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
814 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
815 %attr(640,root,root) %{_sysconfdir}/moduli
816 %attr(754,root,root) /etc/rc.d/init.d/sshd
817 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
819 %{systemdunitdir}/sshd.service
820 %{systemdunitdir}/sshd.socket
821 %{systemdunitdir}/sshd@.service
822
823 %if %{with ldap}
824 %files server-ldap
825 %defattr(644,root,root,755)
826 %doc HOWTO.ldap-keys ldap.conf
827 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
828 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
829 %{_mandir}/man5/ssh-ldap.conf.5*
830 %{_mandir}/man8/ssh-ldap-helper.8*
831 %endif
832
833 %if %{with gnome} || %{with gtk}
834 %files gnome-askpass
835 %defattr(644,root,root,755)
836 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
837 %dir %{_libexecdir}/ssh
838 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
839 %attr(755,root,root) %{_libexecdir}/ssh-askpass
840 %endif
841
842 %if %{with ldap}
843 %files -n openldap-schema-openssh-lpk
844 %defattr(644,root,root,755)
845 %{schemadir}/openssh-lpk.schema
846 %endif
847
848 %if "%{pld_release}" != "ti"
849 %files server-upstart
850 %defattr(644,root,root,755)
851 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
852 %endif
This page took 0.588786 seconds and 3 git commands to generate.