]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- adds hpn and hpn_none "with" bconds (patches 11 and 12).
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  chroot          # without chrooted user environment support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_with     ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
11 %bcond_with     hpn             # with High Performance SSH/SCP - HPN-SSH (see patch comment)
12 %bcond_with     hpn_none        # with hpn (above) and '-z' none cipher option
13 #
14 %if %{with hpn_none}
15 %undefine       with_hpn
16 %endif
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19 Summary:        OpenSSH free Secure Shell (SSH) implementation
20 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
21 Summary(es):    Implementación libre de SSH
22 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
23 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
24 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
25 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
26 Summary(pt_BR): Implementação livre do SSH
27 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
28 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
29 Name:           openssh
30 Version:        4.2p1
31 Release:        5%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
32 Epoch:          2
33 License:        BSD
34 Group:          Applications/Networking
35 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
36 # Source0-md5:  df899194a340c933944b193477c628fa
37 Source1:        %{name}d.conf
38 Source2:        %{name}.conf
39 Source3:        %{name}d.init
40 Source4:        %{name}d.pamd
41 Source5:        %{name}.sysconfig
42 Source6:        passwd.pamd
43 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
44 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
45 Source9:        http://www.taiyo.co.jp/~gotoh/ssh/connect.c
46 # NoSource9-md5:        e1c3cbed88f08ea778d90813d48cd428
47 Source10:       http://www.taiyo.co.jp/~gotoh/ssh/connect.html
48 # NoSource10-md5:       ec74f3e3b2ea3a7dc84c7988235b6fcf
49 Source11:       ssh-agent.sh
50 Source12:       ssh-agent.conf
51 Patch0:         %{name}-no_libnsl.patch
52 Patch2:         %{name}-linux-ipv6.patch
53 Patch3:         %{name}-pam_misc.patch
54 Patch4:         %{name}-sigpipe.patch
55 # http://www.opendarwin.org/projects/openssh-lpk/
56 Patch5:         %{name}-lpk-4.0p1-0.3.patch
57 Patch6:         %{name}-heimdal.patch
58 Patch7:         %{name}-pam-conv.patch
59 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
60 Patch8:         %{name}-chroot.patch
61 Patch9:         %{name}-selinux.patch
62 Patch10:        %{name}-selinux-pld.patch
63 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/ 
64 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
65 Patch11:        %{name}-4.2p1-hpn11.patch
66 # Adds HPN (see p11) and an undocumented -z none cipher flag
67 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
68 Patch12:        %{name}-4.2p1-hpn11-none.patch
69 URL:            http://www.openssh.com/
70 BuildRequires:  autoconf
71 BuildRequires:  automake
72 %{?with_gnome:BuildRequires:    gnome-libs-devel}
73 %{?with_gtk:BuildRequires:      gtk+2-devel}
74 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
75 %{?with_libedit:BuildRequires:  libedit-devel}
76 %{?with_selinux:BuildRequires:  libselinux-devel}
77 BuildRequires:  libwrap-devel
78 %{?with_ldap:BuildRequires:     openldap-devel}
79 BuildRequires:  openssl-devel >= 0.9.7d
80 BuildRequires:  pam-devel
81 BuildRequires:  %{__perl}
82 %{?with_gtk:BuildRequires:      pkgconfig}
83 BuildRequires:  rpmbuild(macros) >= 1.202
84 BuildRequires:  zlib-devel
85 Requires:       FHS >= 2.1-24
86 Requires:       pam >= 0.79.0
87 Obsoletes:      ssh
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _sysconfdir     /etc/ssh
91 %define         _libexecdir     %{_libdir}/%{name}
92 %define         _privsepdir     /usr/share/empty
93
94 %description
95 Ssh (Secure Shell) a program for logging into a remote machine and for
96 executing commands in a remote machine. It is intended to replace
97 rlogin and rsh, and provide secure encrypted communications between
98 two untrusted hosts over an insecure network. X11 connections and
99 arbitrary TCP/IP ports can also be forwarded over the secure channel.
100
101 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
102 it up to date in terms of security and features, as well as removing
103 all patented algorithms to seperate libraries (OpenSSL).
104
105 This package includes the core files necessary for both the OpenSSH
106 client and server. To make this package useful, you should also
107 install openssh-clients, openssh-server, or both.
108 %if %{with hpn} || %{with hpn_none}
109 This release includes High Performance SSH/SCP patches from 
110 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed 
111 to increase throughput on fast connections with high RTT (20-150 msec).
112 See the website for '-w' values for your connection and /proc/sys TCP
113 values. BTW. in a LAN you have got generally RTT < 1 msec.
114 %endif
115 %if %{with hpn_none}
116 It also includes an undocumented '-z' option which switches
117 the cipher to none after authentication is completed. Data is 
118 still secured from tampering and corruption in transit through 
119 the use of the Message Authentication Code (MAC).
120 This option will significantly reduce the number of cpu cycles used 
121 by the SSH/SCP process. This may allow some users to see significant 
122 improvement in (sniffable) data tranfer rates. 
123 %endif
124
125 %description -l de
126 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
127 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
128 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
129 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
130 andere TCP/IP Ports können ebenso über den sicheren Channel
131 weitergeleitet werden.
132
133 %description -l es
134 SSH es un programa para accesar y ejecutar órdenes en computadores
135 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
136 seguro entre dos servidores en una red insegura. Conexiones X11 y
137 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
138 seguro.
139
140 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
141 continuar la última versión gratuita de SSH, actualizándolo en
142 términos de seguridad y recursos,así también eliminando todos los
143 algoritmos patentados y colocándolos en bibliotecas separadas
144 (OpenSSL).
145
146 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
147 también el paquete openssh-clients u openssh-server o ambos.
148
149 %description -l fr
150 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
151 remplace telnet, rlogin, rexec et rsh, tout en assurant des
152 communications cryptées securisées entre deux hôtes non fiabilisés sur
153 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
154 arbitraires peuvent également être transmis sur le canal sécurisé.
155
156 %description -l it
157 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
158 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
159 sicure e crittate tra due host non fidati su una rete non sicura. Le
160 connessioni X11 ad una porta TCP/IP arbitraria possono essere
161 inoltrate attraverso un canale sicuro.
162
163 %description -l pl
164 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
165 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
166 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
167 pomiêdzy dwoma hostami.
168
169 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
170 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
171 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
172 %if %{with hpn} || %{with hpn_none}
173 Ta wersja zawiera ³aty z projektu High Performance SSH/SCP 
174 http://www.psc.edu/networking/projects/hpn-ssh/, które maj± na celu
175 zwiêkszenie przepustowo¶ci transmisji dla szybkich po³±czeñ 
176 z du¿ym RTT (20-150 msec). Na stronie projektu znale¼æ mo¿na 
177 odpowednie dla danego po³±czenia warto¶ci parametru '-w' oraz 
178 opcje /proc/sys dla TCP. Nawiasem mówi±c w sieciach LAN RTT < 1 msec.  
179 %endif
180 %if %{with hpn_none}
181 Obs³ugiwana jest równie¿ nieudokumentowana opcja '-z' odpowiedzialna
182 za wy³±czenie szyfrowania danych po zakoñczeniu procesu uwierzytelniania.
183 Dane s± zabezpieczone przed modyfikacj± lub uszkodzeniem przez 
184 stosowanie Message Authentication Code (MAC).
185 Opcja ta znacznie redukuje liczbê cykli procesora zu¿ywanych przez 
186 procesy SSH/SCP. W wybranych zastosowaniach mo¿e ona wp³yn±æ 
187 na wyra¼ne przyspieszenie (pods³uchiwalnej) transmisji danych. 
188 %endif
189
190 %description -l pt
191 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
192 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
193 cifradas entre duas máquinas sem confiança mútua sobre uma rede
194 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
195 reenviados pelo canal seguro.
196
197 %description -l pt_BR
198 SSH é um programa para acessar e executar comandos em máquinas
199 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
200 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
201 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
202
203 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
204 última versão gratuita do SSH, atualizando-o em termos de segurança e
205 recursos, assim como removendo todos os algoritmos patenteados e
206 colocando-os em bibliotecas separadas (OpenSSL).
207
208 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
209 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
210
211 %description -l ru
212 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
213 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
214 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
215 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
216 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
217 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
218
219 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
220 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
221 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
222 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
223
224 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
225 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
226 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
227
228 %description -l uk
229 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
230 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
231 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
232 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
233 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
234 ËÁÎÁÌ.
235
236 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
237 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
238 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
239 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
240
241 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
242 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
243 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
244
245 %package clients
246 Summary:        OpenSSH Secure Shell protocol clients
247 Summary(es):    Clientes de OpenSSH
248 Summary(pl):    Klienci protoko³u Secure Shell
249 Summary(pt_BR): Clientes do OpenSSH
250 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
251 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
252 Group:          Applications/Networking
253 Requires:       %{name} = %{epoch}:%{version}-%{release}
254 %{?with_sshagentsh:Requires:    xinitrc}
255 Provides:       ssh-clients
256 Obsoletes:      ssh-clients
257
258 %description clients
259 Ssh (Secure Shell) a program for logging into a remote machine and for
260 executing commands in a remote machine. It is intended to replace
261 rlogin and rsh, and provide secure encrypted communications between
262 two untrusted hosts over an insecure network. X11 connections and
263 arbitrary TCP/IP ports can also be forwarded over the secure channel.
264
265 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
266 it up to date in terms of security and features, as well as removing
267 all patented algorithms to seperate libraries (OpenSSL).
268
269 This package includes the clients necessary to make encrypted
270 connections to SSH servers.
271
272 %description clients -l es
273 Este paquete incluye los clientes que se necesitan para hacer
274 conexiones codificadas con servidores SSH.
275
276 %description clients -l pl
277 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
278 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
279 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
280 pomiêdzy dwoma hostami.
281
282 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
283
284 %description clients -l pt_BR
285 Esse pacote inclui os clientes necessários para fazer conexões
286 encriptadas com servidores SSH.
287
288 %description clients -l ru
289 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
290 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
291
292 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
293 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
294
295 %description clients -l uk
296 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
297 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
298
299 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
300 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
301
302 %package server
303 Summary:        OpenSSH Secure Shell protocol server (sshd)
304 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
305 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
306 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
307 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
308 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
309 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
310 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
311 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
312 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
313 Group:          Networking/Daemons
314 Requires:       %{name} = %{epoch}:%{version}-%{release}
315 Requires:       rc-scripts >= 0.4.0.18
316 Requires(pre):  /bin/id
317 Requires(pre):  /usr/sbin/useradd
318 Requires(post,preun):   /sbin/chkconfig
319 Requires(post): chkconfig >= 0.9
320 Requires(post): grep
321 Requires(postun):       /usr/sbin/userdel
322 Requires:       /bin/login
323 Requires:       util-linux
324 Requires:       pam >= 0.77.3
325 Provides:       user(sshd)
326 Provides:       ssh-server
327
328 %description server
329 Ssh (Secure Shell) a program for logging into a remote machine and for
330 executing commands in a remote machine. It is intended to replace
331 rlogin and rsh, and provide secure encrypted communications between
332 two untrusted hosts over an insecure network. X11 connections and
333 arbitrary TCP/IP ports can also be forwarded over the secure channel.
334
335 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
336 it up to date in terms of security and features, as well as removing
337 all patented algorithms to seperate libraries (OpenSSL).
338
339 This package contains the secure shell daemon. The sshd is the server
340 part of the secure shell protocol and allows ssh clients to connect to
341 your host.
342
343 %description server -l de
344 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
345
346 %description server -l es
347 Este paquete contiene el servidor SSH. sshd es la parte servidor del
348 protocolo secure shell y permite que clientes ssh se conecten a su
349 servidor.
350
351 %description server -l fr
352 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
353
354 %description server -l it
355 Questo pacchetto installa sshd, il server di OpenSSH.
356
357 %description server -l pl
358 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
359 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
360 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
361 pomiêdzy dwoma hostami.
362
363 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
364 ssh).
365
366 %description server -l pt
367 Este pacote intala o sshd, o servidor do OpenSSH.
368
369 %description server -l pt_BR
370 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
371 protocolo secure shell e permite que clientes ssh se conectem ao seu
372 host.
373
374 %description server -l ru
375 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
376 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
377
378 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
379 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
380 ×ÁÛÉÍ ÈÏÓÔÏÍ.
381
382 %description server -l uk
383 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
384 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
385
386 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
387 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
388 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
389
390 %package gnome-askpass
391 Summary:        OpenSSH GNOME passphrase dialog
392 Summary(de):    OpenSSH GNOME Passwort-Dialog
393 Summary(es):    Diálogo para introducción de passphrase para GNOME
394 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
395 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
396 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
397 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
398 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
399 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
400 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
401 Group:          Applications/Networking
402 Requires:       %{name} = %{epoch}:%{version}-%{release}
403 Obsoletes:      ssh-extras
404 Obsoletes:      ssh-askpass
405 Obsoletes:      openssh-askpass
406
407 %description gnome-askpass
408 Ssh (Secure Shell) a program for logging into a remote machine and for
409 executing commands in a remote machine. It is intended to replace
410 rlogin and rsh, and provide secure encrypted communications between
411 two untrusted hosts over an insecure network. X11 connections and
412 arbitrary TCP/IP ports can also be forwarded over the secure channel.
413
414 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
415 it up to date in terms of security and features, as well as removing
416 all patented algorithms to seperate libraries (OpenSSL).
417
418 This package contains the GNOME passphrase dialog.
419
420 %description gnome-askpass -l es
421 Este paquete contiene un programa que abre una caja de diálogo para
422 entrada de passphrase en GNOME.
423
424 %description gnome-askpass -l pl
425 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
426 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
427 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
428 pomiêdzy dwoma hostami.
429
430 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
431
432 %description gnome-askpass -l pt_BR
433 Esse pacote contém um programa que abre uma caixa de diálogo para
434 entrada de passphrase no GNOME.
435
436 %description gnome-askpass -l ru
437 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
438 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
439
440 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
441 GNOME.
442
443 %description gnome-askpass -l uk
444 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
445 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
446
447 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
448 GNOME.
449
450 %prep
451 %setup -q
452 %patch0 -p1
453 %patch2 -p1
454 %patch3 -p1
455 %patch4 -p1
456 %{?with_ldap:%patch5 -p1}
457 %{?with_kerberos5:%patch6 -p1}
458 #%patch7 -p1
459 %patch8 -p1
460 %{?with_selinux:%patch9 -p1}
461 %{?with_selinux:%patch10 -p1}
462 %{?with_hpn:%patch11 -p1}
463 %{?with_hpn_none:%patch12 -p1}
464
465 %build
466 cp %{_datadir}/automake/config.sub .
467 %{__aclocal}
468 %{__autoconf}
469 %{?with_chroot:CPPFLAGS="-DCHROOT"}
470 %configure \
471         PERL=%{__perl} \
472         --with-dns \
473         --with-pam \
474         --with-mantype=man \
475         --with-md5-passwords \
476         --with-ipaddr-display \
477         %{?with_libedit:--with-libedit} \
478         --with-4in6 \
479         --disable-suid-ssh \
480         --with-tcp-wrappers \
481         %{?with_ldap:--with-libs="-lldap -llber"} \
482         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
483         %{?with_kerberos5:--with-kerberos5} \
484         --with-privsep-path=%{_privsepdir} \
485         --with-pid-dir=%{_localstatedir}/run \
486         --with-xauth=/usr/X11R6/bin/xauth
487
488 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
489
490 %{__make}
491
492 cp -f %{SOURCE9} .
493 cp -f %{SOURCE10} .
494 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
495
496 cd contrib
497 %if %{with gnome}
498 %{__make} gnome-ssh-askpass1 \
499         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
500 %endif
501 %if %{with gtk}
502 %{__make} gnome-ssh-askpass2 \
503         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
504 %endif
505
506 %install
507 rm -rf $RPM_BUILD_ROOT
508 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
509         $RPM_BUILD_ROOT%{_libexecdir}/ssh
510 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
511
512 %{__make} install \
513         DESTDIR=$RPM_BUILD_ROOT
514
515 install connect    $RPM_BUILD_ROOT%{_bindir}
516 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
517 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
518 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
519 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
520 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
521 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
522 %if %{with sshagentsh}
523 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
524 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
525 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
526 %endif
527
528 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
529
530 %if %{with gnome}
531 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
532 %endif
533 %if %{with gtk}
534 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
535 %endif
536 %if %{with gnome} || %{with gtk}
537 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
538 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
539 EOF
540 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
541 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
542 EOF
543 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
544 %endif
545
546 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
547 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
548
549 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
550
551 %if "%{_lib}" != "lib"
552 find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 perl -pi -e "s#/usr/lib#/usr/%{_lib}#"
553 %endif
554
555 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
556 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
557 EOF
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %pre server
563 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
564
565 %post server
566 /sbin/chkconfig --add sshd
567 if [ -f /var/lock/subsys/sshd ]; then
568         /etc/rc.d/init.d/sshd restart 1>&2
569 else
570         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
571 fi
572 if ! grep -qs ssh /etc/security/passwd.conf ; then
573         umask 022
574         echo "ssh" >> /etc/security/passwd.conf
575 fi
576
577 %preun server
578 if [ "$1" = "0" ]; then
579         if [ -f /var/lock/subsys/sshd ]; then
580                 /etc/rc.d/init.d/sshd stop 1>&2
581         fi
582         /sbin/chkconfig --del sshd
583 fi
584
585 %postun server
586 if [ "$1" = "0" ]; then
587         %userremove sshd
588 fi
589
590 %files
591 %defattr(644,root,root,755)
592 %doc *.RNG TODO README OVERVIEW CREDITS Change*
593 %attr(755,root,root) %{_bindir}/ssh-key*
594 %{_mandir}/man1/ssh-key*.1*
595 %dir %{_sysconfdir}
596 %dir %{_libexecdir}
597
598 %files clients
599 %defattr(644,root,root,755)
600 %doc connect.html
601 %attr(755,root,root) %{_bindir}/connect
602 %attr(755,root,root) %{_bindir}/ssh
603 %attr(755,root,root) %{_bindir}/slogin
604 %attr(755,root,root) %{_bindir}/sftp
605 %attr(755,root,root) %{_bindir}/ssh-agent
606 %attr(755,root,root) %{_bindir}/ssh-add
607 %attr(755,root,root) %{_bindir}/scp
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
609 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
610 %if %{with sshagentsh}
611 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
612 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
613 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
614 %endif
615 %{_mandir}/man1/scp.1*
616 %{_mandir}/man1/ssh.1*
617 %{_mandir}/man1/slogin.1*
618 %{_mandir}/man1/sftp.1*
619 %{_mandir}/man1/ssh-agent.1*
620 %{_mandir}/man1/ssh-add.1*
621 %{_mandir}/man5/ssh_config.5*
622 %lang(it) %{_mandir}/it/man1/ssh.1*
623 %lang(it) %{_mandir}/it/man5/ssh_config.5*
624 %lang(pl) %{_mandir}/pl/man1/scp.1*
625 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
626
627 # for host-based auth (suid required for accessing private host key)
628 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
629 #%{_mandir}/man8/ssh-keysign.8*
630
631 %files server
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_sbindir}/sshd
634 %attr(755,root,root) %{_libexecdir}/sftp-server
635 %attr(755,root,root) %{_libexecdir}/ssh-keysign
636 %{_mandir}/man8/sshd.8*
637 %{_mandir}/man8/sftp-server.8*
638 %{_mandir}/man8/ssh-keysign.8*
639 %{_mandir}/man5/sshd_config.5*
640 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
641 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
642 %attr(640,root,root) %{_sysconfdir}/moduli
643 %attr(754,root,root) /etc/rc.d/init.d/sshd
644 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
645 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
646
647 %if %{with gnome} || %{with gtk}
648 %files gnome-askpass
649 %defattr(644,root,root,755)
650 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
651 %dir %{_libexecdir}/ssh
652 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
653 %attr(755,root,root) %{_libexecdir}/ssh-askpass
654 %endif
This page took 0.07726 seconds and 3 git commands to generate.