]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- typo
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_without  ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13
14 %if "%{pld_release}" == "ac"
15 %define         pam_ver 0.79.0
16 %else
17 %define         pam_ver 0.99.7.1
18 %endif
19
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es.UTF-8):      Implementación libre de SSH
23 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
26 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR.UTF-8):   Implementação livre do SSH
28 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
29 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
30 Name:           openssh
31 Version:        5.8p1
32 Release:        4.1
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  86f5e1c23b4c4845f23b9b7b493fb53d
38 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
40 Source2:        %{name}d.init
41 Source3:        %{name}d.pamd
42 Source4:        %{name}.sysconfig
43 Source5:        ssh-agent.sh
44 Source6:        ssh-agent.conf
45 Source7:        %{name}-lpk.schema
46 Source8:        %{name}d.upstart
47 Patch100:       %{name}-heimdal.patch
48 Patch0:         %{name}-no_libnsl.patch
49 Patch2:         %{name}-pam_misc.patch
50 Patch3:         %{name}-sigpipe.patch
51 # http://code.google.com/p/openssh-lpk/
52 Patch4:         %{name}-lpk.patch
53 Patch5:         %{name}-config.patch
54 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
55 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56 Patch9:         %{name}-5.2p1-hpn13v6.diff
57 Patch10:        %{name}-include.patch
58 Patch11:        %{name}-chroot.patch
59 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
60 Patch12:        %{name}-blacklist.diff
61 Patch13:        %{name}-kuserok.patch
62 URL:            http://www.openssh.com/portable.html
63 BuildRequires:  %{__perl}
64 BuildRequires:  autoconf
65 BuildRequires:  automake
66 %{?with_gnome:BuildRequires:    gnome-libs-devel}
67 %{?with_gtk:BuildRequires:      gtk+2-devel}
68 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
69 %{?with_libedit:BuildRequires:  libedit-devel}
70 %{?with_selinux:BuildRequires:  libselinux-devel}
71 BuildRequires:  libwrap-devel
72 %{?with_ldap:BuildRequires:     openldap-devel}
73 BuildRequires:  openssl-devel >= 0.9.7d
74 BuildRequires:  pam-devel
75 %{?with_gtk:BuildRequires:      pkgconfig}
76 BuildRequires:  rpm >= 4.4.9-56
77 BuildRequires:  rpmbuild(macros) >= 1.318
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  zlib-devel
80 %if "%{pld_release}" == "ac"
81 Requires:       filesystem >= 2.0-1
82 Requires:       pam >= 0.79.0
83 %else
84 Requires:       filesystem >= 3.0-11
85 Requires:       pam >= %{pam_ver}
86 Suggests:       openssh-blacklist
87 Suggests:       xorg-app-xauth
88 %endif
89 Obsoletes:      ssh
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _sysconfdir     /etc/ssh
93 %define         _libexecdir     %{_libdir}/%{name}
94 %define         _privsepdir     /usr/share/empty
95 %define         schemadir       /usr/share/openldap/schema
96
97 ## to be moved to rpm-build-macros
98 ## TODO: handle RPM_SKIP_AUTO_RESTART
99
100 # migrate from init script to upstart job
101 %define upstart_post() \
102         if [ -f /var/lock/subsys/"%1" ] ; then \
103                 /sbin/service --no-upstart "%1" stop \
104                 /sbin/service "%1" start \
105         else \
106                 /sbin/service "%1" try-restart \
107         fi
108
109 # restart the job after upgrade or migrate to init script on removal
110 %define upstart_postun() \
111         if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
112                 /sbin/initctl stop "%1" 2>/dev/null \
113                 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
114         fi
115
116
117 %description
118 Ssh (Secure Shell) a program for logging into a remote machine and for
119 executing commands in a remote machine. It is intended to replace
120 rlogin and rsh, and provide secure encrypted communications between
121 two untrusted hosts over an insecure network. X11 connections and
122 arbitrary TCP/IP ports can also be forwarded over the secure channel.
123
124 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
125 it up to date in terms of security and features, as well as removing
126 all patented algorithms to seperate libraries (OpenSSL).
127
128 This package includes the core files necessary for both the OpenSSH
129 client and server. To make this package useful, you should also
130 install openssh-clients, openssh-server, or both.
131
132 %if %{with hpn}
133 This release includes High Performance SSH/SCP patches from
134 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
135 increase throughput on fast connections with high RTT (20-150 msec).
136 See the website for '-w' values for your connection and /proc/sys TCP
137 values. BTW. in a LAN you have got generally RTT < 1 msec.
138 %endif
139
140 %description -l de.UTF-8
141 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
142 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
143 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
144 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
145 andere TCP/IP Ports können ebenso über den sicheren Channel
146 weitergeleitet werden.
147
148 %description -l es.UTF-8
149 SSH es un programa para accesar y ejecutar órdenes en computadores
150 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
151 seguro entre dos servidores en una red insegura. Conexiones X11 y
152 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
153 seguro.
154
155 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
156 continuar la última versión gratuita de SSH, actualizándolo en
157 términos de seguridad y recursos,así también eliminando todos los
158 algoritmos patentados y colocándolos en bibliotecas separadas
159 (OpenSSL).
160
161 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
162 también el paquete openssh-clients u openssh-server o ambos.
163
164 %description -l fr.UTF-8
165 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
166 remplace telnet, rlogin, rexec et rsh, tout en assurant des
167 communications cryptées securisées entre deux hôtes non fiabilisés sur
168 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
169 arbitraires peuvent également être transmis sur le canal sécurisé.
170
171 %description -l it.UTF-8
172 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
173 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
174 sicure e crittate tra due host non fidati su una rete non sicura. Le
175 connessioni X11 ad una porta TCP/IP arbitraria possono essere
176 inoltrate attraverso un canale sicuro.
177
178 %description -l pl.UTF-8
179 Ssh (Secure Shell) to program służący do logowania się na zdalną
180 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
181 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
182 pomiędzy dwoma hostami.
183
184 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
185 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
186 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
187
188 %if %{with hpn}
189 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
190 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
191 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
192 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
193 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
194 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
195 %endif
196
197 %description -l pt.UTF-8
198 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
199 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
200 cifradas entre duas máquinas sem confiança mútua sobre uma rede
201 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
202 reenviados pelo canal seguro.
203
204 %description -l pt_BR.UTF-8
205 SSH é um programa para acessar e executar comandos em máquinas
206 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
207 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
208 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
209
210 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
211 última versão gratuita do SSH, atualizando-o em termos de segurança e
212 recursos, assim como removendo todos os algoritmos patenteados e
213 colocando-os em bibliotecas separadas (OpenSSL).
214
215 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
216 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
217
218 %description -l ru.UTF-8
219 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
220 машину и для выполнения команд на удаленной машине. Она предназначена
221 для замены rlogin и rsh и обеспечивает безопасную шифрованную
222 коммуникацию между двумя хостами в сети, являющейся небезопасной.
223 Соединения X11 и любые порты TCP/IP могут также быть проведены через
224 безопасный канал.
225
226 OpenSSH - это переделка командой разработчиков OpenBSD последней
227 свободной версии SSH, доведенная до современного состояния в терминах
228 уровня безопасности и поддерживаемых возможностей. Все патентованные
229 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
230
231 Этот пакет содержит файлы, необходимые как для клиента, так и для
232 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
233 openssh-server, или оба пакета.
234
235 %description -l uk.UTF-8
236 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
237 машини та для виконання команд на віддаленій машині. Вона призначена
238 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
239 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
240 довільні порти TCP/IP можуть також бути проведені через безпечний
241 канал.
242
243 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
244 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
245 підтримуваних можливостей. Всі патентовані алгоритми винесені до
246 окремих бібліотек (OpenSSL).
247
248 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
249 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
250 openssh-server, чи обидва пакети.
251
252 %package clients
253 Summary:        OpenSSH Secure Shell protocol clients
254 Summary(es.UTF-8):      Clientes de OpenSSH
255 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
256 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
257 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
258 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
259 Group:          Applications/Networking
260 Requires:       %{name}
261 Provides:       ssh-clients
262 Obsoletes:      ssh-clients
263
264 %description clients
265 Ssh (Secure Shell) a program for logging into a remote machine and for
266 executing commands in a remote machine. It is intended to replace
267 rlogin and rsh, and provide secure encrypted communications between
268 two untrusted hosts over an insecure network. X11 connections and
269 arbitrary TCP/IP ports can also be forwarded over the secure channel.
270
271 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
272 it up to date in terms of security and features, as well as removing
273 all patented algorithms to seperate libraries (OpenSSL).
274
275 This package includes the clients necessary to make encrypted
276 connections to SSH servers.
277
278 %description clients -l es.UTF-8
279 Este paquete incluye los clientes que se necesitan para hacer
280 conexiones codificadas con servidores SSH.
281
282 %description clients -l pl.UTF-8
283 Ssh (Secure Shell) to program służący do logowania się na zdalną
284 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
285 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
286 pomiędzy dwoma hostami.
287
288 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
289
290 %description clients -l pt_BR.UTF-8
291 Esse pacote inclui os clientes necessários para fazer conexões
292 encriptadas com servidores SSH.
293
294 %description clients -l ru.UTF-8
295 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
296 машину и для выполнения команд на удаленной машине.
297
298 Этот пакет содержит программы-клиенты, необходимые для установления
299 зашифрованных соединений с серверами SSH.
300
301 %description clients -l uk.UTF-8
302 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
303 машини та для виконання команд на віддаленій машині.
304
305 Цей пакет містить програми-клієнти, необхідні для встановлення
306 зашифрованих з'єднань з серверами SSH.
307
308 %package clients-agent-profile_d
309 Summary:        OpenSSH Secure Shell agent init script
310 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
311 Group:          Applications/Networking
312 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
313
314 %description clients-agent-profile_d
315 profile.d scripts for starting SSH agent.
316
317 %description clients-agent-profile_d -l pl.UTF-8
318 Skrypty profile.d do uruchamiania agenta SSH.
319
320 %package clients-agent-xinitrc
321 Summary:        OpenSSH Secure Shell agent init script
322 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
323 Group:          Applications/Networking
324 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
325 Requires:       xinitrc
326
327 %description clients-agent-xinitrc
328 xinitrc scripts for starting SSH agent.
329
330 %description clients-agent-xinitrc -l pl.UTF-8
331 Skrypty xinitrc do uruchamiania agenta SSH.
332
333 %package server
334 Summary:        OpenSSH Secure Shell protocol server (sshd)
335 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
336 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
337 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
338 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
339 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
340 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
341 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
342 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
343 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
344 Group:          Networking/Daemons
345 Requires(post): /sbin/chkconfig
346 Requires(post): grep
347 Requires(post,preun):   /sbin/chkconfig
348 Requires(postun):       /usr/sbin/userdel
349 Requires(pre):  /bin/id
350 Requires(pre):  /usr/sbin/useradd
351 Requires:       %{name} = %{epoch}:%{version}-%{release}
352 Requires:       pam >= %{pam_ver}
353 Requires:       rc-scripts >= 0.4.3.0
354 Requires:       util-linux
355 Suggests:       /bin/login
356 Provides:       ssh-server
357 Provides:       user(sshd)
358
359 %description server
360 Ssh (Secure Shell) a program for logging into a remote machine and for
361 executing commands in a remote machine. It is intended to replace
362 rlogin and rsh, and provide secure encrypted communications between
363 two untrusted hosts over an insecure network. X11 connections and
364 arbitrary TCP/IP ports can also be forwarded over the secure channel.
365
366 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
367 it up to date in terms of security and features, as well as removing
368 all patented algorithms to seperate libraries (OpenSSL).
369
370 This package contains the secure shell daemon. The sshd is the server
371 part of the secure shell protocol and allows ssh clients to connect to
372 your host.
373
374 %description server -l de.UTF-8
375 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
376
377 %description server -l es.UTF-8
378 Este paquete contiene el servidor SSH. sshd es la parte servidor del
379 protocolo secure shell y permite que clientes ssh se conecten a su
380 servidor.
381
382 %description server -l fr.UTF-8
383 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
384
385 %description server -l it.UTF-8
386 Questo pacchetto installa sshd, il server di OpenSSH.
387
388 %description server -l pl.UTF-8
389 Ssh (Secure Shell) to program służący do logowania się na zdalną
390 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
391 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
392 pomiędzy dwoma hostami.
393
394 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
395 ssh).
396
397 %description server -l pt.UTF-8
398 Este pacote intala o sshd, o servidor do OpenSSH.
399
400 %description server -l pt_BR.UTF-8
401 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
402 protocolo secure shell e permite que clientes ssh se conectem ao seu
403 host.
404
405 %description server -l ru.UTF-8
406 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
407 машину и для выполнения команд на удаленной машине.
408
409 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
410 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
411 вашим хостом.
412
413 %description server -l uk.UTF-8
414 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
415 машини та для виконання команд на віддаленій машині.
416
417 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
418 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
419 з вашим хостом.
420
421 %package server-upstart
422 Summary:        Upstart job description for OpenSSH server
423 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
424 Group:          Daemons
425 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
426 Requires:       upstart >= 0.6
427
428 %description server-upstart
429 Upstart job description for OpenSSH.
430
431 %description server-upstart -l pl.UTF-8
432 Opis zadania Upstart dla OpenSSH.
433
434 %package gnome-askpass
435 Summary:        OpenSSH GNOME passphrase dialog
436 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
437 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
438 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
439 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
440 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
441 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
442 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
443 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
444 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
445 Group:          Applications/Networking
446 Requires:       %{name} = %{epoch}:%{version}-%{release}
447 Obsoletes:      openssh-askpass
448 Obsoletes:      ssh-askpass
449 Obsoletes:      ssh-extras
450
451 %description gnome-askpass
452 Ssh (Secure Shell) a program for logging into a remote machine and for
453 executing commands in a remote machine. It is intended to replace
454 rlogin and rsh, and provide secure encrypted communications between
455 two untrusted hosts over an insecure network. X11 connections and
456 arbitrary TCP/IP ports can also be forwarded over the secure channel.
457
458 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
459 it up to date in terms of security and features, as well as removing
460 all patented algorithms to seperate libraries (OpenSSL).
461
462 This package contains the GNOME passphrase dialog.
463
464 %description gnome-askpass -l es.UTF-8
465 Este paquete contiene un programa que abre una caja de diálogo para
466 entrada de passphrase en GNOME.
467
468 %description gnome-askpass -l pl.UTF-8
469 Ssh (Secure Shell) to program służący do logowania się na zdalną
470 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
471 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
472 pomiędzy dwoma hostami.
473
474 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
475
476 %description gnome-askpass -l pt_BR.UTF-8
477 Esse pacote contém um programa que abre uma caixa de diálogo para
478 entrada de passphrase no GNOME.
479
480 %description gnome-askpass -l ru.UTF-8
481 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
482 машину и для выполнения команд на удаленной машине.
483
484 Этот пакет содержит диалог ввода ключевой фразы для использования под
485 GNOME.
486
487 %description gnome-askpass -l uk.UTF-8
488 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
489 машини та для виконання команд на віддаленій машині.
490
491 Цей пакет містить діалог вводу ключової фрази для використання під
492 GNOME.
493
494 %package -n openldap-schema-openssh-lpk
495 Summary:        OpenSSH LDAP Public Key schema
496 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
497 Group:          Networking/Daemons
498 Requires(post,postun):  sed >= 4.0
499 Requires:       openldap-servers
500
501 %description -n openldap-schema-openssh-lpk
502 This package contains OpenSSH LDAP Public Key schema for openldap.
503
504 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
505 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
506 openldap-a.
507
508 %prep
509 %setup -q
510 %{?with_kerberos5:%patch100 -p1}
511 %patch0 -p1
512 %patch2 -p1
513 %patch3 -p1
514 %{?with_ldap:%patch4 -p1}
515 %patch5 -p1
516 %{?with_hpn:%patch9 -p1}
517 %patch10 -p1
518 %patch11 -p1
519 %patch12 -p1
520 %patch13 -p1
521
522 %if "%{pld_release}" == "ac"
523 # fix for missing x11.pc
524 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
525 %endif
526
527 %build
528 cp /usr/share/automake/config.sub .
529 %{__aclocal}
530 %{__autoconf}
531 CPPFLAGS="-DCHROOT"
532 %configure \
533         PERL=%{__perl} \
534         --with-pam \
535         --with-mantype=man \
536         --with-md5-passwords \
537         --with-ipaddr-display \
538         %{?with_libedit:--with-libedit} \
539         --with-4in6 \
540         --with-tcp-wrappers \
541         %{?with_ldap:--with-libs="-lldap -llber"} \
542         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
543         %{?with_kerberos5:--with-kerberos5=/usr} \
544         --with-privsep-path=%{_privsepdir} \
545         --with-pid-dir=%{_localstatedir}/run \
546 %if "%{pld_release}" == "ac"
547         --with-xauth=/usr/X11R6/bin/xauth \
548 %else
549         --with-xauth=%{_bindir}/xauth \
550 %endif
551         --enable-utmpx \
552         --enable-wtmpx
553
554 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
555
556 %{__make}
557
558 cd contrib
559 %if %{with gnome}
560 %{__make} gnome-ssh-askpass1 \
561         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
562 %endif
563 %if %{with gtk}
564 %{__make} gnome-ssh-askpass2 \
565         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
566 %endif
567
568 %install
569 rm -rf $RPM_BUILD_ROOT
570 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
571         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
572 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
573
574 %{__make} install \
575         DESTDIR=$RPM_BUILD_ROOT
576
577 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
578
579 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
580 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
581 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
582 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
583 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
584 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
585 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
586
587 install %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
588
589 %if %{with gnome}
590 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
591 %endif
592 %if %{with gtk}
593 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
594 %endif
595 %if %{with gnome} || %{with gtk}
596 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
597 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
598 EOF
599 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
600 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
601 EOF
602 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
603 %endif
604
605 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
606 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
607
608 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
609 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
610
611 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
612
613 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
614 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
615 EOF
616
617 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
618 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
619
620 %clean
621 rm -rf $RPM_BUILD_ROOT
622
623 %post clients
624 %env_update
625
626 %postun clients
627 %env_update
628
629 %post gnome-askpass
630 %env_update
631
632 %postun gnome-askpass
633 %env_update
634
635 %pre server
636 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
637
638 %post server
639 /sbin/chkconfig --add sshd
640 %service sshd reload "openssh daemon"
641 if ! grep -qs ssh /etc/security/passwd.conf ; then
642         umask 022
643         echo "ssh" >> /etc/security/passwd.conf
644 fi
645
646 %preun server
647 if [ "$1" = "0" ]; then
648         %service sshd stop
649         /sbin/chkconfig --del sshd
650 fi
651
652 %postun server
653 if [ "$1" = "0" ]; then
654         %userremove sshd
655 fi
656
657 %post server-upstart
658 %upstart_post sshd
659
660 %postun server-upstart
661 %upstart_postun sshd
662
663 %post -n openldap-schema-openssh-lpk
664 %openldap_schema_register %{schemadir}/openssh-lpk.schema
665 %service -q ldap restart
666
667 %postun -n openldap-schema-openssh-lpk
668 if [ "$1" = "0" ]; then
669         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
670         %service -q ldap restart
671 fi
672
673 %files
674 %defattr(644,root,root,755)
675 %doc *.RNG TODO README OVERVIEW CREDITS Change*
676 %attr(755,root,root) %{_bindir}/ssh-key*
677 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
678 %{_mandir}/man1/ssh-key*.1*
679 %{_mandir}/man1/ssh-vulnkey*.1*
680 %dir %{_sysconfdir}
681 %dir %{_libexecdir}
682
683 %files clients
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_bindir}/ssh
686 %attr(755,root,root) %{_bindir}/slogin
687 %attr(755,root,root) %{_bindir}/sftp
688 %attr(755,root,root) %{_bindir}/ssh-agent
689 %attr(755,root,root) %{_bindir}/ssh-add
690 %attr(755,root,root) %{_bindir}/ssh-copy-id
691 %attr(755,root,root) %{_bindir}/scp
692 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
693 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
694 %{_mandir}/man1/scp.1*
695 %{_mandir}/man1/ssh.1*
696 %{_mandir}/man1/slogin.1*
697 %{_mandir}/man1/sftp.1*
698 %{_mandir}/man1/ssh-agent.1*
699 %{_mandir}/man1/ssh-add.1*
700 %{_mandir}/man1/ssh-copy-id.1*
701 %{_mandir}/man5/ssh_config.5*
702 %lang(it) %{_mandir}/it/man1/ssh.1*
703 %lang(it) %{_mandir}/it/man5/ssh_config.5*
704 %lang(pl) %{_mandir}/pl/man1/scp.1*
705 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
706
707 # for host-based auth (suid required for accessing private host key)
708 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
709 #%{_mandir}/man8/ssh-keysign.8*
710
711 %files clients-agent-profile_d
712 %defattr(644,root,root,755)
713 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
714 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
715
716 %files clients-agent-xinitrc
717 %defattr(644,root,root,755)
718 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
719
720 %files server
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_sbindir}/sshd
723 %attr(755,root,root) %{_libexecdir}/sftp-server
724 %attr(755,root,root) %{_libexecdir}/ssh-keysign
725 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
726 %{_mandir}/man8/sshd.8*
727 %{_mandir}/man8/sftp-server.8*
728 %{_mandir}/man8/ssh-keysign.8*
729 %{_mandir}/man8/ssh-pkcs11-helper.8*
730 %{_mandir}/man5/sshd_config.5*
731 %{_mandir}/man5/moduli.5*
732 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
733 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
734 %attr(640,root,root) %{_sysconfdir}/moduli
735 %attr(754,root,root) /etc/rc.d/init.d/sshd
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
738
739 %if %{with gnome} || %{with gtk}
740 %files gnome-askpass
741 %defattr(644,root,root,755)
742 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
743 %dir %{_libexecdir}/ssh
744 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
745 %attr(755,root,root) %{_libexecdir}/ssh-askpass
746 %endif
747
748 %if %{with ldap}
749 %files -n openldap-schema-openssh-lpk
750 %defattr(644,root,root,755)
751 %{schemadir}/openssh-lpk.schema
752 %endif
753
754 %if "%{pld_release}" != "ti"
755 %files server-upstart
756 %defattr(644,root,root,755)
757 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
758 %endif
This page took 0.07605 seconds and 3 git commands to generate.