]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
66174e3fa1dbff010c93e619b0d7be397b061e4e
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_without  audit           # sshd audit support
4 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
5 %bcond_without  gtk             # without GTK+ (2.x)
6 %bcond_without  ldap            # with ldap support
7 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
8 %bcond_without  kerberos5       # without kerberos5 support
9 %bcond_without  selinux         # build without SELinux support
10 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
11 %bcond_without  tests
12
13 # gtk2-based gnome-askpass means no gnome1-based
14 %{?with_gtk:%undefine with_gnome}
15
16 %if "%{pld_release}" == "ac"
17 %define         pam_ver 0.79.0
18 %else
19 %define         pam_ver 1:1.1.5-5
20 %endif
21
22 Summary:        OpenSSH free Secure Shell (SSH) implementation
23 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
24 Summary(es.UTF-8):      Implementación libre de SSH
25 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
26 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
27 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
28 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29 Summary(pt_BR.UTF-8):   Implementação livre do SSH
30 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
31 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
32 Name:           openssh
33 Version:        5.9p1
34 Release:        8
35 Epoch:          2
36 License:        BSD
37 Group:          Applications/Networking
38 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
39 # Source0-md5:  b50a499fa02616a47984b1920848b565
40 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
42 Source2:        %{name}d.init
43 Source3:        %{name}d.pamd
44 Source4:        %{name}.sysconfig
45 Source5:        ssh-agent.sh
46 Source6:        ssh-agent.conf
47 Source7:        %{name}-lpk.schema
48 Source8:        %{name}d.upstart
49 Source9:        sshd.service
50 Source10:       sshd-keygen
51 Patch100:       %{name}-heimdal.patch
52 Patch0:         %{name}-no_libnsl.patch
53 Patch2:         %{name}-pam_misc.patch
54 Patch3:         %{name}-sigpipe.patch
55 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
56 Patch4:         %{name}-5.9p1-ldap.patch
57 Patch5:         %{name}-5.9p1-ldap-fixes.patch
58 Patch8:         ldap.conf.patch
59 Patch6:         %{name}-config.patch
60 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
61 Patch7:         authorized-keys-command.patch
62 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
63 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
64 Patch9:         %{name}-5.2p1-hpn13v6.diff
65 Patch10:        %{name}-include.patch
66 Patch11:        %{name}-chroot.patch
67 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
68 Patch12:        %{name}-blacklist.diff
69 Patch13:        %{name}-kuserok.patch
70 Patch14:        %{name}-bind.patch
71 URL:            http://www.openssh.com/portable.html
72 BuildRequires:  %{__perl}
73 %{?with_audit:BuildRequires:    audit-libs-devel}
74 BuildRequires:  autoconf >= 2.50
75 BuildRequires:  automake
76 %{?with_gnome:BuildRequires:    gnome-libs-devel}
77 %{?with_gtk:BuildRequires:      gtk+2-devel}
78 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
79 %{?with_libedit:BuildRequires:  libedit-devel}
80 %{?with_selinux:BuildRequires:  libselinux-devel}
81 BuildRequires:  libwrap-devel
82 %{?with_ldap:BuildRequires:     openldap-devel}
83 BuildRequires:  openssl-devel >= 0.9.7d
84 BuildRequires:  pam-devel
85 %{?with_gtk:BuildRequires:      pkgconfig}
86 BuildRequires:  rpm >= 4.4.9-56
87 BuildRequires:  rpmbuild(macros) >= 1.627
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  zlib-devel
90 %if "%{pld_release}" == "ac"
91 Requires:       filesystem >= 2.0-1
92 Requires:       pam >= 0.79.0
93 %else
94 Requires:       filesystem >= 3.0-11
95 Requires:       pam >= %{pam_ver}
96 Suggests:       openssh-blacklist
97 Suggests:       xorg-app-xauth
98 %endif
99 Obsoletes:      ssh
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _sysconfdir     /etc/ssh
103 %define         _libexecdir     %{_libdir}/%{name}
104 %define         _privsepdir     /usr/share/empty
105 %define         schemadir       /usr/share/openldap/schema
106
107 %description
108 Ssh (Secure Shell) a program for logging into a remote machine and for
109 executing commands in a remote machine. It is intended to replace
110 rlogin and rsh, and provide secure encrypted communications between
111 two untrusted hosts over an insecure network. X11 connections and
112 arbitrary TCP/IP ports can also be forwarded over the secure channel.
113
114 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
115 it up to date in terms of security and features, as well as removing
116 all patented algorithms to seperate libraries (OpenSSL).
117
118 This package includes the core files necessary for both the OpenSSH
119 client and server. To make this package useful, you should also
120 install openssh-clients, openssh-server, or both.
121
122 %if %{with hpn}
123 This release includes High Performance SSH/SCP patches from
124 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
125 increase throughput on fast connections with high RTT (20-150 msec).
126 See the website for '-w' values for your connection and /proc/sys TCP
127 values. BTW. in a LAN you have got generally RTT < 1 msec.
128 %endif
129
130 %description -l de.UTF-8
131 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
132 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
133 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
134 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
135 andere TCP/IP Ports können ebenso über den sicheren Channel
136 weitergeleitet werden.
137
138 %description -l es.UTF-8
139 SSH es un programa para accesar y ejecutar órdenes en computadores
140 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
141 seguro entre dos servidores en una red insegura. Conexiones X11 y
142 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
143 seguro.
144
145 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
146 continuar la última versión gratuita de SSH, actualizándolo en
147 términos de seguridad y recursos,así también eliminando todos los
148 algoritmos patentados y colocándolos en bibliotecas separadas
149 (OpenSSL).
150
151 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
152 también el paquete openssh-clients u openssh-server o ambos.
153
154 %description -l fr.UTF-8
155 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
156 remplace telnet, rlogin, rexec et rsh, tout en assurant des
157 communications cryptées securisées entre deux hôtes non fiabilisés sur
158 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
159 arbitraires peuvent également être transmis sur le canal sécurisé.
160
161 %description -l it.UTF-8
162 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
163 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
164 sicure e crittate tra due host non fidati su una rete non sicura. Le
165 connessioni X11 ad una porta TCP/IP arbitraria possono essere
166 inoltrate attraverso un canale sicuro.
167
168 %description -l pl.UTF-8
169 Ssh (Secure Shell) to program służący do logowania się na zdalną
170 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
171 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
172 pomiędzy dwoma hostami.
173
174 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
175 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
176 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
177
178 %if %{with hpn}
179 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
180 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
181 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
182 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
183 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
184 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
185 %endif
186
187 %description -l pt.UTF-8
188 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190 cifradas entre duas máquinas sem confiança mútua sobre uma rede
191 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192 reenviados pelo canal seguro.
193
194 %description -l pt_BR.UTF-8
195 SSH é um programa para acessar e executar comandos em máquinas
196 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201 última versão gratuita do SSH, atualizando-o em termos de segurança e
202 recursos, assim como removendo todos os algoritmos patenteados e
203 colocando-os em bibliotecas separadas (OpenSSL).
204
205 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208 %description -l ru.UTF-8
209 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
210 машину и для выполнения команд на удаленной машине. Она предназначена
211 для замены rlogin и rsh и обеспечивает безопасную шифрованную
212 коммуникацию между двумя хостами в сети, являющейся небезопасной.
213 Соединения X11 и любые порты TCP/IP могут также быть проведены через
214 безопасный канал.
215
216 OpenSSH - это переделка командой разработчиков OpenBSD последней
217 свободной версии SSH, доведенная до современного состояния в терминах
218 уровня безопасности и поддерживаемых возможностей. Все патентованные
219 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
220
221 Этот пакет содержит файлы, необходимые как для клиента, так и для
222 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
223 openssh-server, или оба пакета.
224
225 %description -l uk.UTF-8
226 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
227 машини та для виконання команд на віддаленій машині. Вона призначена
228 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
229 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
230 довільні порти TCP/IP можуть також бути проведені через безпечний
231 канал.
232
233 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
234 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
235 підтримуваних можливостей. Всі патентовані алгоритми винесені до
236 окремих бібліотек (OpenSSL).
237
238 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
239 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
240 openssh-server, чи обидва пакети.
241
242 %package clients
243 Summary:        OpenSSH Secure Shell protocol clients
244 Summary(es.UTF-8):      Clientes de OpenSSH
245 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
246 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
247 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
248 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
249 Group:          Applications/Networking
250 Requires:       %{name}
251 Provides:       ssh-clients
252 Obsoletes:      ssh-clients
253
254 %description clients
255 Ssh (Secure Shell) a program for logging into a remote machine and for
256 executing commands in a remote machine. It is intended to replace
257 rlogin and rsh, and provide secure encrypted communications between
258 two untrusted hosts over an insecure network. X11 connections and
259 arbitrary TCP/IP ports can also be forwarded over the secure channel.
260
261 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
262 it up to date in terms of security and features, as well as removing
263 all patented algorithms to seperate libraries (OpenSSL).
264
265 This package includes the clients necessary to make encrypted
266 connections to SSH servers.
267
268 %description clients -l es.UTF-8
269 Este paquete incluye los clientes que se necesitan para hacer
270 conexiones codificadas con servidores SSH.
271
272 %description clients -l pl.UTF-8
273 Ssh (Secure Shell) to program służący do logowania się na zdalną
274 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
275 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
276 pomiędzy dwoma hostami.
277
278 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
279
280 %description clients -l pt_BR.UTF-8
281 Esse pacote inclui os clientes necessários para fazer conexões
282 encriptadas com servidores SSH.
283
284 %description clients -l ru.UTF-8
285 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
286 машину и для выполнения команд на удаленной машине.
287
288 Этот пакет содержит программы-клиенты, необходимые для установления
289 зашифрованных соединений с серверами SSH.
290
291 %description clients -l uk.UTF-8
292 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
293 машини та для виконання команд на віддаленій машині.
294
295 Цей пакет містить програми-клієнти, необхідні для встановлення
296 зашифрованих з'єднань з серверами SSH.
297
298 %package clients-agent-profile_d
299 Summary:        OpenSSH Secure Shell agent init script
300 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
301 Group:          Applications/Networking
302 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
303
304 %description clients-agent-profile_d
305 profile.d scripts for starting SSH agent.
306
307 %description clients-agent-profile_d -l pl.UTF-8
308 Skrypty profile.d do uruchamiania agenta SSH.
309
310 %package clients-agent-xinitrc
311 Summary:        OpenSSH Secure Shell agent init script
312 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
313 Group:          Applications/Networking
314 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
315 Requires:       xinitrc
316
317 %description clients-agent-xinitrc
318 xinitrc scripts for starting SSH agent.
319
320 %description clients-agent-xinitrc -l pl.UTF-8
321 Skrypty xinitrc do uruchamiania agenta SSH.
322
323 %package server
324 Summary:        OpenSSH Secure Shell protocol server (sshd)
325 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
326 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
327 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
328 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
329 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
330 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
331 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
332 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
333 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
334 Group:          Networking/Daemons
335 Requires(post): /sbin/chkconfig
336 Requires(post): grep
337 Requires(post,preun):   /sbin/chkconfig
338 Requires(postun):       /usr/sbin/userdel
339 Requires(pre):  /bin/id
340 Requires(pre):  /usr/sbin/useradd
341 Requires:       %{name} = %{epoch}:%{version}-%{release}
342 # remove in 6.0, kept for flawless upgrade
343 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
344 Requires:       pam >= %{pam_ver}
345 Requires:       rc-scripts >= 0.4.3.0
346 Requires:       systemd-units >= 37-0.10
347 Requires:       util-linux
348 Suggests:       /bin/login
349 Provides:       ssh-server
350 Provides:       user(sshd)
351
352 %description server
353 Ssh (Secure Shell) a program for logging into a remote machine and for
354 executing commands in a remote machine. It is intended to replace
355 rlogin and rsh, and provide secure encrypted communications between
356 two untrusted hosts over an insecure network. X11 connections and
357 arbitrary TCP/IP ports can also be forwarded over the secure channel.
358
359 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
360 it up to date in terms of security and features, as well as removing
361 all patented algorithms to seperate libraries (OpenSSL).
362
363 This package contains the secure shell daemon. The sshd is the server
364 part of the secure shell protocol and allows ssh clients to connect to
365 your host.
366
367 %description server -l de.UTF-8
368 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
369
370 %description server -l es.UTF-8
371 Este paquete contiene el servidor SSH. sshd es la parte servidor del
372 protocolo secure shell y permite que clientes ssh se conecten a su
373 servidor.
374
375 %description server -l fr.UTF-8
376 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
377
378 %description server -l it.UTF-8
379 Questo pacchetto installa sshd, il server di OpenSSH.
380
381 %description server -l pl.UTF-8
382 Ssh (Secure Shell) to program służący do logowania się na zdalną
383 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
384 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
385 pomiędzy dwoma hostami.
386
387 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
388 ssh).
389
390 %description server -l pt.UTF-8
391 Este pacote intala o sshd, o servidor do OpenSSH.
392
393 %description server -l pt_BR.UTF-8
394 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
395 protocolo secure shell e permite que clientes ssh se conectem ao seu
396 host.
397
398 %description server -l ru.UTF-8
399 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
400 машину и для выполнения команд на удаленной машине.
401
402 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
403 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
404 вашим хостом.
405
406 %description server -l uk.UTF-8
407 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
408 машини та для виконання команд на віддаленій машині.
409
410 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
411 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
412 з вашим хостом.
413
414 %package server-ldap
415 Summary:        A LDAP support for open source SSH server daemon
416 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
417 Group:          Daemons
418 Requires:       %{name} = %{epoch}:%{version}-%{release}
419
420 %description server-ldap
421 OpenSSH LDAP backend is a way how to distribute the authorized tokens
422 among the servers in the network.
423
424 %description server-ldap -l pl.UTF-8
425 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
426 tokenów między serwerami w sieci.
427
428 %package server-upstart
429 Summary:        Upstart job description for OpenSSH server
430 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
431 Group:          Daemons
432 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
433 Requires:       upstart >= 0.6
434 Conflicts:      syslog-ng < 3.2.4-1
435
436 %description server-upstart
437 Upstart job description for OpenSSH.
438
439 %description server-upstart -l pl.UTF-8
440 Opis zadania Upstart dla OpenSSH.
441
442 %package gnome-askpass
443 Summary:        OpenSSH GNOME passphrase dialog
444 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
445 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
446 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
447 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
448 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
449 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
450 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
451 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
452 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
453 Group:          Applications/Networking
454 Requires:       %{name} = %{epoch}:%{version}-%{release}
455 Obsoletes:      openssh-askpass
456 Obsoletes:      ssh-askpass
457 Obsoletes:      ssh-extras
458
459 %description gnome-askpass
460 Ssh (Secure Shell) a program for logging into a remote machine and for
461 executing commands in a remote machine. It is intended to replace
462 rlogin and rsh, and provide secure encrypted communications between
463 two untrusted hosts over an insecure network. X11 connections and
464 arbitrary TCP/IP ports can also be forwarded over the secure channel.
465
466 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
467 it up to date in terms of security and features, as well as removing
468 all patented algorithms to seperate libraries (OpenSSL).
469
470 This package contains the GNOME passphrase dialog.
471
472 %description gnome-askpass -l es.UTF-8
473 Este paquete contiene un programa que abre una caja de diálogo para
474 entrada de passphrase en GNOME.
475
476 %description gnome-askpass -l pl.UTF-8
477 Ssh (Secure Shell) to program służący do logowania się na zdalną
478 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
479 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
480 pomiędzy dwoma hostami.
481
482 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
483
484 %description gnome-askpass -l pt_BR.UTF-8
485 Esse pacote contém um programa que abre uma caixa de diálogo para
486 entrada de passphrase no GNOME.
487
488 %description gnome-askpass -l ru.UTF-8
489 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
490 машину и для выполнения команд на удаленной машине.
491
492 Этот пакет содержит диалог ввода ключевой фразы для использования под
493 GNOME.
494
495 %description gnome-askpass -l uk.UTF-8
496 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
497 машини та для виконання команд на віддаленій машині.
498
499 Цей пакет містить діалог вводу ключової фрази для використання під
500 GNOME.
501
502 %package -n openldap-schema-openssh-lpk
503 Summary:        OpenSSH LDAP Public Key schema
504 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
505 Group:          Networking/Daemons
506 Requires(post,postun):  sed >= 4.0
507 Requires:       openldap-servers
508
509 %description -n openldap-schema-openssh-lpk
510 This package contains OpenSSH LDAP Public Key schema for openldap.
511
512 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
513 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
514 openldap-a.
515
516 %prep
517 %setup -q
518 %{?with_kerberos5:%patch100 -p1}
519 %patch0 -p1
520 %patch2 -p1
521 %patch3 -p1
522 %patch4 -p1
523 %patch5 -p1
524 %patch8 -p1
525 %patch6 -p1
526 %patch7 -p1
527 %{?with_hpn:%patch9 -p1}
528 %patch10 -p1
529 %patch11 -p1
530 %patch12 -p1
531 %patch13 -p1
532 %patch14 -p1
533
534 %if "%{pld_release}" == "ac"
535 # fix for missing x11.pc
536 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
537 %endif
538
539 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
540 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
541
542 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
543 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
544
545 %build
546 cp /usr/share/automake/config.sub .
547 %{__aclocal}
548 %{__autoconf}
549 %{__autoheader}
550 CPPFLAGS="-DCHROOT"
551 %configure \
552         PERL=%{__perl} \
553         --disable-strip \
554         --enable-utmpx \
555         --enable-wtmpx \
556         --with-4in6 \
557         %{?with_audit:--with-audit=linux} \
558         --with-ipaddr-display \
559         %{?with_kerberos5:--with-kerberos5=/usr} \
560         --with-ldap%{!?with_ldap:=no} \
561         %{?with_libedit:--with-libedit} \
562         --with-mantype=man \
563         --with-md5-passwords \
564         --with-pam \
565         --with-authorized-keys-command \
566         --with-pid-dir=%{_localstatedir}/run \
567         --with-privsep-path=%{_privsepdir} \
568         %{?with_selinux:--with-selinux} \
569         --with-tcp-wrappers \
570 %if "%{pld_release}" == "ac"
571         --with-xauth=/usr/X11R6/bin/xauth
572 %else
573         --with-xauth=%{_bindir}/xauth
574 %endif
575
576 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
577
578 %{__make}
579
580 %{?with_tests:%{__make} tests}
581
582 cd contrib
583 %if %{with gnome}
584 %{__make} gnome-ssh-askpass1 \
585         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
586 %endif
587 %if %{with gtk}
588 %{__make} gnome-ssh-askpass2 \
589         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
590 %endif
591
592 %install
593 rm -rf $RPM_BUILD_ROOT
594 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
595         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
596 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
597
598 %{__make} install \
599         DESTDIR=$RPM_BUILD_ROOT
600
601 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
602
603 cp -p %{SOURCE3} sshd.pam
604 install -p %{SOURCE2} sshd.init
605
606 %if "%{pld_release}" == "ac"
607 # not present in ac, no point searching it
608 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
609 # openssl on ac does not have OPENSSL_HAS_ECC
610 %{__sed} -i -e '/ecdsa/d' sshd.init
611 %endif
612
613 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
614 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
615 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
616 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
617 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
618 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
619 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
620 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
621
622 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
623 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
624
625 %if %{with gnome}
626 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
627 %endif
628 %if %{with gtk}
629 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
630 %endif
631 %if %{with gnome} || %{with gtk}
632 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
633 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
634 EOF
635 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
636 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
637 EOF
638 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
639 %endif
640
641 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
642 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
643
644 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
645 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
646
647 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
648
649 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
650 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
651 EOF
652
653 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
654 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
655
656 %clean
657 rm -rf $RPM_BUILD_ROOT
658
659 %post clients
660 %env_update
661
662 %postun clients
663 %env_update
664
665 %post gnome-askpass
666 %env_update
667
668 %postun gnome-askpass
669 %env_update
670
671 %pre server
672 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
673
674 %post server
675 /sbin/chkconfig --add sshd
676 %service sshd reload "OpenSSH Daemon"
677 if ! grep -qs ssh /etc/security/passwd.conf ; then
678         umask 022
679         echo "ssh" >> /etc/security/passwd.conf
680 fi
681 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
682 %banner %{name}-server -e << EOF
683 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
684 ! Native systemd support for sshd has been installed.   !
685 ! Restarting sshd.service with systemctl WILL kill all  !
686 ! active ssh sessions (daemon as such will be started). !
687 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
688 EOF
689 fi
690 NORESTART=1
691 %systemd_post sshd.service
692
693 %preun server
694 if [ "$1" = "0" ]; then
695         %service sshd stop
696         /sbin/chkconfig --del sshd
697 fi
698 %systemd_preun sshd.service
699
700 %postun server
701 if [ "$1" = "0" ]; then
702         %userremove sshd
703 fi
704 %systemd_reload
705
706 %triggerpostun server -- %{name}-server < 2:5.9p1-8
707 # lpk.patch to ldap.patch
708 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
709         echo >&2 "Migrating LPK patch to LDAP patch"
710         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
711         %{__sed} -i -e '
712                 # disable old configs
713                 # just UseLPK/LkpLdapConf supported for now
714                 s/^UseLPK/## Obsolete &/
715                 s/^Lpk/## Obsolete &/
716                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
717                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
718         ' %{_sysconfdir}/sshd_config
719         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
720                 /bin/systemctl try-restart sshd.service || :
721         else
722                 %service -q sshd reload
723         fi
724 fi
725 %systemd_trigger sshd.service
726
727 %post server-upstart
728 %upstart_post sshd
729
730 %postun server-upstart
731 %upstart_postun sshd
732
733 %post -n openldap-schema-openssh-lpk
734 %openldap_schema_register %{schemadir}/openssh-lpk.schema
735 %service -q ldap restart
736
737 %postun -n openldap-schema-openssh-lpk
738 if [ "$1" = "0" ]; then
739         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
740         %service -q ldap restart
741 fi
742
743 %files
744 %defattr(644,root,root,755)
745 %doc TODO README OVERVIEW CREDITS Change*
746 %attr(755,root,root) %{_bindir}/ssh-key*
747 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
748 %{_mandir}/man1/ssh-key*.1*
749 %{_mandir}/man1/ssh-vulnkey*.1*
750 %dir %{_sysconfdir}
751 %dir %{_libexecdir}
752
753 %files clients
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_bindir}/ssh
756 %attr(755,root,root) %{_bindir}/slogin
757 %attr(755,root,root) %{_bindir}/sftp
758 %attr(755,root,root) %{_bindir}/ssh-agent
759 %attr(755,root,root) %{_bindir}/ssh-add
760 %attr(755,root,root) %{_bindir}/ssh-copy-id
761 %attr(755,root,root) %{_bindir}/scp
762 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
763 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
764 %{_mandir}/man1/scp.1*
765 %{_mandir}/man1/ssh.1*
766 %{_mandir}/man1/slogin.1*
767 %{_mandir}/man1/sftp.1*
768 %{_mandir}/man1/ssh-agent.1*
769 %{_mandir}/man1/ssh-add.1*
770 %{_mandir}/man1/ssh-copy-id.1*
771 %{_mandir}/man5/ssh_config.5*
772 %lang(it) %{_mandir}/it/man1/ssh.1*
773 %lang(it) %{_mandir}/it/man5/ssh_config.5*
774 %lang(pl) %{_mandir}/pl/man1/scp.1*
775 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
776
777 # for host-based auth (suid required for accessing private host key)
778 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
779 #%{_mandir}/man8/ssh-keysign.8*
780
781 %files clients-agent-profile_d
782 %defattr(644,root,root,755)
783 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
784 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
785
786 %files clients-agent-xinitrc
787 %defattr(644,root,root,755)
788 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
789
790 %files server
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_sbindir}/sshd
793 %attr(755,root,root) %{_libexecdir}/sftp-server
794 %attr(755,root,root) %{_libexecdir}/ssh-keysign
795 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
796 %attr(755,root,root) %{_libexecdir}/sshd-keygen
797 %{_mandir}/man8/sshd.8*
798 %{_mandir}/man8/sftp-server.8*
799 %{_mandir}/man8/ssh-keysign.8*
800 %{_mandir}/man8/ssh-pkcs11-helper.8*
801 %{_mandir}/man5/sshd_config.5*
802 %{_mandir}/man5/moduli.5*
803 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
804 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
805 %attr(640,root,root) %{_sysconfdir}/moduli
806 %attr(754,root,root) /etc/rc.d/init.d/sshd
807 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
808 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
809 %{systemdunitdir}/sshd.service
810
811 %if %{with ldap}
812 %files server-ldap
813 %defattr(644,root,root,755)
814 %doc HOWTO.ldap-keys ldap.conf
815 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
816 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
817 %{_mandir}/man5/ssh-ldap.conf.5*
818 %{_mandir}/man8/ssh-ldap-helper.8*
819 %endif
820
821 %if %{with gnome} || %{with gtk}
822 %files gnome-askpass
823 %defattr(644,root,root,755)
824 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
825 %dir %{_libexecdir}/ssh
826 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
827 %attr(755,root,root) %{_libexecdir}/ssh-askpass
828 %endif
829
830 %if %{with ldap}
831 %files -n openldap-schema-openssh-lpk
832 %defattr(644,root,root,755)
833 %{schemadir}/openssh-lpk.schema
834 %endif
835
836 %if "%{pld_release}" != "ti"
837 %files server-upstart
838 %defattr(644,root,root,755)
839 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
840 %endif
This page took 0.085654 seconds and 2 git commands to generate.