]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- up to 5.9p1 (lpk patch needs update; builds --without ldap only for now)
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_without  ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13
14 %if "%{pld_release}" == "ac"
15 %define         pam_ver 0.79.0
16 %else
17 %define         pam_ver 0.99.7.1
18 %endif
19
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es.UTF-8):      Implementación libre de SSH
23 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
26 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR.UTF-8):   Implementação livre do SSH
28 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
29 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
30 Name:           openssh
31 Version:        5.9p1
32 Release:        0.1
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  b50a499fa02616a47984b1920848b565
38 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
40 Source2:        %{name}d.init
41 Source3:        %{name}d.pamd
42 Source4:        %{name}.sysconfig
43 Source5:        ssh-agent.sh
44 Source6:        ssh-agent.conf
45 Source7:        %{name}-lpk.schema
46 Source8:        %{name}d.upstart
47 Patch100:       %{name}-heimdal.patch
48 Patch0:         %{name}-no_libnsl.patch
49 Patch2:         %{name}-pam_misc.patch
50 Patch3:         %{name}-sigpipe.patch
51 # http://code.google.com/p/openssh-lpk/
52 Patch4:         %{name}-lpk.patch
53 Patch5:         %{name}-config.patch
54 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
55 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56 Patch9:         %{name}-5.2p1-hpn13v6.diff
57 Patch10:        %{name}-include.patch
58 Patch11:        %{name}-chroot.patch
59 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
60 Patch12:        %{name}-blacklist.diff
61 Patch13:        %{name}-kuserok.patch
62 URL:            http://www.openssh.com/portable.html
63 BuildRequires:  %{__perl}
64 BuildRequires:  autoconf
65 BuildRequires:  automake
66 %{?with_gnome:BuildRequires:    gnome-libs-devel}
67 %{?with_gtk:BuildRequires:      gtk+2-devel}
68 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
69 %{?with_libedit:BuildRequires:  libedit-devel}
70 %{?with_selinux:BuildRequires:  libselinux-devel}
71 BuildRequires:  libwrap-devel
72 %{?with_ldap:BuildRequires:     openldap-devel}
73 BuildRequires:  openssl-devel >= 0.9.7d
74 BuildRequires:  pam-devel
75 %{?with_gtk:BuildRequires:      pkgconfig}
76 BuildRequires:  rpm >= 4.4.9-56
77 BuildRequires:  rpmbuild(macros) >= 1.318
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  zlib-devel
80 %if "%{pld_release}" == "ac"
81 Requires:       filesystem >= 2.0-1
82 Requires:       pam >= 0.79.0
83 %else
84 Requires:       filesystem >= 3.0-11
85 Requires:       pam >= %{pam_ver}
86 Suggests:       openssh-blacklist
87 Suggests:       xorg-app-xauth
88 %endif
89 Obsoletes:      ssh
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _sysconfdir     /etc/ssh
93 %define         _libexecdir     %{_libdir}/%{name}
94 %define         _privsepdir     /usr/share/empty
95 %define         schemadir       /usr/share/openldap/schema
96
97 %description
98 Ssh (Secure Shell) a program for logging into a remote machine and for
99 executing commands in a remote machine. It is intended to replace
100 rlogin and rsh, and provide secure encrypted communications between
101 two untrusted hosts over an insecure network. X11 connections and
102 arbitrary TCP/IP ports can also be forwarded over the secure channel.
103
104 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
105 it up to date in terms of security and features, as well as removing
106 all patented algorithms to seperate libraries (OpenSSL).
107
108 This package includes the core files necessary for both the OpenSSH
109 client and server. To make this package useful, you should also
110 install openssh-clients, openssh-server, or both.
111
112 %if %{with hpn}
113 This release includes High Performance SSH/SCP patches from
114 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
115 increase throughput on fast connections with high RTT (20-150 msec).
116 See the website for '-w' values for your connection and /proc/sys TCP
117 values. BTW. in a LAN you have got generally RTT < 1 msec.
118 %endif
119
120 %description -l de.UTF-8
121 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
122 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
123 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
124 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
125 andere TCP/IP Ports können ebenso über den sicheren Channel
126 weitergeleitet werden.
127
128 %description -l es.UTF-8
129 SSH es un programa para accesar y ejecutar órdenes en computadores
130 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
131 seguro entre dos servidores en una red insegura. Conexiones X11 y
132 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
133 seguro.
134
135 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
136 continuar la última versión gratuita de SSH, actualizándolo en
137 términos de seguridad y recursos,así también eliminando todos los
138 algoritmos patentados y colocándolos en bibliotecas separadas
139 (OpenSSL).
140
141 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
142 también el paquete openssh-clients u openssh-server o ambos.
143
144 %description -l fr.UTF-8
145 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
146 remplace telnet, rlogin, rexec et rsh, tout en assurant des
147 communications cryptées securisées entre deux hôtes non fiabilisés sur
148 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
149 arbitraires peuvent également être transmis sur le canal sécurisé.
150
151 %description -l it.UTF-8
152 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
153 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
154 sicure e crittate tra due host non fidati su una rete non sicura. Le
155 connessioni X11 ad una porta TCP/IP arbitraria possono essere
156 inoltrate attraverso un canale sicuro.
157
158 %description -l pl.UTF-8
159 Ssh (Secure Shell) to program służący do logowania się na zdalną
160 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
161 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
162 pomiędzy dwoma hostami.
163
164 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
165 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
166 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
167
168 %if %{with hpn}
169 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
170 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
171 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
172 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
173 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
174 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
175 %endif
176
177 %description -l pt.UTF-8
178 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
179 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
180 cifradas entre duas máquinas sem confiança mútua sobre uma rede
181 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
182 reenviados pelo canal seguro.
183
184 %description -l pt_BR.UTF-8
185 SSH é um programa para acessar e executar comandos em máquinas
186 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
187 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
188 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
189
190 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
191 última versão gratuita do SSH, atualizando-o em termos de segurança e
192 recursos, assim como removendo todos os algoritmos patenteados e
193 colocando-os em bibliotecas separadas (OpenSSL).
194
195 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
196 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
197
198 %description -l ru.UTF-8
199 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
200 машину и для выполнения команд на удаленной машине. Она предназначена
201 для замены rlogin и rsh и обеспечивает безопасную шифрованную
202 коммуникацию между двумя хостами в сети, являющейся небезопасной.
203 Соединения X11 и любые порты TCP/IP могут также быть проведены через
204 безопасный канал.
205
206 OpenSSH - это переделка командой разработчиков OpenBSD последней
207 свободной версии SSH, доведенная до современного состояния в терминах
208 уровня безопасности и поддерживаемых возможностей. Все патентованные
209 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
210
211 Этот пакет содержит файлы, необходимые как для клиента, так и для
212 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
213 openssh-server, или оба пакета.
214
215 %description -l uk.UTF-8
216 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
217 машини та для виконання команд на віддаленій машині. Вона призначена
218 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
219 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
220 довільні порти TCP/IP можуть також бути проведені через безпечний
221 канал.
222
223 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
224 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
225 підтримуваних можливостей. Всі патентовані алгоритми винесені до
226 окремих бібліотек (OpenSSL).
227
228 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
229 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
230 openssh-server, чи обидва пакети.
231
232 %package clients
233 Summary:        OpenSSH Secure Shell protocol clients
234 Summary(es.UTF-8):      Clientes de OpenSSH
235 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
236 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
237 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
238 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
239 Group:          Applications/Networking
240 Requires:       %{name}
241 Provides:       ssh-clients
242 Obsoletes:      ssh-clients
243
244 %description clients
245 Ssh (Secure Shell) a program for logging into a remote machine and for
246 executing commands in a remote machine. It is intended to replace
247 rlogin and rsh, and provide secure encrypted communications between
248 two untrusted hosts over an insecure network. X11 connections and
249 arbitrary TCP/IP ports can also be forwarded over the secure channel.
250
251 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
252 it up to date in terms of security and features, as well as removing
253 all patented algorithms to seperate libraries (OpenSSL).
254
255 This package includes the clients necessary to make encrypted
256 connections to SSH servers.
257
258 %description clients -l es.UTF-8
259 Este paquete incluye los clientes que se necesitan para hacer
260 conexiones codificadas con servidores SSH.
261
262 %description clients -l pl.UTF-8
263 Ssh (Secure Shell) to program służący do logowania się na zdalną
264 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
265 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
266 pomiędzy dwoma hostami.
267
268 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
269
270 %description clients -l pt_BR.UTF-8
271 Esse pacote inclui os clientes necessários para fazer conexões
272 encriptadas com servidores SSH.
273
274 %description clients -l ru.UTF-8
275 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
276 машину и для выполнения команд на удаленной машине.
277
278 Этот пакет содержит программы-клиенты, необходимые для установления
279 зашифрованных соединений с серверами SSH.
280
281 %description clients -l uk.UTF-8
282 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
283 машини та для виконання команд на віддаленій машині.
284
285 Цей пакет містить програми-клієнти, необхідні для встановлення
286 зашифрованих з'єднань з серверами SSH.
287
288 %package clients-agent-profile_d
289 Summary:        OpenSSH Secure Shell agent init script
290 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
291 Group:          Applications/Networking
292 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
293
294 %description clients-agent-profile_d
295 profile.d scripts for starting SSH agent.
296
297 %description clients-agent-profile_d -l pl.UTF-8
298 Skrypty profile.d do uruchamiania agenta SSH.
299
300 %package clients-agent-xinitrc
301 Summary:        OpenSSH Secure Shell agent init script
302 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
303 Group:          Applications/Networking
304 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
305 Requires:       xinitrc
306
307 %description clients-agent-xinitrc
308 xinitrc scripts for starting SSH agent.
309
310 %description clients-agent-xinitrc -l pl.UTF-8
311 Skrypty xinitrc do uruchamiania agenta SSH.
312
313 %package server
314 Summary:        OpenSSH Secure Shell protocol server (sshd)
315 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
316 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
317 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
318 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
319 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
320 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
321 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
322 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
323 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
324 Group:          Networking/Daemons
325 Requires(post): /sbin/chkconfig
326 Requires(post): grep
327 Requires(post,preun):   /sbin/chkconfig
328 Requires(postun):       /usr/sbin/userdel
329 Requires(pre):  /bin/id
330 Requires(pre):  /usr/sbin/useradd
331 Requires:       %{name} = %{epoch}:%{version}-%{release}
332 Requires:       pam >= %{pam_ver}
333 Requires:       rc-scripts >= 0.4.3.0
334 Requires:       util-linux
335 Suggests:       /bin/login
336 Provides:       ssh-server
337 Provides:       user(sshd)
338
339 %description server
340 Ssh (Secure Shell) a program for logging into a remote machine and for
341 executing commands in a remote machine. It is intended to replace
342 rlogin and rsh, and provide secure encrypted communications between
343 two untrusted hosts over an insecure network. X11 connections and
344 arbitrary TCP/IP ports can also be forwarded over the secure channel.
345
346 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
347 it up to date in terms of security and features, as well as removing
348 all patented algorithms to seperate libraries (OpenSSL).
349
350 This package contains the secure shell daemon. The sshd is the server
351 part of the secure shell protocol and allows ssh clients to connect to
352 your host.
353
354 %description server -l de.UTF-8
355 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
356
357 %description server -l es.UTF-8
358 Este paquete contiene el servidor SSH. sshd es la parte servidor del
359 protocolo secure shell y permite que clientes ssh se conecten a su
360 servidor.
361
362 %description server -l fr.UTF-8
363 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
364
365 %description server -l it.UTF-8
366 Questo pacchetto installa sshd, il server di OpenSSH.
367
368 %description server -l pl.UTF-8
369 Ssh (Secure Shell) to program służący do logowania się na zdalną
370 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
371 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
372 pomiędzy dwoma hostami.
373
374 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
375 ssh).
376
377 %description server -l pt.UTF-8
378 Este pacote intala o sshd, o servidor do OpenSSH.
379
380 %description server -l pt_BR.UTF-8
381 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
382 protocolo secure shell e permite que clientes ssh se conectem ao seu
383 host.
384
385 %description server -l ru.UTF-8
386 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
387 машину и для выполнения команд на удаленной машине.
388
389 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
390 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
391 вашим хостом.
392
393 %description server -l uk.UTF-8
394 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
395 машини та для виконання команд на віддаленій машині.
396
397 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
398 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
399 з вашим хостом.
400
401 %package server-upstart
402 Summary:        Upstart job description for OpenSSH server
403 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
404 Group:          Daemons
405 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
406 Requires:       upstart >= 0.6
407 Conflicts:      syslog-ng < 3.2.4-1
408
409 %description server-upstart
410 Upstart job description for OpenSSH.
411
412 %description server-upstart -l pl.UTF-8
413 Opis zadania Upstart dla OpenSSH.
414
415 %package gnome-askpass
416 Summary:        OpenSSH GNOME passphrase dialog
417 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
418 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
419 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
420 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
421 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
422 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
423 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
424 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
425 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
426 Group:          Applications/Networking
427 Requires:       %{name} = %{epoch}:%{version}-%{release}
428 Obsoletes:      openssh-askpass
429 Obsoletes:      ssh-askpass
430 Obsoletes:      ssh-extras
431
432 %description gnome-askpass
433 Ssh (Secure Shell) a program for logging into a remote machine and for
434 executing commands in a remote machine. It is intended to replace
435 rlogin and rsh, and provide secure encrypted communications between
436 two untrusted hosts over an insecure network. X11 connections and
437 arbitrary TCP/IP ports can also be forwarded over the secure channel.
438
439 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
440 it up to date in terms of security and features, as well as removing
441 all patented algorithms to seperate libraries (OpenSSL).
442
443 This package contains the GNOME passphrase dialog.
444
445 %description gnome-askpass -l es.UTF-8
446 Este paquete contiene un programa que abre una caja de diálogo para
447 entrada de passphrase en GNOME.
448
449 %description gnome-askpass -l pl.UTF-8
450 Ssh (Secure Shell) to program służący do logowania się na zdalną
451 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
452 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
453 pomiędzy dwoma hostami.
454
455 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
456
457 %description gnome-askpass -l pt_BR.UTF-8
458 Esse pacote contém um programa que abre uma caixa de diálogo para
459 entrada de passphrase no GNOME.
460
461 %description gnome-askpass -l ru.UTF-8
462 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
463 машину и для выполнения команд на удаленной машине.
464
465 Этот пакет содержит диалог ввода ключевой фразы для использования под
466 GNOME.
467
468 %description gnome-askpass -l uk.UTF-8
469 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
470 машини та для виконання команд на віддаленій машині.
471
472 Цей пакет містить діалог вводу ключової фрази для використання під
473 GNOME.
474
475 %package -n openldap-schema-openssh-lpk
476 Summary:        OpenSSH LDAP Public Key schema
477 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
478 Group:          Networking/Daemons
479 Requires(post,postun):  sed >= 4.0
480 Requires:       openldap-servers
481
482 %description -n openldap-schema-openssh-lpk
483 This package contains OpenSSH LDAP Public Key schema for openldap.
484
485 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
486 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
487 openldap-a.
488
489 %prep
490 %setup -q
491 %{?with_kerberos5:%patch100 -p1}
492 %patch0 -p1
493 %patch2 -p1
494 %patch3 -p1
495 %{?with_ldap:%patch4 -p1}
496 %patch5 -p1
497 %{?with_hpn:%patch9 -p1}
498 %patch10 -p1
499 %patch11 -p1
500 %patch12 -p1
501 %patch13 -p1
502
503 cp -p %{SOURCE3} sshd.pam
504 install -p %{SOURCE2} sshd.init
505
506 %if "%{pld_release}" == "ac"
507 # fix for missing x11.pc
508 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
509 # not present in ac, no point searching it
510 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
511
512 # openssl on ac does not have OPENSSL_HAS_ECC
513 %{__sed} -i -e '/ecdsa/d' sshd.init
514 %endif
515
516 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
517 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
518
519 %build
520 cp /usr/share/automake/config.sub .
521 %{__aclocal}
522 %{__autoconf}
523 CPPFLAGS="-DCHROOT"
524 %configure \
525         PERL=%{__perl} \
526         --with-pam \
527         --with-mantype=man \
528         --with-md5-passwords \
529         --with-ipaddr-display \
530         %{?with_libedit:--with-libedit} \
531         --with-4in6 \
532         --with-tcp-wrappers \
533         %{?with_ldap:--with-libs="-lldap -llber"} \
534         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
535         %{?with_kerberos5:--with-kerberos5=/usr} \
536         --with-privsep-path=%{_privsepdir} \
537         --with-pid-dir=%{_localstatedir}/run \
538 %if "%{pld_release}" == "ac"
539         --with-xauth=/usr/X11R6/bin/xauth \
540 %else
541         --with-xauth=%{_bindir}/xauth \
542 %endif
543         --enable-utmpx \
544         --enable-wtmpx
545
546 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
547
548 %{__make}
549
550 cd contrib
551 %if %{with gnome}
552 %{__make} gnome-ssh-askpass1 \
553         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
554 %endif
555 %if %{with gtk}
556 %{__make} gnome-ssh-askpass2 \
557         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
558 %endif
559
560 %install
561 rm -rf $RPM_BUILD_ROOT
562 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
563         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
564 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
565
566 %{__make} install \
567         DESTDIR=$RPM_BUILD_ROOT
568
569 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
570
571 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
572 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
573 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
574 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
575 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
576 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
577 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
578 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
579
580 %if %{with gnome}
581 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
582 %endif
583 %if %{with gtk}
584 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
585 %endif
586 %if %{with gnome} || %{with gtk}
587 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
588 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
589 EOF
590 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
591 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
592 EOF
593 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
594 %endif
595
596 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
597 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
598
599 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
600 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
601
602 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
603
604 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
605 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
606 EOF
607
608 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
609 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
610
611 %clean
612 rm -rf $RPM_BUILD_ROOT
613
614 %post clients
615 %env_update
616
617 %postun clients
618 %env_update
619
620 %post gnome-askpass
621 %env_update
622
623 %postun gnome-askpass
624 %env_update
625
626 %pre server
627 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
628
629 %post server
630 /sbin/chkconfig --add sshd
631 %service sshd reload "openssh daemon"
632 if ! grep -qs ssh /etc/security/passwd.conf ; then
633         umask 022
634         echo "ssh" >> /etc/security/passwd.conf
635 fi
636
637 %preun server
638 if [ "$1" = "0" ]; then
639         %service sshd stop
640         /sbin/chkconfig --del sshd
641 fi
642
643 %postun server
644 if [ "$1" = "0" ]; then
645         %userremove sshd
646 fi
647
648 %post server-upstart
649 %upstart_post sshd
650
651 %postun server-upstart
652 %upstart_postun sshd
653
654 %post -n openldap-schema-openssh-lpk
655 %openldap_schema_register %{schemadir}/openssh-lpk.schema
656 %service -q ldap restart
657
658 %postun -n openldap-schema-openssh-lpk
659 if [ "$1" = "0" ]; then
660         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
661         %service -q ldap restart
662 fi
663
664 %files
665 %defattr(644,root,root,755)
666 %doc TODO README OVERVIEW CREDITS Change*
667 %attr(755,root,root) %{_bindir}/ssh-key*
668 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
669 %{_mandir}/man1/ssh-key*.1*
670 %{_mandir}/man1/ssh-vulnkey*.1*
671 %dir %{_sysconfdir}
672 %dir %{_libexecdir}
673
674 %files clients
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/ssh
677 %attr(755,root,root) %{_bindir}/slogin
678 %attr(755,root,root) %{_bindir}/sftp
679 %attr(755,root,root) %{_bindir}/ssh-agent
680 %attr(755,root,root) %{_bindir}/ssh-add
681 %attr(755,root,root) %{_bindir}/ssh-copy-id
682 %attr(755,root,root) %{_bindir}/scp
683 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
684 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
685 %{_mandir}/man1/scp.1*
686 %{_mandir}/man1/ssh.1*
687 %{_mandir}/man1/slogin.1*
688 %{_mandir}/man1/sftp.1*
689 %{_mandir}/man1/ssh-agent.1*
690 %{_mandir}/man1/ssh-add.1*
691 %{_mandir}/man1/ssh-copy-id.1*
692 %{_mandir}/man5/ssh_config.5*
693 %lang(it) %{_mandir}/it/man1/ssh.1*
694 %lang(it) %{_mandir}/it/man5/ssh_config.5*
695 %lang(pl) %{_mandir}/pl/man1/scp.1*
696 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
697
698 # for host-based auth (suid required for accessing private host key)
699 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
700 #%{_mandir}/man8/ssh-keysign.8*
701
702 %files clients-agent-profile_d
703 %defattr(644,root,root,755)
704 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
705 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
706
707 %files clients-agent-xinitrc
708 %defattr(644,root,root,755)
709 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
710
711 %files server
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_sbindir}/sshd
714 %attr(755,root,root) %{_libexecdir}/sftp-server
715 %attr(755,root,root) %{_libexecdir}/ssh-keysign
716 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
717 %{_mandir}/man8/sshd.8*
718 %{_mandir}/man8/sftp-server.8*
719 %{_mandir}/man8/ssh-keysign.8*
720 %{_mandir}/man8/ssh-pkcs11-helper.8*
721 %{_mandir}/man5/sshd_config.5*
722 %{_mandir}/man5/moduli.5*
723 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
724 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
725 %attr(640,root,root) %{_sysconfdir}/moduli
726 %attr(754,root,root) /etc/rc.d/init.d/sshd
727 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
728 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
729
730 %if %{with gnome} || %{with gtk}
731 %files gnome-askpass
732 %defattr(644,root,root,755)
733 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
734 %dir %{_libexecdir}/ssh
735 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
736 %attr(755,root,root) %{_libexecdir}/ssh-askpass
737 %endif
738
739 %if %{with ldap}
740 %files -n openldap-schema-openssh-lpk
741 %defattr(644,root,root,755)
742 %{schemadir}/openssh-lpk.schema
743 %endif
744
745 %if "%{pld_release}" != "ti"
746 %files server-upstart
747 %defattr(644,root,root,755)
748 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
749 %endif
This page took 0.089873 seconds and 3 git commands to generate.