]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
same problem with server too:
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15 %bcond_without  tests
16
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19
20 %if "%{pld_release}" == "ac"
21 %define         pam_ver 0.79.0
22 %else
23 %define         pam_ver 1:1.1.5-5
24 %endif
25
26 Summary:        OpenSSH free Secure Shell (SSH) implementation
27 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
28 Summary(es.UTF-8):      Implementación libre de SSH
29 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
30 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
31 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
32 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
33 Summary(pt_BR.UTF-8):   Implementação livre do SSH
34 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
35 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
36 Name:           openssh
37 Version:        6.2p2
38 Release:        3
39 Epoch:          2
40 License:        BSD
41 Group:          Applications/Networking
42 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
43 # Source0-md5:  be46174dcbb77ebb4ea88ef140685de1
44 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
46 Source2:        %{name}d.init
47 Source3:        %{name}d.pamd
48 Source4:        %{name}.sysconfig
49 Source5:        ssh-agent.sh
50 Source6:        ssh-agent.conf
51 Source7:        %{name}-lpk.schema
52 Source8:        %{name}d.upstart
53 Source9:        sshd.service
54 Source10:       sshd-keygen
55 Source11:       sshd.socket
56 Source12:       sshd@.service
57 Patch100:       %{name}-heimdal.patch
58 Patch0:         %{name}-no_libnsl.patch
59 Patch2:         %{name}-pam_misc.patch
60 Patch3:         %{name}-sigpipe.patch
61 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
62 Patch4:         %{name}-5.9p1-ldap.patch
63 Patch5:         %{name}-5.9p1-ldap-fixes.patch
64 Patch8:         ldap.conf.patch
65 Patch6:         %{name}-config.patch
66
67 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
68 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
69 Patch9:         %{name}-5.2p1-hpn13v6.diff
70 Patch10:        %{name}-include.patch
71 Patch11:        %{name}-chroot.patch
72 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
73 Patch12:        %{name}-blacklist.diff
74 Patch13:        %{name}-kuserok.patch
75 Patch14:        %{name}-bind.patch
76 Patch15:        %{name}-disable_ldap.patch
77 URL:            http://www.openssh.com/portable.html
78 BuildRequires:  %{__perl}
79 %{?with_tests:BuildRequires:    %{name}-server}
80 %{?with_audit:BuildRequires:    audit-libs-devel}
81 BuildRequires:  autoconf >= 2.50
82 BuildRequires:  automake
83 %{?with_gnome:BuildRequires:    gnome-libs-devel}
84 %{?with_gtk:BuildRequires:      gtk+2-devel}
85 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
86 %{?with_libedit:BuildRequires:  libedit-devel}
87 %{?with_selinux:BuildRequires:  libselinux-devel}
88 BuildRequires:  libwrap-devel
89 %{?with_ldap:BuildRequires:     openldap-devel}
90 BuildRequires:  openssl-devel >= 0.9.7d
91 BuildRequires:  pam-devel
92 %{?with_gtk:BuildRequires:      pkgconfig}
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.627
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  zlib-devel >= 1.2.3
97 Requires:       zlib >= 1.2.3
98 %if "%{pld_release}" == "ac"
99 Requires:       filesystem >= 2.0-1
100 Requires:       pam >= 0.79.0
101 %else
102 Requires:       filesystem >= 3.0-11
103 Requires:       pam >= %{pam_ver}
104 Suggests:       openssh-blacklist
105 Suggests:       xorg-app-xauth
106 %endif
107 Obsoletes:      ssh
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define         _sysconfdir     /etc/ssh
111 %define         _libexecdir     %{_libdir}/%{name}
112 %define         _privsepdir     /usr/share/empty
113 %define         schemadir       /usr/share/openldap/schema
114
115 %description
116 Ssh (Secure Shell) a program for logging into a remote machine and for
117 executing commands in a remote machine. It is intended to replace
118 rlogin and rsh, and provide secure encrypted communications between
119 two untrusted hosts over an insecure network. X11 connections and
120 arbitrary TCP/IP ports can also be forwarded over the secure channel.
121
122 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
123 it up to date in terms of security and features, as well as removing
124 all patented algorithms to seperate libraries (OpenSSL).
125
126 This package includes the core files necessary for both the OpenSSH
127 client and server. To make this package useful, you should also
128 install openssh-clients, openssh-server, or both.
129
130 %if %{with hpn}
131 This release includes High Performance SSH/SCP patches from
132 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
133 increase throughput on fast connections with high RTT (20-150 msec).
134 See the website for '-w' values for your connection and /proc/sys TCP
135 values. BTW. in a LAN you have got generally RTT < 1 msec.
136 %endif
137
138 %description -l de.UTF-8
139 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
140 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
141 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
142 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
143 andere TCP/IP Ports können ebenso über den sicheren Channel
144 weitergeleitet werden.
145
146 %description -l es.UTF-8
147 SSH es un programa para accesar y ejecutar órdenes en computadores
148 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
149 seguro entre dos servidores en una red insegura. Conexiones X11 y
150 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
151 seguro.
152
153 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
154 continuar la última versión gratuita de SSH, actualizándolo en
155 términos de seguridad y recursos,así también eliminando todos los
156 algoritmos patentados y colocándolos en bibliotecas separadas
157 (OpenSSL).
158
159 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
160 también el paquete openssh-clients u openssh-server o ambos.
161
162 %description -l fr.UTF-8
163 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
164 remplace telnet, rlogin, rexec et rsh, tout en assurant des
165 communications cryptées securisées entre deux hôtes non fiabilisés sur
166 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
167 arbitraires peuvent également être transmis sur le canal sécurisé.
168
169 %description -l it.UTF-8
170 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
171 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
172 sicure e crittate tra due host non fidati su una rete non sicura. Le
173 connessioni X11 ad una porta TCP/IP arbitraria possono essere
174 inoltrate attraverso un canale sicuro.
175
176 %description -l pl.UTF-8
177 Ssh (Secure Shell) to program służący do logowania się na zdalną
178 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
179 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
180 pomiędzy dwoma hostami.
181
182 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
183 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
184 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
185
186 %if %{with hpn}
187 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
188 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
189 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
190 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
191 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
192 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
193 %endif
194
195 %description -l pt.UTF-8
196 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
197 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
198 cifradas entre duas máquinas sem confiança mútua sobre uma rede
199 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
200 reenviados pelo canal seguro.
201
202 %description -l pt_BR.UTF-8
203 SSH é um programa para acessar e executar comandos em máquinas
204 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
205 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
206 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
207
208 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
209 última versão gratuita do SSH, atualizando-o em termos de segurança e
210 recursos, assim como removendo todos os algoritmos patenteados e
211 colocando-os em bibliotecas separadas (OpenSSL).
212
213 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
214 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
215
216 %description -l ru.UTF-8
217 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
218 машину и для выполнения команд на удаленной машине. Она предназначена
219 для замены rlogin и rsh и обеспечивает безопасную шифрованную
220 коммуникацию между двумя хостами в сети, являющейся небезопасной.
221 Соединения X11 и любые порты TCP/IP могут также быть проведены через
222 безопасный канал.
223
224 OpenSSH - это переделка командой разработчиков OpenBSD последней
225 свободной версии SSH, доведенная до современного состояния в терминах
226 уровня безопасности и поддерживаемых возможностей. Все патентованные
227 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
228
229 Этот пакет содержит файлы, необходимые как для клиента, так и для
230 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
231 openssh-server, или оба пакета.
232
233 %description -l uk.UTF-8
234 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
235 машини та для виконання команд на віддаленій машині. Вона призначена
236 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
237 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
238 довільні порти TCP/IP можуть також бути проведені через безпечний
239 канал.
240
241 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
242 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
243 підтримуваних можливостей. Всі патентовані алгоритми винесені до
244 окремих бібліотек (OpenSSL).
245
246 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
247 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
248 openssh-server, чи обидва пакети.
249
250 %package clients
251 Summary:        OpenSSH Secure Shell protocol clients
252 Summary(es.UTF-8):      Clientes de OpenSSH
253 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
254 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
255 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
256 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
257 Group:          Applications/Networking
258 Requires:       %{name}
259 Provides:       ssh-clients
260 Obsoletes:      ssh-clients
261 %requires_eq_to openssl openssl-devel
262
263 %description clients
264 Ssh (Secure Shell) a program for logging into a remote machine and for
265 executing commands in a remote machine. It is intended to replace
266 rlogin and rsh, and provide secure encrypted communications between
267 two untrusted hosts over an insecure network. X11 connections and
268 arbitrary TCP/IP ports can also be forwarded over the secure channel.
269
270 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
271 it up to date in terms of security and features, as well as removing
272 all patented algorithms to seperate libraries (OpenSSL).
273
274 This package includes the clients necessary to make encrypted
275 connections to SSH servers.
276
277 %description clients -l es.UTF-8
278 Este paquete incluye los clientes que se necesitan para hacer
279 conexiones codificadas con servidores SSH.
280
281 %description clients -l pl.UTF-8
282 Ssh (Secure Shell) to program służący do logowania się na zdalną
283 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
284 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
285 pomiędzy dwoma hostami.
286
287 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
288
289 %description clients -l pt_BR.UTF-8
290 Esse pacote inclui os clientes necessários para fazer conexões
291 encriptadas com servidores SSH.
292
293 %description clients -l ru.UTF-8
294 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
295 машину и для выполнения команд на удаленной машине.
296
297 Этот пакет содержит программы-клиенты, необходимые для установления
298 зашифрованных соединений с серверами SSH.
299
300 %description clients -l uk.UTF-8
301 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
302 машини та для виконання команд на віддаленій машині.
303
304 Цей пакет містить програми-клієнти, необхідні для встановлення
305 зашифрованих з'єднань з серверами SSH.
306
307 %package clients-agent-profile_d
308 Summary:        OpenSSH Secure Shell agent init script
309 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
310 Group:          Applications/Networking
311 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
312
313 %description clients-agent-profile_d
314 profile.d scripts for starting SSH agent.
315
316 %description clients-agent-profile_d -l pl.UTF-8
317 Skrypty profile.d do uruchamiania agenta SSH.
318
319 %package clients-agent-xinitrc
320 Summary:        OpenSSH Secure Shell agent init script
321 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
322 Group:          Applications/Networking
323 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
324 Requires:       xinitrc
325
326 %description clients-agent-xinitrc
327 xinitrc scripts for starting SSH agent.
328
329 %description clients-agent-xinitrc -l pl.UTF-8
330 Skrypty xinitrc do uruchamiania agenta SSH.
331
332 %package server
333 Summary:        OpenSSH Secure Shell protocol server (sshd)
334 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
335 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
336 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
337 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
338 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
339 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
340 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
341 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
342 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
343 Group:          Networking/Daemons
344 Requires(post): /sbin/chkconfig
345 Requires(post): grep
346 Requires(post,preun):   /sbin/chkconfig
347 Requires(postun):       /usr/sbin/userdel
348 Requires(pre):  /bin/id
349 Requires(pre):  /usr/sbin/useradd
350 Requires(post,preun,postun):    systemd-units >= 38
351 Requires:       %{name} = %{epoch}:%{version}-%{release}
352 # remove in 6.0, kept for flawless upgrade
353 %{?with_ldap:Requires:  %{name}-server-ldap = %{epoch}:%{version}-%{release}}
354 Requires:       pam >= %{pam_ver}
355 Requires:       rc-scripts >= 0.4.3.0
356 Requires:       systemd-units >= 38
357 Requires:       util-linux
358 Suggests:       /bin/login
359 Suggests:       xorg-app-xauth
360 Provides:       ssh-server
361 Provides:       user(sshd)
362 %requires_eq_to openssl openssl-devel
363
364 %description server
365 Ssh (Secure Shell) a program for logging into a remote machine and for
366 executing commands in a remote machine. It is intended to replace
367 rlogin and rsh, and provide secure encrypted communications between
368 two untrusted hosts over an insecure network. X11 connections and
369 arbitrary TCP/IP ports can also be forwarded over the secure channel.
370
371 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
372 it up to date in terms of security and features, as well as removing
373 all patented algorithms to seperate libraries (OpenSSL).
374
375 This package contains the secure shell daemon. The sshd is the server
376 part of the secure shell protocol and allows ssh clients to connect to
377 your host.
378
379 %description server -l de.UTF-8
380 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
381
382 %description server -l es.UTF-8
383 Este paquete contiene el servidor SSH. sshd es la parte servidor del
384 protocolo secure shell y permite que clientes ssh se conecten a su
385 servidor.
386
387 %description server -l fr.UTF-8
388 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
389
390 %description server -l it.UTF-8
391 Questo pacchetto installa sshd, il server di OpenSSH.
392
393 %description server -l pl.UTF-8
394 Ssh (Secure Shell) to program służący do logowania się na zdalną
395 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
396 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
397 pomiędzy dwoma hostami.
398
399 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
400 ssh).
401
402 %description server -l pt.UTF-8
403 Este pacote intala o sshd, o servidor do OpenSSH.
404
405 %description server -l pt_BR.UTF-8
406 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
407 protocolo secure shell e permite que clientes ssh se conectem ao seu
408 host.
409
410 %description server -l ru.UTF-8
411 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
412 машину и для выполнения команд на удаленной машине.
413
414 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
415 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
416 вашим хостом.
417
418 %description server -l uk.UTF-8
419 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
420 машини та для виконання команд на віддаленій машині.
421
422 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
423 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
424 з вашим хостом.
425
426 %package server-ldap
427 Summary:        A LDAP support for open source SSH server daemon
428 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
429 Group:          Daemons
430 Requires:       %{name} = %{epoch}:%{version}-%{release}
431
432 %description server-ldap
433 OpenSSH LDAP backend is a way how to distribute the authorized tokens
434 among the servers in the network.
435
436 %description server-ldap -l pl.UTF-8
437 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
438 tokenów między serwerami w sieci.
439
440 %package server-upstart
441 Summary:        Upstart job description for OpenSSH server
442 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
443 Group:          Daemons
444 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
445 Requires:       upstart >= 0.6
446 Conflicts:      syslog-ng < 3.2.4-1
447
448 %description server-upstart
449 Upstart job description for OpenSSH.
450
451 %description server-upstart -l pl.UTF-8
452 Opis zadania Upstart dla OpenSSH.
453
454 %package gnome-askpass
455 Summary:        OpenSSH GNOME passphrase dialog
456 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
457 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
458 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
459 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
460 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
461 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
462 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
463 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
464 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
465 Group:          Applications/Networking
466 Requires:       %{name} = %{epoch}:%{version}-%{release}
467 Obsoletes:      openssh-askpass
468 Obsoletes:      ssh-askpass
469 Obsoletes:      ssh-extras
470
471 %description gnome-askpass
472 Ssh (Secure Shell) a program for logging into a remote machine and for
473 executing commands in a remote machine. It is intended to replace
474 rlogin and rsh, and provide secure encrypted communications between
475 two untrusted hosts over an insecure network. X11 connections and
476 arbitrary TCP/IP ports can also be forwarded over the secure channel.
477
478 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
479 it up to date in terms of security and features, as well as removing
480 all patented algorithms to seperate libraries (OpenSSL).
481
482 This package contains the GNOME passphrase dialog.
483
484 %description gnome-askpass -l es.UTF-8
485 Este paquete contiene un programa que abre una caja de diálogo para
486 entrada de passphrase en GNOME.
487
488 %description gnome-askpass -l pl.UTF-8
489 Ssh (Secure Shell) to program służący do logowania się na zdalną
490 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
491 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
492 pomiędzy dwoma hostami.
493
494 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
495
496 %description gnome-askpass -l pt_BR.UTF-8
497 Esse pacote contém um programa que abre uma caixa de diálogo para
498 entrada de passphrase no GNOME.
499
500 %description gnome-askpass -l ru.UTF-8
501 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
502 машину и для выполнения команд на удаленной машине.
503
504 Этот пакет содержит диалог ввода ключевой фразы для использования под
505 GNOME.
506
507 %description gnome-askpass -l uk.UTF-8
508 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
509 машини та для виконання команд на віддаленій машині.
510
511 Цей пакет містить діалог вводу ключової фрази для використання під
512 GNOME.
513
514 %package -n openldap-schema-openssh-lpk
515 Summary:        OpenSSH LDAP Public Key schema
516 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
517 Group:          Networking/Daemons
518 Requires(post,postun):  sed >= 4.0
519 Requires:       openldap-servers
520
521 %description -n openldap-schema-openssh-lpk
522 This package contains OpenSSH LDAP Public Key schema for openldap.
523
524 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
525 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
526 openldap-a.
527
528 %prep
529 %setup -q
530 %{?with_kerberos5:%patch100 -p1}
531 %patch0 -p1
532 %patch2 -p1
533 %patch3 -p1
534 %patch4 -p1
535 %patch5 -p1
536 %patch8 -p1
537 %patch6 -p1
538
539 %{?with_hpn:%patch9 -p1}
540 %patch10 -p1
541 %patch11 -p1
542 %patch12 -p1
543 %patch13 -p1
544 %patch14 -p1
545 %{!?with_ldap:%patch15 -p1}
546
547 %if "%{pld_release}" == "ac"
548 # fix for missing x11.pc
549 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
550 %endif
551
552 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
553 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
554
555 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
556 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
557
558 %build
559 cp /usr/share/automake/config.sub .
560 %{__aclocal}
561 %{__autoconf}
562 %{__autoheader}
563 CPPFLAGS="-DCHROOT"
564 %configure \
565         PERL=%{__perl} \
566         --disable-strip \
567         --enable-utmpx \
568         --enable-wtmpx \
569         --with-4in6 \
570         %{?with_audit:--with-audit=linux} \
571         --with-ipaddr-display \
572         %{?with_kerberos5:--with-kerberos5=/usr} \
573         --with-ldap%{!?with_ldap:=no} \
574         %{?with_libedit:--with-libedit} \
575         --with-mantype=man \
576         --with-md5-passwords \
577         --with-pam \
578         --with-pid-dir=%{_localstatedir}/run \
579         --with-privsep-path=%{_privsepdir} \
580         --with-sandbox=seccomp_filter \
581         %{?with_selinux:--with-selinux} \
582         --with-tcp-wrappers \
583 %if "%{pld_release}" == "ac"
584         --with-xauth=/usr/X11R6/bin/xauth
585 %else
586         --with-xauth=%{_bindir}/xauth
587 %endif
588
589 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
590
591 %{__make}
592
593 %{?with_tests:%{__make} tests}
594
595 cd contrib
596 %if %{with gnome}
597 %{__make} gnome-ssh-askpass1 \
598         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
599 %endif
600 %if %{with gtk}
601 %{__make} gnome-ssh-askpass2 \
602         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
603 %endif
604
605 %install
606 rm -rf $RPM_BUILD_ROOT
607 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
608         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
609 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
610
611 %{__make} install \
612         DESTDIR=$RPM_BUILD_ROOT
613
614 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
615
616 cp -p %{SOURCE3} sshd.pam
617 install -p %{SOURCE2} sshd.init
618
619 %if "%{pld_release}" == "ac"
620 # not present in ac, no point searching it
621 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
622 # openssl on ac does not have OPENSSL_HAS_ECC
623 %{__sed} -i -e '/ecdsa/d' sshd.init
624 %endif
625
626 %if %{without audit}
627 # remove recording user's login uid to the process attribute
628 %{__sed} -i -e '/pam_loginuid.so/d' sshd.pam
629 %endif
630
631 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
632 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
633 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
634 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
635 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
636 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
637 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
638 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
639
640 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
641 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
642
643 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
644 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
645
646 %if %{with gnome}
647 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
648 %endif
649 %if %{with gtk}
650 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
651 %endif
652 %if %{with gnome} || %{with gtk}
653 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
654 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
655 EOF
656 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
657 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
658 EOF
659 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
660 %endif
661
662 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
663 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
664
665 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
666 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
667
668 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
669
670 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
671 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
672 EOF
673
674 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
675 %{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
676
677 %clean
678 rm -rf $RPM_BUILD_ROOT
679
680 %post clients
681 %env_update
682
683 %postun clients
684 %env_update
685
686 %post gnome-askpass
687 %env_update
688
689 %postun gnome-askpass
690 %env_update
691
692 %pre server
693 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
694
695 %post server
696 /sbin/chkconfig --add sshd
697 %service sshd reload "OpenSSH Daemon"
698 NORESTART=1
699 %systemd_post sshd.service
700
701 %preun server
702 if [ "$1" = "0" ]; then
703         %service sshd stop
704         /sbin/chkconfig --del sshd
705 fi
706 %systemd_preun sshd.service
707
708 %postun server
709 if [ "$1" = "0" ]; then
710         %userremove sshd
711 fi
712 %systemd_reload
713
714 %triggerpostun server -- %{name}-server < 6.2p1-1
715 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
716 sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
717
718 %triggerpostun server -- %{name}-server < 2:5.9p1-8
719 # lpk.patch to ldap.patch
720 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
721         echo >&2 "Migrating LPK patch to LDAP patch"
722         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
723         %{__sed} -i -e '
724                 # disable old configs
725                 # just UseLPK/LkpLdapConf supported for now
726                 s/^\s*UseLPK/## Obsolete &/
727                 s/^\s*Lpk/## Obsolete &/
728                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
729                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
730         ' %{_sysconfdir}/sshd_config
731         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
732                 /bin/systemctl try-restart sshd.service || :
733         else
734                 %service -q sshd reload
735         fi
736 fi
737 %systemd_trigger sshd.service
738 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
739 %banner %{name}-server -e << EOF
740 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
741 ! Native systemd support for sshd has been installed.   !
742 ! Restarting sshd.service with systemctl WILL kill all  !
743 ! active ssh sessions (daemon as such will be started). !
744 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
745 EOF
746 fi
747
748 %post server-upstart
749 %upstart_post sshd
750
751 %postun server-upstart
752 %upstart_postun sshd
753
754 %post -n openldap-schema-openssh-lpk
755 %openldap_schema_register %{schemadir}/openssh-lpk.schema
756 %service -q ldap restart
757
758 %postun -n openldap-schema-openssh-lpk
759 if [ "$1" = "0" ]; then
760         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
761         %service -q ldap restart
762 fi
763
764 %files
765 %defattr(644,root,root,755)
766 %doc TODO README OVERVIEW CREDITS Change*
767 %attr(755,root,root) %{_bindir}/ssh-key*
768 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
769 %{_mandir}/man1/ssh-key*.1*
770 %{_mandir}/man1/ssh-vulnkey*.1*
771 %dir %{_sysconfdir}
772 %dir %{_libexecdir}
773
774 %files clients
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_bindir}/ssh
777 %attr(755,root,root) %{_bindir}/slogin
778 %attr(755,root,root) %{_bindir}/sftp
779 %attr(755,root,root) %{_bindir}/ssh-agent
780 %attr(755,root,root) %{_bindir}/ssh-add
781 %attr(755,root,root) %{_bindir}/ssh-copy-id
782 %attr(755,root,root) %{_bindir}/scp
783 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
784 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
785 %{_mandir}/man1/scp.1*
786 %{_mandir}/man1/ssh.1*
787 %{_mandir}/man1/slogin.1*
788 %{_mandir}/man1/sftp.1*
789 %{_mandir}/man1/ssh-agent.1*
790 %{_mandir}/man1/ssh-add.1*
791 %{_mandir}/man1/ssh-copy-id.1*
792 %{_mandir}/man5/ssh_config.5*
793 %lang(it) %{_mandir}/it/man1/ssh.1*
794 %lang(it) %{_mandir}/it/man5/ssh_config.5*
795 %lang(pl) %{_mandir}/pl/man1/scp.1*
796 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
797
798 # for host-based auth (suid required for accessing private host key)
799 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
800 #%{_mandir}/man8/ssh-keysign.8*
801
802 %files clients-agent-profile_d
803 %defattr(644,root,root,755)
804 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
805 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
806
807 %files clients-agent-xinitrc
808 %defattr(644,root,root,755)
809 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
810
811 %files server
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_sbindir}/sshd
814 %attr(755,root,root) %{_libexecdir}/sftp-server
815 %attr(755,root,root) %{_libexecdir}/ssh-keysign
816 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
817 %attr(755,root,root) %{_libexecdir}/sshd-keygen
818 %{_mandir}/man8/sshd.8*
819 %{_mandir}/man8/sftp-server.8*
820 %{_mandir}/man8/ssh-keysign.8*
821 %{_mandir}/man8/ssh-pkcs11-helper.8*
822 %{_mandir}/man5/sshd_config.5*
823 %{_mandir}/man5/moduli.5*
824 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
825 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
826 %attr(640,root,root) %{_sysconfdir}/moduli
827 %attr(754,root,root) /etc/rc.d/init.d/sshd
828 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
829 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
830 %{systemdunitdir}/sshd.service
831 %{systemdunitdir}/sshd.socket
832 %{systemdunitdir}/sshd@.service
833
834 %if %{with ldap}
835 %files server-ldap
836 %defattr(644,root,root,755)
837 %doc HOWTO.ldap-keys ldap.conf
838 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
839 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
840 %{_mandir}/man5/ssh-ldap.conf.5*
841 %{_mandir}/man8/ssh-ldap-helper.8*
842 %endif
843
844 %if %{with gnome} || %{with gtk}
845 %files gnome-askpass
846 %defattr(644,root,root,755)
847 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
848 %dir %{_libexecdir}/ssh
849 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
850 %attr(755,root,root) %{_libexecdir}/ssh-askpass
851 %endif
852
853 %if %{with ldap}
854 %files -n openldap-schema-openssh-lpk
855 %defattr(644,root,root,755)
856 %{schemadir}/openssh-lpk.schema
857 %endif
858
859 %if "%{pld_release}" != "ti"
860 %files server-upstart
861 %defattr(644,root,root,755)
862 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
863 %endif
This page took 0.111173 seconds and 3 git commands to generate.