]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- %%groupremove/%%userremove support, some standarization
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # without gnome-askpass utility
4 %bcond_without  gtk             # without gtk (2.x)
5 %bcond_with     ldap            # with ldap support
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  chroot          # without chrooted user environment support
8 %bcond_with     sshagentsh      # with system-wide script for starting ssh-agent
9 #
10 # gtk2-based gnome-askpass means no gnome1-based
11 %{?with_gtk:%undefine with_gnome}
12 Summary:        OpenSSH free Secure Shell (SSH) implementation
13 Summary(de):    OpenSSH - freie Implementation der Secure Shell (SSH)
14 Summary(es):    Implementación libre de SSH
15 Summary(fr):    Implémentation libre du shell sécurisé OpenSSH (SSH)
16 Summary(it):    Implementazione gratuita OpenSSH della Secure Shell
17 Summary(pl):    Publicznie dostêpna implementacja bezpiecznego shella (SSH)
18 Summary(pt):    Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
19 Summary(pt_BR): Implementação livre do SSH
20 Summary(ru):    OpenSSH - Ó×ÏÂÏÄÎÁÑ ÒÅÁÌÉÚÁÃÉÑ ÐÒÏÔÏËÏÌÁ Secure Shell (SSH)
21 Summary(uk):    OpenSSH - ×¦ÌØÎÁ ÒÅÁ̦ÚÁæѠÐÒÏÔÏËÏÌÕ Secure Shell (SSH)
22 Name:           openssh
23 Version:        3.9p1
24 Release:        2
25 Epoch:          2
26 License:        BSD
27 Group:          Applications/Networking
28 Source0:        ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
29 # Source0-md5:  8e1774d0b52aff08f817f3987442a16e
30 Source1:        %{name}d.conf
31 Source2:        %{name}.conf
32 Source3:        %{name}d.init
33 Source4:        %{name}d.pamd
34 Source5:        %{name}.sysconfig
35 Source6:        passwd.pamd
36 Source7:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/openssh-non-english-man-pages.tar.bz2
37 # Source7-md5:  66943d481cc422512b537bcc2c7400d1
38 Source9:        http://www.imasy.or.jp/~gotoh/ssh/connect.c
39 # NoSource9-md5:        c78de727e1208799072be78c05d64398
40 Source10:       http://www.imasy.or.jp/~gotoh/ssh/connect.html
41 # NoSource10-md5:       f14cb61fafd067a3f5ce4eaa9643bf05
42 Source11:       ssh-agent.sh
43 Source12:       ssh-agent.conf
44 Patch0:         %{name}-no_libnsl.patch
45 Patch2:         %{name}-linux-ipv6.patch
46 Patch3:         %{name}-pam_misc.patch
47 Patch4:         %{name}-sigpipe.patch
48 # http://ldappubkey.gcu-squad.org/
49 Patch5:         ldappubkey-ossh3.6-v2.patch
50 Patch6:         %{name}-heimdal.patch
51 Patch7:         %{name}-pam-conv.patch
52 # http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
53 Patch8:         %{name}-chroot.patch
54 Patch9:         %{name}-selinux.patch
55 Patch10:        %{name}-selinux-pld.patch
56 URL:            http://www.openssh.com/
57 BuildRequires:  autoconf
58 BuildRequires:  automake
59 %{?with_gnome:BuildRequires:    gnome-libs-devel}
60 %{?with_gtk:BuildRequires:      gtk+2-devel}
61 %{?with_kerberos5:BuildRequires:        heimdal-devel}
62 BuildRequires:  libselinux-devel
63 BuildRequires:  libwrap-devel
64 %{?with_ldap:BuildRequires:     openldap-devel}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 BuildRequires:  pam-devel
67 BuildRequires:  %{__perl}
68 %{?with_gtk:BuildRequires:      pkgconfig}
69 BuildRequires:  rpmbuild(macros) >= 1.159
70 BuildRequires:  zlib-devel
71 PreReq:         FHS >= 2.1-24
72 PreReq:         openssl >= 0.9.7d
73 Obsoletes:      ssh
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/ssh
77 %define         _libexecdir     %{_libdir}/%{name}
78 %define         _privsepdir     /usr/share/empty
79
80 %description
81 Ssh (Secure Shell) a program for logging into a remote machine and for
82 executing commands in a remote machine. It is intended to replace
83 rlogin and rsh, and provide secure encrypted communications between
84 two untrusted hosts over an insecure network. X11 connections and
85 arbitrary TCP/IP ports can also be forwarded over the secure channel.
86
87 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
88 it up to date in terms of security and features, as well as removing
89 all patented algorithms to seperate libraries (OpenSSL).
90
91 This package includes the core files necessary for both the OpenSSH
92 client and server. To make this package useful, you should also
93 install openssh-clients, openssh-server, or both.
94
95 %description -l de
96 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
97 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
98 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
99 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
100 andere TCP/IP Ports können ebenso über den sicheren Channel
101 weitergeleitet werden.
102
103 %description -l es
104 SSH es un programa para accesar y ejecutar órdenes en computadores
105 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
106 seguro entre dos servidores en una red insegura. Conexiones X11 y
107 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
108 seguro.
109
110 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
111 continuar la última versión gratuita de SSH, actualizándolo en
112 términos de seguridad y recursos,así también eliminando todos los
113 algoritmos patentados y colocándolos en bibliotecas separadas
114 (OpenSSL).
115
116 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
117 también el paquete openssh-clients u openssh-server o ambos.
118
119 %description -l fr
120 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
121 remplace telnet, rlogin, rexec et rsh, tout en assurant des
122 communications cryptées securisées entre deux hôtes non fiabilisés sur
123 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
124 arbitraires peuvent également être transmis sur le canal sécurisé.
125
126 %description -l it
127 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
128 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
129 sicure e crittate tra due host non fidati su una rete non sicura. Le
130 connessioni X11 ad una porta TCP/IP arbitraria possono essere
131 inoltrate attraverso un canale sicuro.
132
133 %description -l pl
134 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
135 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
136 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
137 pomiêdzy dwoma hostami.
138
139 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
140 klienta jak i serwera OpenSSH. Aby by³ u¿yteczny, trzeba zainstalowaæ
141 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
142
143 %description -l pt
144 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
145 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
146 cifradas entre duas máquinas sem confiança mútua sobre uma rede
147 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
148 reenviados pelo canal seguro.
149
150 %description -l pt_BR
151 SSH é um programa para acessar e executar comandos em máquinas
152 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
153 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
154 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
155
156 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
157 última versão gratuita do SSH, atualizando-o em termos de segurança e
158 recursos, assim como removendo todos os algoritmos patenteados e
159 colocando-os em bibliotecas separadas (OpenSSL).
160
161 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
162 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
163
164 %description -l ru
165 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
166 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ. ïÎÁ ÐÒÅÄÎÁÚÎÁÞÅÎÁ
167 ÄÌÑ ÚÁÍÅÎÙ rlogin É rsh É ÏÂÅÓÐÅÞÉ×ÁÅÔ ÂÅÚÏÐÁÓÎÕÀ ÛÉÆÒÏ×ÁÎÎÕÀ
168 ËÏÍÍÕÎÉËÁÃÉÀ ÍÅÖÄÕ Ä×ÕÍÑ ÈÏÓÔÁÍÉ × ÓÅÔÉ, Ñ×ÌÑÀÝÅÊÓÑ ÎÅÂÅÚÏÐÁÓÎÏÊ.
169 óÏÅÄÉÎÅÎÉÑ X11 É ÌÀÂÙÅ ÐÏÒÔÙ TCP/IP ÍÏÇÕÔ ÔÁËÖÅ ÂÙÔØ ÐÒÏ×ÅÄÅÎÙ ÞÅÒÅÚ
170 ÂÅÚÏÐÁÓÎÙÊ ËÁÎÁÌ.
171
172 OpenSSH - ÜÔÏ ÐÅÒÅÄÅÌËÁ ËÏÍÁÎÄÏÊ ÒÁÚÒÁÂÏÔÞÉËÏ× OpenBSD ÐÏÓÌÅÄÎÅÊ
173 Ó×ÏÂÏÄÎÏÊ ×ÅÒÓÉÉ SSH, ÄÏ×ÅÄÅÎÎÁÑ ÄÏ ÓÏ×ÒÅÍÅÎÎÏÇÏ ÓÏÓÔÏÑÎÉÑ × ÔÅÒÍÉÎÁÈ
174 ÕÒÏ×ÎÑ ÂÅÚÏÐÁÓÎÏÓÔÉ É ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ. ÷ÓÅ ÐÁÔÅÎÔÏ×ÁÎÎÙÅ
175 ÁÌÇÏÒÉÔÍÙ ×ÙÎÅÓÅÎÙ × ÏÔÄÅÌØÎÙÅ ÂÉÂÌÉÏÔÅËÉ (OpenSSL).
176
177 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ËÁË ÄÌÑ ËÌÉÅÎÔÁ, ÔÁË É ÄÌÑ
178 ÓÅÒ×ÅÒÁ OpenSSH. ÷ÁÍ ÎÕÖÎÏ ÂÕÄÅÔ ÕÓÔÁÎÏ×ÉÔØ ÅÝÅ openssh-clients,
179 openssh-server, ÉÌÉ ÏÂÁ ÐÁËÅÔÁ.
180
181 %description -l uk
182 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
183 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ. ÷ÏÎÁ ÐÒÉÚÎÁÞÅÎÁ
184 ÄÌÑ ÚÁͦÎÉ rlogin ÔÁ rsh ¦ ÚÁÂÅÚÐÅÞÕ¤ ÂÅÚÐÅÞÎÕ ÛÉÆÒÏ×ÁÎÕ ËÏÍÕΦËÁæÀ
185 ͦ֠Ä×ÏÍÁ ÈÏÓÔÁÍÉ × ÍÅÒÅÖ¦, ÑËÁ ÎÅ ¤ ÂÅÚÐÅÞÎÏÀ. ú'¤ÄÎÁÎÎÑ X11 ÔÁ
186 ÄÏצÌØΦ ÐÏÒÔÉ TCP/IP ÍÏÖÕÔØ ÔÁËÏÖ ÂÕÔÉ ÐÒÏ×ÅÄÅΦ ÞÅÒÅÚ ÂÅÚÐÅÞÎÉÊ
187 ËÁÎÁÌ.
188
189 OpenSSH - ÃÅ ÐÅÒÅÒÏÂËÁ ËÏÍÁÎÄÏÀ ÒÏÚÒÏÂÎÉ˦נOpenBSD ÏÓÔÁÎÎØϧ ×¦ÌØÎϧ
190 ×ÅÒÓ¦§ SSH, ÄÏ×ÅÄÅÎÁ ÄÏ ÓÕÞÁÓÎÏÇÏ ÓÔÁÎÕ × ÔÅÒͦÎÁÈ Ò¦×ÎÑ ÂÅÚÐÅËÉ ÔÁ
191 ЦÄÔÒÉÍÕ×ÁÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ. ÷Ó¦ ÐÁÔÅÎÔÏ×ÁΦ ÁÌÇÏÒÉÔÍÉ ×ÉÎÅÓÅΦ ÄÏ
192 ÏËÒÅÍÉȠ¦Â̦ÏÔÅË (OpenSSL).
193
194 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÑË ÄÌÑ Ë̦¤ÎÔÁ, ÔÁË ¦ ÄÌÑ ÓÅÒ×ÅÒÁ
195 OpenSSH. ÷ÁÍ ÐÏÔÒ¦ÂÎÏ ÂÕÄÅ ÝÅ ×ÓÔÁÎÏ×ÉÔÉ openssh-clients,
196 openssh-server, ÞÉ ÏÂÉÄ×Á ÐÁËÅÔÉ.
197
198 %package clients
199 Summary:        OpenSSH Secure Shell protocol clients
200 Summary(es):    Clientes de OpenSSH
201 Summary(pl):    Klienci protoko³u Secure Shell
202 Summary(pt_BR): Clientes do OpenSSH
203 Summary(ru):    OpenSSH - ËÌÉÅÎÔÙ ÐÒÏÔÏËÏÌÁ Secure Shell
204 Summary(uk):    OpenSSH - Ë̦¤ÎÔÉ ÐÒÏÔÏËÏÌÕ Secure Shell
205 Group:          Applications/Networking
206 Requires:       %{name} = %{epoch}:%{version}-%{release}
207 %{?with_sshagentsh:Requires:    xinitrc}
208 Provides:       ssh-clients
209 Obsoletes:      ssh-clients
210
211 %description clients
212 Ssh (Secure Shell) a program for logging into a remote machine and for
213 executing commands in a remote machine. It is intended to replace
214 rlogin and rsh, and provide secure encrypted communications between
215 two untrusted hosts over an insecure network. X11 connections and
216 arbitrary TCP/IP ports can also be forwarded over the secure channel.
217
218 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
219 it up to date in terms of security and features, as well as removing
220 all patented algorithms to seperate libraries (OpenSSL).
221
222 This package includes the clients necessary to make encrypted
223 connections to SSH servers.
224
225 %description clients -l es
226 Este paquete incluye los clientes que se necesitan para hacer
227 conexiones codificadas con servidores SSH.
228
229 %description clients -l pl
230 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
231 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
232 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
233 pomiêdzy dwoma hostami.
234
235 Ten pakiet zawiera klientów s³u¿±cych do ³±czenia siê z serwerami SSH.
236
237 %description clients -l pt_BR
238 Esse pacote inclui os clientes necessários para fazer conexões
239 encriptadas com servidores SSH.
240
241 %description clients -l ru
242 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
243 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
244
245 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÐÒÏÇÒÁÍÍÙ-ËÌÉÅÎÔÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÕÓÔÁÎÏ×ÌÅÎÉÑ
246 ÚÁÛÉÆÒÏ×ÁÎÎÙÈ ÓÏÅÄÉÎÅÎÉÊ Ó ÓÅÒ×ÅÒÁÍÉ SSH.
247
248 %description clients -l uk
249 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
250 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
251
252 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÐÒÏÇÒÁÍÉ-Ë̦¤ÎÔÉ, ÎÅÏÂȦÄΦ ÄÌÑ ×ÓÔÁÎÏ×ÌÅÎÎÑ
253 ÚÁÛÉÆÒÏ×ÁÎÉÈ Ú'¤ÄÎÁÎØ Ú ÓÅÒ×ÅÒÁÍÉ SSH.
254
255 %package server
256 Summary:        OpenSSH Secure Shell protocol server (sshd)
257 Summary(de):    OpenSSH Secure Shell Protocol-Server (sshd)
258 Summary(es):    Servidor OpenSSH para comunicaciones codificadas
259 Summary(fr):    Serveur de protocole du shell sécurisé OpenSSH (sshd)
260 Summary(it):    Server OpenSSH per il protocollo Secure Shell (sshd)
261 Summary(pl):    Serwer protoko³u Secure Shell (sshd)
262 Summary(pt):    Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
263 Summary(pt_BR): Servidor OpenSSH para comunicações encriptadas
264 Summary(ru):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÁ Secure Shell (sshd)
265 Summary(uk):    OpenSSH - ÓÅÒ×ÅÒ ÐÒÏÔÏËÏÌÕ Secure Shell (sshd)
266 Group:          Networking/Daemons
267 PreReq:         %{name} = %{epoch}:%{version}-%{release}
268 PreReq:         rc-scripts >= 0.3.1-15
269 Requires(pre):  /bin/id
270 Requires(pre):  /usr/sbin/useradd
271 Requires(post,preun):   /sbin/chkconfig
272 Requires(post): chkconfig >= 0.9
273 Requires(post): grep
274 Requires(postun):       /usr/sbin/userdel
275 Requires:       /bin/login
276 Requires:       util-linux
277 Requires:       pam >= 0.77.3
278 Provides:       user(sshd)
279 Provides:       ssh-server
280
281 %description server
282 Ssh (Secure Shell) a program for logging into a remote machine and for
283 executing commands in a remote machine. It is intended to replace
284 rlogin and rsh, and provide secure encrypted communications between
285 two untrusted hosts over an insecure network. X11 connections and
286 arbitrary TCP/IP ports can also be forwarded over the secure channel.
287
288 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
289 it up to date in terms of security and features, as well as removing
290 all patented algorithms to seperate libraries (OpenSSL).
291
292 This package contains the secure shell daemon. The sshd is the server
293 part of the secure shell protocol and allows ssh clients to connect to
294 your host.
295
296 %description server -l de
297 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
298
299 %description server -l es
300 Este paquete contiene el servidor SSH. sshd es la parte servidor del
301 protocolo secure shell y permite que clientes ssh se conecten a su
302 servidor.
303
304 %description server -l fr
305 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
306
307 %description server -l it
308 Questo pacchetto installa sshd, il server di OpenSSH.
309
310 %description server -l pl
311 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
312 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
313 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
314 pomiêdzy dwoma hostami.
315
316 Ten pakiet zawiera serwer sshd (do którego mog± ³±czyæ siê klienci
317 ssh).
318
319 %description server -l pt
320 Este pacote intala o sshd, o servidor do OpenSSH.
321
322 %description server -l pt_BR
323 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
324 protocolo secure shell e permite que clientes ssh se conectem ao seu
325 host.
326
327 %description server -l ru
328 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
329 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
330
331 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÜÔÏ ÓÅÒ×ÅÒÎÁÑ
332 ÞÁÓÔØ ÐÒÏÔÏËÏÌÁ Secure Shell, ÐÏÚ×ÏÌÑÀÝÁÑ ËÌÉÅÎÔÁÍ ssh ÓÏÅÄÉÎÑÔØÓÑ Ó
333 ×ÁÛÉÍ ÈÏÓÔÏÍ.
334
335 %description server -l uk
336 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
337 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
338
339 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ sshd - "ÄÅÍÏÎ" Secure Shell. sshd - ÃÅ ÓÅÒ×ÅÒÎÁ
340 ÞÁÓÔÉÎÁ ÐÒÏÔÏËÏÌÕ Secure Shell, ÑËÁ ÄÏÚ×ÏÌѤ Ë̦¤ÎÔÁÍ ssh Ú×'ÑÚÕ×ÁÔÉÓØ
341 Ú ×ÁÛÉÍ ÈÏÓÔÏÍ.
342
343 %package gnome-askpass
344 Summary:        OpenSSH GNOME passphrase dialog
345 Summary(de):    OpenSSH GNOME Passwort-Dialog
346 Summary(es):    Diálogo para introducción de passphrase para GNOME
347 Summary(fr):    Dialogue pass-phrase GNOME d'OpenSSH
348 Summary(it):    Finestra di dialogo GNOME per la frase segreta di OpenSSH
349 Summary(pl):    Odpytywacz has³a OpenSSH dla GNOME
350 Summary(pt):    Diálogo de pedido de senha para GNOME do OpenSSH
351 Summary(pt_BR): Diálogo para entrada de passphrase para GNOME
352 Summary(ru):    OpenSSH - ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ (passphrase) ÄÌÑ GNOME
353 Summary(uk):    OpenSSH - Ä¦ÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ (passphrase) ÄÌÑ GNOME
354 Group:          Applications/Networking
355 Requires:       %{name} = %{epoch}:%{version}-%{release}
356 Obsoletes:      ssh-extras
357 Obsoletes:      ssh-askpass
358 Obsoletes:      openssh-askpass
359
360 %description gnome-askpass
361 Ssh (Secure Shell) a program for logging into a remote machine and for
362 executing commands in a remote machine. It is intended to replace
363 rlogin and rsh, and provide secure encrypted communications between
364 two untrusted hosts over an insecure network. X11 connections and
365 arbitrary TCP/IP ports can also be forwarded over the secure channel.
366
367 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
368 it up to date in terms of security and features, as well as removing
369 all patented algorithms to seperate libraries (OpenSSL).
370
371 This package contains the GNOME passphrase dialog.
372
373 %description gnome-askpass -l es
374 Este paquete contiene un programa que abre una caja de diálogo para
375 entrada de passphrase en GNOME.
376
377 %description gnome-askpass -l pl
378 Ssh (Secure Shell) to program s³u¿±cy do logowania siê na zdaln±
379 maszynê i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
380 zast±piæ rlogin, rsh i dostarczyæ bezpieczne, szyfrowane po³±czenie
381 pomiêdzy dwoma hostami.
382
383 Ten pakiet zawiera ,,odpytywacz has³a'' dla GNOME.
384
385 %description gnome-askpass -l pt_BR
386 Esse pacote contém um programa que abre uma caixa de diálogo para
387 entrada de passphrase no GNOME.
388
389 %description gnome-askpass -l ru
390 Ssh (Secure Shell) - ÜÔÏ ÐÒÏÇÒÁÍÍÁ ÄÌÑ "ÚÁÈÏÄÁ" (login) ÎÁ ÕÄÁÌÅÎÎÕÀ
391 ÍÁÛÉÎÕ É ÄÌÑ ×ÙÐÏÌÎÅÎÉÑ ËÏÍÁÎÄ ÎÁ ÕÄÁÌÅÎÎÏÊ ÍÁÛÉÎÅ.
392
393 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÉÁÌÏÇ ××ÏÄÁ ËÌÀÞÅ×ÏÊ ÆÒÁÚÙ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ÐÏÄ
394 GNOME.
395
396 %description gnome-askpass -l uk
397 Ssh (Secure Shell) - ÃÅ ÐÒÏÇÒÁÍÁ ÄÌÑ "ÚÁÈÏÄÕ" (login) ÄϠצÄÄÁÌÅÎϧ
398 ÍÁÛÉÎÉ ÔÁ ÄÌÑ ×ÉËÏÎÁÎÎÑ ËÏÍÁÎÄ ÎÁ ×¦ÄÄÁÌÅΦʠÍÁÛÉΦ.
399
400 ãÅÊ ÐÁËÅԠͦÓÔÉÔؠĦÁÌÏÇ ××ÏÄÕ ËÌÀÞÏ×ϧ ÆÒÁÚÉ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎѠЦÄ
401 GNOME.
402
403 %prep
404 %setup -q
405 %patch0 -p1
406 %patch2 -p1
407 %patch3 -p1
408 %patch4 -p1
409 %{?with_ldap:%patch5 -p1}
410 %{?with_kerberos5:%patch6 -p1}
411 #%patch7 -p1
412 %patch8 -p1
413 %patch9 -p1
414 %patch10 -p1
415
416 %build
417 cp %{_datadir}/automake/config.sub .
418 %{__aclocal}
419 %{__autoconf}
420 %{?with_chroot:CPPFLAGS="-DCHROOT"}
421 %configure \
422         PERL=%{__perl} \
423         --with-dns \
424         --with-pam \
425         --with-mantype=man \
426         --with-md5-passwords \
427         --with-ipaddr-display \
428         --with-4in6 \
429         --disable-suid-ssh \
430         --with-tcp-wrappers \
431         %{?with_ldap:--with-libs="-lldap -llber"} \
432         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
433         %{?with_kerberos5:--with-kerberos5} \
434         --with-privsep-path=%{_privsepdir} \
435         --with-pid-dir=%{_localstatedir}/run \
436         --with-xauth=/usr/X11R6/bin/xauth
437
438 echo '#define LOGIN_PROGRAM           "/bin/login"' >>config.h
439
440 %{__make}
441
442 cp -f %{SOURCE9} .
443 cp -f %{SOURCE10} .
444 %{__cc} %{rpmcflags} %{rpmldflags} connect.c -o connect
445
446 cd contrib
447 %if %{with gnome}
448 %{__make} gnome-ssh-askpass1 \
449         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
450 %endif
451 %if %{with gtk}
452 %{__make} gnome-ssh-askpass2 \
453         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
454 %endif
455
456 %install
457 rm -rf $RPM_BUILD_ROOT
458 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
459         $RPM_BUILD_ROOT%{_libexecdir}/ssh
460 %{?with_sshagentsh:install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}}
461
462 %{__make} install \
463         DESTDIR=$RPM_BUILD_ROOT
464
465 install connect    $RPM_BUILD_ROOT%{_bindir}
466 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
467 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/passwdssh
468 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
469 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
470 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
471 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
472 %if %{with sshagentsh}
473 install %{SOURCE11} $RPM_BUILD_ROOT/etc/profile.d/
474 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
475 install %{SOURCE12} $RPM_BUILD_ROOT/etc/ssh/
476 %endif
477
478 bzip2 -dc %{SOURCE7} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
479
480 %if %{with gnome}
481 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
482 %endif
483 %if %{with gtk}
484 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
485 %endif
486 %if %{with gnome} || %{with gtk}
487 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
488 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
489 EOF
490 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
491 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
492 EOF
493 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
494 %endif
495
496 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
497 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
498
499 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
500
501 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
502 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
503 EOF
504
505 %clean
506 rm -rf $RPM_BUILD_ROOT
507
508 %pre server
509 if [ -n "`/bin/id -u sshd 2>/dev/null`" ]; then
510         if [ "`/bin/id -u sshd`" != "40" ]; then
511                 echo "Error: user sshd doesn't have uid=40. Correct this before installing ssh server." 1>&2
512                 exit 1
513         fi
514 else
515         /usr/sbin/useradd -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd 1>&2
516 fi
517
518 %post server
519 /sbin/chkconfig --add sshd
520 if [ -f /var/lock/subsys/sshd ]; then
521         /etc/rc.d/init.d/sshd restart 1>&2
522 else
523         echo "Run \"/etc/rc.d/init.d/sshd start\" to start openssh daemon."
524 fi
525 if ! grep -qs ssh /etc/security/passwd.conf ; then
526         umask 022
527         echo "ssh" >> /etc/security/passwd.conf
528 fi
529
530 %preun server
531 if [ "$1" = "0" ]; then
532         if [ -f /var/lock/subsys/sshd ]; then
533                 /etc/rc.d/init.d/sshd stop 1>&2
534         fi
535         /sbin/chkconfig --del sshd
536 fi
537
538 %postun server
539 if [ "$1" = "0" ]; then
540         %userremove sshd
541 fi
542
543 %files
544 %defattr(644,root,root,755)
545 %doc *.RNG TODO README OVERVIEW CREDITS Change*
546 %attr(755,root,root) %{_bindir}/ssh-key*
547 %{_mandir}/man1/ssh-key*.1*
548 %dir %{_sysconfdir}
549 %dir %{_libexecdir}
550
551 %files clients
552 %defattr(644,root,root,755)
553 %doc connect.html
554 %attr(755,root,root) %{_bindir}/connect
555 %attr(755,root,root) %{_bindir}/ssh
556 %attr(755,root,root) %{_bindir}/slogin
557 %attr(755,root,root) %{_bindir}/sftp
558 %attr(755,root,root) %{_bindir}/ssh-agent
559 %attr(755,root,root) %{_bindir}/ssh-add
560 %attr(755,root,root) %{_bindir}/scp
561 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
562 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/SSH_ASKPASS
563 %if %{with sshagentsh}
564 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh-agent.conf
565 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
566 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
567 %endif
568 %{_mandir}/man1/scp.1*
569 %{_mandir}/man1/ssh.1*
570 %{_mandir}/man1/slogin.1*
571 %{_mandir}/man1/sftp.1*
572 %{_mandir}/man1/ssh-agent.1*
573 %{_mandir}/man1/ssh-add.1*
574 %{_mandir}/man5/ssh_config.5*
575 %lang(it) %{_mandir}/it/man1/ssh.1*
576 %lang(it) %{_mandir}/it/man5/ssh_config.5*
577 %lang(pl) %{_mandir}/pl/man1/scp.1*
578 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
579
580 # for host-based auth (suid required for accessing private host key)
581 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
582 #%{_mandir}/man8/ssh-keysign.8*
583
584 %files server
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_sbindir}/sshd
587 %attr(755,root,root) %{_libexecdir}/sftp-server
588 %attr(755,root,root) %{_libexecdir}/ssh-keysign
589 %{_mandir}/man8/sshd.8*
590 %{_mandir}/man8/sftp-server.8*
591 %{_mandir}/man8/ssh-keysign.8*
592 %{_mandir}/man5/sshd_config.5*
593 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
594 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
595 %attr(640,root,root) %{_sysconfdir}/moduli
596 %attr(754,root,root) /etc/rc.d/init.d/sshd
597 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
598 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/security/blacklist.sshd
599
600 %if %{with gnome} || %{with gtk}
601 %files gnome-askpass
602 %defattr(644,root,root,755)
603 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/GNOME_SSH_ASKPASS*
604 %dir %{_libexecdir}/ssh
605 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
606 %attr(755,root,root) %{_libexecdir}/ssh-askpass
607 %endif
This page took 0.132941 seconds and 3 git commands to generate.