]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
1d0449a825c697300df08bf6dce68e9bbc2e0ee5
[packages/openssh.git] / openssh.spec
1 # TODO:
2 # - add trigger to enable this:
3 #  * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4 #   new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5 #
6 # Conditional build:
7 %bcond_without  audit           # sshd audit support
8 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
9 %bcond_without  gtk             # without GTK+ (2.x)
10 %bcond_without  ldap            # with ldap support
11 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
12 %bcond_without  kerberos5       # without kerberos5 support
13 %bcond_without  selinux         # build without SELinux support
14 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
15 %bcond_without  tests
16
17 # gtk2-based gnome-askpass means no gnome1-based
18 %{?with_gtk:%undefine with_gnome}
19
20 %if "%{pld_release}" == "ac"
21 %define         pam_ver 0.79.0
22 %else
23 %define         pam_ver 1:1.1.5-5
24 %endif
25
26 Summary:        OpenSSH free Secure Shell (SSH) implementation
27 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
28 Summary(es.UTF-8):      Implementación libre de SSH
29 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
30 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
31 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
32 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
33 Summary(pt_BR.UTF-8):   Implementação livre do SSH
34 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
35 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
36 Name:           openssh
37 Version:        6.1p1
38 Release:        2
39 Epoch:          2
40 License:        BSD
41 Group:          Applications/Networking
42 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
43 # Source0-md5:  3345cbf4efe90ffb06a78670ab2d05d5
44 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
45 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
46 Source2:        %{name}d.init
47 Source3:        %{name}d.pamd
48 Source4:        %{name}.sysconfig
49 Source5:        ssh-agent.sh
50 Source6:        ssh-agent.conf
51 Source7:        %{name}-lpk.schema
52 Source8:        %{name}d.upstart
53 Source9:        sshd.service
54 Source10:       sshd-keygen
55 Source11:       sshd.socket
56 Source12:       sshd@.service
57 Patch100:       %{name}-heimdal.patch
58 Patch0:         %{name}-no_libnsl.patch
59 Patch2:         %{name}-pam_misc.patch
60 Patch3:         %{name}-sigpipe.patch
61 # http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
62 Patch4:         %{name}-5.9p1-ldap.patch
63 Patch5:         %{name}-5.9p1-ldap-fixes.patch
64 Patch8:         ldap.conf.patch
65 Patch6:         %{name}-config.patch
66 # https://bugzilla.mindrot.org/show_bug.cgi?id=1663
67 Patch7:         authorized-keys-command.patch
68 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
69 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
70 Patch9:         %{name}-5.2p1-hpn13v6.diff
71 Patch10:        %{name}-include.patch
72 Patch11:        %{name}-chroot.patch
73 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
74 Patch12:        %{name}-blacklist.diff
75 Patch13:        %{name}-kuserok.patch
76 Patch14:        %{name}-bind.patch
77 URL:            http://www.openssh.com/portable.html
78 BuildRequires:  %{__perl}
79 %{?with_tests:BuildRequires:    %{name}-server}
80 %{?with_audit:BuildRequires:    audit-libs-devel}
81 BuildRequires:  autoconf >= 2.50
82 BuildRequires:  automake
83 %{?with_gnome:BuildRequires:    gnome-libs-devel}
84 %{?with_gtk:BuildRequires:      gtk+2-devel}
85 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
86 %{?with_libedit:BuildRequires:  libedit-devel}
87 %{?with_selinux:BuildRequires:  libselinux-devel}
88 BuildRequires:  libwrap-devel
89 %{?with_ldap:BuildRequires:     openldap-devel}
90 BuildRequires:  openssl-devel >= 0.9.7d
91 BuildRequires:  pam-devel
92 %{?with_gtk:BuildRequires:      pkgconfig}
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.627
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  zlib-devel >= 1.2.3
97 Requires:       zlib >= 1.2.3
98 %if "%{pld_release}" == "ac"
99 Requires:       filesystem >= 2.0-1
100 Requires:       pam >= 0.79.0
101 %else
102 Requires:       filesystem >= 3.0-11
103 Requires:       pam >= %{pam_ver}
104 Suggests:       openssh-blacklist
105 Suggests:       xorg-app-xauth
106 %endif
107 Obsoletes:      ssh
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define         _sysconfdir     /etc/ssh
111 %define         _libexecdir     %{_libdir}/%{name}
112 %define         _privsepdir     /usr/share/empty
113 %define         schemadir       /usr/share/openldap/schema
114
115 %description
116 Ssh (Secure Shell) a program for logging into a remote machine and for
117 executing commands in a remote machine. It is intended to replace
118 rlogin and rsh, and provide secure encrypted communications between
119 two untrusted hosts over an insecure network. X11 connections and
120 arbitrary TCP/IP ports can also be forwarded over the secure channel.
121
122 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
123 it up to date in terms of security and features, as well as removing
124 all patented algorithms to seperate libraries (OpenSSL).
125
126 This package includes the core files necessary for both the OpenSSH
127 client and server. To make this package useful, you should also
128 install openssh-clients, openssh-server, or both.
129
130 %if %{with hpn}
131 This release includes High Performance SSH/SCP patches from
132 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
133 increase throughput on fast connections with high RTT (20-150 msec).
134 See the website for '-w' values for your connection and /proc/sys TCP
135 values. BTW. in a LAN you have got generally RTT < 1 msec.
136 %endif
137
138 %description -l de.UTF-8
139 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
140 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
141 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
142 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
143 andere TCP/IP Ports können ebenso über den sicheren Channel
144 weitergeleitet werden.
145
146 %description -l es.UTF-8
147 SSH es un programa para accesar y ejecutar órdenes en computadores
148 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
149 seguro entre dos servidores en una red insegura. Conexiones X11 y
150 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
151 seguro.
152
153 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
154 continuar la última versión gratuita de SSH, actualizándolo en
155 términos de seguridad y recursos,así también eliminando todos los
156 algoritmos patentados y colocándolos en bibliotecas separadas
157 (OpenSSL).
158
159 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
160 también el paquete openssh-clients u openssh-server o ambos.
161
162 %description -l fr.UTF-8
163 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
164 remplace telnet, rlogin, rexec et rsh, tout en assurant des
165 communications cryptées securisées entre deux hôtes non fiabilisés sur
166 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
167 arbitraires peuvent également être transmis sur le canal sécurisé.
168
169 %description -l it.UTF-8
170 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
171 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
172 sicure e crittate tra due host non fidati su una rete non sicura. Le
173 connessioni X11 ad una porta TCP/IP arbitraria possono essere
174 inoltrate attraverso un canale sicuro.
175
176 %description -l pl.UTF-8
177 Ssh (Secure Shell) to program służący do logowania się na zdalną
178 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
179 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
180 pomiędzy dwoma hostami.
181
182 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
183 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
184 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
185
186 %if %{with hpn}
187 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
188 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
189 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
190 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
191 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
192 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
193 %endif
194
195 %description -l pt.UTF-8
196 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
197 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
198 cifradas entre duas máquinas sem confiança mútua sobre uma rede
199 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
200 reenviados pelo canal seguro.
201
202 %description -l pt_BR.UTF-8
203 SSH é um programa para acessar e executar comandos em máquinas
204 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
205 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
206 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
207
208 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
209 última versão gratuita do SSH, atualizando-o em termos de segurança e
210 recursos, assim como removendo todos os algoritmos patenteados e
211 colocando-os em bibliotecas separadas (OpenSSL).
212
213 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
214 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
215
216 %description -l ru.UTF-8
217 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
218 машину и для выполнения команд на удаленной машине. Она предназначена
219 для замены rlogin и rsh и обеспечивает безопасную шифрованную
220 коммуникацию между двумя хостами в сети, являющейся небезопасной.
221 Соединения X11 и любые порты TCP/IP могут также быть проведены через
222 безопасный канал.
223
224 OpenSSH - это переделка командой разработчиков OpenBSD последней
225 свободной версии SSH, доведенная до современного состояния в терминах
226 уровня безопасности и поддерживаемых возможностей. Все патентованные
227 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
228
229 Этот пакет содержит файлы, необходимые как для клиента, так и для
230 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
231 openssh-server, или оба пакета.
232
233 %description -l uk.UTF-8
234 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
235 машини та для виконання команд на віддаленій машині. Вона призначена
236 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
237 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
238 довільні порти TCP/IP можуть також бути проведені через безпечний
239 канал.
240
241 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
242 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
243 підтримуваних можливостей. Всі патентовані алгоритми винесені до
244 окремих бібліотек (OpenSSL).
245
246 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
247 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
248 openssh-server, чи обидва пакети.
249
250 %package clients
251 Summary:        OpenSSH Secure Shell protocol clients
252 Summary(es.UTF-8):      Clientes de OpenSSH
253 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
254 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
255 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
256 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
257 Group:          Applications/Networking
258 Requires:       %{name}
259 Provides:       ssh-clients
260 Obsoletes:      ssh-clients
261
262 %description clients
263 Ssh (Secure Shell) a program for logging into a remote machine and for
264 executing commands in a remote machine. It is intended to replace
265 rlogin and rsh, and provide secure encrypted communications between
266 two untrusted hosts over an insecure network. X11 connections and
267 arbitrary TCP/IP ports can also be forwarded over the secure channel.
268
269 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
270 it up to date in terms of security and features, as well as removing
271 all patented algorithms to seperate libraries (OpenSSL).
272
273 This package includes the clients necessary to make encrypted
274 connections to SSH servers.
275
276 %description clients -l es.UTF-8
277 Este paquete incluye los clientes que se necesitan para hacer
278 conexiones codificadas con servidores SSH.
279
280 %description clients -l pl.UTF-8
281 Ssh (Secure Shell) to program służący do logowania się na zdalną
282 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
283 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
284 pomiędzy dwoma hostami.
285
286 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
287
288 %description clients -l pt_BR.UTF-8
289 Esse pacote inclui os clientes necessários para fazer conexões
290 encriptadas com servidores SSH.
291
292 %description clients -l ru.UTF-8
293 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
294 машину и для выполнения команд на удаленной машине.
295
296 Этот пакет содержит программы-клиенты, необходимые для установления
297 зашифрованных соединений с серверами SSH.
298
299 %description clients -l uk.UTF-8
300 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
301 машини та для виконання команд на віддаленій машині.
302
303 Цей пакет містить програми-клієнти, необхідні для встановлення
304 зашифрованих з'єднань з серверами SSH.
305
306 %package clients-agent-profile_d
307 Summary:        OpenSSH Secure Shell agent init script
308 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
309 Group:          Applications/Networking
310 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
311
312 %description clients-agent-profile_d
313 profile.d scripts for starting SSH agent.
314
315 %description clients-agent-profile_d -l pl.UTF-8
316 Skrypty profile.d do uruchamiania agenta SSH.
317
318 %package clients-agent-xinitrc
319 Summary:        OpenSSH Secure Shell agent init script
320 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
321 Group:          Applications/Networking
322 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
323 Requires:       xinitrc
324
325 %description clients-agent-xinitrc
326 xinitrc scripts for starting SSH agent.
327
328 %description clients-agent-xinitrc -l pl.UTF-8
329 Skrypty xinitrc do uruchamiania agenta SSH.
330
331 %package server
332 Summary:        OpenSSH Secure Shell protocol server (sshd)
333 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
334 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
335 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
336 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
337 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
338 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
339 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
340 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
341 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
342 Group:          Networking/Daemons
343 Requires(post): /sbin/chkconfig
344 Requires(post): grep
345 Requires(post,preun):   /sbin/chkconfig
346 Requires(postun):       /usr/sbin/userdel
347 Requires(pre):  /bin/id
348 Requires(pre):  /usr/sbin/useradd
349 Requires(post,preun,postun):    systemd-units >= 38
350 Requires:       %{name} = %{epoch}:%{version}-%{release}
351 # remove in 6.0, kept for flawless upgrade
352 Requires:       %{name}-server-ldap = %{epoch}:%{version}-%{release}
353 Requires:       pam >= %{pam_ver}
354 Requires:       rc-scripts >= 0.4.3.0
355 Requires:       systemd-units >= 38
356 Requires:       util-linux
357 Suggests:       /bin/login
358 Provides:       ssh-server
359 Provides:       user(sshd)
360
361 %description server
362 Ssh (Secure Shell) a program for logging into a remote machine and for
363 executing commands in a remote machine. It is intended to replace
364 rlogin and rsh, and provide secure encrypted communications between
365 two untrusted hosts over an insecure network. X11 connections and
366 arbitrary TCP/IP ports can also be forwarded over the secure channel.
367
368 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
369 it up to date in terms of security and features, as well as removing
370 all patented algorithms to seperate libraries (OpenSSL).
371
372 This package contains the secure shell daemon. The sshd is the server
373 part of the secure shell protocol and allows ssh clients to connect to
374 your host.
375
376 %description server -l de.UTF-8
377 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
378
379 %description server -l es.UTF-8
380 Este paquete contiene el servidor SSH. sshd es la parte servidor del
381 protocolo secure shell y permite que clientes ssh se conecten a su
382 servidor.
383
384 %description server -l fr.UTF-8
385 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
386
387 %description server -l it.UTF-8
388 Questo pacchetto installa sshd, il server di OpenSSH.
389
390 %description server -l pl.UTF-8
391 Ssh (Secure Shell) to program służący do logowania się na zdalną
392 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
393 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
394 pomiędzy dwoma hostami.
395
396 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
397 ssh).
398
399 %description server -l pt.UTF-8
400 Este pacote intala o sshd, o servidor do OpenSSH.
401
402 %description server -l pt_BR.UTF-8
403 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
404 protocolo secure shell e permite que clientes ssh se conectem ao seu
405 host.
406
407 %description server -l ru.UTF-8
408 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
409 машину и для выполнения команд на удаленной машине.
410
411 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
412 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
413 вашим хостом.
414
415 %description server -l uk.UTF-8
416 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
417 машини та для виконання команд на віддаленій машині.
418
419 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
420 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
421 з вашим хостом.
422
423 %package server-ldap
424 Summary:        A LDAP support for open source SSH server daemon
425 Summary(pl.UTF-8):      Wsparcie LDAP dla serwera OpenSSH
426 Group:          Daemons
427 Requires:       %{name} = %{epoch}:%{version}-%{release}
428
429 %description server-ldap
430 OpenSSH LDAP backend is a way how to distribute the authorized tokens
431 among the servers in the network.
432
433 %description server-ldap -l pl.UTF-8
434 Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
435 tokenów między serwerami w sieci.
436
437 %package server-upstart
438 Summary:        Upstart job description for OpenSSH server
439 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
440 Group:          Daemons
441 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
442 Requires:       upstart >= 0.6
443 Conflicts:      syslog-ng < 3.2.4-1
444
445 %description server-upstart
446 Upstart job description for OpenSSH.
447
448 %description server-upstart -l pl.UTF-8
449 Opis zadania Upstart dla OpenSSH.
450
451 %package gnome-askpass
452 Summary:        OpenSSH GNOME passphrase dialog
453 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
454 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
455 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
456 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
457 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
458 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
459 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
460 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
461 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
462 Group:          Applications/Networking
463 Requires:       %{name} = %{epoch}:%{version}-%{release}
464 Obsoletes:      openssh-askpass
465 Obsoletes:      ssh-askpass
466 Obsoletes:      ssh-extras
467
468 %description gnome-askpass
469 Ssh (Secure Shell) a program for logging into a remote machine and for
470 executing commands in a remote machine. It is intended to replace
471 rlogin and rsh, and provide secure encrypted communications between
472 two untrusted hosts over an insecure network. X11 connections and
473 arbitrary TCP/IP ports can also be forwarded over the secure channel.
474
475 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
476 it up to date in terms of security and features, as well as removing
477 all patented algorithms to seperate libraries (OpenSSL).
478
479 This package contains the GNOME passphrase dialog.
480
481 %description gnome-askpass -l es.UTF-8
482 Este paquete contiene un programa que abre una caja de diálogo para
483 entrada de passphrase en GNOME.
484
485 %description gnome-askpass -l pl.UTF-8
486 Ssh (Secure Shell) to program służący do logowania się na zdalną
487 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
488 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
489 pomiędzy dwoma hostami.
490
491 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
492
493 %description gnome-askpass -l pt_BR.UTF-8
494 Esse pacote contém um programa que abre uma caixa de diálogo para
495 entrada de passphrase no GNOME.
496
497 %description gnome-askpass -l ru.UTF-8
498 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
499 машину и для выполнения команд на удаленной машине.
500
501 Этот пакет содержит диалог ввода ключевой фразы для использования под
502 GNOME.
503
504 %description gnome-askpass -l uk.UTF-8
505 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
506 машини та для виконання команд на віддаленій машині.
507
508 Цей пакет містить діалог вводу ключової фрази для використання під
509 GNOME.
510
511 %package -n openldap-schema-openssh-lpk
512 Summary:        OpenSSH LDAP Public Key schema
513 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
514 Group:          Networking/Daemons
515 Requires(post,postun):  sed >= 4.0
516 Requires:       openldap-servers
517
518 %description -n openldap-schema-openssh-lpk
519 This package contains OpenSSH LDAP Public Key schema for openldap.
520
521 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
522 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
523 openldap-a.
524
525 %prep
526 %setup -q
527 %{?with_kerberos5:%patch100 -p1}
528 %patch0 -p1
529 %patch2 -p1
530 %patch3 -p1
531 %patch4 -p1
532 %patch5 -p1
533 %patch8 -p1
534 %patch6 -p1
535 %patch7 -p1
536 %{?with_hpn:%patch9 -p1}
537 %patch10 -p1
538 %patch11 -p1
539 %patch12 -p1
540 %patch13 -p1
541 %patch14 -p1
542
543 %if "%{pld_release}" == "ac"
544 # fix for missing x11.pc
545 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
546 %endif
547
548 # hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
549 sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh#g' Makefile*
550
551 grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
552 %{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
553
554 %build
555 cp /usr/share/automake/config.sub .
556 %{__aclocal}
557 %{__autoconf}
558 %{__autoheader}
559 CPPFLAGS="-DCHROOT"
560 %configure \
561         PERL=%{__perl} \
562         --disable-strip \
563         --enable-utmpx \
564         --enable-wtmpx \
565         --with-4in6 \
566         %{?with_audit:--with-audit=linux} \
567         --with-ipaddr-display \
568         %{?with_kerberos5:--with-kerberos5=/usr} \
569         --with-ldap%{!?with_ldap:=no} \
570         %{?with_libedit:--with-libedit} \
571         --with-mantype=man \
572         --with-md5-passwords \
573         --with-pam \
574         --with-authorized-keys-command \
575         --with-pid-dir=%{_localstatedir}/run \
576         --with-privsep-path=%{_privsepdir} \
577         %{?with_selinux:--with-selinux} \
578         --with-tcp-wrappers \
579 %if "%{pld_release}" == "ac"
580         --with-xauth=/usr/X11R6/bin/xauth
581 %else
582         --with-xauth=%{_bindir}/xauth
583 %endif
584
585 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
586
587 %{__make}
588
589 %{?with_tests:%{__make} tests}
590
591 cd contrib
592 %if %{with gnome}
593 %{__make} gnome-ssh-askpass1 \
594         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
595 %endif
596 %if %{with gtk}
597 %{__make} gnome-ssh-askpass2 \
598         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
599 %endif
600
601 %install
602 rm -rf $RPM_BUILD_ROOT
603 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
604         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
605 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
606
607 %{__make} install \
608         DESTDIR=$RPM_BUILD_ROOT
609
610 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
611
612 cp -p %{SOURCE3} sshd.pam
613 install -p %{SOURCE2} sshd.init
614
615 %if "%{pld_release}" == "ac"
616 # not present in ac, no point searching it
617 %{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
618 # openssl on ac does not have OPENSSL_HAS_ECC
619 %{__sed} -i -e '/ecdsa/d' sshd.init
620 %endif
621
622 install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
623 cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
624 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
625 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
626 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
627 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
628 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
629 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
630
631 %{__sed} -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' %{SOURCE9} >$RPM_BUILD_ROOT%{systemdunitdir}/sshd.service
632 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
633
634 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
635 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
636
637 %if %{with gnome}
638 install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
639 %endif
640 %if %{with gtk}
641 install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
642 %endif
643 %if %{with gnome} || %{with gtk}
644 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
645 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
646 EOF
647 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
648 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
649 EOF
650 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
651 %endif
652
653 install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
654 cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
655
656 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
657 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
658
659 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
660
661 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
662 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
663 EOF
664
665 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
666 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf
667
668 %clean
669 rm -rf $RPM_BUILD_ROOT
670
671 %post clients
672 %env_update
673
674 %postun clients
675 %env_update
676
677 %post gnome-askpass
678 %env_update
679
680 %postun gnome-askpass
681 %env_update
682
683 %pre server
684 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
685
686 %post server
687 /sbin/chkconfig --add sshd
688 %service sshd reload "OpenSSH Daemon"
689 NORESTART=1
690 %systemd_post sshd.service
691
692 %preun server
693 if [ "$1" = "0" ]; then
694         %service sshd stop
695         /sbin/chkconfig --del sshd
696 fi
697 %systemd_preun sshd.service
698
699 %postun server
700 if [ "$1" = "0" ]; then
701         %userremove sshd
702 fi
703 %systemd_reload
704
705 %triggerpostun server -- %{name}-server < 2:5.9p1-8
706 # lpk.patch to ldap.patch
707 if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
708         echo >&2 "Migrating LPK patch to LDAP patch"
709         cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
710         %{__sed} -i -e '
711                 # disable old configs
712                 # just UseLPK/LkpLdapConf supported for now
713                 s/^\s*UseLPK/## Obsolete &/
714                 s/^\s*Lpk/## Obsolete &/
715                 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
716                 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
717         ' %{_sysconfdir}/sshd_config
718         if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
719                 /bin/systemctl try-restart sshd.service || :
720         else
721                 %service -q sshd reload
722         fi
723 fi
724 %systemd_trigger sshd.service
725 if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
726 %banner %{name}-server -e << EOF
727 !!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
728 ! Native systemd support for sshd has been installed.   !
729 ! Restarting sshd.service with systemctl WILL kill all  !
730 ! active ssh sessions (daemon as such will be started). !
731 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
732 EOF
733 fi
734
735 %post server-upstart
736 %upstart_post sshd
737
738 %postun server-upstart
739 %upstart_postun sshd
740
741 %post -n openldap-schema-openssh-lpk
742 %openldap_schema_register %{schemadir}/openssh-lpk.schema
743 %service -q ldap restart
744
745 %postun -n openldap-schema-openssh-lpk
746 if [ "$1" = "0" ]; then
747         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
748         %service -q ldap restart
749 fi
750
751 %files
752 %defattr(644,root,root,755)
753 %doc TODO README OVERVIEW CREDITS Change*
754 %attr(755,root,root) %{_bindir}/ssh-key*
755 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
756 %{_mandir}/man1/ssh-key*.1*
757 %{_mandir}/man1/ssh-vulnkey*.1*
758 %dir %{_sysconfdir}
759 %dir %{_libexecdir}
760
761 %files clients
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_bindir}/ssh
764 %attr(755,root,root) %{_bindir}/slogin
765 %attr(755,root,root) %{_bindir}/sftp
766 %attr(755,root,root) %{_bindir}/ssh-agent
767 %attr(755,root,root) %{_bindir}/ssh-add
768 %attr(755,root,root) %{_bindir}/ssh-copy-id
769 %attr(755,root,root) %{_bindir}/scp
770 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
771 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
772 %{_mandir}/man1/scp.1*
773 %{_mandir}/man1/ssh.1*
774 %{_mandir}/man1/slogin.1*
775 %{_mandir}/man1/sftp.1*
776 %{_mandir}/man1/ssh-agent.1*
777 %{_mandir}/man1/ssh-add.1*
778 %{_mandir}/man1/ssh-copy-id.1*
779 %{_mandir}/man5/ssh_config.5*
780 %lang(it) %{_mandir}/it/man1/ssh.1*
781 %lang(it) %{_mandir}/it/man5/ssh_config.5*
782 %lang(pl) %{_mandir}/pl/man1/scp.1*
783 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
784
785 # for host-based auth (suid required for accessing private host key)
786 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
787 #%{_mandir}/man8/ssh-keysign.8*
788
789 %files clients-agent-profile_d
790 %defattr(644,root,root,755)
791 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
792 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
793
794 %files clients-agent-xinitrc
795 %defattr(644,root,root,755)
796 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
797
798 %files server
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_sbindir}/sshd
801 %attr(755,root,root) %{_libexecdir}/sftp-server
802 %attr(755,root,root) %{_libexecdir}/ssh-keysign
803 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
804 %attr(755,root,root) %{_libexecdir}/sshd-keygen
805 %{_mandir}/man8/sshd.8*
806 %{_mandir}/man8/sftp-server.8*
807 %{_mandir}/man8/ssh-keysign.8*
808 %{_mandir}/man8/ssh-pkcs11-helper.8*
809 %{_mandir}/man5/sshd_config.5*
810 %{_mandir}/man5/moduli.5*
811 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
812 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
813 %attr(640,root,root) %{_sysconfdir}/moduli
814 %attr(754,root,root) /etc/rc.d/init.d/sshd
815 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
816 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
817 %{systemdunitdir}/sshd.service
818 %{systemdunitdir}/sshd.socket
819 %{systemdunitdir}/sshd@.service
820
821 %if %{with ldap}
822 %files server-ldap
823 %defattr(644,root,root,755)
824 %doc HOWTO.ldap-keys ldap.conf
825 %attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
826 %attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
827 %{_mandir}/man5/ssh-ldap.conf.5*
828 %{_mandir}/man8/ssh-ldap-helper.8*
829 %endif
830
831 %if %{with gnome} || %{with gtk}
832 %files gnome-askpass
833 %defattr(644,root,root,755)
834 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
835 %dir %{_libexecdir}/ssh
836 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
837 %attr(755,root,root) %{_libexecdir}/ssh-askpass
838 %endif
839
840 %if %{with ldap}
841 %files -n openldap-schema-openssh-lpk
842 %defattr(644,root,root,755)
843 %{schemadir}/openssh-lpk.schema
844 %endif
845
846 %if "%{pld_release}" != "ti"
847 %files server-upstart
848 %defattr(644,root,root,755)
849 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
850 %endif
This page took 0.963977 seconds and 2 git commands to generate.