]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- release 3
[packages/openssh.git] / openssh.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
4 %bcond_without  gtk             # without GTK+ (2.x)
5 %bcond_without  ldap            # with ldap support
6 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
7 %bcond_without  kerberos5       # without kerberos5 support
8 %bcond_without  selinux         # build without SELinux support
9 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11 # gtk2-based gnome-askpass means no gnome1-based
12 %{?with_gtk:%undefine with_gnome}
13
14 %if "%{pld_release}" == "ac"
15 %define         pam_ver 0.79.0
16 %else
17 %define         pam_ver 0.99.7.1
18 %endif
19
20 Summary:        OpenSSH free Secure Shell (SSH) implementation
21 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
22 Summary(es.UTF-8):      Implementación libre de SSH
23 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
24 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
25 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
26 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27 Summary(pt_BR.UTF-8):   Implementação livre do SSH
28 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
29 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
30 Name:           openssh
31 Version:        5.8p1
32 Release:        3
33 Epoch:          2
34 License:        BSD
35 Group:          Applications/Networking
36 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37 # Source0-md5:  86f5e1c23b4c4845f23b9b7b493fb53d
38 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
40 Source2:        %{name}d.init
41 Source3:        %{name}d.pamd
42 Source4:        %{name}.sysconfig
43 Source5:        ssh-agent.sh
44 Source6:        ssh-agent.conf
45 Source7:        %{name}-lpk.schema
46 Source8:        %{name}d.upstart
47 Patch100:       %{name}-heimdal.patch
48 Patch0:         %{name}-no_libnsl.patch
49 Patch2:         %{name}-pam_misc.patch
50 Patch3:         %{name}-sigpipe.patch
51 # http://code.google.com/p/openssh-lpk/
52 Patch4:         %{name}-lpk.patch
53 Patch5:         %{name}-config.patch
54 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
55 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56 Patch9:         %{name}-5.2p1-hpn13v6.diff
57 Patch10:        %{name}-include.patch
58 Patch11:        %{name}-chroot.patch
59 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
60 Patch12:        %{name}-blacklist.diff
61 URL:            http://www.openssh.com/portable.html
62 BuildRequires:  %{__perl}
63 BuildRequires:  autoconf
64 BuildRequires:  automake
65 %{?with_gnome:BuildRequires:    gnome-libs-devel}
66 %{?with_gtk:BuildRequires:      gtk+2-devel}
67 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
68 %{?with_libedit:BuildRequires:  libedit-devel}
69 %{?with_selinux:BuildRequires:  libselinux-devel}
70 BuildRequires:  libwrap-devel
71 %{?with_ldap:BuildRequires:     openldap-devel}
72 BuildRequires:  openssl-devel >= 0.9.7d
73 BuildRequires:  pam-devel
74 %{?with_gtk:BuildRequires:      pkgconfig}
75 BuildRequires:  rpm >= 4.4.9-56
76 BuildRequires:  rpmbuild(macros) >= 1.318
77 BuildRequires:  sed >= 4.0
78 BuildRequires:  zlib-devel
79 %if "%{pld_release}" == "ac"
80 Requires:       filesystem >= 2.0-1
81 Requires:       pam >= 0.79.0
82 %else
83 Requires:       filesystem >= 3.0-11
84 Requires:       pam >= %{pam_ver}
85 Suggests:       openssh-blacklist
86 Suggests:       xorg-app-xauth
87 %endif
88 Obsoletes:      ssh
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         _sysconfdir     /etc/ssh
92 %define         _libexecdir     %{_libdir}/%{name}
93 %define         _privsepdir     /usr/share/empty
94 %define         schemadir       /usr/share/openldap/schema
95
96 ## to be moved to rpm-build-macros
97 ## TODO: handle RPM_SKIP_AUTO_RESTART
98
99 # migrate from init script to upstart job
100 %define upstart_post() \
101         if [ -f /var/lock/subsys/"%1" ] ; then \
102                 /sbin/service --no-upstart "%1" stop \
103                 /sbin/service "%1" start \
104         else \
105                 /sbin/service "%1" try-restart \
106         fi
107
108 # restart the job after upgrade or migrate to init script on removal
109 %define upstart_postun() \
110         if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
111                 /sbin/initctl stop "%1" 2>/dev/null \
112                 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
113         fi
114
115
116 %description
117 Ssh (Secure Shell) a program for logging into a remote machine and for
118 executing commands in a remote machine. It is intended to replace
119 rlogin and rsh, and provide secure encrypted communications between
120 two untrusted hosts over an insecure network. X11 connections and
121 arbitrary TCP/IP ports can also be forwarded over the secure channel.
122
123 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
124 it up to date in terms of security and features, as well as removing
125 all patented algorithms to seperate libraries (OpenSSL).
126
127 This package includes the core files necessary for both the OpenSSH
128 client and server. To make this package useful, you should also
129 install openssh-clients, openssh-server, or both.
130
131 %if %{with hpn}
132 This release includes High Performance SSH/SCP patches from
133 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
134 increase throughput on fast connections with high RTT (20-150 msec).
135 See the website for '-w' values for your connection and /proc/sys TCP
136 values. BTW. in a LAN you have got generally RTT < 1 msec.
137 %endif
138
139 %description -l de.UTF-8
140 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
141 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
142 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
143 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
144 andere TCP/IP Ports können ebenso über den sicheren Channel
145 weitergeleitet werden.
146
147 %description -l es.UTF-8
148 SSH es un programa para accesar y ejecutar órdenes en computadores
149 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
150 seguro entre dos servidores en una red insegura. Conexiones X11 y
151 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
152 seguro.
153
154 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
155 continuar la última versión gratuita de SSH, actualizándolo en
156 términos de seguridad y recursos,así también eliminando todos los
157 algoritmos patentados y colocándolos en bibliotecas separadas
158 (OpenSSL).
159
160 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
161 también el paquete openssh-clients u openssh-server o ambos.
162
163 %description -l fr.UTF-8
164 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
165 remplace telnet, rlogin, rexec et rsh, tout en assurant des
166 communications cryptées securisées entre deux hôtes non fiabilisés sur
167 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
168 arbitraires peuvent également être transmis sur le canal sécurisé.
169
170 %description -l it.UTF-8
171 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
172 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
173 sicure e crittate tra due host non fidati su una rete non sicura. Le
174 connessioni X11 ad una porta TCP/IP arbitraria possono essere
175 inoltrate attraverso un canale sicuro.
176
177 %description -l pl.UTF-8
178 Ssh (Secure Shell) to program służący do logowania się na zdalną
179 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
180 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
181 pomiędzy dwoma hostami.
182
183 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
184 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
185 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
186
187 %if %{with hpn}
188 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
189 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
190 zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
191 RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
192 danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
193 TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
194 %endif
195
196 %description -l pt.UTF-8
197 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
198 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
199 cifradas entre duas máquinas sem confiança mútua sobre uma rede
200 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
201 reenviados pelo canal seguro.
202
203 %description -l pt_BR.UTF-8
204 SSH é um programa para acessar e executar comandos em máquinas
205 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
206 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
207 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
208
209 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
210 última versão gratuita do SSH, atualizando-o em termos de segurança e
211 recursos, assim como removendo todos os algoritmos patenteados e
212 colocando-os em bibliotecas separadas (OpenSSL).
213
214 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
215 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
216
217 %description -l ru.UTF-8
218 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
219 машину и для выполнения команд на удаленной машине. Она предназначена
220 для замены rlogin и rsh и обеспечивает безопасную шифрованную
221 коммуникацию между двумя хостами в сети, являющейся небезопасной.
222 Соединения X11 и любые порты TCP/IP могут также быть проведены через
223 безопасный канал.
224
225 OpenSSH - это переделка командой разработчиков OpenBSD последней
226 свободной версии SSH, доведенная до современного состояния в терминах
227 уровня безопасности и поддерживаемых возможностей. Все патентованные
228 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
229
230 Этот пакет содержит файлы, необходимые как для клиента, так и для
231 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
232 openssh-server, или оба пакета.
233
234 %description -l uk.UTF-8
235 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
236 машини та для виконання команд на віддаленій машині. Вона призначена
237 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
238 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
239 довільні порти TCP/IP можуть також бути проведені через безпечний
240 канал.
241
242 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
243 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
244 підтримуваних можливостей. Всі патентовані алгоритми винесені до
245 окремих бібліотек (OpenSSL).
246
247 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
248 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
249 openssh-server, чи обидва пакети.
250
251 %package clients
252 Summary:        OpenSSH Secure Shell protocol clients
253 Summary(es.UTF-8):      Clientes de OpenSSH
254 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
255 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
256 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
257 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
258 Group:          Applications/Networking
259 Requires:       %{name}
260 Provides:       ssh-clients
261 Obsoletes:      ssh-clients
262
263 %description clients
264 Ssh (Secure Shell) a program for logging into a remote machine and for
265 executing commands in a remote machine. It is intended to replace
266 rlogin and rsh, and provide secure encrypted communications between
267 two untrusted hosts over an insecure network. X11 connections and
268 arbitrary TCP/IP ports can also be forwarded over the secure channel.
269
270 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
271 it up to date in terms of security and features, as well as removing
272 all patented algorithms to seperate libraries (OpenSSL).
273
274 This package includes the clients necessary to make encrypted
275 connections to SSH servers.
276
277 %description clients -l es.UTF-8
278 Este paquete incluye los clientes que se necesitan para hacer
279 conexiones codificadas con servidores SSH.
280
281 %description clients -l pl.UTF-8
282 Ssh (Secure Shell) to program służący do logowania się na zdalną
283 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
284 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
285 pomiędzy dwoma hostami.
286
287 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
288
289 %description clients -l pt_BR.UTF-8
290 Esse pacote inclui os clientes necessários para fazer conexões
291 encriptadas com servidores SSH.
292
293 %description clients -l ru.UTF-8
294 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
295 машину и для выполнения команд на удаленной машине.
296
297 Этот пакет содержит программы-клиенты, необходимые для установления
298 зашифрованных соединений с серверами SSH.
299
300 %description clients -l uk.UTF-8
301 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
302 машини та для виконання команд на віддаленій машині.
303
304 Цей пакет містить програми-клієнти, необхідні для встановлення
305 зашифрованих з'єднань з серверами SSH.
306
307 %package clients-agent-profile_d
308 Summary:        OpenSSH Secure Shell agent init script
309 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
310 Group:          Applications/Networking
311 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
312
313 %description clients-agent-profile_d
314 profile.d scripts for starting SSH agent.
315
316 %description clients-agent-profile_d -l pl.UTF-8
317 Skrypty profile.d do uruchamiania agenta SSH.
318
319 %package clients-agent-xinitrc
320 Summary:        OpenSSH Secure Shell agent init script
321 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
322 Group:          Applications/Networking
323 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
324 Requires:       xinitrc
325
326 %description clients-agent-xinitrc
327 xinitrc scripts for starting SSH agent.
328
329 %description clients-agent-xinitrc -l pl.UTF-8
330 Skrypty xinitrc do uruchamiania agenta SSH.
331
332 %package server
333 Summary:        OpenSSH Secure Shell protocol server (sshd)
334 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
335 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
336 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
337 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
338 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
339 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
340 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
341 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
342 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
343 Group:          Networking/Daemons
344 Requires(post): /sbin/chkconfig
345 Requires(post): grep
346 Requires(post,preun):   /sbin/chkconfig
347 Requires(postun):       /usr/sbin/userdel
348 Requires(pre):  /bin/id
349 Requires(pre):  /usr/sbin/useradd
350 Requires:       %{name} = %{epoch}:%{version}-%{release}
351 Requires:       pam >= %{pam_ver}
352 Requires:       rc-scripts >= 0.4.3.0
353 Requires:       util-linux
354 Suggests:       /bin/login
355 Provides:       ssh-server
356 Provides:       user(sshd)
357
358 %description server
359 Ssh (Secure Shell) a program for logging into a remote machine and for
360 executing commands in a remote machine. It is intended to replace
361 rlogin and rsh, and provide secure encrypted communications between
362 two untrusted hosts over an insecure network. X11 connections and
363 arbitrary TCP/IP ports can also be forwarded over the secure channel.
364
365 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
366 it up to date in terms of security and features, as well as removing
367 all patented algorithms to seperate libraries (OpenSSL).
368
369 This package contains the secure shell daemon. The sshd is the server
370 part of the secure shell protocol and allows ssh clients to connect to
371 your host.
372
373 %description server -l de.UTF-8
374 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
375
376 %description server -l es.UTF-8
377 Este paquete contiene el servidor SSH. sshd es la parte servidor del
378 protocolo secure shell y permite que clientes ssh se conecten a su
379 servidor.
380
381 %description server -l fr.UTF-8
382 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
383
384 %description server -l it.UTF-8
385 Questo pacchetto installa sshd, il server di OpenSSH.
386
387 %description server -l pl.UTF-8
388 Ssh (Secure Shell) to program służący do logowania się na zdalną
389 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
390 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
391 pomiędzy dwoma hostami.
392
393 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
394 ssh).
395
396 %description server -l pt.UTF-8
397 Este pacote intala o sshd, o servidor do OpenSSH.
398
399 %description server -l pt_BR.UTF-8
400 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
401 protocolo secure shell e permite que clientes ssh se conectem ao seu
402 host.
403
404 %description server -l ru.UTF-8
405 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
406 машину и для выполнения команд на удаленной машине.
407
408 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
409 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
410 вашим хостом.
411
412 %description server -l uk.UTF-8
413 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
414 машини та для виконання команд на віддаленій машині.
415
416 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
417 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
418 з вашим хостом.
419
420 %package server-upstart
421 Summary:        Upstart job description for OpenSSH server
422 Summary(pl.UTF-8):      Opis zadania Upstart dla serwera OpenSSH
423 Group:          Daemons
424 Requires:       %{name}-server = %{epoch}:%{version}-%{release}
425 Requires:       upstart >= 0.6
426
427 %description server-upstart
428 Upstart job description for OpenSSH.
429
430 %description server-upstart -l pl.UTF-8
431 Opis zadania Upstart dla OpenSSH.
432
433 %package gnome-askpass
434 Summary:        OpenSSH GNOME passphrase dialog
435 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
436 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
437 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
438 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
439 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
440 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
441 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
442 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
443 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
444 Group:          Applications/Networking
445 Requires:       %{name} = %{epoch}:%{version}-%{release}
446 Obsoletes:      openssh-askpass
447 Obsoletes:      ssh-askpass
448 Obsoletes:      ssh-extras
449
450 %description gnome-askpass
451 Ssh (Secure Shell) a program for logging into a remote machine and for
452 executing commands in a remote machine. It is intended to replace
453 rlogin and rsh, and provide secure encrypted communications between
454 two untrusted hosts over an insecure network. X11 connections and
455 arbitrary TCP/IP ports can also be forwarded over the secure channel.
456
457 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
458 it up to date in terms of security and features, as well as removing
459 all patented algorithms to seperate libraries (OpenSSL).
460
461 This package contains the GNOME passphrase dialog.
462
463 %description gnome-askpass -l es.UTF-8
464 Este paquete contiene un programa que abre una caja de diálogo para
465 entrada de passphrase en GNOME.
466
467 %description gnome-askpass -l pl.UTF-8
468 Ssh (Secure Shell) to program służący do logowania się na zdalną
469 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
470 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
471 pomiędzy dwoma hostami.
472
473 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
474
475 %description gnome-askpass -l pt_BR.UTF-8
476 Esse pacote contém um programa que abre uma caixa de diálogo para
477 entrada de passphrase no GNOME.
478
479 %description gnome-askpass -l ru.UTF-8
480 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
481 машину и для выполнения команд на удаленной машине.
482
483 Этот пакет содержит диалог ввода ключевой фразы для использования под
484 GNOME.
485
486 %description gnome-askpass -l uk.UTF-8
487 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
488 машини та для виконання команд на віддаленій машині.
489
490 Цей пакет містить діалог вводу ключової фрази для використання під
491 GNOME.
492
493 %package -n openldap-schema-openssh-lpk
494 Summary:        OpenSSH LDAP Public Key schema
495 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
496 Group:          Networking/Daemons
497 Requires(post,postun):  sed >= 4.0
498 Requires:       openldap-servers
499
500 %description -n openldap-schema-openssh-lpk
501 This package contains OpenSSH LDAP Public Key schema for openldap.
502
503 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
504 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
505 openldap-a.
506
507 %prep
508 %setup -q
509 %{?with_kerberos5:%patch100 -p1}
510 %patch0 -p1
511 %patch2 -p1
512 %patch3 -p1
513 %{?with_ldap:%patch4 -p1}
514 %patch5 -p1
515 %{?with_hpn:%patch9 -p1}
516 %patch10 -p1
517 %patch11 -p1
518 %patch12 -p1
519
520 %if "%{pld_release}" == "ac"
521 # fix for missing x11.pc
522 %{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
523 %endif
524
525 %build
526 cp /usr/share/automake/config.sub .
527 %{__aclocal}
528 %{__autoconf}
529 CPPFLAGS="-DCHROOT"
530 %configure \
531         PERL=%{__perl} \
532         --with-pam \
533         --with-mantype=man \
534         --with-md5-passwords \
535         --with-ipaddr-display \
536         %{?with_libedit:--with-libedit} \
537         --with-4in6 \
538         --with-tcp-wrappers \
539         %{?with_ldap:--with-libs="-lldap -llber"} \
540         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
541         %{?with_kerberos5:--with-kerberos5=/usr} \
542         --with-privsep-path=%{_privsepdir} \
543         --with-pid-dir=%{_localstatedir}/run \
544 %if "%{pld_release}" == "ac"
545         --with-xauth=/usr/X11R6/bin/xauth \
546 %else
547         --with-xauth=%{_bindir}/xauth \
548 %endif
549         --enable-utmpx \
550         --enable-wtmpx
551
552 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
553
554 %{__make}
555
556 cd contrib
557 %if %{with gnome}
558 %{__make} gnome-ssh-askpass1 \
559         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
560 %endif
561 %if %{with gtk}
562 %{__make} gnome-ssh-askpass2 \
563         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
564 %endif
565
566 %install
567 rm -rf $RPM_BUILD_ROOT
568 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
569         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
570 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
571
572 %{__make} install \
573         DESTDIR=$RPM_BUILD_ROOT
574
575 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
576
577 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
578 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
579 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
580 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
581 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
582 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
583 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
584
585 install %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
586
587 %if %{with gnome}
588 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
589 %endif
590 %if %{with gtk}
591 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
592 %endif
593 %if %{with gnome} || %{with gtk}
594 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
595 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
596 EOF
597 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
598 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
599 EOF
600 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
601 %endif
602
603 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
604 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
605
606 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
607 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
608
609 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
610
611 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
612 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
613 EOF
614
615 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
616 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
617
618 %clean
619 rm -rf $RPM_BUILD_ROOT
620
621 %post clients
622 %env_update
623
624 %postun clients
625 %env_update
626
627 %post gnome-askpass
628 %env_update
629
630 %postun gnome-askpass
631 %env_update
632
633 %pre server
634 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
635
636 %post server
637 /sbin/chkconfig --add sshd
638 %service sshd reload "openssh daemon"
639 if ! grep -qs ssh /etc/security/passwd.conf ; then
640         umask 022
641         echo "ssh" >> /etc/security/passwd.conf
642 fi
643
644 %preun server
645 if [ "$1" = "0" ]; then
646         %service sshd stop
647         /sbin/chkconfig --del sshd
648 fi
649
650 %postun server
651 if [ "$1" = "0" ]; then
652         %userremove sshd
653 fi
654
655 %post server-upstart
656 %upstart_post sshd
657
658 %postun server-upstart
659 %upstart_postun sshd
660
661 %post -n openldap-schema-openssh-lpk
662 %openldap_schema_register %{schemadir}/openssh-lpk.schema
663 %service -q ldap restart
664
665 %postun -n openldap-schema-openssh-lpk
666 if [ "$1" = "0" ]; then
667         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
668         %service -q ldap restart
669 fi
670
671 %files
672 %defattr(644,root,root,755)
673 %doc *.RNG TODO README OVERVIEW CREDITS Change*
674 %attr(755,root,root) %{_bindir}/ssh-key*
675 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
676 %{_mandir}/man1/ssh-key*.1*
677 %{_mandir}/man1/ssh-vulnkey*.1*
678 %dir %{_sysconfdir}
679 %dir %{_libexecdir}
680
681 %files clients
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_bindir}/ssh
684 %attr(755,root,root) %{_bindir}/slogin
685 %attr(755,root,root) %{_bindir}/sftp
686 %attr(755,root,root) %{_bindir}/ssh-agent
687 %attr(755,root,root) %{_bindir}/ssh-add
688 %attr(755,root,root) %{_bindir}/ssh-copy-id
689 %attr(755,root,root) %{_bindir}/scp
690 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
691 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
692 %{_mandir}/man1/scp.1*
693 %{_mandir}/man1/ssh.1*
694 %{_mandir}/man1/slogin.1*
695 %{_mandir}/man1/sftp.1*
696 %{_mandir}/man1/ssh-agent.1*
697 %{_mandir}/man1/ssh-add.1*
698 %{_mandir}/man1/ssh-copy-id.1*
699 %{_mandir}/man5/ssh_config.5*
700 %lang(it) %{_mandir}/it/man1/ssh.1*
701 %lang(it) %{_mandir}/it/man5/ssh_config.5*
702 %lang(pl) %{_mandir}/pl/man1/scp.1*
703 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
704
705 # for host-based auth (suid required for accessing private host key)
706 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
707 #%{_mandir}/man8/ssh-keysign.8*
708
709 %files clients-agent-profile_d
710 %defattr(644,root,root,755)
711 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
712 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
713
714 %files clients-agent-xinitrc
715 %defattr(644,root,root,755)
716 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
717
718 %files server
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_sbindir}/sshd
721 %attr(755,root,root) %{_libexecdir}/sftp-server
722 %attr(755,root,root) %{_libexecdir}/ssh-keysign
723 %attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
724 %{_mandir}/man8/sshd.8*
725 %{_mandir}/man8/sftp-server.8*
726 %{_mandir}/man8/ssh-keysign.8*
727 %{_mandir}/man8/ssh-pkcs11-helper.8*
728 %{_mandir}/man5/sshd_config.5*
729 %{_mandir}/man5/moduli.5*
730 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
732 %attr(640,root,root) %{_sysconfdir}/moduli
733 %attr(754,root,root) /etc/rc.d/init.d/sshd
734 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
736
737 %if %{with gnome} || %{with gtk}
738 %files gnome-askpass
739 %defattr(644,root,root,755)
740 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
741 %dir %{_libexecdir}/ssh
742 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
743 %attr(755,root,root) %{_libexecdir}/ssh-askpass
744 %endif
745
746 %if %{with ldap}
747 %files -n openldap-schema-openssh-lpk
748 %defattr(644,root,root,755)
749 %{schemadir}/openssh-lpk.schema
750 %endif
751
752 %if "%{pld_release}" != "ti"
753 %files server-upstart
754 %defattr(644,root,root,755)
755 %config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
756 %endif
This page took 2.905551 seconds and 3 git commands to generate.