]> git.pld-linux.org Git - packages/openssh.git/blame - openssh.spec
- xorg fix for ac
[packages/openssh.git] / openssh.spec
CommitLineData
2ebfbf87
ER
1# TODO
2# - configure: WARNING: unrecognized options: --with-dns, --disable-suid-ssh
3#
2ca913e8 4# Conditional build:
f6c7fa07 5%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
cd53fc87 6%bcond_without gtk # without GTK+ (2.x)
b32891d6 7%bcond_without ldap # with ldap support
f6c7fa07 8%bcond_without libedit # without libedit (editline/history support in sftp client)
9cfed0b2 9%bcond_without kerberos5 # without kerberos5 support
70329622 10%bcond_without selinux # build without SELinux support
5c609334 11%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
516496e1 12
cef904f1
JB
13# gtk2-based gnome-askpass means no gnome1-based
14%{?with_gtk:%undefine with_gnome}
cc788d8e 15
2ebfbf87
ER
16%if "%{pld_release}" == "ac"
17%define pam_ver 0.79.0
18%else
19%define pam_ver 0.99.7.1
20%endif
21
52000378 22Summary: OpenSSH free Secure Shell (SSH) implementation
25e16946
ER
23Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
24Summary(es.UTF-8): Implementación libre de SSH
25Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
26Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
27Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
28Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29Summary(pt_BR.UTF-8): Implementação livre do SSH
30Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
31Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
52000378 32Name: openssh
6b22dba3
AM
33Version: 5.5p1
34Release: 1
f5fc6a92 35Epoch: 2
5d1c7089 36License: BSD
37Group: Applications/Networking
6481986b 38Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
6b22dba3 39# Source0-md5: 88633408f4cb1eb11ec7e2ec58b519eb
486d736c
JR
40Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41# Source1-md5: 66943d481cc422512b537bcc2c7400d1
42Source2: %{name}d.init
43Source3: %{name}d.pamd
44Source4: %{name}.sysconfig
45Source5: ssh-agent.sh
46Source6: ssh-agent.conf
b32891d6 47Source7: %{name}-lpk.schema
2ebfbf87 48Patch100: %{name}-heimdal.patch
89eac7b5 49Patch0: %{name}-no_libnsl.patch
8d59ede4
JB
50Patch2: %{name}-pam_misc.patch
51Patch3: %{name}-sigpipe.patch
b32891d6
JR
52# http://code.google.com/p/openssh-lpk/
53Patch4: %{name}-lpk.patch
8d59ede4 54Patch5: %{name}-config.patch
8d59ede4 55Patch7: %{name}-selinux.patch
0a069c2e 56# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
0d5b2bd4
ER
57# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
58Patch9: %{name}-5.2p1-hpn13v6.diff
8d59ede4 59Patch10: %{name}-include.patch
100234b3 60Patch11: %{name}-chroot.patch
342ae3ba 61# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
cc788d8e 62Patch12: %{name}-blacklist.diff
e9cfdffe 63URL: http://www.openssh.com/
0a069c2e 64BuildRequires: %{__perl}
92d612e6 65BuildRequires: autoconf
8f12ae30 66BuildRequires: automake
9cfed0b2 67%{?with_gnome:BuildRequires: gnome-libs-devel}
68%{?with_gtk:BuildRequires: gtk+2-devel}
044fff96 69%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
f6c7fa07 70%{?with_libedit:BuildRequires: libedit-devel}
70329622 71%{?with_selinux:BuildRequires: libselinux-devel}
a14c109c 72BuildRequires: libwrap-devel
044fff96 73%{?with_ldap:BuildRequires: openldap-devel}
b12dd014 74BuildRequires: openssl-devel >= 0.9.7d
92d612e6 75BuildRequires: pam-devel
9cfed0b2 76%{?with_gtk:BuildRequires: pkgconfig}
2ebfbf87 77BuildRequires: rpm >= 4.4.9-56
9be30b5d 78BuildRequires: rpmbuild(macros) >= 1.318
a42c5034 79BuildRequires: sed >= 4.0
a14c109c 80BuildRequires: zlib-devel
2ebfbf87
ER
81%if "%{pld_release}" == "ac"
82Requires: filesystem >= 2.0-1
83Requires: pam >= 0.79.0
84%else
680fc8d4 85Requires: filesystem >= 3.0-11
2ebfbf87 86Requires: pam >= %{pam_ver}
35844bbb 87Suggests: openssh-blacklist
a9abed26 88Suggests: xorg-app-xauth
2ebfbf87 89%endif
f937b661 90Obsoletes: ssh
05fbd2e9 91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52000378 92
b7b47957 93%define _sysconfdir /etc/ssh
1dd7cf18 94%define _libexecdir %{_libdir}/%{name}
a14c109c 95%define _privsepdir /usr/share/empty
b32891d6 96%define schemadir /usr/share/openldap/schema
6fe24471
AF
97
98%description
99Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 100executing commands in a remote machine. It is intended to replace
101rlogin and rsh, and provide secure encrypted communications between
102two untrusted hosts over an insecure network. X11 connections and
103arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 104
11530f15 105OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
106it up to date in terms of security and features, as well as removing
107all patented algorithms to seperate libraries (OpenSSL).
6fe24471 108
11530f15 109This package includes the core files necessary for both the OpenSSH
110client and server. To make this package useful, you should also
111install openssh-clients, openssh-server, or both.
a42c5034 112
0d5b2bd4 113%if %{with hpn}
0a069c2e 114This release includes High Performance SSH/SCP patches from
a42c5034
ER
115http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
116increase throughput on fast connections with high RTT (20-150 msec).
088aab43 117See the website for '-w' values for your connection and /proc/sys TCP
118values. BTW. in a LAN you have got generally RTT < 1 msec.
119%endif
6fe24471 120
84ae85a3 121%description -l de.UTF-8
aebfac88
JB
122OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
123ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
84ae85a3
JR
124verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
125über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
126andere TCP/IP Ports können ebenso über den sicheren Channel
aebfac88
JB
127weitergeleitet werden.
128
84ae85a3
JR
129%description -l es.UTF-8
130SSH es un programa para accesar y ejecutar órdenes en computadores
131remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
6c34819e 132seguro entre dos servidores en una red insegura. Conexiones X11 y
84ae85a3 133puertas TCP/IP arbitrárias también pueden ser usadas por el canal
6c34819e 134seguro.
135
136OpenSSH es el resultado del trabajo del equipo de OpenBSD para
84ae85a3
JR
137continuar la última versión gratuita de SSH, actualizándolo en
138términos de seguridad y recursos,así también eliminando todos los
139algoritmos patentados y colocándolos en bibliotecas separadas
6c34819e 140(OpenSSL).
141
142Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
84ae85a3 143también el paquete openssh-clients u openssh-server o ambos.
6c34819e 144
84ae85a3
JR
145%description -l fr.UTF-8
146OpenSSH (Secure Shell) fournit un accès à un système distant. Il
aebfac88 147remplace telnet, rlogin, rexec et rsh, tout en assurant des
84ae85a3
JR
148communications cryptées securisées entre deux hôtes non fiabilisés sur
149un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
150arbitraires peuvent également être transmis sur le canal sécurisé.
aebfac88 151
84ae85a3 152%description -l it.UTF-8
aebfac88
JB
153OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
154Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
155sicure e crittate tra due host non fidati su una rete non sicura. Le
156connessioni X11 ad una porta TCP/IP arbitraria possono essere
157inoltrate attraverso un canale sicuro.
158
84ae85a3
JR
159%description -l pl.UTF-8
160Ssh (Secure Shell) to program służący do logowania się na zdalną
161maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
162zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
163pomiędzy dwoma hostami.
93e2d77c 164
84ae85a3
JR
165Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
166klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
167co najmniej jeden z pakietów: openssh-clients lub openssh-server.
a42c5034 168
0d5b2bd4 169%if %{with hpn}
84ae85a3
JR
170Ta wersja zawiera łaty z projektu High Performance SSH/SCP
171http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
a42c5034
ER
172zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
173RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
174danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
175TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
088aab43 176%endif
aebfac88 177
84ae85a3 178%description -l pt.UTF-8
aebfac88 179OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
84ae85a3
JR
180telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
181cifradas entre duas máquinas sem confiança mútua sobre uma rede
182insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
aebfac88
JB
183reenviados pelo canal seguro.
184
84ae85a3
JR
185%description -l pt_BR.UTF-8
186SSH é um programa para acessar e executar comandos em máquinas
187remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
188seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
189TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
6c34819e 190
84ae85a3
JR
191OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
192última versão gratuita do SSH, atualizando-o em termos de segurança e
6c34819e 193recursos, assim como removendo todos os algoritmos patenteados e
194colocando-os em bibliotecas separadas (OpenSSL).
195
84ae85a3
JR
196Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
197também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
198
199%description -l ru.UTF-8
200Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
201машину и для выполнения команд на удаленной машине. Она предназначена
202для замены rlogin и rsh и обеспечивает безопасную шифрованную
203коммуникацию между двумя хостами в сети, являющейся небезопасной.
204Соединения X11 и любые порты TCP/IP могут также быть проведены через
205безопасный канал.
206
207OpenSSH - это переделка командой разработчиков OpenBSD последней
208свободной версии SSH, доведенная до современного состояния в терминах
209уровня безопасности и поддерживаемых возможностей. Все патентованные
210алгоритмы вынесены в отдельные библиотеки (OpenSSL).
211
212Этот пакет содержит файлы, необходимые как для клиента, так и для
213сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
214openssh-server, или оба пакета.
215
216%description -l uk.UTF-8
217Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
218машини та для виконання команд на віддаленій машині. Вона призначена
219для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
220між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
221довільні порти TCP/IP можуть також бути проведені через безпечний
222канал.
223
224OpenSSH - це переробка командою розробників OpenBSD останньої вільної
225версії SSH, доведена до сучасного стану в термінах рівня безпеки та
226підтримуваних можливостей. Всі патентовані алгоритми винесені до
227окремих бібліотек (OpenSSL).
228
229Цей пакет містить файли, необхідні як для клієнта, так і для сервера
230OpenSSH. Вам потрібно буде ще встановити openssh-clients,
231openssh-server, чи обидва пакети.
cb086001 232
52000378
AF
233%package clients
234Summary: OpenSSH Secure Shell protocol clients
25e16946
ER
235Summary(es.UTF-8): Clientes de OpenSSH
236Summary(pl.UTF-8): Klienci protokołu Secure Shell
237Summary(pt_BR.UTF-8): Clientes do OpenSSH
238Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
239Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
52000378 240Group: Applications/Networking
f1608a0c 241Requires: %{name}
516496e1 242Provides: ssh-clients
a14c109c 243Obsoletes: ssh-clients
6fe24471 244
52000378
AF
245%description clients
246Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 247executing commands in a remote machine. It is intended to replace
248rlogin and rsh, and provide secure encrypted communications between
249two untrusted hosts over an insecure network. X11 connections and
250arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 251
11530f15 252OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
253it up to date in terms of security and features, as well as removing
254all patented algorithms to seperate libraries (OpenSSL).
52000378 255
11530f15 256This package includes the clients necessary to make encrypted
257connections to SSH servers.
52000378 258
84ae85a3 259%description clients -l es.UTF-8
6c34819e 260Este paquete incluye los clientes que se necesitan para hacer
261conexiones codificadas con servidores SSH.
262
84ae85a3
JR
263%description clients -l pl.UTF-8
264Ssh (Secure Shell) to program służący do logowania się na zdalną
265maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
266zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
267pomiędzy dwoma hostami.
93e2d77c 268
84ae85a3 269Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
93e2d77c 270
84ae85a3
JR
271%description clients -l pt_BR.UTF-8
272Esse pacote inclui os clientes necessários para fazer conexões
6c34819e 273encriptadas com servidores SSH.
274
84ae85a3
JR
275%description clients -l ru.UTF-8
276Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
277машину и для выполнения команд на удаленной машине.
cb086001 278
84ae85a3
JR
279Этот пакет содержит программы-клиенты, необходимые для установления
280зашифрованных соединений с серверами SSH.
cb086001 281
84ae85a3
JR
282%description clients -l uk.UTF-8
283Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
284машини та для виконання команд на віддаленій машині.
cb086001 285
84ae85a3
JR
286Цей пакет містить програми-клієнти, необхідні для встановлення
287зашифрованих з'єднань з серверами SSH.
cb086001 288
8a7ba6eb
AM
289%package clients-agent-profile_d
290Summary: OpenSSH Secure Shell agent init script
4944be5f 291Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
8a7ba6eb
AM
292Group: Applications/Networking
293Requires: %{name}-clients = %{epoch}:%{version}-%{release}
294
295%description clients-agent-profile_d
296profile.d scripts for starting SSH agent.
297
4944be5f
JB
298%description clients-agent-profile_d -l pl.UTF-8
299Skrypty profile.d do uruchamiania agenta SSH.
300
8a7ba6eb
AM
301%package clients-agent-xinitrc
302Summary: OpenSSH Secure Shell agent init script
303Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
304Group: Applications/Networking
305Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
306Requires: xinitrc
307
308%description clients-agent-xinitrc
309xinitrc scripts for starting SSH agent.
310
4944be5f
JB
311%description clients-agent-xinitrc -l pl.UTF-8
312Skrypty xinitrc do uruchamiania agenta SSH.
8a7ba6eb 313
52000378
AF
314%package server
315Summary: OpenSSH Secure Shell protocol server (sshd)
25e16946
ER
316Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
317Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
318Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
319Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
320Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
321Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
322Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
323Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
324Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
52000378 325Group: Networking/Daemons
2ebfbf87 326Requires(post): /sbin/chkconfig
40cb2e83 327Requires(post): grep
0a069c2e 328Requires(post,preun): /sbin/chkconfig
9b604401 329Requires(postun): /usr/sbin/userdel
0a069c2e
ER
330Requires(pre): /bin/id
331Requires(pre): /usr/sbin/useradd
332Requires: %{name} = %{epoch}:%{version}-%{release}
2ebfbf87 333Requires: pam >= %{pam_ver}
aa0e4c97 334Requires: rc-scripts >= 0.4.1.23
0a069c2e 335Requires: util-linux
0d5b2bd4 336Suggests: /bin/login
516496e1
ER
337Provides: ssh-server
338Provides: user(sshd)
52000378
AF
339
340%description server
341Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 342executing commands in a remote machine. It is intended to replace
343rlogin and rsh, and provide secure encrypted communications between
344two untrusted hosts over an insecure network. X11 connections and
345arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 346
11530f15 347OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
348it up to date in terms of security and features, as well as removing
349all patented algorithms to seperate libraries (OpenSSL).
52000378 350
11530f15 351This package contains the secure shell daemon. The sshd is the server
352part of the secure shell protocol and allows ssh clients to connect to
353your host.
6fe24471 354
84ae85a3 355%description server -l de.UTF-8
aebfac88
JB
356Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
357
84ae85a3 358%description server -l es.UTF-8
6c34819e 359Este paquete contiene el servidor SSH. sshd es la parte servidor del
360protocolo secure shell y permite que clientes ssh se conecten a su
361servidor.
362
84ae85a3 363%description server -l fr.UTF-8
aebfac88
JB
364Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
365
84ae85a3 366%description server -l it.UTF-8
aebfac88
JB
367Questo pacchetto installa sshd, il server di OpenSSH.
368
84ae85a3
JR
369%description server -l pl.UTF-8
370Ssh (Secure Shell) to program służący do logowania się na zdalną
371maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
372zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
373pomiędzy dwoma hostami.
93e2d77c 374
84ae85a3 375Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
11530f15 376ssh).
93e2d77c 377
84ae85a3 378%description server -l pt.UTF-8
aebfac88
JB
379Este pacote intala o sshd, o servidor do OpenSSH.
380
84ae85a3
JR
381%description server -l pt_BR.UTF-8
382Esse pacote contém o servidor SSH. O sshd é a parte servidor do
6c34819e 383protocolo secure shell e permite que clientes ssh se conectem ao seu
384host.
385
84ae85a3
JR
386%description server -l ru.UTF-8
387Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
388машину и для выполнения команд на удаленной машине.
cb086001 389
84ae85a3
JR
390Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
391часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
392вашим хостом.
cb086001 393
84ae85a3
JR
394%description server -l uk.UTF-8
395Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
396машини та для виконання команд на віддаленій машині.
cb086001 397
84ae85a3
JR
398Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
399частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
400з вашим хостом.
cb086001 401
6e70f4f7 402%package gnome-askpass
52000378 403Summary: OpenSSH GNOME passphrase dialog
25e16946
ER
404Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
405Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
406Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
407Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
408Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
409Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
410Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
411Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
412Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
52000378 413Group: Applications/Networking
96f686c2 414Requires: %{name} = %{epoch}:%{version}-%{release}
f937b661 415Obsoletes: openssh-askpass
0a069c2e
ER
416Obsoletes: ssh-askpass
417Obsoletes: ssh-extras
52000378 418
6e70f4f7 419%description gnome-askpass
52000378 420Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 421executing commands in a remote machine. It is intended to replace
422rlogin and rsh, and provide secure encrypted communications between
423two untrusted hosts over an insecure network. X11 connections and
424arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 425
11530f15 426OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
427it up to date in terms of security and features, as well as removing
428all patented algorithms to seperate libraries (OpenSSL).
52000378
AF
429
430This package contains the GNOME passphrase dialog.
431
84ae85a3
JR
432%description gnome-askpass -l es.UTF-8
433Este paquete contiene un programa que abre una caja de diálogo para
6c34819e 434entrada de passphrase en GNOME.
435
84ae85a3
JR
436%description gnome-askpass -l pl.UTF-8
437Ssh (Secure Shell) to program służący do logowania się na zdalną
438maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
439zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
440pomiędzy dwoma hostami.
93e2d77c 441
84ae85a3 442Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
93e2d77c 443
84ae85a3
JR
444%description gnome-askpass -l pt_BR.UTF-8
445Esse pacote contém um programa que abre uma caixa de diálogo para
6c34819e 446entrada de passphrase no GNOME.
447
84ae85a3
JR
448%description gnome-askpass -l ru.UTF-8
449Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
450машину и для выполнения команд на удаленной машине.
cb086001 451
84ae85a3 452Этот пакет содержит диалог ввода ключевой фразы для использования под
cb086001 453GNOME.
454
84ae85a3
JR
455%description gnome-askpass -l uk.UTF-8
456Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
457машини та для виконання команд на віддаленій машині.
cb086001 458
84ae85a3 459Цей пакет містить діалог вводу ключової фрази для використання під
cb086001 460GNOME.
461
b32891d6
JR
462%package -n openldap-schema-openssh-lpk
463Summary: OpenSSH LDAP Public Key schema
464Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
465Group: Networking/Daemons
466Requires(post,postun): sed >= 4.0
467Requires: openldap-servers
468
469%description -n openldap-schema-openssh-lpk
470This package contains OpenSSH LDAP Public Key schema for openldap.
471
472%description -n openldap-schema-openssh-lpk -l pl.UTF-8
0d5b2bd4
ER
473Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
474openldap-a.
b32891d6 475
52000378 476%prep
ecf377a3 477%setup -q
2ebfbf87 478%{?with_kerberos5:%patch100 -p1}
4946f6e5 479%patch0 -p1
1aca01a4 480%patch2 -p1
200ba837 481%patch3 -p1
8d59ede4
JB
482%{?with_ldap:%patch4 -p1}
483%patch5 -p1
8d59ede4 484%patch7 -p1
516496e1 485%{?with_hpn:%patch9 -p1}
8d59ede4 486%patch10 -p1
100234b3 487%patch11 -p1
35844bbb 488%patch12 -p1
52000378 489
a42c5034
ER
490%if "%{pld_release}" == "ac"
491# fix for missing x11.pc
492%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
493%endif
494
52000378 495%build
64f1c35c 496cp /usr/share/automake/config.sub .
0b24ec17 497%{__aclocal}
5c76eb87 498%{__autoconf}
37aa5700 499CPPFLAGS="-DCHROOT"
52000378 500%configure \
c59fae24 501 PERL=%{__perl} \
ad852e00 502 --with-dns \
41897191
AM
503 --with-pam \
504 --with-mantype=man \
f9bf943b 505 --with-md5-passwords \
4946f6e5 506 --with-ipaddr-display \
f6c7fa07 507 %{?with_libedit:--with-libedit} \
93e2d77c 508 --with-4in6 \
41897191 509 --disable-suid-ssh \
06b95d40 510 --with-tcp-wrappers \
9cfed0b2 511 %{?with_ldap:--with-libs="-lldap -llber"} \
512 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
4a5c0c7d 513 %{?with_kerberos5:--with-kerberos5=/usr} \
a14c109c 514 --with-privsep-path=%{_privsepdir} \
05fbd2e9 515 --with-pid-dir=%{_localstatedir}/run \
2ebfbf87
ER
516%if "%{pld_release}" == "ac"
517 --with-xauth=/usr/X11R6/bin/xauth \
518%else
c7963a12 519 --with-xauth=/usr/bin/xauth \
2ebfbf87 520%endif
c7963a12
JR
521 --enable-utmpx \
522 --enable-wtmpx
82f989ae 523
b8002dec 524echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
f9bf943b 525
100832a0 526%{__make}
475ef6df 527
40cb2e83 528cd contrib
9cfed0b2 529%if %{with gnome}
40cb2e83
JB
530%{__make} gnome-ssh-askpass1 \
531 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
532%endif
9cfed0b2 533%if %{with gtk}
40cb2e83
JB
534%{__make} gnome-ssh-askpass2 \
535 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
536%endif
6fe24471
AF
537
538%install
539rm -rf $RPM_BUILD_ROOT
1d1e6997 540install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
b32891d6 541 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
8a7ba6eb 542install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
52000378 543
9a2a459a
PG
544%{__make} install \
545 DESTDIR=$RPM_BUILD_ROOT
0d32b20f 546
486d736c 547bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
40cb2e83 548
486d736c
JR
549install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
550install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
551install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
552install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
553ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
554install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
b32891d6 555install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
2b7669a6 556
9cfed0b2 557%if %{with gnome}
40cb2e83
JB
558install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
559%endif
9cfed0b2 560%if %{with gtk}
40cb2e83 561install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
1d1e6997
PG
562%endif
563%if %{with gnome} || %{with gtk}
6157007b 564cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
1d1e6997
PG
565#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
566EOF
6157007b 567cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
1d1e6997
PG
568#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
569EOF
4ae0bc0d 570ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
40cb2e83 571%endif
6e70f4f7 572
0906c8d0 573install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
574install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
575
8e700b6b 576rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
5f72fe6f 577echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
41897191 578
ffbc041f 579touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
643dc12f 580
b8002dec 581cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
1d1e6997
PG
582#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
583EOF
584
92815192
ER
585rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
586rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
587
6fe24471
AF
588%clean
589rm -rf $RPM_BUILD_ROOT
590
b259ae2c
ER
591%post clients
592%env_update
593
594%postun clients
595%env_update
596
597%post gnome-askpass
598%env_update
599
600%postun gnome-askpass
601%env_update
602
8a304ceb 603%pre server
0225d3b8 604%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
4c8ae2f8 605
52000378 606%post server
d7fde396 607/sbin/chkconfig --add sshd
2c99507e 608%service sshd reload "openssh daemon"
40cb2e83
JB
609if ! grep -qs ssh /etc/security/passwd.conf ; then
610 umask 022
ec00afd0
JR
611 echo "ssh" >> /etc/security/passwd.conf
612fi
6fe24471 613
52000378 614%preun server
d7fde396 615if [ "$1" = "0" ]; then
b054de44 616 %service sshd stop
d7fde396 617 /sbin/chkconfig --del sshd
618fi
6fe24471 619
9b604401
JB
620%postun server
621if [ "$1" = "0" ]; then
5f4ffc90 622 %userremove sshd
9b604401
JB
623fi
624
7073aeeb
JR
625%post -n openldap-schema-openssh-lpk
626%openldap_schema_register %{schemadir}/openssh-lpk.schema
627%service -q ldap restart
628
629%postun -n openldap-schema-openssh-lpk
630if [ "$1" = "0" ]; then
631 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
632 %service -q ldap restart
633fi
634
6fe24471 635%files
52000378 636%defattr(644,root,root,755)
7cc45b9b 637%doc *.RNG TODO README OVERVIEW CREDITS Change*
a6eef44c 638%attr(755,root,root) %{_bindir}/ssh-key*
35844bbb 639%attr(755,root,root) %{_bindir}/ssh-vulnkey*
a6eef44c 640%{_mandir}/man1/ssh-key*.1*
35844bbb 641%{_mandir}/man1/ssh-vulnkey*.1*
52000378 642%dir %{_sysconfdir}
9df62d0f 643%dir %{_libexecdir}
52000378
AF
644
645%files clients
646%defattr(644,root,root,755)
96f686c2
JB
647%attr(755,root,root) %{_bindir}/ssh
648%attr(755,root,root) %{_bindir}/slogin
649%attr(755,root,root) %{_bindir}/sftp
650%attr(755,root,root) %{_bindir}/ssh-agent
651%attr(755,root,root) %{_bindir}/ssh-add
0906c8d0 652%attr(755,root,root) %{_bindir}/ssh-copy-id
96f686c2 653%attr(755,root,root) %{_bindir}/scp
794e0987
JB
654%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
655%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
52000378
AF
656%{_mandir}/man1/scp.1*
657%{_mandir}/man1/ssh.1*
41897191 658%{_mandir}/man1/slogin.1*
a6eef44c 659%{_mandir}/man1/sftp.1*
52000378
AF
660%{_mandir}/man1/ssh-agent.1*
661%{_mandir}/man1/ssh-add.1*
0906c8d0 662%{_mandir}/man1/ssh-copy-id.1*
902cef13 663%{_mandir}/man5/ssh_config.5*
2b7669a6 664%lang(it) %{_mandir}/it/man1/ssh.1*
665%lang(it) %{_mandir}/it/man5/ssh_config.5*
666%lang(pl) %{_mandir}/pl/man1/scp.1*
667%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
ec82f607
JB
668
669# for host-based auth (suid required for accessing private host key)
670#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
671#%{_mandir}/man8/ssh-keysign.8*
52000378 672
8a7ba6eb
AM
673%files clients-agent-profile_d
674%defattr(644,root,root,755)
675%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
676%attr(755,root,root) /etc/profile.d/ssh-agent.sh
677
678%files clients-agent-xinitrc
679%defattr(644,root,root,755)
680%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
681
52000378
AF
682%files server
683%defattr(644,root,root,755)
684%attr(755,root,root) %{_sbindir}/sshd
a6eef44c 685%attr(755,root,root) %{_libexecdir}/sftp-server
ad852e00 686%attr(755,root,root) %{_libexecdir}/ssh-keysign
50835229 687%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
52000378 688%{_mandir}/man8/sshd.8*
a6eef44c 689%{_mandir}/man8/sftp-server.8*
ad852e00 690%{_mandir}/man8/ssh-keysign.8*
50835229 691%{_mandir}/man8/ssh-pkcs11-helper.8*
902cef13 692%{_mandir}/man5/sshd_config.5*
78aa4c3c 693%{_mandir}/man5/moduli.5*
794e0987
JB
694%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
695%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
634d69b4 696%attr(640,root,root) %{_sysconfdir}/moduli
52000378 697%attr(754,root,root) /etc/rc.d/init.d/sshd
794e0987
JB
698%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
699%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
52000378 700
0d32b20f 701%if %{with gnome} || %{with gtk}
40cb2e83
JB
702%files gnome-askpass
703%defattr(644,root,root,755)
794e0987 704%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
40cb2e83
JB
705%dir %{_libexecdir}/ssh
706%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
4ae0bc0d 707%attr(755,root,root) %{_libexecdir}/ssh-askpass
40cb2e83 708%endif
b32891d6
JR
709
710%if %{with ldap}
711%files -n openldap-schema-openssh-lpk
712%defattr(644,root,root,755)
713%{schemadir}/openssh-lpk.schema
714%endif
This page took 0.217111 seconds and 4 git commands to generate.