]> git.pld-linux.org Git - packages/openscad.git/commitdiff
- build fixes for boost 1.73 and gcc 10 auto/th/openscad-2019.05-5
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 7 Aug 2020 23:42:02 +0000 (01:42 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 7 Aug 2020 23:42:02 +0000 (01:42 +0200)
- rel 5

boost-1.73.patch [new file with mode: 0644]
gcc10.patch [new file with mode: 0644]
openscad.spec

diff --git a/boost-1.73.patch b/boost-1.73.patch
new file mode 100644 (file)
index 0000000..64b3d05
--- /dev/null
@@ -0,0 +1,10 @@
+--- openscad-2019.05/src/import.cc~    2019-03-31 06:14:41.000000000 +0200
++++ openscad-2019.05/src/import.cc     2020-08-08 01:19:22.113104409 +0200
+@@ -50,7 +50,6 @@
+ #include <boost/assign/std/vector.hpp>
+ using namespace boost::assign; // bring 'operator+=()' into scope
+-#include <boost/detail/endian.hpp>
+ #include <cstdint>
+ extern PolySet * import_amf(std::string, const Location &loc);
diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644 (file)
index 0000000..7b396a5
--- /dev/null
@@ -0,0 +1,10 @@
+--- openscad-2019.05/src/parser.y~     2019-04-07 17:45:27.000000000 +0200
++++ openscad-2019.05/src/parser.y      2020-08-08 01:27:32.558842432 +0200
+@@ -46,6 +46,7 @@
+ #include "printutils.h"
+ #include "memory.h"
+ #include <sstream>
++#include <stack>
+ #include <boost/filesystem.hpp>
+ #include "boost-utils.h"
index cef92ecaac13c21da09bae7c2f5e9c3486c1feb8..92f643faeafe4106ceb9906e2a4a1db71d6d371b 100644 (file)
@@ -8,7 +8,7 @@
 Summary:       The Programmers Solid 3D CAD Modeller
 Name:          openscad
 Version:       2019.05
-Release:       4
+Release:       5
 # COPYING contains a linking exception for CGAL
 # Appdata file is CC0
 # Examples are CC0
@@ -18,6 +18,8 @@ Source0:      http://files.openscad.org/%{name}-%{version}.src.tar.gz
 # Source0-md5: 2b63e249d56e2eba62ed5b042e1d82bc
 Patch0:                %{name}-polyclipping.patch
 Patch1:                localedir.patch
+Patch2:                boost-1.73.patch
+Patch3:                gcc10.patch
 URL:           http://www.openscad.org/
 BuildRequires: Qt5Network-devel
 BuildRequires: Qt5Concurrent-devel
@@ -148,6 +150,8 @@ expect some API changes, however many things are already working.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 # use system package
 %{__rm} -r src/ext/polyclipping
This page took 0.09673 seconds and 4 git commands to generate.