]> git.pld-linux.org Git - packages/openscad.git/blob - openscad.spec
- initial; based on FC; TODO: fix locales
[packages/openscad.git] / openscad.spec
1 %bcond_with     tests
2 Name:           openscad
3 Version:        2015.03.1
4 %global upversion 2015.03-1
5 Summary:        The Programmers Solid 3D CAD Modeller
6 Release:        0.1
7 # COPYING contains a linking exception for CGAL
8 # Appdata file is CC0
9 # Examples are CC0
10 License:        GPLv2 with exceptions and CC0
11 Group:          Applications/Engineering
12 URL:            http://www.openscad.org/
13 Source0:        http://files.openscad.org/%{name}-%{upversion}.src.tar.gz
14 # Source0-md5:  c5994220078f5f5c13984da304e4a2fe
15 Patch0:         %{name}-polyclipping.patch
16 BuildRequires:  CGAL-devel >= 3.6
17 BuildRequires:  ImageMagick
18 BuildRequires:  Mesa-dri-driver-swrast
19 BuildRequires:  bison >= 2.4
20 BuildRequires:  boost-devel >= 1.35
21 BuildRequires:  desktop-file-utils
22 BuildRequires:  eigen3
23 BuildRequires:  flex >= 2.5.35
24 BuildRequires:  fontconfig-devel >= 2.10
25 BuildRequires:  freetype-devel >= 2.4
26 BuildRequires:  gettext
27 BuildRequires:  glew-devel >= 1.6
28 BuildRequires:  glib2-devel
29 BuildRequires:  gmp-devel >= 5.0.0
30 BuildRequires:  harfbuzz-devel >= 0.9.19
31 BuildRequires:  mpfr-devel >= 3.0.0
32 BuildRequires:  opencsg-devel >= 1.3.2
33 BuildRequires:  polyclipping-devel >= 6.1.3
34 BuildRequires:  procps
35 BuildRequires:  python
36 BuildRequires:  qscintilla2-devel
37 BuildRequires:  qt4-build >= 4.4
38 BuildRequires:  xorg-xserver-Xvfb
39 Requires:       font(liberationmono)
40 Requires:       font(liberationsans)
41 Requires:       font(liberationserif)
42
43 %description
44 OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
45 free software for creating 3D models (such as the famous application
46 Blender) it does not focus on the artistic aspects of 3D modeling but
47 instead on the CAD aspects. Thus it might be the application you are
48 looking for when you are planning to create 3D models of machine parts
49 but pretty sure is not what you are looking for when you are more
50 interested in creating computer-animated movies.
51
52
53 ###############################################
54 %package        MCAD
55 Summary:        OpenSCAD Parametric CAD Library
56 License:        LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
57 URL:            https://www.github.com/openscad/MCAD
58 Requires:       %{name} = %{version}-%{release}
59 BuildArch:      noarch
60
61 %description    MCAD
62 This library contains components commonly used in designing and
63 moching up mechanical designs. It is currently unfinished and you can
64 expect some API changes, however many things are already working.
65
66 ### LICENSES:
67
68 ## LGPLv2+: # 2Dshapes.scad # 3d_triangle.scad # fonts.scad #
69 gridbeam.scad # hardware.scad # libtriangles.scad # multiply.scad #
70 shapes.scad # screw.scad
71
72 ## LGPLv2: # gears.scad # involute_gears.scad # servos.scad #
73 transformations.scad # triangles.scad # unregular_shapes.scad #
74 bitmap/letter_necklace.scad
75
76 ## LGPLv3+: # teardrop.scad
77
78 ## GPLv3 or LGPLv2: # motors.scad # nuts_and_bolts.scad
79
80
81 ## GPLv3+ or LGPLv2: # metric_fastners.scad # regular_shapes.scad
82
83 ## CC-BY-SA or LGPLv2+: # bearing.scad # materials.scad # stepper.scad
84 # utilities.scad
85
86 ## CC-BY-SA or LGPLv2: # units.scad
87
88 ## CC-BY: # polyholes.scad # bitmap/alphabet_block.scad #
89 bitmap/bitmap.scad # bitmap/height_map.scad # bitmap/name_tag.scad
90
91 ## BSD # boxes.scad
92
93 ## MIT # constants.scad # curves.scad # math.scad
94
95 ## Public Domain # lego_compatibility.scad # trochoids.scad
96
97 ###############################################
98
99 %prep
100 %setup -qn %{name}-%{upversion}
101 %patch0 -p1
102
103 rm -rf src/polyclipping
104
105 %build
106 qmake-qt4 \
107         PREFIX=%{_prefix}
108 %{__make}
109
110 # tests
111 cd tests
112 install -d build
113 cd build
114 %{__cmake} ..
115 %{__make}
116 cd ../..
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} -j1 install \
122         INSTALL_ROOT=$RPM_BUILD_ROOT
123
124 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
125
126 :> %{name}.lang
127 # TODO: fix this to find the files
128 #%find_lang %{name}
129
130 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
131 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
132 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
133
134 %if %{with tests}
135 cd tests
136 ctest
137 cd ..
138 %endif
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc README.md RELEASE_NOTES
143 %attr(755,root,root) %{_bindir}/%{name}
144 %{_datadir}/appdata/*.xml
145 %{_desktopdir}/%{name}.desktop
146 %{_pixmapsdir}/%{name}.png
147 %{_datadir}/mime/packages/%{name}.xml
148 %dir %{_datadir}/%{name}
149 %{_datadir}/%{name}/examples
150 %{_datadir}/%{name}/color-schemes
151 %dir %{_datadir}/%{name}/locale
152 # drop when find_lang is fixed
153 %{_datadir}/%{name}/locale/*
154 %dir %{_datadir}/%{name}/libraries
155 %{_mandir}/man1/*
156
157 %files MCAD
158 %defattr(644,root,root,755)
159 %doc libraries/MCAD/README.markdown libraries/MCAD/TODO
160 %{_datadir}/%{name}/libraries/MCAD
161
162 %changelog
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
This page took 0.074283 seconds and 4 git commands to generate.