]> git.pld-linux.org Git - packages/opensc.git/blame_incremental - opensc.spec
- converted to UTF-8
[packages/opensc.git] / opensc.spec
... / ...
CommitLineData
1Summary: OpenSC library - for accessing SmartCard devices using PC/SC Lite
2Summary(pl.UTF-8): Biblioteka OpenSC - do korzystania z kart procesorowych przy użyciu PC/SC Lite
3Name: opensc
4Version: 0.11.1
5Release: 2
6Epoch: 0
7License: LGPL
8Group: Applications
9Source0: http://www.opensc-project.org/files/opensc/%{name}-%{version}.tar.gz
10# Source0-md5: 94ce00a6bda38fac10ab06f5d5d1a8c3
11Patch0: %{name}-explorer-debug.patch
12Patch1: %{name}-libassuan.patch
13URL: http://www.opensc-project.org/
14BuildRequires: autoconf >= 2.52
15BuildRequires: automake
16BuildRequires: libassuan-devel >= 1:0.6.0
17BuildRequires: libltdl-devel
18BuildRequires: libtool >= 1:1.4.2-9
19BuildRequires: openct-devel
20BuildRequires: openldap-devel
21BuildRequires: openssl-devel >= 0.9.7d
22BuildRequires: pcsc-lite-devel
23BuildRequires: pkgconfig >= 1:0.9.0
24BuildRequires: readline-devel
25BuildRequires: rpmbuild(macros) >= 1.236
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28# datadir is used for config files and (editable) profiles
29%define _datadir /etc
30%define _sysconfdir /etc/opensc
31%define _plugindir %{_libdir}/browser-plugins
32
33# TODO: galeon and skipstone.
34# use macro, otherwise extra LF inserted along with the ifarch
35%define browsers mozilla, mozilla-firefox, konqueror, opera, seamonkey
36
37%description
38libopensc is a library for accessing SmartCard devices using PC/SC
39Lite middleware package. It is also the core library of the OpenSC
40project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
41work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
42using private keys on the SmartCard is at the moment possible only
43with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
44IDentity) card manufactured by Setec.
45
46%description -l pl.UTF-8
47libopensc to biblioteka do korzystania z kart procesorowych przy
48użyciu pakietu warstwy pośredniej PC/SC Lite. Jest to także podstawowa
49biblioteka projektu OpenSC. Podstawowa funkcjonalność (np. SELECT
50FILE, READ BINARY) powinna działać także z dowolną kartą procesorową
51zgodną z ISO-7816-4. Szyfrowanie i odszyfrowywanie przy użyciu
52prywatnych kluczy na karcie na razie jest możliwe tylko przy użyciu
53kart kompatybilnych z PKCS#16, takich jak FINEID (Finnish Electronic
54IDentity) produkowanych przez Setec.
55
56%package devel
57Summary: OpenSC development files
58Summary(pl.UTF-8): Pliki dla programistów używających OpenSC
59Group: Development/Tools
60Requires: %{name} = %{epoch}:%{version}-%{release}
61Requires: libltdl-devel
62Requires: openct-devel
63Requires: openssl-devel
64Requires: pcsc-lite-devel
65
66%description devel
67OpenSC development files.
68
69%description devel -l pl.UTF-8
70Pliki dla programistów używających OpenSC.
71
72%package static
73Summary: Static OpenSC libraries
74Summary(pl.UTF-8): Bibloteki statyczne OpenSC
75Group: Development/Tools
76Requires: %{name}-devel = %{epoch}:%{version}-%{release}
77
78%description static
79Static OpenSC libraries.
80
81%description static -l pl.UTF-8
82Statyczne biblioteki OpenSC.
83
84%package -n browser-plugin-opensc
85Summary: OpenSC Signer plugin for Mozilla
86Summary(pl.UTF-8): Wtyczka OpenSC Signer dla Mozilli
87Group: X11/Applications
88Requires: %{name} = %{epoch}:%{version}-%{release}
89Requires: browser-plugins(%{_target_base_arch})
90Requires: pinentry-gtk
91Provides: mozilla-plugin-opensc
92Obsoletes: mozilla-plugin-opensc
93
94%description -n browser-plugin-opensc
95OpenSC Signer browser plugin.
96
97Supported browsers: %{browsers}.
98
99%description -n browser-plugin-opensc -l pl.UTF-8
100Wtyczka OpenSC Signer dla przeglądarek.
101
102Obsługiwane przeglądarki: %{browsers}.
103
104%prep
105%setup -q
106%patch0 -p1
107%patch1 -p1
108
109%build
110touch config.rpath
111%{__libtoolize}
112%{__aclocal} -I aclocal
113%{__autoconf}
114%{__autoheader}
115%{__automake}
116%configure \
117 --with-pin-entry=/usr/bin/pinentry-gtk \
118 --with-plugin-dir="%{_plugindir}"
119
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124install -d $RPM_BUILD_ROOT%{_plugindir}
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
129# just install instead of symlinking
130rm -f $RPM_BUILD_ROOT%{_plugindir}/opensc-signer.so
131mv -f $RPM_BUILD_ROOT%{_libdir}/opensc-signer.so $RPM_BUILD_ROOT%{_plugindir}
132
133# default config
134install etc/opensc.conf $RPM_BUILD_ROOT%{_sysconfdir}
135
136# useless (dlopened by *.so)
137rm -f $RPM_BUILD_ROOT%{_libdir}/{opensc,pkcs11}-*.{a,la} \
138 $RPM_BUILD_ROOT%{_libdir}/opensc/*.{a,la}
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%triggerin -n browser-plugin-opensc -- mozilla-firefox
147%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins opensc-signer.so
148
149%triggerun -n browser-plugin-opensc -- mozilla-firefox
150%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins opensc-signer.so
151
152%triggerin -n browser-plugin-opensc -- mozilla
153%nsplugin_install -d %{_libdir}/mozilla/plugins opensc-signer.so
154
155%triggerun -n browser-plugin-opensc -- mozilla
156%nsplugin_uninstall -d %{_libdir}/mozilla/plugins opensc-signer.so
157
158%triggerin -n browser-plugin-opensc -- opera
159%nsplugin_install -d %{_libdir}/opera/plugins opensc-signer.so
160
161%triggerun -n browser-plugin-opensc -- opera
162%nsplugin_uninstall -d %{_libdir}/opera/plugins opensc-signer.so
163
164%triggerin -n browser-plugin-opensc -- konqueror
165%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror opensc-signer.so
166
167%triggerun -n browser-plugin-opensc -- konqueror
168%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror opensc-signer.so
169
170%triggerin -n browser-plugin-opensc -- seamonkey
171%nsplugin_install -d %{_libdir}/seamonkey/plugins opensc-signer.so
172
173%triggerun -n browser-plugin-opensc -- seamonkey
174%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins opensc-signer.so
175
176# as rpm removes the old obsoleted package files after the triggers
177# are ran, add another trigger to make the links there.
178%triggerpostun -n browser-plugin-opensc -- mozilla-plugin-opensc
179%nsplugin_install -f -d %{_libdir}/mozilla/plugins opensc-signer.so
180
181%files
182%defattr(644,root,root,755)
183%doc NEWS README doc/ChangeLog doc/{*.{html,css},html/tools.html}
184%attr(755,root,root) %{_bindir}/cardos-info
185%attr(755,root,root) %{_bindir}/cryptoflex-tool
186%attr(755,root,root) %{_bindir}/eidenv
187%attr(755,root,root) %{_bindir}/netkey-tool
188%attr(755,root,root) %{_bindir}/opensc-explorer
189%attr(755,root,root) %{_bindir}/opensc-tool
190%attr(755,root,root) %{_bindir}/piv-tool
191%attr(755,root,root) %{_bindir}/pkcs11-tool
192%attr(755,root,root) %{_bindir}/pkcs15-*
193%attr(755,root,root) %{_libdir}/lib*.so.*.*
194%attr(755,root,root) %{_libdir}/opensc-pkcs11.so
195%attr(755,root,root) %{_libdir}/pkcs11-spy.so
196%dir %{_datadir}/opensc
197%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
198%config(noreplace) %verify(not md5 mtime size) %{_datadir}/opensc/*.profile
199%{_mandir}/man1/cardos-info.1*
200%{_mandir}/man1/cryptoflex-tool.1*
201%{_mandir}/man1/netkey-tool.1*
202%{_mandir}/man1/opensc-explorer.1*
203%{_mandir}/man1/opensc-tool.1*
204%{_mandir}/man1/pkcs11-tool.1*
205%{_mandir}/man1/pkcs15-*.1*
206%{_mandir}/man[57]/*
207
208%files devel
209%defattr(644,root,root,755)
210%doc doc/html/api.html
211%attr(755,root,root) %{_bindir}/opensc-config
212%attr(755,root,root) %{_libdir}/libopensc.so
213%attr(755,root,root) %{_libdir}/libpkcs15init.so
214%attr(755,root,root) %{_libdir}/libscconf.so
215%{_libdir}/libopensc.la
216%{_libdir}/libpkcs15init.la
217%{_libdir}/libscconf.la
218%{_includedir}/opensc
219%{_pkgconfigdir}/*.pc
220%{_mandir}/man1/opensc-config.1*
221%{_mandir}/man3/*
222
223%files static
224%defattr(644,root,root,755)
225%{_libdir}/libopensc.a
226%{_libdir}/libpkcs15init.a
227%{_libdir}/libscconf.a
228
229%files -n browser-plugin-opensc
230%defattr(644,root,root,755)
231%attr(755,root,root) %{_plugindir}/opensc-signer.so
This page took 0.064294 seconds and 4 git commands to generate.