]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- added c patch (C compatibility for legacy headers)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 10 Mar 2011 17:05:07 +0000 (17:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 7

Changed files:
    opencv-c.patch -> 1.1
    opencv.spec -> 1.26

opencv-c.patch [new file with mode: 0644]
opencv.spec

diff --git a/opencv-c.patch b/opencv-c.patch
new file mode 100644 (file)
index 0000000..52256d1
--- /dev/null
@@ -0,0 +1,21 @@
+--- OpenCV-2.2.0/modules/legacy/include/opencv2/legacy/blobtrack.hpp.orig      2010-12-05 04:35:25.000000000 +0100
++++ OpenCV-2.2.0/modules/legacy/include/opencv2/legacy/blobtrack.hpp   2011-03-09 19:14:52.579414618 +0100
+@@ -47,6 +47,9 @@
+ //#if _MSC_VER >= 1200
+ #include "opencv2/core/core_c.h"
++
++#ifdef __cplusplus
++
+ #include <stdio.h>
+ #if _MSC_VER >= 1200 || defined __BORLANDC__
+@@ -943,6 +946,8 @@
+ CV_EXPORTS void cvTestSeqAddIntensityVariation(CvTestSeq* pTestSeq, float DI_per_frame, float MinI, float MaxI);
+ CV_EXPORTS void cvTestSeqSetFrame(CvTestSeq* pTestSeq, int n);
++#endif /* __cplusplus */
++
+ #endif
+ /* End of file. */
index 7160feead680c881ff55bbaed9d64520ca883a53..3285a1995cfd5c9e498246eccc4ac43c16dc978e 100644 (file)
@@ -12,7 +12,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       2.2.0
-Release:       6
+Release:       7
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -26,6 +26,7 @@ Patch0:               %{name}-multilib.patch
 Patch1:                %{name}-cflags.patch
 Patch2:                %{name}-link.patch
 Patch3:                %{name}-unicap-c++.patch
+Patch4:                %{name}-c.patch
 URL:           http://opencv.willowgarage.com/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 BuildRequires: OpenEXR-devel
@@ -138,6 +139,7 @@ Wiązania Pythona do OpenCV.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 install -d build
This page took 0.517863 seconds and 4 git commands to generate.