]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- added opengl bcond
[packages/opencv.git] / opencv.spec
1 #
2 # TODO:
3 # - OpenCL
4 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ ?)
5 # - CUDA support (on bcond)
6 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
7 #
8 # Conditional build:
9 # - general options:
10 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
11 %bcond_with     sse             # use SSE instructions
12 %bcond_with     sse2            # use SSE2 instructions
13 # - highgui options:
14 %bcond_without  gstreamer       # GStreamer support in highgui
15 %bcond_without  opengl          # OpenGL support
16 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
17 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
18 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
19 %bcond_with     unicap          # Unicap support in highgui (GPL)
20 %bcond_with     v4l             # Video4Linux in highgui (even V4L2 support currently relies on V4L1 API)
21 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
22 %bcond_with     xine            # XINE support in highgui (GPL)
23 #
24 %ifarch pentium3 pentium4 %{x8664}
25 %define         with_sse        1
26 %endif
27 %ifarch pentium4 %{x8664}
28 %define         with_sse2       1
29 %endif
30 Summary:        A library of programming functions mainly aimed at real time computer vision
31 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
32 Name:           opencv
33 Version:        2.4.3
34 Release:        1
35 Epoch:          1
36 %if %{with unicap} || %{with xine}
37 License:        GPL (enforced by used libraries), BSD (opencv itself)
38 %else
39 License:        BSD
40 %endif
41 Group:          Libraries
42 Source0:        http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz2
43 # Source0-md5:  c0a5af4ff9d0d540684c0bf00ef35dbe
44 Patch0:         %{name}-cflags.patch
45 Patch1:         %{name}-link.patch
46 Patch2:         %{name}-unicap-c++.patch
47 Patch3:         %{name}-c.patch
48 Patch4:         %{name}-gcc.patch
49 Patch5:         %{name}-ximea.patch
50 URL:            http://opencv.willowgarage.com/
51 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
52 BuildRequires:  OpenEXR-devel
53 %{?with_opengl:BuildRequires:   OpenGL-devel}
54 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
55 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
56 %{?with_openni:BuildRequires:   OpenNI-devel}
57 %{?with_ximea:BuildRequires:    XIMEA-devel}
58 BuildRequires:  cmake >= 2.4
59 BuildRequires:  doxygen
60 BuildRequires:  eigen3 >= 3
61 BuildRequires:  ffmpeg-devel >= 0.7
62 %if %{with gstreamer}
63 BuildRequires:  gstreamer-devel >= 0.10
64 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
65 %endif
66 BuildRequires:  jasper-devel
67 BuildRequires:  libdc1394-devel
68 BuildRequires:  libjpeg-devel
69 BuildRequires:  libpng-devel
70 BuildRequires:  libraw1394-devel
71 BuildRequires:  libstdc++-devel
72 BuildRequires:  libtiff-devel
73 BuildRequires:  libtool
74 %if %{with unicap}
75 BuildRequires:  libucil-devel
76 BuildRequires:  libunicap-devel
77 %endif
78 BuildRequires:  libv4l-devel
79 BuildRequires:  pkgconfig
80 BuildRequires:  python-devel
81 BuildRequires:  python-numpy-devel
82 BuildRequires:  rpm-pythonprov
83 BuildRequires:  rpmbuild(macros) >= 1.606
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  swig-python
86 %{?with_tbb:BuildRequires:      tbb-devel}
87 %{?with_xine:BuildRequires:     xine-lib-devel}
88 BuildRequires:  zlib-devel
89 %if %{with qt}
90 BuildRequires:  QtCore-devel >= 4
91 BuildRequires:  QtGui-devel >= 4
92 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
93 BuildRequires:  qt4-qmake >= 4
94 %else
95 BuildRequires:  gtk+2-devel >= 2.0
96 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
97 %endif
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 OpenCV (Open Source Computer Vision) is a library of programming
102 functions mainly aimed at real time computer vision.
103
104 Example applications of the OpenCV library are:
105 - Human-Computer Interaction (HCI)
106 - Object Identification, Segmentation and Recognition
107 - Face Recognition
108 - Gesture Recognition
109 - Motion Tracking
110 - Ego Motion, Motion Understanding
111 - Structure From Motion (SFM)
112 - Stereo and Multi-Camera Calibration and Depth Computation
113 - Mobile Robotics.
114
115 %description -l pl.UTF-8
116 OpenCV (Open Source Computer Vision) to biblioteka funkcji
117 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
118
119 Przykładowe zastosowania biblioteki OpenCV to
120 - interakcje człowiek-komputer (HCI)
121 - identyfikacja, segmentacja i rozpoznawanie obiektów
122 - rozpoznawanie twarzy
123 - rozpoznawanie gestów
124 - śledzenie ruchu
125 - rozumienie ruchu
126 - SFM (Structure From Motion)
127 - kalibracja dwu- i wielokamerowa, obliczanie głębi
128 - robotyka ruchu.
129
130 %package devel
131 Summary:        Header files for OpenCV library
132 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
133 Group:          Development/Libraries
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 Obsoletes:      opencv-static
136
137 %description devel
138 Header files for OpenCV library.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe biblioteki OpenCV.
142
143 %package -n python-opencv
144 Summary:        OpenCV Python bindings
145 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
146 Group:          Libraries/Python
147 Requires:       %{name} = %{epoch}:%{version}-%{release}
148 %pyrequires_eq  python-libs
149
150 %description -n python-opencv
151 OpenCV Python bindings.
152
153 %description -n python-opencv -l pl.UTF-8
154 Wiązania Pythona do OpenCV.
155
156 %prep
157 %setup -q -n OpenCV-%{version}
158
159 %undos CMakeLists.txt
160 %undos modules/gpu/CMakeLists.txt
161
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165 %patch3 -p1
166 %patch4 -p1
167 %patch5 -p1
168
169 %build
170 install -d build
171 cd build
172 %cmake .. \
173         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
174         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
175         -DBUILD_NEW_PYTHON_SUPPORT=ON \
176         -DUSE_O3=OFF \
177         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
178         %{?with_opengl:-DWITH_OPENGL=ON} \
179         %{?with_openni:-DWITH_OPENNI=ON} \
180         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
181         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
182         %{?with_tbb:-DWITH_TBB=ON} \
183         %{?with_unicap:-DWITH_UNICAP=ON} \
184         %{!?with_v4l:-DWITH_V4L=OFF} \
185         %{?with_ximea:-DWITH_XIMEA=ON} \
186         %{?with_xine:-DWITH_XINE=ON}
187
188 %{__make}
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192
193 %{__make} -C build install \
194         DESTDIR=$RPM_BUILD_ROOT
195
196 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
197 install build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
198
199 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
200 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
201 %py_postclean
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post   -p /sbin/ldconfig
207 %postun -p /sbin/ldconfig
208
209 %files
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/opencv_*
212 %attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.4
214 %dir %{_datadir}/OpenCV
215 %doc %{_datadir}/OpenCV/doc
216 %{_datadir}/OpenCV/haarcascades
217 %{_datadir}/OpenCV/lbpcascades
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libopencv_*.so
222 %{_includedir}/opencv
223 %{_includedir}/opencv2
224 %{_datadir}/OpenCV/OpenCVConfig*.cmake
225 %{_pkgconfigdir}/opencv.pc
226
227 %files -n python-opencv
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{py_sitedir}/cv2.so
230 %{py_sitedir}/cv.py[co]
This page took 0.049669 seconds and 4 git commands to generate.