]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
cd4cb8ff9530ff5d1839ac310f34ddeeb3728cfe
[packages/opencv.git] / opencv.spec
1 #
2 # TODO:
3 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
4 # - CUDA support (on bcond)
5 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
6 #
7 # Conditional build:
8 # - general options:
9 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
10 %bcond_with     sse             # use SSE instructions
11 %bcond_with     sse2            # use SSE2 instructions
12 %bcond_without  opencl          # OpenCL support
13 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
14 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
15 %bcond_without  opengl          # OpenGL support
16 # - bindings
17 %bcond_without  java            # Java binding
18 # - highgui options:
19 %bcond_without  ffmpeg          # FFMpeg support in highgui
20 %bcond_without  gstreamer       # GStreamer support in highgui
21 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
22 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
23 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
24 %bcond_with     unicap          # Unicap support in highgui (GPL)
25 %bcond_with     v4l             # Video4Linux in highgui (even V4L2 support currently relies on V4L1 API)
26 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
27 %bcond_with     xine            # XINE support in highgui (GPL)
28
29 %ifarch pentium3 pentium4 %{x8664}
30 %define         with_sse        1
31 %endif
32 %ifarch pentium4 %{x8664}
33 %define         with_sse2       1
34 %endif
35 Summary:        A library of programming functions mainly aimed at real time computer vision
36 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
37 Name:           opencv
38 Version:        2.4.6.2
39 Release:        1
40 Epoch:          1
41 %if %{with unicap} || %{with xine}
42 License:        GPL (enforced by used libraries), BSD (opencv itself)
43 %else
44 License:        BSD
45 %endif
46 Group:          Libraries
47 Source0:        https://github.com/Itseez/opencv/archive/%{version}.tar.gz
48 # Source0-md5:  b9cb3420fa715c2e23f012d42a9b0988
49 Patch0:         %{name}-cflags.patch
50 Patch1:         %{name}-link.patch
51 Patch2:         %{name}-unicap-c++.patch
52 Patch3:         %{name}-c.patch
53 Patch4:         %{name}-gcc.patch
54 Patch5:         %{name}-ximea.patch
55 Patch6:         %{name}-ocl-fft.patch
56 Patch7:         java-ant-sourcelevel.patch
57 URL:            http://opencv.willowgarage.com/
58 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
59 %{?with_opencl:BuildRequires:   OpenCL-devel}
60 BuildRequires:  OpenEXR-devel
61 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
62 %{?with_opengl:BuildRequires:   OpenGL-devel}
63 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
64 %{?with_openni:BuildRequires:   OpenNI-devel}
65 %{?with_ximea:BuildRequires:    XIMEA-devel}
66 %{?with_java:BuildRequires:     ant}
67 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
68 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
69 BuildRequires:  cmake >= 2.8
70 BuildRequires:  doxygen
71 BuildRequires:  eigen3 >= 3
72 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
73 %if %{with gstreamer}
74 BuildRequires:  gstreamer-devel >= 0.10
75 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
76 %endif
77 BuildRequires:  jasper-devel
78 %{?with_java:BuildRequires:     jdk}
79 BuildRequires:  libdc1394-devel
80 BuildRequires:  libjpeg-devel
81 BuildRequires:  libpng-devel
82 BuildRequires:  libraw1394-devel
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libtiff-devel
85 BuildRequires:  libtool
86 %if %{with unicap}
87 BuildRequires:  libucil-devel
88 BuildRequires:  libunicap-devel
89 %endif
90 BuildRequires:  libv4l-devel
91 BuildRequires:  pkgconfig
92 BuildRequires:  python
93 BuildRequires:  python-devel
94 BuildRequires:  python-numpy-devel
95 BuildRequires:  rpm-pythonprov
96 BuildRequires:  rpmbuild(macros) >= 1.606
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  swig-python
99 %{?with_tbb:BuildRequires:      tbb-devel}
100 %{?with_xine:BuildRequires:     xine-lib-devel}
101 BuildRequires:  zlib-devel
102 %if %{with qt}
103 BuildRequires:  QtCore-devel >= 4
104 BuildRequires:  QtGui-devel >= 4
105 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
106 BuildRequires:  qt4-qmake >= 4
107 %else
108 BuildRequires:  gtk+2-devel >= 2.0
109 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
110 %endif
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 # build broken, can't find g++
114 %undefine       with_ccache
115
116 %description
117 OpenCV (Open Source Computer Vision) is a library of programming
118 functions mainly aimed at real time computer vision.
119
120 Example applications of the OpenCV library are:
121 - Human-Computer Interaction (HCI)
122 - Object Identification, Segmentation and Recognition
123 - Face Recognition
124 - Gesture Recognition
125 - Motion Tracking
126 - Ego Motion, Motion Understanding
127 - Structure From Motion (SFM)
128 - Stereo and Multi-Camera Calibration and Depth Computation
129 - Mobile Robotics.
130
131 %description -l pl.UTF-8
132 OpenCV (Open Source Computer Vision) to biblioteka funkcji
133 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
134
135 Przykładowe zastosowania biblioteki OpenCV to
136 - interakcje człowiek-komputer (HCI)
137 - identyfikacja, segmentacja i rozpoznawanie obiektów
138 - rozpoznawanie twarzy
139 - rozpoznawanie gestów
140 - śledzenie ruchu
141 - rozumienie ruchu
142 - SFM (Structure From Motion)
143 - kalibracja dwu- i wielokamerowa, obliczanie głębi
144 - robotyka ruchu.
145
146 %package devel
147 Summary:        Header files for OpenCV library
148 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
149 Group:          Development/Libraries
150 Requires:       %{name} = %{epoch}:%{version}-%{release}
151 Obsoletes:      opencv-static
152
153 %description devel
154 Header files for OpenCV library.
155
156 %description devel -l pl.UTF-8
157 Pliki nagłówkowe biblioteki OpenCV.
158
159 %package doc
160 Summary:        Manual for OpenCV
161 Summary(fr.UTF-8):      Documentation pour OpenCV
162 Summary(it.UTF-8):      Documentazione di OpenCV
163 Summary(pl.UTF-8):      Podręcznik dla OpenCV
164 Group:          Documentation
165 # noarch subpackages only when building with rpm5
166 %if "%{_rpmversion}" >= "5"
167 BuildArch:      noarch
168 %endif
169
170 %description doc
171 Documentation for OpenCV.
172
173 %description doc -l fr.UTF-8
174 Documentation pour OpenCV.
175
176 %description doc -l it.UTF-8
177 Documentazione di OpenCV.
178
179 %description doc -l pl.UTF-8
180 Dokumentacja do OpenCV.
181
182 %package -n java-opencv
183 Summary:        OpenCV Java bindings
184 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
185 Group:          Libraries/Java
186 Requires:       %{name} = %{epoch}:%{version}-%{release}
187 Requires:       jre
188
189 %description -n java-opencv
190 OpenCV Java bindings.
191
192 %description -n java-opencv -l pl.UTF-8
193 Wiązania Javy do OpenCV.
194
195 %package -n python-opencv
196 Summary:        OpenCV Python bindings
197 Summary(pl.UTF-8):      Wiązania Pythona do OpenCV
198 Group:          Libraries/Python
199 Requires:       %{name} = %{epoch}:%{version}-%{release}
200 Requires:       python-libs
201
202 %description -n python-opencv
203 OpenCV Python bindings.
204
205 %description -n python-opencv -l pl.UTF-8
206 Wiązania Pythona do OpenCV.
207
208 %prep
209 %setup -q
210
211 %undos CMakeLists.txt
212 %undos modules/gpu/CMakeLists.txt
213
214 %patch0 -p1
215 %patch1 -p1
216 %patch2 -p1
217 %patch3 -p1
218 %patch4 -p1
219 %patch5 -p1
220 %patch6 -p1
221 %patch7 -p1
222
223 %build
224 install -d build
225 cd build
226 %cmake .. \
227         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
228         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
229         -DBUILD_NEW_PYTHON_SUPPORT=ON \
230         -DUSE_O3=OFF \
231         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
232         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
233         %{?with_opencl:-DWITH_OPENCL=ON} \
234         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
235         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
236         %{?with_opengl:-DWITH_OPENGL=ON} \
237         %{?with_openni:-DWITH_OPENNI=ON} \
238         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
239         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
240         %{?with_tbb:-DWITH_TBB=ON} \
241         %{?with_unicap:-DWITH_UNICAP=ON} \
242         %{!?with_v4l:-DWITH_V4L=OFF} \
243         %{?with_ximea:-DWITH_XIMEA=ON} \
244         %{?with_xine:-DWITH_XINE=ON}
245
246 %{__make}
247
248 %install
249 rm -rf $RPM_BUILD_ROOT
250 %{__make} -C build install \
251         DESTDIR=$RPM_BUILD_ROOT
252
253 # see -doc package
254 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/OpenCV/doc
255
256 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
257 cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
258
259 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
260 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
261 %py_postclean
262
263 %if %{with java}
264 # move to proper directories, create symlink
265 install -d $RPM_BUILD_ROOT%{_javadir}
266 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
267 %{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
268 rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
269 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
270 %endif
271
272 %clean
273 rm -rf $RPM_BUILD_ROOT
274
275 %post   -p /sbin/ldconfig
276 %postun -p /sbin/ldconfig
277
278 %post   -n java-opencv -p /sbin/ldconfig
279 %postun -n java-opencv -p /sbin/ldconfig
280
281 %files
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_bindir}/opencv_*
284 %attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
285 %attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.4
286 %dir %{_datadir}/OpenCV
287 %{_datadir}/OpenCV/haarcascades
288 %{_datadir}/OpenCV/lbpcascades
289
290 %files devel
291 %defattr(644,root,root,755)
292 %attr(755,root,root) %{_libdir}/libopencv_*.so
293 %if %{with java}
294 %exclude %{_libdir}/libopencv_java246.so
295 %endif
296 %{_includedir}/opencv
297 %{_includedir}/opencv2
298 %{_datadir}/OpenCV/OpenCVConfig*.cmake
299 %{_pkgconfigdir}/opencv.pc
300
301 %files doc
302 %defattr(644,root,root,755)
303 # TODO: probably could rebuild them and package via make install
304 %doc doc/*
305
306 %if %{with java}
307 %files -n java-opencv
308 %defattr(644,root,root,755)
309 %attr(755,root,root) %{_libdir}/libopencv_java246.so
310 %{_javadir}/opencv-246.jar
311 %{_javadir}/opencv.jar
312 %endif
313
314 %files -n python-opencv
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{py_sitedir}/cv2.so
317 %{py_sitedir}/cv.py[co]
This page took 0.05894 seconds and 3 git commands to generate.