]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- TODO
[packages/opencv.git] / opencv.spec
1 #
2 # TODO: re-enable static libs
3 #
4 %bcond_with     xine
5 Summary:        A library of programming functions mainly aimed at real time computer vision
6 Name:           opencv
7 Version:        2.1.0
8 Release:        1
9 Epoch:          1
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}.tar.bz2
13 # Source0-md5:  1d71584fb4e04214c0085108f95e24c8
14 Patch0:         %{name}-2.0.0-libpng14.patch
15 Patch1:         %{name}-2.1.0-mmap.patch
16 Patch2:         %{name}-2.1.0-multilib.patch
17 Patch3:         %{name}-cflags.patch
18 URL:            http://opencv.willowgarage.com
19 BuildRequires:  cmake
20 BuildRequires:  ffmpeg-devel
21 BuildRequires:  jasper-devel
22 BuildRequires:  libdc1394-devel
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  libraw1394-devel
26 BuildRequires:  libtiff-devel
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-devel
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  swig-python
32 BuildRequires:  zlib-devel
33 %pyrequires_eq  python-libs
34 %{?with_xine:BuildRequires:     xine-lib-devel}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 OpenCV (Open Source Computer Vision) is a library of programming
39 functions mainly aimed at real time computer vision.
40
41 Example applications of the OpenCV library are Human-Computer
42 Interaction (HCI); Object Identification, Segmentation and
43 Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
44 Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
45 and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
46
47 %package devel
48 Summary:        Header files and develpment documentation for opencv
49 Group:          Development/Libraries
50 Requires:       %{name} = %{epoch}:%{version}-%{release}
51
52 %description devel
53 Header files and opencv documentation.
54
55 %package static
56 Summary:        Static opencv library
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
59
60 %description static
61 This package contains the static library used for development.
62
63 %package -n python-opencv
64 Summary:        OpenCV Python bindings
65 Group:          Development/Languages/Python
66 %pyrequires_eq  python
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68
69 %description -n python-opencv
70 OpenCV Python bindings.
71
72 %prep
73 %setup -q -n OpenCV-%{version}
74
75 %undos src/ml/CMakeLists.txt
76 %undos CMakeLists.txt
77 %undos src/cv/CMakeLists.txt
78 %undos src/cxcore/CMakeLists.txt
79
80 %patch0 -p0
81 %patch1 -p0
82 %patch2 -p1
83 %patch3 -p1
84
85 %build
86 install -d build
87 cd build
88 %cmake \
89         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
90 %ifarch i686 pentium4 athlon %{x8664}
91         -DENABLE_SSE2=ON \
92 %endif
93         -DBUILD_NEW_PYTHON_SUPPORT=ON \
94 %if %{with xine}
95         -DWITH_XINE=ON \
96 %endif
97         -DWITH_GSTREAMER=OFF \
98         -DWITH_1394=ON \
99         -DWITH_FFMPEG=ON \
100         -DWITH_GTK=ON \
101         -DWITH_V4L=ON \
102 %if "%{_lib}" == "lib64"
103         -DLIB_SUFFIX=64 \
104 %endif
105         ../
106
107 %{__make} \
108         VERBOSE=1
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} -C build install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
117 install build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/lib*so.*.*
129 %attr(755,root,root) %ghost %{_libdir}/lib*.so.2.1
130 %dir %{_datadir}/opencv
131 %{_datadir}/opencv/doc
132 %{_datadir}/opencv/haarcascades
133 %{_datadir}/opencv/lbpcascades
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/lib*.so
138 %{_includedir}/opencv
139 %{_datadir}/opencv/OpenCVConfig.cmake
140 %{_pkgconfigdir}/*.pc
141
142 #%files static
143 #%defattr(644,root,root,755)
144 #%{_libdir}/lib*.a
145
146 %files -n python-opencv
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{py_sitedir}/cv.so
This page took 0.034186 seconds and 3 git commands to generate.