]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
081a005c8046e99cb86a8b25bd5e4a24e4f429cc
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        4.5.1
63 Release:        1
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  2205d3169238ec1f184438a96de68513
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  19a31bf7271978ab426112dbf5d1b83f
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 # See opencv-4.5.1/modules/gapi/CMakeLists.txt
103 Source40:       https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104 # Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
105 Patch0:         %{name}-ximea.patch
106 Patch1:         python-install.patch
107 URL:            http://www.opencv.org/
108 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
109 %{?with_opencl:BuildRequires:   OpenCL-devel}
110 BuildRequires:  OpenEXR-devel
111 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
112 %{?with_opengl:BuildRequires:   OpenGL-devel}
113 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
114 %{?with_openni:BuildRequires:   OpenNI-devel}
115 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
116 %{?with_java:BuildRequires:     ant}
117 BuildRequires:  boost-devel
118 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
119 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
120 BuildRequires:  cmake >= 2.8
121 BuildRequires:  doxygen
122 BuildRequires:  eigen3 >= 3
123 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
124 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
125 BuildRequires:  gflags-devel
126 BuildRequires:  gl2ps-devel
127 BuildRequires:  glog-devel
128 %if %{with gstreamer}
129 BuildRequires:  gstreamer-devel >= 1.0
130 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
131 %endif
132 BuildRequires:  jasper-devel
133 %{?with_java:BuildRequires:     jdk}
134 BuildRequires:  libdc1394-devel >= 2
135 %{?with_openmp:BuildRequires:   libgomp-devel}
136 BuildRequires:  libjpeg-devel
137 BuildRequires:  libpng-devel
138 BuildRequires:  libraw1394-devel
139 BuildRequires:  libstdc++-devel
140 BuildRequires:  libtiff-devel
141 BuildRequires:  libtool
142 %if %{with unicap}
143 BuildRequires:  libucil-devel
144 BuildRequires:  libunicap-devel
145 %endif
146 BuildRequires:  libv4l-devel
147 BuildRequires:  pkgconfig
148 BuildRequires:  protobuf-devel
149 BuildRequires:  python >= 2.0
150 BuildRequires:  python-devel >= 2.0
151 BuildRequires:  python-numpy-devel
152 BuildRequires:  python3 >= 1:3.2
153 BuildRequires:  python3-devel >= 1:3.2
154 BuildRequires:  python3-numpy-devel
155 BuildRequires:  rpm-pythonprov
156 BuildRequires:  rpmbuild(macros) >= 1.606
157 BuildRequires:  sed >= 4.0
158 BuildRequires:  sphinx-pdg
159 BuildRequires:  swig-python
160 %{?with_tbb:BuildRequires:      tbb-devel}
161 %if %{with vtk}
162 BuildRequires:  vtk-devel >= 5.8.0
163 BuildRequires:  vtk-java >= 5.8.0
164 BuildRequires:  vtk-python3-devel >= 5.8.0
165 %endif
166 %{?with_xine:BuildRequires:     xine-lib-devel}
167 BuildRequires:  xorg-lib-libX11-devel
168 BuildRequires:  zlib-devel
169 %if %{with qt}
170 BuildRequires:  QtCore-devel >= 4
171 BuildRequires:  QtGui-devel >= 4
172 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
173 BuildRequires:  qt4-qmake >= 4
174 %else
175 BuildRequires:  gtk+2-devel >= 2.0
176 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
177 %endif
178 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
179 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
180
181 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
182 %define         sover   %(echo %{version} | cut -d. -f1-2)
183
184 %description
185 OpenCV (Open Source Computer Vision) is a library of programming
186 functions mainly aimed at real time computer vision.
187
188 Example applications of the OpenCV library are:
189 - Human-Computer Interaction (HCI)
190 - Object Identification, Segmentation and Recognition
191 - Face Recognition
192 - Gesture Recognition
193 - Motion Tracking
194 - Ego Motion, Motion Understanding
195 - Structure From Motion (SFM)
196 - Stereo and Multi-Camera Calibration and Depth Computation
197 - Mobile Robotics.
198
199 %description -l pl.UTF-8
200 OpenCV (Open Source Computer Vision) to biblioteka funkcji
201 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
202
203 Przykładowe zastosowania biblioteki OpenCV to
204 - interakcje człowiek-komputer (HCI)
205 - identyfikacja, segmentacja i rozpoznawanie obiektów
206 - rozpoznawanie twarzy
207 - rozpoznawanie gestów
208 - śledzenie ruchu
209 - rozumienie ruchu
210 - SFM (Structure From Motion)
211 - kalibracja dwu- i wielokamerowa, obliczanie głębi
212 - robotyka ruchu.
213
214 %package core
215 Summary:        OpenCV core libraries
216 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
217 Group:          Libraries
218 Conflicts:      opencv < 2.4.6.2-1
219
220 %description core
221 This package contains the OpenCV C/C++ core libraries.
222
223 %description core -l pl.UTF-8
224 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
225
226 %package viz
227 Summary:        OpenCV viz library (VTK support)
228 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
229 Group:          Libraries
230 Requires:       %{name} = %{epoch}:%{version}-%{release}
231
232 %description viz
233 OpenCV viz library (VTK support).
234
235 %description viz -l pl.UTF-8
236 Biblioteka OpenCV viz (obsługa VTK).
237
238 %package devel
239 Summary:        Header files for OpenCV library
240 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
241 Group:          Development/Libraries
242 Requires:       %{name} = %{epoch}:%{version}-%{release}
243 %if %{with vtk}
244 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
245 %endif
246 Obsoletes:      opencv-static
247
248 %description devel
249 Header files for OpenCV library.
250
251 %description devel -l pl.UTF-8
252 Pliki nagłówkowe biblioteki OpenCV.
253
254 %package doc
255 Summary:        Manual for OpenCV
256 Summary(fr.UTF-8):      Documentation pour OpenCV
257 Summary(it.UTF-8):      Documentazione di OpenCV
258 Summary(pl.UTF-8):      Podręcznik dla OpenCV
259 Group:          Documentation
260 # noarch subpackages only when building with rpm5
261 BuildArch:      noarch
262
263 %description doc
264 Documentation for OpenCV.
265
266 %description doc -l fr.UTF-8
267 Documentation pour OpenCV.
268
269 %description doc -l it.UTF-8
270 Documentazione di OpenCV.
271
272 %description doc -l pl.UTF-8
273 Dokumentacja do OpenCV.
274
275 %package examples
276 Summary:        OpenCV code examples
277 Group:          Documentation
278 BuildArch:      noarch
279
280 %description examples
281 OpenCV code examples.
282
283 %package -n java-opencv
284 Summary:        OpenCV Java bindings
285 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
286 Group:          Libraries/Java
287 Requires:       %{name} = %{epoch}:%{version}-%{release}
288 Requires:       jre
289
290 %description -n java-opencv
291 OpenCV Java bindings.
292
293 %description -n java-opencv -l pl.UTF-8
294 Wiązania Javy do OpenCV.
295
296 %package -n python-opencv
297 Summary:        OpenCV Python 2 bindings
298 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
299 Group:          Libraries/Python
300 Requires:       %{name} = %{epoch}:%{version}-%{release}
301 Requires:       python-libs
302
303 %description -n python-opencv
304 OpenCV Python 2 bindings.
305
306 %description -n python-opencv -l pl.UTF-8
307 Wiązania Pythona 2 do OpenCV.
308
309 %package -n python3-opencv
310 Summary:        OpenCV Python 3 bindings
311 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
312 Group:          Libraries/Python
313 Requires:       %{name} = %{epoch}:%{version}-%{release}
314 Requires:       python3-libs
315
316 %description -n python3-opencv
317 OpenCV Python 3 bindings.
318
319 %description -n python3-opencv -l pl.UTF-8
320 Wiązania Pythona 3 do OpenCV.
321
322 %prep
323 %setup -q -a1
324
325 %undos CMakeLists.txt
326
327 %patch0 -p1
328 %patch1 -p1
329
330 cache_file() {
331         f="$1"
332         d="$2"
333         md5="$(md5sum "$f" | awk '{print $1}')"
334         file="$(basename "$f")"
335         mkdir -p ".cache/$d"
336         install "$f" ".cache/$d/$md5-$file"
337 }
338 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
339         cache_file $f xfeatures2d/boostdesc
340 done
341 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
342         cache_file $f xfeatures2d/vgg
343 done
344 cache_file %{SOURCE30} data
345 cache_file %{SOURCE40} ade
346
347 %build
348 mkdir -p build
349 cd build
350
351 # handle cmake & ccache
352 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
353 if [[ "%{__cc}" = *ccache* ]]; then
354         cc="%{__cc}"
355         cxx="%{__cxx}"
356         ccache="
357         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
358         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
359         "
360 fi
361
362 %cmake .. \
363         $ccache \
364         -DENABLE_PRECOMPILED_HEADERS=OFF \
365         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
366         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
367         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
368         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
369         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
370         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
371         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
372         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
373         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
374         -DBUILD_NEW_PYTHON_SUPPORT=ON \
375         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
376 %if %{with examples}
377         -DINSTALL_C_EXAMPLES=ON \
378         -DINSTALL_PYTHON_EXAMPLES=ON \
379 %endif
380         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
381         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
382         %{?with_opencl:-DWITH_OPENCL=ON} \
383         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
384         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
385         %{?with_opengl:-DWITH_OPENGL=ON} \
386         %{?with_openmp:-DWITH_OPENMP=ON} \
387         %{?with_openni:-DWITH_OPENNI=ON} \
388         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
389         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
390         %{?with_tbb:-DWITH_TBB=ON} \
391         %{?with_unicap:-DWITH_UNICAP=ON} \
392         %{!?with_v4l:-DWITH_V4L=OFF} \
393         %{?with_vtk:-DWITH_VTK=ON} \
394         %{?with_ximea:-DWITH_XIMEA=ON} \
395         %{?with_xine:-DWITH_XINE=ON} \
396         -DWITH_IPP=OFF
397
398 %{__make}
399
400 %install
401 rm -rf $RPM_BUILD_ROOT
402 %{__make} -C build install \
403         DESTDIR=$RPM_BUILD_ROOT
404
405 %if %{with examples}
406 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
407 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
408 %endif
409
410 # disable completeness check incompatible with split packaging
411 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
412
413 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
414 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
415 %py_postclean
416
417 %if %{with java}
418 # move to proper directories, create symlink
419 install -d $RPM_BUILD_ROOT%{_javadir}
420 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
421 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
422         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
423 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
424 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
425 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
426 %endif
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %post   -p /sbin/ldconfig
432 %postun -p /sbin/ldconfig
433
434 %post   core -p /sbin/ldconfig
435 %postun core -p /sbin/ldconfig
436
437 %post   viz -p /sbin/ldconfig
438 %postun viz -p /sbin/ldconfig
439
440 %post   -n java-opencv -p /sbin/ldconfig
441 %postun -n java-opencv -p /sbin/ldconfig
442
443 %files
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_bindir}/opencv_annotation
446 #%attr(755,root,root) %{_bindir}/opencv_createsamples
447 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
448 #%attr(755,root,root) %{_bindir}/opencv_traincascade
449 %attr(755,root,root) %{_bindir}/opencv_version
450 %attr(755,root,root) %{_bindir}/opencv_visualisation
451 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
452 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
453 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
454 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
455 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
456 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
457 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
458 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
460 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
462 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
464 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
466 # contrib modules
467 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
468 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
469 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
470 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
471 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
473 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
475 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
477 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
478 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
479 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
480 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
481 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
482 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
483 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
484 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
485 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
486 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
487 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
488 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
489 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
490 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
491 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
492 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
493 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
494 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
495 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
497 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
498 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
499 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
500 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
501 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
502 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
503 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
505 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
507 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
509 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
510 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
511 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
512 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
513 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
515 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
517 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
519 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
521 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
523 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
525 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
527 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
529 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
531 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
533 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
535 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
537 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
539 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
541 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
543 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
545 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
546
547 %dir %{_datadir}/opencv4
548 %{_datadir}/opencv4/haarcascades
549 %{_datadir}/opencv4/lbpcascades
550 %{_datadir}/opencv4/quality
551
552 %files core
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
555 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
556 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
557 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
558 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
560 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
562 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
564 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
565 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
566 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
567 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
568 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
570 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
571 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
572
573 %if %{with vtk}
574 %files viz
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
578 %endif
579
580 %files devel
581 %defattr(644,root,root,755)
582 # core
583 %{_libdir}/libopencv_core.so
584 %{_libdir}/libopencv_flann.so
585 %{_libdir}/libopencv_imgproc.so
586 %{_libdir}/libopencv_ml.so
587 %{_libdir}/libopencv_photo.so
588 %{_libdir}/libopencv_video.so
589 # GUI/extensions (base package)
590 %{_libdir}/libopencv_calib3d.so
591 %{_libdir}/libopencv_features2d.so
592 %{_libdir}/libopencv_highgui.so
593 %{_libdir}/libopencv_objdetect.so
594 %{_libdir}/libopencv_stitching.so
595 %{_libdir}/libopencv_superres.so
596 %{_libdir}/libopencv_videostab.so
597 %{_libdir}/libopencv_imgcodecs.so
598 %{_libdir}/libopencv_shape.so
599 %{_libdir}/libopencv_videoio.so
600 # contrib
601 %{_libdir}/libopencv_aruco.so
602 %{_libdir}/libopencv_bgsegm.so
603 %{_libdir}/libopencv_bioinspired.so
604 %{_libdir}/libopencv_ccalib.so
605 %{_libdir}/libopencv_datasets.so
606 %{_libdir}/libopencv_dnn.so
607 %{_libdir}/libopencv_dnn_objdetect.so
608 %{_libdir}/libopencv_dpm.so
609 %{_libdir}/libopencv_face.so
610 %{_libdir}/libopencv_freetype.so
611 %{_libdir}/libopencv_fuzzy.so
612 %{_libdir}/libopencv_hdf.so
613 %{_libdir}/libopencv_hfs.so
614 %{_libdir}/libopencv_img_hash.so
615 %{_libdir}/libopencv_line_descriptor.so
616 %{_libdir}/libopencv_optflow.so
617 %{_libdir}/libopencv_ovis.so
618 %{_libdir}/libopencv_phase_unwrapping.so
619 %{_libdir}/libopencv_plot.so
620 %{_libdir}/libopencv_reg.so
621 %{_libdir}/libopencv_rgbd.so
622 %{_libdir}/libopencv_saliency.so
623 %{_libdir}/libopencv_sfm.so
624 %{_libdir}/libopencv_stereo.so
625 %{_libdir}/libopencv_structured_light.so
626 %{_libdir}/libopencv_surface_matching.so
627 %{_libdir}/libopencv_text.so
628 %{_libdir}/libopencv_tracking.so
629 %{_libdir}/libopencv_xfeatures2d.so
630 %{_libdir}/libopencv_ximgproc.so
631 %{_libdir}/libopencv_xobjdetect.so
632 %{_libdir}/libopencv_xphoto.so
633 %{_libdir}/libopencv_alphamat.so
634 %{_libdir}/libopencv_dnn_superres.so
635 %{_libdir}/libopencv_gapi.so
636 %{_libdir}/libopencv_intensity_transform.so
637 %{_libdir}/libopencv_mcc.so
638 %{_libdir}/libopencv_quality.so
639 %{_libdir}/libopencv_rapid.so
640 # viz
641 %if %{with vtk}
642 %{_libdir}/libopencv_viz.so
643 %endif
644 %{_includedir}/opencv4
645 %{_libdir}/cmake/opencv4/OpenCV*.cmake
646 %{_pkgconfigdir}/opencv4.pc
647
648 %files doc
649 %defattr(644,root,root,755)
650 # TODO: probably could rebuild them and package via make install
651 %doc doc/*
652
653 %if %{with examples}
654 %files examples
655 %defattr(644,root,root,755)
656 %{_examplesdir}/%{name}-%{version}
657 %endif
658
659 %if %{with java}
660 %files -n java-opencv
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
663 %{_javadir}/opencv-%{jver}.jar
664 %{_javadir}/opencv.jar
665 %endif
666
667 %files -n python-opencv
668 %defattr(644,root,root,755)
669 %dir %{py_sitedir}/cv2
670 %dir %{py_sitedir}/cv2/python-*
671 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
672 %{py_sitedir}/cv2/*.py[co]
673
674 %files -n python3-opencv
675 %defattr(644,root,root,755)
676 %dir %{py3_sitedir}/cv2
677 %dir %{py3_sitedir}/cv2/python-*
678 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
679 %{py3_sitedir}/cv2/*.py
This page took 0.064466 seconds and 2 git commands to generate.