]> git.pld-linux.org Git - packages/opencv.git/blame_incremental - opencv.spec
- rel 6
[packages/opencv.git] / opencv.spec
... / ...
CommitLineData
1# TODO:
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
17#
18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21#
22# Conditional build:
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
36%bcond_without openmp # OpenMP support (available when not using tbb)
37%bcond_without examples # Install examples
38# - bindings
39%bcond_without java # Java binding
40# - highgui options:
41%bcond_without ffmpeg # FFMpeg support in highgui
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45%bcond_with qt # Qt backend instead of GTK+ in highgui
46%bcond_with unicap # Unicap support in highgui (GPL)
47%bcond_without v4l # Video4Linux in highgui
48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
49%bcond_with xine # XINE support in highgui (GPL)
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
52
53%ifarch pentium3 pentium4 %{x8664} x32
54%define with_sse 1
55%endif
56%ifarch pentium4 %{x8664} x32
57%define with_sse2 1
58%endif
59Summary: A library of programming functions mainly aimed at real time computer vision
60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61Name: opencv
62Version: 3.4.1
63Release: 6
64Epoch: 1
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
68License: BSD
69%endif
70Group: Libraries
71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72# Source0-md5: a0b7a47899e67b3490ea31edc4f6e8e6
73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74# Source1-md5: dd0c63f4185ab8a4829d8154ae382266
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
99# See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102Patch0: ix86-pause.patch
103Patch1: %{name}-ximea.patch
104Patch2: cplusplus.patch
105Patch3: cmake-install-path.patch
106Patch4: build.patch
107URL: http://www.opencv.org/
108%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
109%{?with_opencl:BuildRequires: OpenCL-devel}
110BuildRequires: OpenEXR-devel
111%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
112%{?with_opengl:BuildRequires: OpenGL-devel}
113# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
114%{?with_openni:BuildRequires: OpenNI-devel}
115%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
116%{?with_java:BuildRequires: ant}
117BuildRequires: boost-devel
118%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
119%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
120BuildRequires: cmake >= 2.8
121BuildRequires: doxygen
122BuildRequires: eigen3 >= 3
123%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
124%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
125BuildRequires: gflags-devel
126BuildRequires: gl2ps-devel
127BuildRequires: glog-devel
128%if %{with gstreamer}
129BuildRequires: gstreamer-devel >= 1.0
130BuildRequires: gstreamer-plugins-base-devel >= 1.0
131%endif
132BuildRequires: jasper-devel
133%{?with_java:BuildRequires: jdk}
134BuildRequires: libdc1394-devel >= 2
135%{?with_openmp:BuildRequires: libgomp-devel}
136BuildRequires: libjpeg-devel
137BuildRequires: libpng-devel
138BuildRequires: libraw1394-devel
139BuildRequires: libstdc++-devel
140BuildRequires: libtiff-devel
141BuildRequires: libtool
142%if %{with unicap}
143BuildRequires: libucil-devel
144BuildRequires: libunicap-devel
145%endif
146BuildRequires: libv4l-devel
147BuildRequires: pkgconfig
148BuildRequires: python >= 2.0
149BuildRequires: python-devel >= 2.0
150BuildRequires: python-numpy-devel
151BuildRequires: python3 >= 1:3.2
152BuildRequires: python3-devel >= 1:3.2
153BuildRequires: python3-numpy-devel
154BuildRequires: rpm-pythonprov
155BuildRequires: rpmbuild(macros) >= 1.606
156BuildRequires: sed >= 4.0
157BuildRequires: sphinx-pdg
158BuildRequires: swig-python
159%{?with_tbb:BuildRequires: tbb-devel}
160%if %{with vtk}
161BuildRequires: vtk-devel >= 5.8.0
162BuildRequires: vtk-java >= 5.8.0
163BuildRequires: vtk-tcl >= 5.8.0
164%endif
165%{?with_xine:BuildRequires: xine-lib-devel}
166BuildRequires: xorg-lib-libX11-devel
167BuildRequires: zlib-devel
168%if %{with qt}
169BuildRequires: QtCore-devel >= 4
170BuildRequires: QtGui-devel >= 4
171%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
172BuildRequires: qt4-qmake >= 4
173%else
174BuildRequires: gtk+2-devel >= 2.0
175%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
176%endif
177Requires: %{name}-core = %{epoch}:%{version}-%{release}
178BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
179
180%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
181%define sover %(echo %{version} | cut -d. -f1-2)
182
183%description
184OpenCV (Open Source Computer Vision) is a library of programming
185functions mainly aimed at real time computer vision.
186
187Example applications of the OpenCV library are:
188- Human-Computer Interaction (HCI)
189- Object Identification, Segmentation and Recognition
190- Face Recognition
191- Gesture Recognition
192- Motion Tracking
193- Ego Motion, Motion Understanding
194- Structure From Motion (SFM)
195- Stereo and Multi-Camera Calibration and Depth Computation
196- Mobile Robotics.
197
198%description -l pl.UTF-8
199OpenCV (Open Source Computer Vision) to biblioteka funkcji
200przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
201
202Przykładowe zastosowania biblioteki OpenCV to
203- interakcje człowiek-komputer (HCI)
204- identyfikacja, segmentacja i rozpoznawanie obiektów
205- rozpoznawanie twarzy
206- rozpoznawanie gestów
207- śledzenie ruchu
208- rozumienie ruchu
209- SFM (Structure From Motion)
210- kalibracja dwu- i wielokamerowa, obliczanie głębi
211- robotyka ruchu.
212
213%package core
214Summary: OpenCV core libraries
215Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
216Group: Libraries
217Conflicts: opencv < 2.4.6.2-1
218
219%description core
220This package contains the OpenCV C/C++ core libraries.
221
222%description core -l pl.UTF-8
223Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
224
225%package viz
226Summary: OpenCV viz library (VTK support)
227Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
228Group: Libraries
229Requires: %{name} = %{epoch}:%{version}-%{release}
230
231%description viz
232OpenCV viz library (VTK support).
233
234%description viz -l pl.UTF-8
235Biblioteka OpenCV viz (obsługa VTK).
236
237%package devel
238Summary: Header files for OpenCV library
239Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
240Group: Development/Libraries
241Requires: %{name} = %{epoch}:%{version}-%{release}
242%if %{with vtk}
243Requires: %{name}-viz = %{epoch}:%{version}-%{release}
244%endif
245Obsoletes: opencv-static
246
247%description devel
248Header files for OpenCV library.
249
250%description devel -l pl.UTF-8
251Pliki nagłówkowe biblioteki OpenCV.
252
253%package doc
254Summary: Manual for OpenCV
255Summary(fr.UTF-8): Documentation pour OpenCV
256Summary(it.UTF-8): Documentazione di OpenCV
257Summary(pl.UTF-8): Podręcznik dla OpenCV
258Group: Documentation
259# noarch subpackages only when building with rpm5
260%if "%{_rpmversion}" >= "5"
261BuildArch: noarch
262%endif
263
264%description doc
265Documentation for OpenCV.
266
267%description doc -l fr.UTF-8
268Documentation pour OpenCV.
269
270%description doc -l it.UTF-8
271Documentazione di OpenCV.
272
273%description doc -l pl.UTF-8
274Dokumentacja do OpenCV.
275
276%package examples
277Summary: OpenCV code examples
278Group: Documentation
279%if "%{_rpmversion}" >= "5"
280BuildArch: noarch
281%endif
282
283%description examples
284OpenCV code examples.
285
286%package -n java-opencv
287Summary: OpenCV Java bindings
288Summary(pl.UTF-8): Wiązania Javy do OpenCV
289Group: Libraries/Java
290Requires: %{name} = %{epoch}:%{version}-%{release}
291Requires: jre
292
293%description -n java-opencv
294OpenCV Java bindings.
295
296%description -n java-opencv -l pl.UTF-8
297Wiązania Javy do OpenCV.
298
299%package -n python-opencv
300Summary: OpenCV Python 2 bindings
301Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
302Group: Libraries/Python
303Requires: %{name} = %{epoch}:%{version}-%{release}
304Requires: python-libs
305
306%description -n python-opencv
307OpenCV Python 2 bindings.
308
309%description -n python-opencv -l pl.UTF-8
310Wiązania Pythona 2 do OpenCV.
311
312%package -n python3-opencv
313Summary: OpenCV Python 3 bindings
314Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
315Group: Libraries/Python
316Requires: %{name} = %{epoch}:%{version}-%{release}
317Requires: python3-libs
318
319%description -n python3-opencv
320OpenCV Python 3 bindings.
321
322%description -n python3-opencv -l pl.UTF-8
323Wiązania Pythona 3 do OpenCV.
324
325%prep
326%setup -q -a1
327
328%undos CMakeLists.txt
329
330%patch0 -p1
331%patch1 -p1
332%patch2 -p1
333%patch3 -p1
334%patch4 -p1
335
336%build
337install -d build/{share/OpenCV/testdata/cv/face,downloads/xfeatures2d}
338cd build
339
340install %{SOURCE30} share/OpenCV/testdata/cv/face/
341install %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} downloads/xfeatures2d/
342install %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} downloads/xfeatures2d/
343
344# handle cmake & ccache
345# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
346if [[ "%{__cc}" = *ccache* ]]; then
347 cc="%{__cc}"
348 cxx="%{__cxx}"
349 ccache="
350 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
351 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
352 "
353fi
354
355%cmake .. \
356 $ccache \
357 -DENABLE_PRECOMPILED_HEADERS=OFF \
358 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
359 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
360 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
361 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
362 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
363 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
364 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
365 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
366 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
367 -DBUILD_NEW_PYTHON_SUPPORT=ON \
368%if %{with examples}
369 -DINSTALL_C_EXAMPLES=ON \
370 -DINSTALL_PYTHON_EXAMPLES=ON \
371%endif
372 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
373 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
374 %{?with_opencl:-DWITH_OPENCL=ON} \
375 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
376 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
377 %{?with_opengl:-DWITH_OPENGL=ON} \
378 %{?with_openmp:-DWITH_OPENMP=ON} \
379 %{?with_openni:-DWITH_OPENNI=ON} \
380 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
381 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
382 %{?with_tbb:-DWITH_TBB=ON} \
383 %{?with_unicap:-DWITH_UNICAP=ON} \
384 %{!?with_v4l:-DWITH_V4L=OFF} \
385 %{?with_vtk:-DWITH_VTK=ON} \
386 %{?with_ximea:-DWITH_XIMEA=ON} \
387 %{?with_xine:-DWITH_XINE=ON} \
388 -DWITH_IPP=OFF
389
390%{__make}
391
392%install
393rm -rf $RPM_BUILD_ROOT
394%{__make} -C build install \
395 DESTDIR=$RPM_BUILD_ROOT
396
397%if %{with examples}
398install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
399mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
400%endif
401
402install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
403cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
404
405# disable completeness check incompatible with split packaging
406%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
407
408%py_comp $RPM_BUILD_ROOT%{py_sitedir}
409%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
410%py_postclean
411
412%if %{with java}
413# move to proper directories, create symlink
414install -d $RPM_BUILD_ROOT%{_javadir}
415%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
416sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
417 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
418%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
419rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
420ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
421%endif
422
423%clean
424rm -rf $RPM_BUILD_ROOT
425
426%post -p /sbin/ldconfig
427%postun -p /sbin/ldconfig
428
429%post core -p /sbin/ldconfig
430%postun core -p /sbin/ldconfig
431
432%post viz -p /sbin/ldconfig
433%postun viz -p /sbin/ldconfig
434
435%post -n java-opencv -p /sbin/ldconfig
436%postun -n java-opencv -p /sbin/ldconfig
437
438%files
439%defattr(644,root,root,755)
440%attr(755,root,root) %{_bindir}/opencv_annotation
441%attr(755,root,root) %{_bindir}/opencv_createsamples
442%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
443%attr(755,root,root) %{_bindir}/opencv_traincascade
444%attr(755,root,root) %{_bindir}/opencv_version
445%attr(755,root,root) %{_bindir}/opencv_visualisation
446%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
447%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
448%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
449%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
450%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
451%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
452%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
453%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
454%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
455%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
456%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
457%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
458%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
459%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
460# contrib modules
461%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
462%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
463%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
464%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
465%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
466%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
467%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
468%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
469%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
470%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
471%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
472%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
473%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
474%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
475%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
476%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
477%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
478%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
479%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
480%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
481%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
482%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
483%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
484%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
485%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
486%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
487%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
488%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
489%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
490%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
491%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
492%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
493%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
494%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
495%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
496%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
497%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
498%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
499%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
500%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
501%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
502%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
503%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
504%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
505%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
506%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
507%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
508%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
509%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
510%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
511%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
512%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
513%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
514%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
515%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
516%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
517%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
518%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
519%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
520%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
521%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
522%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
523%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
524
525%dir %{_datadir}/OpenCV
526%{_datadir}/OpenCV/haarcascades
527%{_datadir}/OpenCV/lbpcascades
528
529%files core
530%defattr(644,root,root,755)
531%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
532%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
533%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
534%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
535%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
536%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
537%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
538%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
539%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
540%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
541%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
542%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
543%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
544%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
545%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
546%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
547%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
548%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
549
550%if %{with vtk}
551%files viz
552%defattr(644,root,root,755)
553%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
554%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
555%endif
556
557%files devel
558%defattr(644,root,root,755)
559# core
560%attr(755,root,root) %{_libdir}/libopencv_core.so
561%attr(755,root,root) %{_libdir}/libopencv_flann.so
562%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
563%attr(755,root,root) %{_libdir}/libopencv_ml.so
564%attr(755,root,root) %{_libdir}/libopencv_photo.so
565%attr(755,root,root) %{_libdir}/libopencv_video.so
566# GUI/extensions (base package)
567%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
568%attr(755,root,root) %{_libdir}/libopencv_features2d.so
569%attr(755,root,root) %{_libdir}/libopencv_highgui.so
570%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
571%attr(755,root,root) %{_libdir}/libopencv_stitching.so
572%attr(755,root,root) %{_libdir}/libopencv_superres.so
573%attr(755,root,root) %{_libdir}/libopencv_videostab.so
574%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
575%attr(755,root,root) %{_libdir}/libopencv_shape.so
576%attr(755,root,root) %{_libdir}/libopencv_videoio.so
577# contrib
578%attr(755,root,root) %{_libdir}/libopencv_aruco.so
579%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so
580%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so
581%attr(755,root,root) %{_libdir}/libopencv_ccalib.so
582%attr(755,root,root) %{_libdir}/libopencv_datasets.so
583%attr(755,root,root) %{_libdir}/libopencv_dnn.so
584%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so
585%attr(755,root,root) %{_libdir}/libopencv_dpm.so
586%attr(755,root,root) %{_libdir}/libopencv_face.so
587%attr(755,root,root) %{_libdir}/libopencv_freetype.so
588%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so
589%attr(755,root,root) %{_libdir}/libopencv_hdf.so
590%attr(755,root,root) %{_libdir}/libopencv_hfs.so
591%attr(755,root,root) %{_libdir}/libopencv_img_hash.so
592%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so
593%attr(755,root,root) %{_libdir}/libopencv_optflow.so
594%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so
595%attr(755,root,root) %{_libdir}/libopencv_plot.so
596%attr(755,root,root) %{_libdir}/libopencv_reg.so
597%attr(755,root,root) %{_libdir}/libopencv_rgbd.so
598%attr(755,root,root) %{_libdir}/libopencv_saliency.so
599%attr(755,root,root) %{_libdir}/libopencv_sfm.so
600%attr(755,root,root) %{_libdir}/libopencv_stereo.so
601%attr(755,root,root) %{_libdir}/libopencv_structured_light.so
602%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so
603%attr(755,root,root) %{_libdir}/libopencv_text.so
604%attr(755,root,root) %{_libdir}/libopencv_tracking.so
605%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so
606%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so
607%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so
608%attr(755,root,root) %{_libdir}/libopencv_xphoto.so
609#%{_libdir}/libopencv_ts.a
610# viz
611%if %{with vtk}
612%attr(755,root,root) %{_libdir}/libopencv_viz.so
613%endif
614%{_includedir}/opencv
615%{_includedir}/opencv2
616%{_datadir}/OpenCV/OpenCV*.cmake
617%{_pkgconfigdir}/opencv.pc
618
619%files doc
620%defattr(644,root,root,755)
621# TODO: probably could rebuild them and package via make install
622%doc doc/*
623
624%if %{with examples}
625%files examples
626%defattr(644,root,root,755)
627%{_examplesdir}/%{name}-%{version}
628%endif
629
630%if %{with java}
631%files -n java-opencv
632%defattr(644,root,root,755)
633%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
634%{_javadir}/opencv-%{jver}.jar
635%{_javadir}/opencv.jar
636%endif
637
638%files -n python-opencv
639%defattr(644,root,root,755)
640%attr(755,root,root) %{py_sitedir}/cv2.so
641
642%files -n python3-opencv
643%defattr(644,root,root,755)
644%attr(755,root,root) %{py3_sitedir}/cv2.cpython-*.so
This page took 0.141333 seconds and 4 git commands to generate.