]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- rel 6 auto/th/opencv-3.4.1-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 6 Jul 2018 17:49:02 +0000 (19:49 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 6 Jul 2018 17:49:02 +0000 (19:49 +0200)
build.patch [new file with mode: 0644]
opencv.spec

diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..6d0098e
--- /dev/null
@@ -0,0 +1,11 @@
+--- opencv-3.4.1/modules/python/src2/cv2.cpp~  2018-02-23 09:38:33.000000000 +0100
++++ opencv-3.4.1/modules/python/src2/cv2.cpp   2018-07-06 19:10:56.563061072 +0200
+@@ -886,7 +886,7 @@ bool pyopencv_to(PyObject* obj, String&
+     (void)name;
+     if(!obj || obj == Py_None)
+         return true;
+-    char* str = PyString_AsString(obj);
++    char* str = (char *)PyString_AsString(obj);
+     if(!str)
+         return false;
+     value = String(str);
index e99d742ebba9cca25689f0f11b9272611fb082b8..814c69ad46b1bd1e75b3663763d8e1e3cc6a1217 100644 (file)
@@ -60,7 +60,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       3.4.1
-Release:       5
+Release:       6
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -103,6 +103,7 @@ Patch0:             ix86-pause.patch
 Patch1:                %{name}-ximea.patch
 Patch2:                cplusplus.patch
 Patch3:                cmake-install-path.patch
+Patch4:                build.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -330,6 +331,7 @@ Wiązania Pythona 3 do OpenCV.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 install -d build/{share/OpenCV/testdata/cv/face,downloads/xfeatures2d}
This page took 0.103513 seconds and 4 git commands to generate.