]> git.pld-linux.org Git - packages/open-vm-tools.git/commitdiff
fix build with gcc 10
authorJan Palus <atler@pld-linux.org>
Mon, 17 Aug 2020 18:58:11 +0000 (20:58 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 17 Aug 2020 18:58:11 +0000 (20:58 +0200)
gcc10.patch [new file with mode: 0644]
open-vm-tools.spec

diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644 (file)
index 0000000..b880050
--- /dev/null
@@ -0,0 +1,39 @@
+From 6578e6a740a027e8957b8af1442277feba022ef9 Mon Sep 17 00:00:00 2001
+From: John Wolfe <jwolfe@vmware.com>
+Date: Fri, 31 Jul 2020 13:36:35 -0700
+Subject: [PATCH] Remove duplicate global definitions.
+
+Remove duplicate and unused global definitions for
+GDK_SELECTION_TYPE_TIMESTAMP and GDK_SELECTION_TYPE_UTF8_STRING.
+
+This fix will address https://github.com/vmware/open-vm-tools/issues/451
+---
+ .../services/plugins/dndcp/copyPasteUIX11.cpp          | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/open-vm-tools/services/plugins/dndcp/copyPasteUIX11.cpp b/open-vm-tools/services/plugins/dndcp/copyPasteUIX11.cpp
+index be8369e74..68212ab8b 100644
+--- a/open-vm-tools/services/plugins/dndcp/copyPasteUIX11.cpp
++++ b/open-vm-tools/services/plugins/dndcp/copyPasteUIX11.cpp
+@@ -1,5 +1,5 @@
+ /*********************************************************
+- * Copyright (C) 2009-2019 VMware, Inc. All rights reserved.
++ * Copyright (C) 2009-2020 VMware, Inc. All rights reserved.
+  *
+  * This program is free software; you can redistribute it and/or modify it
+  * under the terms of the GNU Lesser General Public License as published
+@@ -97,14 +97,6 @@ extern "C" {
+ GdkAtom GDK_SELECTION_CLIPBOARD;
+ #endif
+-#ifndef GDK_SELECTION_TYPE_TIMESTAMP
+-GdkAtom GDK_SELECTION_TYPE_TIMESTAMP;
+-#endif
+-
+-#ifndef GDK_SELECTION_TYPE_UTF8_STRING
+-GdkAtom GDK_SELECTION_TYPE_UTF8_STRING;
+-#endif
+-
+ /*
+  *-----------------------------------------------------------------------------
index a008c224b2c291ce02bfbbf124841cd8669c8231..fab64532c5de69fc3fc4b5f8581023c7a1de829a 100644 (file)
@@ -27,6 +27,7 @@ Source6:      vmtoolsd.pamd
 Patch0:                %{name}-dnd.patch
 Patch1:                iopl.patch
 Patch2:                log.patch
+Patch3:                gcc10.patch
 URL:           https://github.com/vmware/open-vm-tools
 BuildRequires: autoconf
 BuildRequires: doxygen
@@ -141,6 +142,7 @@ ReguĊ‚y UDEV dla open-vm-tools.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cp %{SOURCE1} open-vm-tools/packaging
 
This page took 0.309759 seconds and 4 git commands to generate.