]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
- release 2
[packages/opal.git] / opal.spec
1 # TODO:
2 #       fix static libname (libopal_s.a)
3 #       IPv6 support requires IPv6 support in ptlib
4 #       x264+ffmpeg detection sucks - it doesn't work with --as-needed
5 #       SpanDSP FAX support requires t38_indicator symbol
6 #       MPEG4 rate control correction requires libavcodec sources
7 #       CAPI support
8 #
9 # Don't touch this! strip removes all symbols from library
10 %define         no_install_post_strip           1
11 #
12 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
13 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
14 Name:           opal
15 Version:        3.6.6
16 Release:        2
17 License:        MPL
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/opal/3.6/%{name}-%{version}.tar.bz2
20 # Source0-md5:  43b363c860780e7f1a0361cfee8f9f4a
21 #Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
22 Patch0:         %{name}-libname.patch
23 Patch1:         %{name}-mak_files.patch
24 Patch2:         %{name}-ac.patch
25 Patch3:         %{name}-build.patch
26 URL:            http://www.openh323.org/
27 BuildRequires:  SDL-devel
28 BuildRequires:  automake
29 BuildRequires:  autoconf
30 BuildRequires:  ffmpeg-devel
31 BuildRequires:  libgsm-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtheora-devel
34 BuildRequires:  libx264-devel
35 BuildRequires:  openssl-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  ptlib-devel >= 2.4.2-3
38 BuildRequires:  sed >= 4.0
39 BuildRequires:  speex-devel >= 1:1.1.5
40 %requires_eq    ptlib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         filterout_ld    -Wl,--as-needed
44
45 %description
46 The OPAL project aims to create a full featured, interoperable,
47 Open Source implementation of the ITU H.323 teleconferencing protocol
48 that can be used by personal developers and commercial users without
49 charge.
50
51 %description -l pl.UTF-8
52 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
53 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
54 który może być używany przez użytkowników prywatnych i komercyjnych
55 bez opłat.
56
57 %package devel
58 Summary:        Opal development files
59 Summary(pl.UTF-8):      Pliki dla developerów Opal
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       libstdc++-devel
63 Requires:       ptlib-devel
64
65 %description devel
66 Header files and libraries for developing applications that use
67 OPAL.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
71 używających OPAL.
72
73 %package static
74 Summary:        OPAL static libraries
75 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 OPAL static libraries.
81
82 %description static -l pl.UTF-8
83 Biblioteki statyczne OPAL.
84
85 %prep
86 %setup -q
87 #patch0 -p1
88 #patch1 -p1
89 #%patch2 -p1
90 %patch3 -p1
91
92 %build
93 PWLIBDIR=%{_prefix}; export PWLIBDIR
94 OPALDIR=`pwd`; export OPALDIR
95 OPAL_BUILD="yes"; export OPAL_BUILD
96 %{__aclocal}
97 %{__autoconf}
98 %configure \
99         --enable-ixj
100
101 %{__make} %{?debug:debug}%{!?debug:opt} \
102         CC="%{__cc}" \
103         CPLUS="%{__cxx}" \
104         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
105
106 %{__cp} -a */libopal* .
107 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
108         CC="%{__cc}" \
109         CPLUS=%{__cxx} \
110         CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
111         LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_bindir}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/*
131 %attr(755,root,root) %{_libdir}/lib*.so.*.*
132 %dir %{_libdir}/opal-%{version}
133 %dir %{_libdir}/opal-%{version}/codecs
134 %dir %{_libdir}/opal-%{version}/codecs/audio
135 %dir %{_libdir}/opal-%{version}/codecs/video
136 %dir %{_libdir}/opal-%{version}/lid
137 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_audio_pwplugin.so
138 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_audio_pwplugin.so
139 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_audio_pwplugin.so
140 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_pwplugin.so
141 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ilbc_audio_pwplugin.so
142 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_audio_pwplugin.so
143 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_audio_pwplugin.so
144 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_audio_pwplugin.so
145 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261-vic_video_pwplugin.so
146 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-1998_video_pwplugin.so
147 #%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-ffmpeg_video_pwplugin.so
148 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
149 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin.so
150 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4-ffmpeg_video_pwplugin.so
151 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_video_pwplugin.so
152 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
153 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_lid_pwplugin.so
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/*.so
158 %{_includedir}/opal
159 %{_pkgconfigdir}/opal.pc
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/*.a
This page took 0.079588 seconds and 3 git commands to generate.