]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
- up to 2.2.5
[packages/opal.git] / opal.spec
1 #
2 # Don't touch this! strip removes all symbols from library
3 %define         no_install_post_strip           1
4 #
5 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
6 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
7 Name:           opal
8 Version:        2.2.5
9 Release:        1
10 License:        MPL
11 Group:          Libraries
12 Source0:        http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
13 # Source0-md5:  d85407085c391fecc89451fd5c132645
14 Patch0:         %{name}-libname.patch
15 Patch1:         %{name}-mak_files.patch
16 URL:            http://www.openh323.org/
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pwlib-devel >= 1.10.3
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  speex-devel >= 1:1.1.5
21 %requires_eq    pwlib
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The OPAL project aims to create a full featured, interoperable,
26 Open Source implementation of the ITU H.323 teleconferencing protocol
27 that can be used by personal developers and commercial users without
28 charge.
29
30 %description -l pl.UTF-8
31 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
32 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
33 który może być używany przez użytkowników prywatnych i komercyjnych
34 bez opłat.
35
36 %package devel
37 Summary:        Opal development files
38 Summary(pl.UTF-8):      Pliki dla developerów Opal
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libstdc++-devel
42 Requires:       pwlib-devel
43
44 %description devel
45 Header files and libraries for developing applications that use
46 OPAL.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
50 używających OPAL.
51
52 %package static
53 Summary:        OPAL static libraries
54 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 OPAL static libraries.
60
61 %description static -l pl.UTF-8
62 Biblioteki statyczne OPAL.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68
69 %build
70 PWLIBDIR=%{_prefix}; export PWLIBDIR
71 OPALDIR=`pwd`; export OPALDIR
72 OPAL_BUILD="yes"; export OPAL_BUILD
73 %configure 
74
75 %{__make} %{?debug:debug}%{!?debug:opt} \
76         CC="%{__cc}" \
77         CPLUS="%{__cxx}" \
78         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
79
80 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
81         CC="%{__cc}" \
82         CPLUS=%{__cxx} \
83         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/opal,%{_bindir},%{_datadir}/%{name}}
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # using cp as install won't preserve links
93 cp -d lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
94 install version.h $RPM_BUILD_ROOT%{_includedir}/opal
95 install samples/simple/obj_*/simpleopal $RPM_BUILD_ROOT%{_bindir}
96 sed -i -e 's@\$(OPALDIR)/include@&/opal@' \
97        -e 's@\$(OPALDIR)/lib@\$(OPALDIR)/%{_lib}@' $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc.mak
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/*
108 %attr(755,root,root) %{_libdir}/lib*.so.*.*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/*.so
113 %{_includedir}/*
114 %{_datadir}/%{name}
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/*.a
This page took 0.047091 seconds and 3 git commands to generate.