]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
- now devel requires ptlib-devel
[packages/opal.git] / opal.spec
1 # TODO:
2 #       fix static libname (libopal_s.a)
3 #       check why:
4 #               checking PTLIB has expat... no
5 #               checking PTLIB has vxml... no
6 #               checking PTLIB has ipv6... no
7 #               checking PTLIB has ldap... no
8 #       ... and check plugin configuration:
9 #                              GSM :  yes (internal)
10 #                           H.263+ :  
11 #                           H.264  :  no
12 #                          THEORA  :  no
13 #                    MPEG4 Part 2  :  no
14 #                     SpanDSP FAX  :  no
15 #                            CAPI  :  no
16 #           Quicknet xJACK support :  no
17 #
18 # Don't touch this! strip removes all symbols from library
19 %define         no_install_post_strip           1
20 #
21 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
22 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
23 Name:           opal
24 Version:        3.4.2
25 Release:        0.2
26 License:        MPL
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/opal/3.4/%{name}-%{version}.tar.bz2
29 # Source0-md5:  a1d11099fa00d77a79dcfe513872e8dc
30 #Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
31 Patch0:         %{name}-libname.patch
32 Patch1:         %{name}-mak_files.patch
33 Patch2:         %{name}-ac.patch
34 Patch3:         %{name}-build.patch
35 URL:            http://www.openh323.org/
36 BuildRequires:  SDL-devel
37 BuildRequires:  automake
38 BuildRequires:  autoconf
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  openssl-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  ptlib-devel
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  speex-devel >= 1:1.1.5
45 %requires_eq    pwlib
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 The OPAL project aims to create a full featured, interoperable,
50 Open Source implementation of the ITU H.323 teleconferencing protocol
51 that can be used by personal developers and commercial users without
52 charge.
53
54 %description -l pl.UTF-8
55 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
56 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
57 który może być używany przez użytkowników prywatnych i komercyjnych
58 bez opłat.
59
60 %package devel
61 Summary:        Opal development files
62 Summary(pl.UTF-8):      Pliki dla developerów Opal
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       libstdc++-devel
66 Requires:       ptlib-devel
67
68 %description devel
69 Header files and libraries for developing applications that use
70 OPAL.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
74 używających OPAL.
75
76 %package static
77 Summary:        OPAL static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 OPAL static libraries.
84
85 %description static -l pl.UTF-8
86 Biblioteki statyczne OPAL.
87
88 %prep
89 %setup -q
90 #patch0 -p1
91 #patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94
95 %build
96 PWLIBDIR=%{_prefix}; export PWLIBDIR
97 OPALDIR=`pwd`; export OPALDIR
98 OPAL_BUILD="yes"; export OPAL_BUILD
99 %{__aclocal}
100 %{__autoconf}
101 %configure
102
103 %{__make} %{?debug:debug}%{!?debug:opt} \
104         CC="%{__cc}" \
105         CPLUS="%{__cxx}" \
106         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
107
108 %{__cp} -a */libopal* .
109 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
110         CC="%{__cc}" \
111         CPLUS=%{__cxx} \
112         CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
113         LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_bindir}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/*
133 %attr(755,root,root) %{_libdir}/lib*.so.*.*
134 %dir %{_libdir}/opal-3.4.2
135 %dir %{_libdir}/opal-3.4.2/codecs
136 %dir %{_libdir}/opal-3.4.2/codecs/audio
137 %dir %{_libdir}/opal-3.4.2/codecs/video
138 %dir %{_libdir}/opal-3.4.2/lid
139 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/g726_audio_pwplugin.so
140 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsm0610_audio_pwplugin.so
141 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsmamrcodec_pwplugin.so
142 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ilbc_audio_pwplugin.so
143 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ima_adpcm_audio_pwplugin.so
144 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/lpc10_audio_pwplugin.so
145 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/speex_audio_pwplugin.so
146 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h261-vic_video_pwplugin.so
147 %attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h263-ffmpeg_video_pwplugin.so
148 %attr(755,root,root) %{_libdir}/opal-3.4.2/lid/vpb_lid_pwplugin.so
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/*.so
153 %{_includedir}/opal
154 %{_pkgconfigdir}/opal.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/*.a
This page took 0.061248 seconds and 3 git commands to generate.