]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
- updated to 3.1.4
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 Summary:        Open Geographic Datastore Interface
3 Summary(pl):    OGDI - otwarty interfejs do danych geograficznych
4 Name:           ogdi
5 Version:        3.1.4
6 Release:        1
7 License:        BSD-like
8 Group:          Applications
9 Source0:        http://dl.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
10 # Source0-md5:  d54a5dcce211e37b8ba317531312ff55
11 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
12 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
13 Patch0:         %{name}-driversdir.patch
14 Patch1:         %{name}-pic.patch
15 URL:            http://ogdi.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  expat-devel
18 BuildRequires:  proj-devel
19 BuildRequires:  tcl-devel
20 BuildRequires:  unixODBC-devel
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 OGDI is the Open Geographic Datastore Interface. OGDI is an
26 application programming interface (API) that uses a standardized
27 access methods to work in conjunction with GIS software packages (the
28 application) and various geospatial data products. OGDI uses a
29 client/server architecture to facilitate the dissemination of
30 geospatial data products over any TCP/IP network, and a
31 driver-oriented approach to facilitate access to several geospatial
32 data products/formats.
33
34 %description -l pl
35 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
36 do danych geograficznych. OGDI to API u¿ywaj±ce ustandaryzowanych
37 metod dostêpu do pracy z pakietami oprogramowania GIS i ró¿nymi danymi
38 geograficznymi. OGDI u¿ywa architektury klient-serwer aby udostêpniaæ
39 dane po dowolnej sieci TCP/IP oraz podej¶cia bazuj±cego na
40 sterownikach aby zapewniæ dostêp do ró¿nych produktów/formatów danych
41 geograficznych.
42
43 %package devel
44 Summary:        OGDI header files and documentation
45 Summary(pl):    Pliki nag³ówkowe i dokumentacja OGDI
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 OGDI header files and developer's documentation.
51
52 %description devel -l pl
53 Pliki nag³ówkowe i dokumentacja programisty do OGDI.
54
55 %package odbc
56 Summary:        ODBC driver for OGDI
57 Summary(pl):    Sterownik ODBC do OGDI
58 Group:          Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description odbc
62 ODBC driver for OGDI.
63
64 %description odbc -l pl
65 Sterownik ODBC do OGDI.
66
67 %package -n tcl-ogdi
68 Summary:        Tcl wrapper for OGDI
69 Summary(pl):    Interfejs Tcl do OGDI
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description -n tcl-ogdi
74 Tcl wrapper for OGDI.
75
76 %description -n tcl-ogdi -l pl
77 Interfejs Tcl do OGDI.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 cp -f %{SOURCE1} .
85
86 %build
87 %{__autoconf}
88 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
89 %configure \
90         --with-expat \
91         --with-proj \
92         --with-zlib
93
94 %{__make} \
95         OPTIMIZATION="%{rpmcflags}"
96
97 %{__make} -C ogdi/tcl_interface \
98         OPTIMIZATION="%{rpmcflags}" \
99         TCL_LINKLIB="-ltcl"
100 %{__make} -C contrib/gdal \
101         OPTIMIZATION="%{rpmcflags}"
102 %{__make} -C ogdi/attr_driver/odbc \
103         OPTIMIZATION="%{rpmcflags}" \
104         ODBC_LINKLIB="-lodbc"
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
110
111 %{__make} install \
112         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
113         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi \
114         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
115
116 %{__make} install -C ogdi/tcl_interface \
117         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
118 %{__make} install -C contrib/gdal \
119         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
120 %{__make} install -C ogdi/attr_driver/odbc \
121         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
122
123 # only libogdi* is common library, the rest are dlopened drivers
124 mv -f $RPM_BUILD_ROOT%{_libdir}/ogdi/libogdi*.so $RPM_BUILD_ROOT%{_libdir}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc LICENSE NEWS
135 %attr(755,root,root) %{_bindir}/gltpd
136 %attr(755,root,root) %{_bindir}/ogdi_*
137 %attr(755,root,root) %{_libdir}/libogdi*.so
138 %dir %{_libdir}/ogdi
139 %attr(755,root,root) %{_libdir}/ogdi/lib[^l]*.so
140
141 %files devel
142 %defattr(644,root,root,755)
143 %doc ogdi.pdf
144 %{_includedir}/*.h
145
146 %files odbc
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
149
150 %files -n tcl-ogdi
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libecs_tcl.so
This page took 0.411064 seconds and 4 git commands to generate.