]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
d85ef156e4d6246f1f52e55398e1a5117db0ce90
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 #
3 # Conditional build:
4 %bcond_without  tcl     # disable gui and nviz
5 %bcond_without  odbc    # disable unixODBC support
6 #
7 Summary:        Open Geographic Datastore Interface
8 Summary(pl.UTF-8):      OGDI - otwarty interfejs do danych geograficznych
9 Name:           ogdi
10 Version:        4.0.0
11 Release:        1
12 License:        BSD-like
13 Group:          Applications/Databases
14 #Source0Download: https://github.com/libogdi/ogdi/releases/
15 Source0:        https://github.com/libogdi/ogdi/archive/ogdi_4_0_0/%{name}-%{version}.tar.gz
16 # Source0-md5:  d1d91f71b4748313d3f60c8f301e03da
17 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
18 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
19 Patch1:         %{name}-format.patch
20 URL:            http://ogdi.sourceforge.net/
21 BuildRequires:  autoconf
22 BuildRequires:  expat-devel
23 BuildRequires:  rpmbuild(macros) >= 1.446
24 %{?with_tcl:BuildRequires:      tcl-devel}
25 %{?with_odbc:BuildRequires:     unixODBC-devel}
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 OGDI is the Open Geographic Datastore Interface. OGDI is an
31 application programming interface (API) that uses a standardized
32 access methods to work in conjunction with GIS software packages (the
33 application) and various geospatial data products. OGDI uses a
34 client/server architecture to facilitate the dissemination of
35 geospatial data products over any TCP/IP network, and a
36 driver-oriented approach to facilitate access to several geospatial
37 data products/formats.
38
39 %description -l pl.UTF-8
40 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
41 do danych geograficznych. OGDI to API używające ustandaryzowanych
42 metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
43 geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
44 dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
45 sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
46 geograficznych.
47
48 %package devel
49 Summary:        OGDI header files and documentation
50 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja OGDI
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 OGDI header files and developer's documentation.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe i dokumentacja programisty do OGDI.
59
60 %package odbc
61 Summary:        ODBC driver for OGDI
62 Summary(pl.UTF-8):      Sterownik ODBC do OGDI
63 Group:          Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description odbc
67 ODBC driver for OGDI.
68
69 %description odbc -l pl.UTF-8
70 Sterownik ODBC do OGDI.
71
72 %package -n tcl-ogdi
73 Summary:        Tcl wrapper for OGDI
74 Summary(pl.UTF-8):      Interfejs Tcl do OGDI
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description -n tcl-ogdi
79 Tcl wrapper for OGDI.
80
81 %description -n tcl-ogdi -l pl.UTF-8
82 Interfejs Tcl do OGDI.
83
84 %prep
85 %setup -q -n ogdi-ogdi_4_0_0
86 %patch1 -p1
87
88 cp -f %{SOURCE1} .
89
90 %build
91 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
92 %configure \
93         --with-expat \
94         --with-zlib
95
96 # bash because of pushd/popd used in makefiles
97 %{__make} -j 1 \
98         SHELL=/bin/bash \
99         INST_LIB=%{_libdir} \
100         OPTIMIZATION="%{rpmcflags}"
101
102 %if %{with tcl}
103 %{__make} -j 1 -C ogdi/tcl_interface \
104         OPTIMIZATION="%{rpmcflags}" \
105         TCL_LINKLIB="-ltcl"
106 %endif
107 %{__make} -j 1 -C contrib/gdal \
108         OPTIMIZATION="%{rpmcflags}"
109 %if %{with odbc}
110 %{__make} -j 1 -C ogdi/attr_driver/odbc \
111         OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
112         ODBC_LINKLIB="-lodbc"
113 %endif
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
119
120 %{__make} -j 1 install \
121         SHELL=/bin/bash \
122         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
123         INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
124         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
125
126 # omitted from make install
127 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
128 cp -p ogdi.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
129 install ogdi-config $RPM_BUILD_ROOT%{_bindir}
130
131 %if %{with tcl}
132 %{__make} -j 1 install -C ogdi/tcl_interface \
133         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
134 %endif
135 %{__make} -j 1 install -C contrib/gdal \
136         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
137 %if %{with odbc}
138 %{__make} -j 1 install -C ogdi/attr_driver/odbc \
139         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
140 %endif
141
142 %{__rm} $RPM_BUILD_ROOT%{_bindir}/example?
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc LICENSE NEWS
153 %attr(755,root,root) %{_bindir}/gltpd
154 %attr(755,root,root) %{_bindir}/ogdi_*
155 %attr(755,root,root) %{_libdir}/libogdi.so.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libogdi.so.4
157 %dir %{_libdir}/ogdi
158 %attr(755,root,root) %{_libdir}/ogdi/libadrg.so
159 %attr(755,root,root) %{_libdir}/ogdi/libdted.so
160 %attr(755,root,root) %{_libdir}/ogdi/libgdal.so
161 %attr(755,root,root) %{_libdir}/ogdi/libremote.so
162 %attr(755,root,root) %{_libdir}/ogdi/librpf.so
163 %attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
164 %attr(755,root,root) %{_libdir}/ogdi/libvrf.so
165
166 %files devel
167 %defattr(644,root,root,755)
168 %doc ogdi.pdf
169 %attr(755,root,root) %{_bindir}/ogdi-config
170 %attr(755,root,root) %{_libdir}/libogdi.so
171 %{_includedir}/ecs.h
172 %{_includedir}/ecs_util.h
173 %{_pkgconfigdir}/ogdi.pc
174
175 %if %{with odbc}
176 %files odbc
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
179 %endif
180
181 %if %{with tcl}
182 %files -n tcl-ogdi
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
185 %endif
This page took 0.034505 seconds and 2 git commands to generate.