]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
- devel reqs proj-devel
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 Summary:        Open Geographic Datastore Interface
3 Summary(pl):    OGDI - otwarty interfejs do danych geograficznych
4 Name:           ogdi
5 Version:        3.1.4
6 Release:        1
7 License:        BSD-like
8 Group:          Applications
9 Source0:        http://dl.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
10 # Source0-md5:  d54a5dcce211e37b8ba317531312ff55
11 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
12 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
13 Patch0:         %{name}-driversdir.patch
14 Patch1:         %{name}-pic.patch
15 URL:            http://ogdi.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  expat-devel
18 BuildRequires:  proj-devel
19 BuildRequires:  tcl-devel
20 BuildRequires:  unixODBC-devel
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 OGDI is the Open Geographic Datastore Interface. OGDI is an
26 application programming interface (API) that uses a standardized
27 access methods to work in conjunction with GIS software packages (the
28 application) and various geospatial data products. OGDI uses a
29 client/server architecture to facilitate the dissemination of
30 geospatial data products over any TCP/IP network, and a
31 driver-oriented approach to facilitate access to several geospatial
32 data products/formats.
33
34 %description -l pl
35 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
36 do danych geograficznych. OGDI to API u¿ywaj±ce ustandaryzowanych
37 metod dostêpu do pracy z pakietami oprogramowania GIS i ró¿nymi danymi
38 geograficznymi. OGDI u¿ywa architektury klient-serwer aby udostêpniaæ
39 dane po dowolnej sieci TCP/IP oraz podej¶cia bazuj±cego na
40 sterownikach aby zapewniæ dostêp do ró¿nych produktów/formatów danych
41 geograficznych.
42
43 %package devel
44 Summary:        OGDI header files and documentation
45 Summary(pl):    Pliki nag³ówkowe i dokumentacja OGDI
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       proj-devel
49
50 %description devel
51 OGDI header files and developer's documentation.
52
53 %description devel -l pl
54 Pliki nag³ówkowe i dokumentacja programisty do OGDI.
55
56 %package odbc
57 Summary:        ODBC driver for OGDI
58 Summary(pl):    Sterownik ODBC do OGDI
59 Group:          Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description odbc
63 ODBC driver for OGDI.
64
65 %description odbc -l pl
66 Sterownik ODBC do OGDI.
67
68 %package -n tcl-ogdi
69 Summary:        Tcl wrapper for OGDI
70 Summary(pl):    Interfejs Tcl do OGDI
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description -n tcl-ogdi
75 Tcl wrapper for OGDI.
76
77 %description -n tcl-ogdi -l pl
78 Interfejs Tcl do OGDI.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84
85 cp -f %{SOURCE1} .
86
87 %build
88 %{__autoconf}
89 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
90 %configure \
91         --with-expat \
92         --with-proj \
93         --with-zlib
94
95 %{__make} \
96         OPTIMIZATION="%{rpmcflags}"
97
98 %{__make} -C ogdi/tcl_interface \
99         OPTIMIZATION="%{rpmcflags}" \
100         TCL_LINKLIB="-ltcl"
101 %{__make} -C contrib/gdal \
102         OPTIMIZATION="%{rpmcflags}"
103 %{__make} -C ogdi/attr_driver/odbc \
104         OPTIMIZATION="%{rpmcflags}" \
105         ODBC_LINKLIB="-lodbc"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
111
112 %{__make} install \
113         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
114         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi \
115         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
116
117 %{__make} install -C ogdi/tcl_interface \
118         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
119 %{__make} install -C contrib/gdal \
120         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
121 %{__make} install -C ogdi/attr_driver/odbc \
122         INST_LIB=$RPM_BUILD_ROOT%{_libdir}/ogdi
123
124 # only libogdi* is common library, the rest are dlopened drivers
125 mv -f $RPM_BUILD_ROOT%{_libdir}/ogdi/libogdi*.so $RPM_BUILD_ROOT%{_libdir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc LICENSE NEWS
136 %attr(755,root,root) %{_bindir}/gltpd
137 %attr(755,root,root) %{_bindir}/ogdi_*
138 %attr(755,root,root) %{_libdir}/libogdi*.so
139 %dir %{_libdir}/ogdi
140 %attr(755,root,root) %{_libdir}/ogdi/lib[^l]*.so
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc ogdi.pdf
145 %{_includedir}/*.h
146
147 %files odbc
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
150
151 %files -n tcl-ogdi
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libecs_tcl.so
This page took 0.045754 seconds and 3 git commands to generate.