]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
- release 9 (by relup.sh)
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 #
3 # Conditional build:
4 %bcond_without  tcl             # disable gui and nviz
5 %bcond_without  odbc    # disable unixODBC support
6 #
7 Summary:        Open Geographic Datastore Interface
8 Summary(pl.UTF-8):      OGDI - otwarty interfejs do danych geograficznych
9 Name:           ogdi
10 Version:        3.1.6
11 Release:        9
12 License:        BSD-like
13 Group:          Applications/Databases
14 Source0:        http://downloads.sourceforge.net/ogdi/%{name}-%{version}.tar.gz
15 # Source0-md5:  212ad71896aa70528ed139c95bed6511
16 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
17 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
18 Patch0:         %{name}-pic.patch
19 Patch1:         %{name}-proj480.patch
20 Patch2:         %{name}-format.patch
21 URL:            http://ogdi.sourceforge.net/
22 BuildRequires:  autoconf
23 BuildRequires:  expat-devel
24 BuildRequires:  proj-devel >= 4.8
25 %{?with_tcl:BuildRequires:      tcl-devel}
26 %{?with_odbc:BuildRequires:     unixODBC-devel}
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 OGDI is the Open Geographic Datastore Interface. OGDI is an
32 application programming interface (API) that uses a standardized
33 access methods to work in conjunction with GIS software packages (the
34 application) and various geospatial data products. OGDI uses a
35 client/server architecture to facilitate the dissemination of
36 geospatial data products over any TCP/IP network, and a
37 driver-oriented approach to facilitate access to several geospatial
38 data products/formats.
39
40 %description -l pl.UTF-8
41 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
42 do danych geograficznych. OGDI to API używające ustandaryzowanych
43 metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
44 geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
45 dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
46 sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
47 geograficznych.
48
49 %package devel
50 Summary:        OGDI header files and documentation
51 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja OGDI
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       proj-devel >= 4.8
55
56 %description devel
57 OGDI header files and developer's documentation.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe i dokumentacja programisty do OGDI.
61
62 %package odbc
63 Summary:        ODBC driver for OGDI
64 Summary(pl.UTF-8):      Sterownik ODBC do OGDI
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description odbc
69 ODBC driver for OGDI.
70
71 %description odbc -l pl.UTF-8
72 Sterownik ODBC do OGDI.
73
74 %package -n tcl-ogdi
75 Summary:        Tcl wrapper for OGDI
76 Summary(pl.UTF-8):      Interfejs Tcl do OGDI
77 Group:          Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n tcl-ogdi
81 Tcl wrapper for OGDI.
82
83 %description -n tcl-ogdi -l pl.UTF-8
84 Interfejs Tcl do OGDI.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 cp -f %{SOURCE1} .
93
94 %build
95 %{__autoconf}
96 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
97 %configure \
98         --with-expat \
99         --with-proj \
100         --with-zlib
101
102 # bash because of pushd/popd used in makefiles
103 %{__make} -j 1 \
104         SHELL=/bin/bash \
105         INST_LIB=%{_libdir} \
106         OPTIMIZATION="%{rpmcflags}"
107
108 %if %{with tcl}
109 %{__make} -j 1 -C ogdi/tcl_interface \
110         OPTIMIZATION="%{rpmcflags}" \
111         TCL_LINKLIB="-ltcl"
112 %endif
113 %{__make} -j 1 -C contrib/gdal \
114         OPTIMIZATION="%{rpmcflags}"
115 %if %{with odbc}
116 %{__make} -j 1 -C ogdi/attr_driver/odbc \
117         OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
118         ODBC_LINKLIB="-lodbc"
119 %endif
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
125
126 %{__make} -j 1 install \
127         SHELL=/bin/bash \
128         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
129         INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
130         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
131
132 %if %{with tcl}
133 %{__make} -j 1 install -C ogdi/tcl_interface \
134         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
135 %endif
136 %{__make} -j 1 install -C contrib/gdal \
137         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
138 %if %{with odbc}
139 %{__make} -j 1 install -C ogdi/attr_driver/odbc \
140         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
141 %endif
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc LICENSE NEWS
152 %attr(755,root,root) %{_bindir}/gltpd
153 %attr(755,root,root) %{_bindir}/ogdi_*
154 %attr(755,root,root) %{_libdir}/libogdi.so.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libogdi.so.3
156 %dir %{_libdir}/ogdi
157 %attr(755,root,root) %{_libdir}/ogdi/libadrg.so
158 %attr(755,root,root) %{_libdir}/ogdi/libdtcanada.so
159 %attr(755,root,root) %{_libdir}/ogdi/libdted.so
160 %attr(755,root,root) %{_libdir}/ogdi/libdtusa.so
161 %attr(755,root,root) %{_libdir}/ogdi/libgdal.so
162 %attr(755,root,root) %{_libdir}/ogdi/libremote.so
163 %attr(755,root,root) %{_libdir}/ogdi/librpf.so
164 %attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
165 %attr(755,root,root) %{_libdir}/ogdi/libvrf.so
166
167 %files devel
168 %defattr(644,root,root,755)
169 %doc ogdi.pdf
170 %attr(755,root,root) %{_libdir}/libogdi.so
171 %{_includedir}/ecs.h
172 %{_includedir}/ecs_util.h
173
174 %if %{with odbc}
175 %files odbc
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
178 %endif
179
180 %if %{with tcl}
181 %files -n tcl-ogdi
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
184 %endif
This page took 0.461908 seconds and 3 git commands to generate.