]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
rebuild with tirpc; rel 2
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 #
3 # Conditional build:
4 %bcond_without  tcl     # disable gui and nviz
5 %bcond_without  odbc    # disable unixODBC support
6 #
7 Summary:        Open Geographic Datastore Interface
8 Summary(pl.UTF-8):      OGDI - otwarty interfejs do danych geograficznych
9 Name:           ogdi
10 Version:        4.0.0
11 Release:        2
12 License:        BSD-like
13 Group:          Applications/Databases
14 #Source0Download: https://github.com/libogdi/ogdi/releases/
15 Source0:        https://github.com/libogdi/ogdi/archive/ogdi_4_0_0/%{name}-%{version}.tar.gz
16 # Source0-md5:  d1d91f71b4748313d3f60c8f301e03da
17 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
18 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
19 Patch1:         %{name}-format.patch
20 URL:            http://ogdi.sourceforge.net/
21 BuildRequires:  autoconf
22 BuildRequires:  expat-devel
23 BuildRequires:  libtirpc-devel
24 BuildRequires:  rpmbuild(macros) >= 1.446
25 %{?with_tcl:BuildRequires:      tcl-devel}
26 %{?with_odbc:BuildRequires:     unixODBC-devel}
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 OGDI is the Open Geographic Datastore Interface. OGDI is an
32 application programming interface (API) that uses a standardized
33 access methods to work in conjunction with GIS software packages (the
34 application) and various geospatial data products. OGDI uses a
35 client/server architecture to facilitate the dissemination of
36 geospatial data products over any TCP/IP network, and a
37 driver-oriented approach to facilitate access to several geospatial
38 data products/formats.
39
40 %description -l pl.UTF-8
41 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
42 do danych geograficznych. OGDI to API używające ustandaryzowanych
43 metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
44 geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
45 dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
46 sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
47 geograficznych.
48
49 %package devel
50 Summary:        OGDI header files and documentation
51 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja OGDI
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libtirpc-devel
55
56 %description devel
57 OGDI header files and developer's documentation.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe i dokumentacja programisty do OGDI.
61
62 %package odbc
63 Summary:        ODBC driver for OGDI
64 Summary(pl.UTF-8):      Sterownik ODBC do OGDI
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description odbc
69 ODBC driver for OGDI.
70
71 %description odbc -l pl.UTF-8
72 Sterownik ODBC do OGDI.
73
74 %package -n tcl-ogdi
75 Summary:        Tcl wrapper for OGDI
76 Summary(pl.UTF-8):      Interfejs Tcl do OGDI
77 Group:          Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n tcl-ogdi
81 Tcl wrapper for OGDI.
82
83 %description -n tcl-ogdi -l pl.UTF-8
84 Interfejs Tcl do OGDI.
85
86 %prep
87 %setup -q -n ogdi-ogdi_4_0_0
88 %patch1 -p1
89
90 cp -f %{SOURCE1} .
91
92 %build
93 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
94 %configure \
95         --with-expat \
96         --with-zlib
97
98 # bash because of pushd/popd used in makefiles
99 %{__make} -j 1 \
100         SHELL=/bin/bash \
101         INST_LIB=%{_libdir} \
102         OPTIMIZATION="%{rpmcflags}"
103
104 %if %{with tcl}
105 %{__make} -j 1 -C ogdi/tcl_interface \
106         OPTIMIZATION="%{rpmcflags}" \
107         TCL_LINKLIB="-ltcl"
108 %endif
109 %{__make} -j 1 -C contrib/gdal \
110         OPTIMIZATION="%{rpmcflags}"
111 %if %{with odbc}
112 %{__make} -j 1 -C ogdi/attr_driver/odbc \
113         OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
114         ODBC_LINKLIB="-lodbc"
115 %endif
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
121
122 %{__make} -j 1 install \
123         SHELL=/bin/bash \
124         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
125         INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
126         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
127
128 # omitted from make install
129 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
130 cp -p ogdi.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
131 install ogdi-config $RPM_BUILD_ROOT%{_bindir}
132
133 %if %{with tcl}
134 %{__make} -j 1 install -C ogdi/tcl_interface \
135         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
136 %endif
137 %{__make} -j 1 install -C contrib/gdal \
138         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
139 %if %{with odbc}
140 %{__make} -j 1 install -C ogdi/attr_driver/odbc \
141         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
142 %endif
143
144 %{__rm} $RPM_BUILD_ROOT%{_bindir}/example?
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc LICENSE NEWS
155 %attr(755,root,root) %{_bindir}/gltpd
156 %attr(755,root,root) %{_bindir}/ogdi_*
157 %attr(755,root,root) %{_libdir}/libogdi.so.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libogdi.so.4
159 %dir %{_libdir}/ogdi
160 %attr(755,root,root) %{_libdir}/ogdi/libadrg.so
161 %attr(755,root,root) %{_libdir}/ogdi/libdted.so
162 %attr(755,root,root) %{_libdir}/ogdi/libgdal.so
163 %attr(755,root,root) %{_libdir}/ogdi/libremote.so
164 %attr(755,root,root) %{_libdir}/ogdi/librpf.so
165 %attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
166 %attr(755,root,root) %{_libdir}/ogdi/libvrf.so
167
168 %files devel
169 %defattr(644,root,root,755)
170 %doc ogdi.pdf
171 %attr(755,root,root) %{_bindir}/ogdi-config
172 %attr(755,root,root) %{_libdir}/libogdi.so
173 %{_includedir}/ecs.h
174 %{_includedir}/ecs_util.h
175 %{_pkgconfigdir}/ogdi.pc
176
177 %if %{with odbc}
178 %files odbc
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
181 %endif
182
183 %if %{with tcl}
184 %files -n tcl-ogdi
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
187 %endif
This page took 0.150632 seconds and 3 git commands to generate.