]> git.pld-linux.org Git - packages/ofono.git/commitdiff
- updated to 1.23 auto/th/ofono-1.23-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 14 Apr 2018 07:49:04 +0000 (09:49 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 14 Apr 2018 07:49:04 +0000 (09:49 +0200)
- added missing patch (missing file from git)

ofono-missing.patch [new file with mode: 0644]
ofono.spec

diff --git a/ofono-missing.patch b/ofono-missing.patch
new file mode 100644 (file)
index 0000000..fae6a59
--- /dev/null
@@ -0,0 +1,62 @@
+--- ofono-1.23/drivers/mbimmodem/mbim-private.h.orig   1970-01-01 01:00:00.000000000 +0100
++++ ofono-1.23/drivers/mbimmodem/mbim-private.h        2018-04-14 09:31:26.477397218 +0200
+@@ -0,0 +1,59 @@
++/*
++ *
++ *  oFono - Open Source Telephony
++ *
++ *  Copyright (C) 2017  Intel Corporation. All rights reserved.
++ *
++ *  This program is free software; you can redistribute it and/or modify
++ *  it under the terms of the GNU General Public License version 2 as
++ *  published by the Free Software Foundation.
++ *
++ *  This program is distributed in the hope that it will be useful,
++ *  but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *  GNU General Public License for more details.
++ *
++ *  You should have received a copy of the GNU General Public License
++ *  along with this program; if not, write to the Free Software
++ *  Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
++ *
++ */
++
++#define align_len(len, boundary) (((len)+(boundary)-1) & ~((boundary)-1))
++
++enum mbim_control_message {
++      MBIM_OPEN_MSG = 0x1,
++      MBIM_CLOSE_MSG = 0x2,
++      MBIM_COMMAND_MSG = 0x3,
++      MBIM_HOST_ERROR_MSG = 0x4,
++      MBIM_OPEN_DONE = 0x80000001,
++      MBIM_CLOSE_DONE = 0x80000002,
++      MBIM_COMMAND_DONE = 0x80000003,
++      MBIM_FUNCTION_ERROR_MSG = 0x80000004,
++      MBIM_INDICATE_STATUS_MSG = 0x80000007,
++};
++
++/* MBIM v1.0, Section 9.1 */
++struct mbim_message_header {
++      __le32 type;
++      __le32 len;
++      __le32 tid;
++} __attribute__ ((packed));
++
++/* MBIM v1.0, Section 9.1 */
++struct mbim_fragment_header {
++      __le32 num_frags;
++      __le32 cur_frag;
++} __attribute__ ((packed));
++
++struct mbim_message *_mbim_message_build(const void *header,
++                                              struct iovec *frags,
++                                              uint32_t n_frags);
++struct mbim_message *_mbim_message_new_command_done(const uint8_t *uuid,
++                                      uint32_t cid, uint32_t status);
++uint32_t _mbim_information_buffer_offset(uint32_t type);
++void _mbim_message_set_tid(struct mbim_message *message, uint32_t tid);
++void *_mbim_message_to_bytearray(struct mbim_message *message, size_t *out_len);
++void *_mbim_message_get_header(struct mbim_message *message, size_t *out_len);
++struct iovec *_mbim_message_get_body(struct mbim_message *message,
++                                      size_t *out_n_iov, size_t *out_len);
index 704fd19a05e113d9740c03d6243f2a090b6e3fd1..ecf6b7ee9e66602a8895992cd006b5cbfc0a7e09 100644 (file)
@@ -1,15 +1,17 @@
 Summary:       oFono - Open Source Telephony
 Summary(pl.UTF-8):     oFono - telefonia o otwartych źródłach
 Name:          ofono
-Version:       1.20
+Version:       1.23
 Release:       1
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       https://www.kernel.org/pub/linux/network/ofono/%{name}-%{version}.tar.xz
-# Source0-md5: fad0630fce6a9aecdb7db37bc1f1db7d
+# Source0-md5: 27ea2f1a155231af49d520486b8ebc05
+Patch0:                %{name}-missing.patch
 URL:           https://01.org/ofono
 BuildRequires: bluez-libs-devel >= 4.99
 BuildRequires: dbus-devel >= 1.4
+BuildRequires: ell-devel >= 0.2
 BuildRequires: gcc >= 5:3.4
 BuildRequires: glib2-devel >= 1:2.32
 BuildRequires: libusb-devel >= 1.0
@@ -56,11 +58,14 @@ Pliki nagłówkowe dla wtyczek oFono.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure \
        --disable-silent-rules \
        --enable-dundee \
+       --enable-ell \
+       --enable-mbimmodem \
        --enable-pie \
        --enable-threads \
        --enable-tools
This page took 0.12904 seconds and 4 git commands to generate.