]> git.pld-linux.org Git - packages/ocfs2-tools.git/commitdiff
- up to 1.8.6 master auto/th/ocfs2-tools-1.8.6-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 19 Oct 2019 22:14:56 +0000 (00:14 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 19 Oct 2019 22:14:56 +0000 (00:14 +0200)
ocfs2-tools-format.patch
ocfs2-tools.spec

index 583f2037f5c736e9421632e186da4a3c99a343df..a2d3de2f0c843c23e22eac1499abfadb7153088e 100644 (file)
---- ocfs2-tools-1.4.4/fsck.ocfs2/problem.c.orig        2008-12-03 19:38:21.000000000 +0100
-+++ ocfs2-tools-1.4.4/fsck.ocfs2/problem.c     2015-12-13 18:22:46.957121947 +0100
-@@ -112,9 +112,9 @@
-               ans = ost->ost_answer ? 'y' : 'n';
-       } else {
-               if (flags & PY)
--                      printf(yes);
-+                      fputs(yes, stdout);
-               else if (flags & PN)
--                      printf(no);
-+                      fputs(no, stdout);
-       }
-       fflush(stdout);
---- ocfs2-tools-1.4.4/tunefs.ocfs2/op_query.c.orig     2009-04-14 00:10:40.000000000 +0200
-+++ ocfs2-tools-1.4.4/tunefs.ocfs2/op_query.c  2015-12-13 18:47:05.127060750 +0100
-@@ -150,7 +150,7 @@
- {
-       char label[OCFS2_MAX_VOL_LABEL_LEN + 1];
--      snprintf(label, OCFS2_MAX_VOL_LABEL_LEN + 1,
-+      snprintf(label, OCFS2_MAX_VOL_LABEL_LEN + 1, "%s",
-                (char *)OCFS2_RAW_SB(query_fs->fs_super)->s_label);
-       return print_string(stream, info, args, label);
-@@ -338,7 +338,7 @@
+--- ocfs2-tools-ocfs2-tools-1.8.6/tunefs.ocfs2/op_query.c~     2019-05-23 12:16:26.000000000 +0200
++++ ocfs2-tools-ocfs2-tools-1.8.6/tunefs.ocfs2/op_query.c      2019-10-20 00:05:43.621595719 +0200
+@@ -338,7 +338,7 @@ static int query_run(struct tunefs_opera
        register_printf_function('O', handle_ro_compat, handle_arginfo);
  
        query_fs = fs;
 -      fprintf(stdout, fmt);
-+      fprintf(stdout, fmt, NULL /* hack */);
++      fprintf(stdout, "%s", fmt);
        query_fs = NULL;
  
        ocfs2_free(&fmt);
---- ocfs2-tools-1.4.4/debugfs.ocfs2/commands.c.orig    2010-03-17 01:10:43.000000000 +0100
-+++ ocfs2-tools-1.4.4/debugfs.ocfs2/commands.c 2015-12-13 19:23:59.780301145 +0100
-@@ -677,7 +677,7 @@
-       gbls.cwd = strdup("/");
-       /* lookup heartbeat file */
--      snprintf (sysfile, sizeof(sysfile),
-+      snprintf (sysfile, sizeof(sysfile), "%s",
-                 ocfs2_system_inodes[HEARTBEAT_SYSTEM_INODE].si_name);
-       ret = ocfs2_lookup(gbls.fs, gbls.sysdir_blkno, sysfile,
-                          strlen(sysfile), NULL, &gbls.hb_blkno);
-@@ -685,7 +685,7 @@
-               gbls.hb_blkno = 0;
-       /* lookup slotmap file */
--      snprintf (sysfile, sizeof(sysfile),
-+      snprintf (sysfile, sizeof(sysfile), "%s",
-                 ocfs2_system_inodes[SLOT_MAP_SYSTEM_INODE].si_name);
-       ret = ocfs2_lookup(gbls.fs, gbls.sysdir_blkno, sysfile,
-                          strlen(sysfile), NULL, &gbls.slotmap_blkno);
---- ocfs2-tools-1.4.4/debugfs.ocfs2/find_block_inode.c.orig    2010-03-11 20:29:36.000000000 +0100
-+++ ocfs2-tools-1.4.4/debugfs.ocfs2/find_block_inode.c 2015-12-13 19:24:25.760300055 +0100
-@@ -203,7 +203,7 @@
-       char sysfile[50];
-       errcode_t ret = 0;
--      snprintf(sysfile, sizeof(sysfile),
-+      snprintf(sysfile, sizeof(sysfile), "%s",
-                ocfs2_system_inodes[GLOBAL_BITMAP_SYSTEM_INODE].si_name);
-       ret = ocfs2_lookup(fs, fs->fs_sysdir_blkno, sysfile,
---- ocfs2-tools-1.4.4/mount.ocfs2/mount.ocfs2.c.orig   2015-12-13 17:42:28.663890097 +0100
-+++ ocfs2-tools-1.4.4/mount.ocfs2/mount.ocfs2.c        2015-12-13 19:25:34.140297185 +0100
-@@ -185,7 +185,7 @@
-       }
-       if (mo->type && strcmp(mo->type, OCFS2_FS_NAME)) {
--              com_err(progname, OCFS2_ET_UNKNOWN_FILESYSTEM, mo->type);
-+              com_err(progname, OCFS2_ET_UNKNOWN_FILESYSTEM, "%s", mo->type);
-               return -1;
-       }
---- ocfs2-tools-1.4.4/fswreck/chain.c.orig     2010-02-25 03:06:23.000000000 +0100
-+++ ocfs2-tools-1.4.4/fswreck/chain.c  2015-12-13 19:28:24.540290032 +0100
-@@ -345,7 +345,7 @@
-       struct ocfs2_super_block *sb = OCFS2_RAW_SB(fs->fs_super);
-       
-       if (slotnum == UINT16_MAX)
--              snprintf(sysfile, sizeof(sysfile),
-+              snprintf(sysfile, sizeof(sysfile), "%s",
-               ocfs2_system_inodes[GLOBAL_BITMAP_SYSTEM_INODE].si_name);
-       else
-               snprintf(sysfile, sizeof(sysfile),
-@@ -401,7 +401,7 @@
-       uint64_t blkno;
-       struct ocfs2_super_block *sb = OCFS2_RAW_SB(fs->fs_super);
--      snprintf(sysfile, sizeof(sysfile),
-+      snprintf(sysfile, sizeof(sysfile), "%s",
-                ocfs2_system_inodes[GLOBAL_BITMAP_SYSTEM_INODE].si_name);
-       ret = ocfs2_lookup(fs, sb->s_system_dir_blkno, sysfile,
---- ocfs2-tools-1.4.4/fswreck/group.c.orig     2010-02-25 03:06:24.000000000 +0100
-+++ ocfs2-tools-1.4.4/fswreck/group.c  2015-12-13 19:29:30.580287261 +0100
-@@ -214,7 +214,7 @@
-       struct ocfs2_super_block *sb = OCFS2_RAW_SB(fs->fs_super);
-       
-       if (slotnum == UINT16_MAX)
--              snprintf(sysfile, sizeof(sysfile),
-+              snprintf(sysfile, sizeof(sysfile), "%s",
-               ocfs2_system_inodes[GLOBAL_BITMAP_SYSTEM_INODE].si_name);
-       else
-               snprintf(sysfile, sizeof(sysfile),
---- ocfs2-tools-1.6.4/extras/check_metaecc.c.orig      2010-12-10 20:37:07.000000000 +0100
-+++ ocfs2-tools-1.6.4/extras/check_metaecc.c   2015-12-20 22:26:27.487793994 +0100
-@@ -163,7 +163,7 @@
-               if (crc == new_check.bc_crc32e) {
-                       snprintf(outbuf + result_offset,
-                               sizeof(outbuf) - result_offset, "PASS\n");
--                      fprintf(stderr, outbuf);
-+                      fputs(outbuf, stderr);
-                       goto do_check_end;
-               }
-@@ -176,13 +176,13 @@
-               if (crc == new_check.bc_crc32e) {
-                       snprintf(outbuf + result_offset,
-                               sizeof(outbuf) - result_offset, "ECC Fixup\n");
--                      fprintf(stderr, outbuf);
-+                      fputs(outbuf, stderr);
-                       goto do_check_end;
-               }
-               snprintf(outbuf + result_offset,
-                       sizeof(outbuf) - result_offset, "FAIL\n");
--              fprintf(stderr, outbuf);
-+              fputs(outbuf, stderr);
-               offset = snprintf(outbuf, sizeof(outbuf), "Calculated");
-               while (offset < crc_offset)
-@@ -190,7 +190,7 @@
-               snprintf(outbuf + crc_offset, sizeof(outbuf) - crc_offset,
-                       "CRC32: %.8"PRIx32"    ECC: %.4"PRIx16"\n",
-                       crc, ecc);
--              fprintf(stderr, outbuf);
-+              fputs(outbuf, stderr);
-               err = -1;
- do_check_end:
-               check.bc_crc32e = cpu_to_le32(new_check.bc_crc32e);
index 726f5c118b45c6334b25e37eb3dfd24b579f970b..1020c68faf18bb1a05e9e672e6a2973a552c55b1 100644 (file)
 Summary:       Tools for the OCFS2 filesystem
 Summary(pl.UTF-8):     Narzędzia dla systemu plików OCFS2
 Name:          ocfs2-tools
-Version:       1.6.4
-Release:       3
+Version:       1.8.6
+Release:       1
 License:       GPL v2+
 Group:         Applications/System
-#Source0Download: https://oss.oracle.com/projects/ocfs2-tools/files/source/
-Source0:       https://oss.oracle.com/projects/ocfs2-tools/dist/files/source/v1.6/%{name}-%{version}.tar.gz
-# Source0-md5: 2e94423507b63fcc08f93c094e789be8
+Source0:       https://github.com/markfasheh/ocfs2-tools/archive/%{name}-%{version}.tar.gz
+# Source0-md5: fc64af70a6a2533948f47fa9cb2fc1c4
 Source1:       ocfs2.init
 Source2:       o2cb.init
 Source3:       o2cb.sysconfig
@@ -82,12 +81,14 @@ GTK+ interface to OCFS2 Tools.
 Interfejs GTK+ do narzędzi OCFS2.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{name}-%{version}
 %patch0 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 
+sed -i -e 's#-Wno-format##g' */Makefile
+
 %build
 %{__aclocal} -I .
 %{__autoconf}
@@ -149,11 +150,14 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/o2cb
 %attr(754,root,root) /etc/rc.d/init.d/ocfs2
 %attr(755,root,root) /sbin/debugfs.ocfs2
+%attr(755,root,root) /sbin/defragfs.ocfs2
 %attr(755,root,root) /sbin/fsck.ocfs2
 %attr(755,root,root) /sbin/mkfs.ocfs2
-%attr(755,root,root) /sbin/mount.ocfs2
 %attr(755,root,root) /sbin/mounted.ocfs2
+%attr(755,root,root) /sbin/mount.ocfs2
+%attr(755,root,root) /sbin/o2cb
 %attr(755,root,root) /sbin/o2cb_ctl
+%attr(755,root,root) /sbin/o2cluster
 %attr(755,root,root) /sbin/o2image
 %attr(755,root,root) /sbin/ocfs2_hb_ctl
 %attr(755,root,root) /sbin/tunefs.ocfs2
@@ -172,14 +176,21 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/o2cb
 %dir /dlm
 %{_mandir}/man1/o2info.1*
+%{_mandir}/man5/o2cb.sysconfig.5.*
+%{_mandir}/man5/ocfs2.cluster.conf.5.*
 %{_mandir}/man7/o2cb.7*
+%{_mandir}/man7/ocfs2.7.*
 %{_mandir}/man8/debugfs.ocfs2.8*
+%{_mandir}/man8/defragfs.ocfs2.8.*
 %{_mandir}/man8/fsck.ocfs2.8*
 %{_mandir}/man8/fsck.ocfs2.checks.8*
 %{_mandir}/man8/mkfs.ocfs2.8*
-%{_mandir}/man8/mount.ocfs2.8*
 %{_mandir}/man8/mounted.ocfs2.8*
+%{_mandir}/man8/mount.ocfs2.8*
+%{_mandir}/man8/o2cb.8.*
 %{_mandir}/man8/o2cb_ctl.8*
+%{_mandir}/man8/o2cluster.8.*
+%{_mandir}/man8/o2hbmonitor.8.*
 %{_mandir}/man8/o2image.8*
 %{_mandir}/man8/ocfs2_hb_ctl.8*
 %{_mandir}/man8/tunefs.ocfs2.8*
This page took 0.146183 seconds and 4 git commands to generate.