]> git.pld-linux.org Git - packages/ocfs2-tools.git/blob - ocfs2-tools.spec
- BR: scons
[packages/ocfs2-tools.git] / ocfs2-tools.spec
1 Summary:        Tools for the OCFS2 filesystem
2 Summary(pl):    Narzêdzia dla systemu plików OCFS2
3 Name:           ocfs2-tools
4 Version:        1.2.1
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://oss.oracle.com/projects/ocfs2-tools/dist/files/source/v1.2/%{name}-%{version}.tar.gz
9 # Source0-md5:  62c24ae0f3016eb5c15f0dfc90fe956a
10 Source1:        ocfs2.init
11 Source2:        o2cb.init
12 URL:            http://oss.oracle.com/projects/ocfs2-tools/
13 BuildRequires:  e2fsprogs-devel
14 BuildRequires:  glib2-devel
15 BuildRequires:  libcom_err-devel
16 BuildRequires:  libuuid-devel
17 BuildRequires:  pkgconfig
18 BuildRequires:  python-devel
19 BuildRequires:  readline-devel
20 BuildRequires:  scons
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Tools and support files for creating and managing OCFS2 volumes.
25
26 %description -l pl
27 Narzêdzia do tworzenia i zarz±dzania wolumenami OCFS2.
28
29 %package gtk
30 Summary:        GTK+ interface to OCFS2 Tools
31 Summary(pl):    Interfejs GTK+ do narzêdzi OCFS2
32 Group:          X11/Applications
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       python-pygtk-gtk
35
36 %description gtk
37 GTK+ interface to OCFS2 Tools.
38
39 %description gtk -l pl
40 Interfejs GTK+ do narzêdzi OCFS2.
41
42 %prep
43 %setup -q
44
45 %build
46 %configure \
47         --enable-dynamic-fsck=yes \
48         --enable-dynamic-ctl=yes \
49         --enable-ocfs2console=yes
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ocfs2
60 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/o2cb
61
62 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
63 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %postun -p /sbin/ldconfig
69
70 %post
71 /sbin/ldconfig
72 /sbin/chkconfig --add o2cb
73 /sbin/chkconfig --add %{name}
74 %service o2cb restart
75 %service %{name} restart
76
77 %preun
78 if [ "$1" = "0" ]; then
79         %service -q %{name} stop
80         %service -q o2cb stop
81         /sbin/chkconfig --del %{name}
82         /sbin/chkconfig --del o2cb
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %attr(754,root,root) /etc/rc.d/init.d/o2cb
88 %attr(754,root,root) /etc/rc.d/init.d/ocfs2
89 %attr(755,root,root) /sbin/*
90 %{_mandir}/man8/*
91
92 %files gtk
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_sbindir}/*
95 %dir %{py_sitedir}/ocfs2interface
96 %attr(755,root,root) %{py_sitedir}/ocfs2interface/*.so
97 %{py_sitedir}/ocfs2interface/*.py[co]
This page took 0.087578 seconds and 3 git commands to generate.